Backport upstream patch "Fix unittest.exp failure
due to 'set debuginfod' addition" (RHBZ 2024875, Tom Tromey).
This commit is contained in:
parent
f7bcd3d6e0
commit
adc0bf8d9d
@ -342,3 +342,7 @@ Patch082: gdb-rhbz2024875-expand-documentation-for-debuginfod.patch
|
|||||||
#7811fa5995f gdb: add set/show commands for managing debuginfo
|
#7811fa5995f gdb: add set/show commands for managing debuginfo
|
||||||
Patch083: gdb-rhbz2024875-set_show-for-managing-debuginfod.patch
|
Patch083: gdb-rhbz2024875-set_show-for-managing-debuginfod.patch
|
||||||
|
|
||||||
|
#Backport upstream commit from Tom Tromey
|
||||||
|
#2a8f1f47446 Fix unittest.exp failure due to 'set debuginfod' addition
|
||||||
|
Patch084: gdb-rhbz2024875-fix-unittest-failure.patch
|
||||||
|
|
||||||
|
@ -81,3 +81,4 @@
|
|||||||
%patch081 -p1
|
%patch081 -p1
|
||||||
%patch082 -p1
|
%patch082 -p1
|
||||||
%patch083 -p1
|
%patch083 -p1
|
||||||
|
%patch084 -p1
|
||||||
|
@ -81,3 +81,4 @@ gdb-rhbz2022177-dprintf-1.patch
|
|||||||
gdb-rhbz2022177-dprintf-2.patch
|
gdb-rhbz2022177-dprintf-2.patch
|
||||||
gdb-rhbz2024875-expand-documentation-for-debuginfod.patch
|
gdb-rhbz2024875-expand-documentation-for-debuginfod.patch
|
||||||
gdb-rhbz2024875-set_show-for-managing-debuginfod.patch
|
gdb-rhbz2024875-set_show-for-managing-debuginfod.patch
|
||||||
|
gdb-rhbz2024875-fix-unittest-failure.patch
|
||||||
|
37
gdb-rhbz2024875-fix-unittest-failure.patch
Normal file
37
gdb-rhbz2024875-fix-unittest-failure.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Alexandra=20H=C3=A1jkov=C3=A1?= <ahajkova@redhat.com>
|
||||||
|
Date: Tue, 11 Jan 2022 12:22:29 +0100
|
||||||
|
Subject: gdb-rhbz2024875-fix-unittest-failure.patch
|
||||||
|
|
||||||
|
;;Backport upstream commit from Tom Tromey
|
||||||
|
;;2a8f1f47446 Fix unittest.exp failure due to 'set debuginfod' addition
|
||||||
|
|
||||||
|
Fix unittest.exp failure due to 'set debuginfod' addition
|
||||||
|
|
||||||
|
The 'set debuginfod' change caused a regression in unittest.exp:
|
||||||
|
|
||||||
|
Running selftest help_doc_invariants.
|
||||||
|
help doc broken invariant: command 'info set debuginfod' help doc first line is not terminated with a '.' character
|
||||||
|
help doc broken invariant: command 'set debuginfod' help doc first line is not terminated with a '.' character
|
||||||
|
help doc broken invariant: command 'show debuginfod' help doc first line is not terminated with a '.' character
|
||||||
|
Self test failed: self-test failed at ../../binutils-gdb/gdb/unittests/command-def-selftests.c:100
|
||||||
|
|
||||||
|
This patch fixes the problem. I'm checking it in.
|
||||||
|
|
||||||
|
diff --git a/gdb/debuginfod-support.c b/gdb/debuginfod-support.c
|
||||||
|
--- a/gdb/debuginfod-support.c
|
||||||
|
+++ b/gdb/debuginfod-support.c
|
||||||
|
@@ -390,11 +390,11 @@ _initialize_debuginfod ()
|
||||||
|
{
|
||||||
|
/* set/show debuginfod */
|
||||||
|
add_basic_prefix_cmd ("debuginfod", class_run,
|
||||||
|
- _("Set debuginfod options"),
|
||||||
|
+ _("Set debuginfod options."),
|
||||||
|
&set_debuginfod_prefix_list, 0, &setlist);
|
||||||
|
|
||||||
|
add_show_prefix_cmd ("debuginfod", class_run,
|
||||||
|
- _("Show debuginfod options"),
|
||||||
|
+ _("Show debuginfod option."),
|
||||||
|
&show_debuginfod_prefix_list, 0, &showlist);
|
||||||
|
|
||||||
|
/* set debuginfod on */
|
4
gdb.spec
4
gdb.spec
@ -1144,6 +1144,10 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 11 2021 Alexandra Hájková - 11.1-8
|
||||||
|
- Backport upstream patch "Fix unittest.exp failure due to 'set debuginfod' addition"
|
||||||
|
(RHBZ 2024875, Tom Tromey).
|
||||||
|
|
||||||
* Mon Jan 10 2021 Alexandra Hájková - 11.1-8
|
* Mon Jan 10 2021 Alexandra Hájková - 11.1-8
|
||||||
- Add -Wno-unused-function to --enable-gdb-build-warnings to prevent the build failure:
|
- Add -Wno-unused-function to --enable-gdb-build-warnings to prevent the build failure:
|
||||||
"../../gdb/c-exp.y:3455:1: error: 'void c_print_token(FILE*, int, YYSTYPE)'
|
"../../gdb/c-exp.y:3455:1: error: 'void c_print_token(FILE*, int, YYSTYPE)'
|
||||||
|
Loading…
Reference in New Issue
Block a user