[dts+el7] [x86*] Bundle libipt - fix#2 its initialization (RH BZ 1256513).
This commit is contained in:
parent
92d45fce5d
commit
aacdec2a04
@ -208,13 +208,14 @@ Index: gdb-7.11.1/gdb/configure.ac
|
||||
if test "$perf_event" != yes; then
|
||||
--- gdb-7.11.1/gdb/gdb.c-orig 2016-02-10 04:19:39.000000000 +0100
|
||||
+++ gdb-7.11.1/gdb/gdb.c 2016-08-23 09:15:13.169650953 +0200
|
||||
@@ -25,6 +25,10 @@ main (int argc, char **argv)
|
||||
@@ -25,6 +25,11 @@ main (int argc, char **argv)
|
||||
{
|
||||
struct captured_main_args args;
|
||||
|
||||
+ // RHEL DTS bundle:
|
||||
+#ifdef PERF_ATTR_SIZE_VER5_BUNDLE
|
||||
+ extern void __libipt_init(void);
|
||||
+ __libipt_init();
|
||||
+#endif
|
||||
+
|
||||
memset (&args, 0, sizeof args);
|
||||
args.argc = argc;
|
||||
|
5
gdb.spec
5
gdb.spec
@ -27,7 +27,7 @@ Version: 7.11.1
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 81%{?dist}
|
||||
Release: 82%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1457,6 +1457,9 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Tue Aug 23 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11.1-82.fc24
|
||||
- [dts+el7] [x86*] Bundle libipt - fix#2 its initialization (RH BZ 1256513).
|
||||
|
||||
* Tue Aug 23 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11.1-81.fc24
|
||||
- [dts+el7] [x86*] Bundle libipt - fix its initialization (RH BZ 1256513).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user