- Modify previous gcore patch to not use linux_proc_xfer_memory even for
main thread.
This commit is contained in:
parent
28fdd9467e
commit
9dde329b20
@ -1,11 +1,11 @@
|
|||||||
2005-02-07 Jeff Johnston <jjohnstn@redhat.com>
|
2005-02-07 Jeff Johnston <jjohnstn@redhat.com>
|
||||||
|
|
||||||
* linux-nat.c (linux_nat_xfer_memory): Don't use
|
* linux-nat.c (linux_nat_xfer_memory): Don't use
|
||||||
linux_proc_xfer_memory for ia64 threads.
|
linux_proc_xfer_memory for ia64.
|
||||||
|
|
||||||
--- gdb-6.3/gdb/linux-nat.c.fix Fri Feb 4 22:52:40 2005
|
--- gdb-6.3/gdb/linux-nat.c.fix Fri Feb 4 22:52:40 2005
|
||||||
+++ gdb-6.3/gdb/linux-nat.c Mon Feb 7 19:56:01 2005
|
+++ gdb-6.3/gdb/linux-nat.c Tue Feb 8 15:49:09 2005
|
||||||
@@ -2381,12 +2381,31 @@ linux_nat_xfer_memory (CORE_ADDR memaddr
|
@@ -2381,12 +2381,22 @@ linux_nat_xfer_memory (CORE_ADDR memaddr
|
||||||
struct cleanup *old_chain = save_inferior_ptid ();
|
struct cleanup *old_chain = save_inferior_ptid ();
|
||||||
int xfer;
|
int xfer;
|
||||||
|
|
||||||
@ -14,18 +14,9 @@
|
|||||||
+ for accessing thread storage. Revert when Bugzilla 147436
|
+ for accessing thread storage. Revert when Bugzilla 147436
|
||||||
+ is fixed. */
|
+ is fixed. */
|
||||||
+ if (is_lwp (inferior_ptid))
|
+ if (is_lwp (inferior_ptid))
|
||||||
+ {
|
+ inferior_ptid = pid_to_ptid (GET_LWP (inferior_ptid));
|
||||||
+ /* For lwps, we cannot use linux_proc_xfer_memory. */
|
+
|
||||||
+ inferior_ptid = pid_to_ptid (GET_LWP (inferior_ptid));
|
+ xfer = child_xfer_memory (memaddr, myaddr, len, write, attrib, target);
|
||||||
+ xfer = child_xfer_memory (memaddr, myaddr, len, write, attrib, target);
|
|
||||||
+ }
|
|
||||||
+ else
|
|
||||||
+ {
|
|
||||||
+ xfer = linux_proc_xfer_memory (memaddr, myaddr, len, write,
|
|
||||||
+ attrib, target);
|
|
||||||
+ if (xfer == 0)
|
|
||||||
+ xfer = child_xfer_memory (memaddr, myaddr, len, write, attrib, target);
|
|
||||||
+ }
|
|
||||||
+#else
|
+#else
|
||||||
if (is_lwp (inferior_ptid))
|
if (is_lwp (inferior_ptid))
|
||||||
inferior_ptid = pid_to_ptid (GET_LWP (inferior_ptid));
|
inferior_ptid = pid_to_ptid (GET_LWP (inferior_ptid));
|
||||||
|
6
gdb.spec
6
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
|||||||
Version: 6.3.0.0
|
Version: 6.3.0.0
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 0.
|
# The release always contains a leading reserved number, start it at 0.
|
||||||
Release: 0.17
|
Release: 0.18
|
||||||
|
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -418,6 +418,10 @@ fi
|
|||||||
# don't include the files in include, they are part of binutils
|
# don't include the files in include, they are part of binutils
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 08 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.18
|
||||||
|
- Modify previous gcore patch to not use linux_proc_xfer_memory even
|
||||||
|
for main thread.
|
||||||
|
|
||||||
* Mon Feb 07 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.17
|
* Mon Feb 07 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.17
|
||||||
- Modify previous gcore patch to only apply to ia64.
|
- Modify previous gcore patch to only apply to ia64.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user