- Bump up release number.
Mon Feb 14 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.24 - Fix gdb to always grab the terminal before a readline call. - Bugzilla 147880
This commit is contained in:
parent
3eb6817783
commit
955cd49926
31
gdb-6.3-terminal-fix-20050214.patch
Normal file
31
gdb-6.3-terminal-fix-20050214.patch
Normal file
@ -0,0 +1,31 @@
|
||||
2005-02-14 Jeff Johnston <jjohnstn@redhat.com>
|
||||
|
||||
* top.c (gdb_readline_wrapper): Ensure terminal is gdb's before calling
|
||||
readline.
|
||||
|
||||
--- gdb-6.3/gdb/top.c.fix 2005-02-14 16:28:56.000000000 -0500
|
||||
+++ gdb-6.3/gdb/top.c 2005-02-14 16:30:20.000000000 -0500
|
||||
@@ -1,7 +1,7 @@
|
||||
/* Top level stuff for GDB, the GNU debugger.
|
||||
|
||||
Copyright 1986, 1987, 1988, 1989, 1990, 1991, 1992, 1993, 1994,
|
||||
- 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004
|
||||
+ 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
|
||||
Free Software Foundation, Inc.
|
||||
|
||||
This file is part of GDB.
|
||||
@@ -982,6 +982,14 @@ gdb_readline_wrapper (char *prompt)
|
||||
after_char_processing_hook = NULL;
|
||||
}
|
||||
|
||||
+ /* Before calling readline, ensure we have the terminal. If we don't
|
||||
+ have the terminal and call readline, we risk the possibility of
|
||||
+ gdb being thrown into the background. This problem occurs when
|
||||
+ we attach to a background process on the same terminal the background
|
||||
+ process was started from and then perform some action which requires
|
||||
+ a page break prompt. */
|
||||
+ terminal_ours ();
|
||||
+
|
||||
return readline (prompt);
|
||||
}
|
||||
|
13
gdb.spec
13
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
||||
Version: 6.3.0.0
|
||||
|
||||
# The release always contains a leading reserved number, start it at 0.
|
||||
Release: 0.23
|
||||
Release: 0.25
|
||||
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
@ -180,6 +180,9 @@ Patch140: gdb-6.3-gcore-thread-20050204.patch
|
||||
# Fix stepping over thread exit
|
||||
Patch141: gdb-6.3-step-thread-exit-20050211.patch
|
||||
|
||||
# Prevent gdb from being pushed into background
|
||||
Patch142: gdb-6.3-terminal-fix-20050214.patch
|
||||
|
||||
%ifarch ia64
|
||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu libunwind >= 0.96-3
|
||||
%else
|
||||
@ -254,6 +257,7 @@ and printing their data.
|
||||
%patch139 -p1
|
||||
%patch140 -p1
|
||||
%patch141 -p1
|
||||
%patch142 -p1
|
||||
|
||||
# Change the version that gets printed at GDB startup, so it is RedHat
|
||||
# specific.
|
||||
@ -422,6 +426,13 @@ fi
|
||||
# don't include the files in include, they are part of binutils
|
||||
|
||||
%changelog
|
||||
* Mon Feb 14 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.25
|
||||
- Bump up release number.
|
||||
|
||||
* Mon Feb 14 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.24
|
||||
- Fix gdb to always grab the terminal before a readline call.
|
||||
- Bugzilla 147880
|
||||
|
||||
* Fri Feb 11 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.23
|
||||
- Bump up release number.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user