- The Koji build failures may have been by forgotten check-in of the
Patch360.
This commit is contained in:
parent
dc95c8ce1c
commit
94cd124608
105
gdb-6.8-bz457187-largefile-test.patch
Executable file
105
gdb-6.8-bz457187-largefile-test.patch
Executable file
@ -0,0 +1,105 @@
|
||||
--- /dev/null 2009-04-19 14:49:00.974648389 +0200
|
||||
+++ gdb-6.8/gdb/testsuite/gdb.arch/i386-biarch-core.exp 2009-04-19 16:30:12.000000000 +0200
|
||||
@@ -0,0 +1,61 @@
|
||||
+# This testcase is part of GDB, the GNU debugger.
|
||||
+
|
||||
+# Copyright 2009 Free Software Foundation, Inc.
|
||||
+
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 2 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program; if not, write to the Free Software
|
||||
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+
|
||||
+# Test ability to load an elf64-i386 core file. The provided core file was
|
||||
+# elf64-x8664 one but it got binary patched to i386:
|
||||
+# Elf32_Ehdr.e_machine @0x12..0x13
|
||||
+# Elf64_Ehdr.e_machine @0x12..0x13
|
||||
+# #define EM_386 3 /* Intel 80386 */
|
||||
+# #define EM_X86_64 62 /* AMD x86-64 architecture */
|
||||
+# patch @0x12: 0x3E -> 0x03
|
||||
+
|
||||
+if { ![istarget "i?86-*-*"] && ![istarget "x86_64-*-*"] } then {
|
||||
+ verbose "Skipping i386-biarch-core test."
|
||||
+ return
|
||||
+}
|
||||
+
|
||||
+set testfile "i386-biarch-core"
|
||||
+set corebz2uufile ${srcdir}/${subdir}/${testfile}.core.bz2.uu
|
||||
+set corefile ${objdir}/${subdir}/${testfile}.core
|
||||
+# Entry point of the original executable.
|
||||
+set address 0x400078
|
||||
+
|
||||
+if {[catch "system \"uudecode -o - ${corebz2uufile} | bzip2 -dc >${corefile}\""] != 0} {
|
||||
+ untested "failed uudecode or bzip2"
|
||||
+ return -1
|
||||
+}
|
||||
+file stat ${corefile} corestat
|
||||
+if {$corestat(size) != 102400} {
|
||||
+ untested "uudecode or bzip2 produce invalid result"
|
||||
+ return -1
|
||||
+}
|
||||
+
|
||||
+gdb_exit
|
||||
+gdb_start
|
||||
+gdb_reinitialize_dir $srcdir/$subdir
|
||||
+
|
||||
+# Wrongly built GDB complains by:
|
||||
+# "..." is not a core dump: File format not recognized
|
||||
+# As the provided test core has 64bit PRSTATUS i386 built GDB cannot parse it.
|
||||
+# This is just a problem of the test care, real-world elf64-i386 file will have
|
||||
+# 32bit PRSTATUS. One cannot prepare elf64-i386 core file from elf32-i386 by
|
||||
+# objcopy as it corrupts the core file beyond all recognition.
|
||||
+# "\r\nCore was generated by `\[^\r\n\]*'\\.\r\nProgram terminated with signal 11, Segmentation fault\\.\r\n.*"
|
||||
+gdb_test "core-file ${corefile}"
|
||||
+
|
||||
+gdb_test "x/i $address" "\r\n$address:\[ \t\]*hlt\[ \t\]*" ".text is readable"
|
||||
--- /dev/null 2009-04-19 14:49:00.974648389 +0200
|
||||
+++ gdb-6.8/gdb/testsuite/gdb.arch/i386-biarch-core.S 2009-04-19 14:52:28.000000000 +0200
|
||||
@@ -0,0 +1,22 @@
|
||||
+/* This testcase is part of GDB, the GNU debugger.
|
||||
+
|
||||
+ Copyright 2009 Free Software Foundation, Inc.
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 2 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program; if not, write to the Free Software
|
||||
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+ */
|
||||
+
|
||||
+ .globl _start
|
||||
+_start:
|
||||
+ hlt
|
||||
--- /dev/null 2009-04-19 14:49:00.974648389 +0200
|
||||
+++ gdb-6.8/gdb/testsuite/gdb.arch/i386-biarch-core.core.bz2.uu 2009-04-19 15:02:12.000000000 +0200
|
||||
@@ -0,0 +1,13 @@
|
||||
+begin 600 i386-biarch-core.core.bz2
|
||||
+M0EIH.3%!629361`P1\P`!)?_____\9'@"8Q)6P380'9@'&#`0D@``"``%(``
|
||||
+M@`#`"!<(L`%F"(:$GH13::F-)M&D&U,AD:`--#)M0&FT0XR9--,)D9`P(Q-&
|
||||
+M",(-&F``02)%38HT]0T`&AH```'H@``T^>9T*(,("&)SE`>`9@+GP=[,N)KB
|
||||
+M'I8BL(L]N5TCY\%V]/?DB.BN*UZ'U@]TN7-]UJ5\_%0QTT<*086#%MHT7XVJ
|
||||
+M9D"+C!"2*L:8D1XPD!`--M@*XT1H5RFYN&)(!0P0#:`I:;2;$5M&\*9"0@%:
|
||||
+MK@X[T()M)9N7`D$VA!^63)%,;@8LT`(7\K&[7G;U:"B6'!GG+46ALOZF.2F-
|
||||
+M!@>C*%86X$-]C2`KE;HG)UL(913VR2G]0BD:J=Z_`G@S,`W%.8RMS-#5P:J0
|
||||
+MAJ2\8&X?@DE;UF68QHM<,D`('::J65/S:PAG*R-09["8DBI)'V]Y.[(/AM*L
|
||||
+M"X_O^V;%FY.S6Q]FM=D37>5F,%4-F1ZF#,CFJVU;H*^IT<(%<V`.32$`JU["
|
||||
+/G`68?\7<D4X4)`0,$?,`
|
||||
+`
|
||||
+end
|
6
gdb.spec
6
gdb.spec
@ -13,7 +13,7 @@ Version: 6.8.50.20090302
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 24%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 25%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -390,7 +390,6 @@ BuildRequires: readline-devel
|
||||
BuildRequires: rpm-devel
|
||||
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
|
||||
Requires: python-libs
|
||||
BuildPreReq: python
|
||||
BuildRequires: python-devel
|
||||
# Temporarily before it gets moved to libstdc++.rpm
|
||||
BuildRequires: libstdc++
|
||||
@ -862,6 +861,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Apr 27 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-25
|
||||
- The Koji build failures may have been by forgotten check-in of the Patch360.
|
||||
|
||||
* Mon Apr 27 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-24
|
||||
- Another new Koji build fix attempt now by: BuildPreReq: python
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user