- Support constant DW_AT_data_member_location by GCC PR debug/40659 (BZ
515377). - Fix .spec URL. - archer-jankratochvil-fedora12 commit: 81de3c6abae4f7e3738aa9bcc0ab2f8725cce252
This commit is contained in:
parent
273e7e98b2
commit
912c39689b
@ -1 +1 @@
|
||||
gdb-6.8.50.20090810.tar.bz2
|
||||
gdb-6.8.50.20090811.tar.bz2
|
||||
|
@ -1021,7 +1021,7 @@ Index: gdb-6.8.50.20090809/gdb/solib.c
|
||||
/*
|
||||
|
||||
GLOBAL FUNCTION
|
||||
@@ -449,14 +453,38 @@ symbol_add_stub (struct so_list *so, int
|
||||
@@ -453,14 +453,38 @@ symbol_add_stub (struct so_list *so, int
|
||||
/* Have we already loaded this shared object? */
|
||||
ALL_OBJFILES (so->objfile)
|
||||
{
|
||||
@ -1061,7 +1061,7 @@ Index: gdb-6.8.50.20090809/gdb/solib.c
|
||||
+
|
||||
p_refcount = xmalloc (sizeof (*p_refcount));
|
||||
*p_refcount = 2; /* Both solib and objfile refer to this abfd. */
|
||||
so->abfd->usrdata = p_refcount;
|
||||
bfd_usrdata (so->abfd) = p_refcount;
|
||||
@@ -600,6 +628,10 @@ update_solib_list (int from_tty, struct
|
||||
}
|
||||
else
|
||||
|
@ -138,28 +138,24 @@ Index: gdb-6.8.50.20090802/gdb/amd64-tdep.c
|
||||
(*this_id) = frame_id_build (cache->base + 16, cache->pc);
|
||||
}
|
||||
|
||||
Index: gdb-6.8.50.20090802/gdb/i386-tdep.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090802.orig/gdb/i386-tdep.c 2009-07-12 19:46:21.000000000 +0200
|
||||
+++ gdb-6.8.50.20090802/gdb/i386-tdep.c 2009-08-03 15:50:08.000000000 +0200
|
||||
@@ -5307,6 +5307,9 @@ i386_gdbarch_init (struct gdbarch_info i
|
||||
--- gdb-6.8.50.20090811/gdb/i386-tdep.c.orig 2009-08-10 05:02:39.000000000 +0200
|
||||
+++ gdb-6.8.50.20090811/gdb/i386-tdep.c 2009-08-11 16:33:51.000000000 +0200
|
||||
@@ -5432,6 +5432,9 @@ i386_gdbarch_init (struct gdbarch_info i
|
||||
tdep->sc_pc_offset = -1;
|
||||
tdep->sc_sp_offset = -1;
|
||||
|
||||
+ /* Unwinding stops on i386 automatically. */
|
||||
+ tdep->outermost_frame_p = NULL;
|
||||
+
|
||||
tdep->record_regmap = i386_record_regmap;
|
||||
|
||||
/* The format used for `long double' on almost all i386 targets is
|
||||
the i387 extended floating-point format. In fact, of all targets
|
||||
in the GCC 2.95 tree, only OSF/1 does it different, and insists
|
||||
Index: gdb-6.8.50.20090802/gdb/i386-tdep.h
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090802.orig/gdb/i386-tdep.h 2009-07-02 19:25:54.000000000 +0200
|
||||
+++ gdb-6.8.50.20090802/gdb/i386-tdep.h 2009-08-03 15:50:29.000000000 +0200
|
||||
@@ -115,6 +115,9 @@ struct gdbarch_tdep
|
||||
int (*i386_intx80_record) (struct regcache *regcache);
|
||||
/* Parse sysenter args. */
|
||||
--- gdb-6.8.50.20090811/gdb/i386-tdep.h.orig 2009-08-10 05:02:39.000000000 +0200
|
||||
+++ gdb-6.8.50.20090811/gdb/i386-tdep.h 2009-08-11 16:34:08.000000000 +0200
|
||||
@@ -120,6 +120,9 @@ struct gdbarch_tdep
|
||||
int (*i386_sysenter_record) (struct regcache *regcache);
|
||||
/* Parse syscall args. */
|
||||
int (*i386_syscall_record) (struct regcache *regcache);
|
||||
+
|
||||
+ /* Detect OS dependent outermost frames; such as `clone'. */
|
||||
+ int (*outermost_frame_p) (struct frame_info *this_frame);
|
||||
|
972
gdb-archer.patch
972
gdb-archer.patch
File diff suppressed because it is too large
Load Diff
17
gdb.spec
17
gdb.spec
@ -10,15 +10,15 @@ Name: gdb%{?_with_debug:-debug}
|
||||
# Set version to contents of gdb/version.in.
|
||||
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
|
||||
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
|
||||
Version: 6.8.50.20090810
|
||||
Version: 6.8.50.20090811
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 2%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 1%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
Source: ftp://sourceware.org/pub/gdb/releases/gdb-%{version}.tar.bz2
|
||||
Source: ftp://sourceware.org/pub/gdb/snapshots/current/gdb-%{version}.tar.bz2
|
||||
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
URL: http://gnu.org/software/gdb/
|
||||
|
||||
@ -217,8 +217,8 @@ Patch229: gdb-6.3-bz140532-ppc-unwinding-test.patch
|
||||
# Testcase for exec() from threaded program (BZ 202689).
|
||||
Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
||||
|
||||
# Backported post gdb-6.8.50.20090810 snapshot fixups.
|
||||
#Patch232: gdb-6.8.50.20090810-upstream.patch
|
||||
# Backported post gdb-6.8.50.20090811 snapshot fixups.
|
||||
#Patch232: gdb-6.8.50.20090811-upstream.patch
|
||||
|
||||
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
||||
Patch234: gdb-6.6-bz230000-power6-disassembly-test.patch
|
||||
@ -825,7 +825,12 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Aug 10 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090810-1
|
||||
* Tue Aug 11 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090811-1
|
||||
- Support constant DW_AT_data_member_location by GCC PR debug/40659 (BZ 515377).
|
||||
- Fix .spec URL.
|
||||
- archer-jankratochvil-fedora12 commit: 81de3c6abae4f7e3738aa9bcc0ab2f8725cce252
|
||||
|
||||
* Mon Aug 10 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090810-2
|
||||
- Upgrade to the FSF GDB gdb-6.8.50 snapshot: 6.8.50.20090810
|
||||
- archer-jankratochvil-fedora12 commit: 93ec16e6f5000dd64d433d86674e820ed0f35b72
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user