Fix compilation error by upstream symfile.c fix.
This commit is contained in:
parent
d6851d1cc9
commit
8dde8d1082
@ -2595,3 +2595,139 @@ Date: Wed Apr 27 21:27:40 2016 +0200
|
|||||||
/* Next, we possibly activate noack mode.
|
/* Next, we possibly activate noack mode.
|
||||||
|
|
||||||
If the QStartNoAckMode packet configuration is set to AUTO,
|
If the QStartNoAckMode packet configuration is set to AUTO,
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
commit b631e59ba05af7c888838d3e2d6d408bfe60b57f
|
||||||
|
Author: Kyrylo Tkachov <kyrylo.tkachov@arm.com>
|
||||||
|
Date: Tue May 3 09:40:54 2016 +0100
|
||||||
|
|
||||||
|
[gdb] Fix -Wparentheses warnings
|
||||||
|
|
||||||
|
2016-05-03 Kyrylo Tkachov <kyrylo.tkachov@arm.com>
|
||||||
|
|
||||||
|
* symfile.c (find_pc_overlay): Add braces to avoid -Wparentheses
|
||||||
|
warning.
|
||||||
|
(find_pc_mapped_section): Likewise.
|
||||||
|
(list_overlays_command): Likewise.
|
||||||
|
|
||||||
|
### a/gdb/ChangeLog
|
||||||
|
### b/gdb/ChangeLog
|
||||||
|
## -1,3 +1,10 @@
|
||||||
|
+2016-05-03 Kyrylo Tkachov <kyrylo.tkachov@arm.com>
|
||||||
|
+
|
||||||
|
+ * symfile.c (find_pc_overlay): Add braces to avoid -Wparentheses
|
||||||
|
+ warning.
|
||||||
|
+ (find_pc_mapped_section): Likewise.
|
||||||
|
+ (list_overlays_command): Likewise.
|
||||||
|
+
|
||||||
|
2016-05-02 Eli Zaretskii <eliz@gnu.org>
|
||||||
|
|
||||||
|
* windows-nat.c (_initialize_check_for_gdb_ini): Fix off-by-one
|
||||||
|
--- a/gdb/symfile.c
|
||||||
|
+++ b/gdb/symfile.c
|
||||||
|
@@ -3285,19 +3285,21 @@ find_pc_overlay (CORE_ADDR pc)
|
||||||
|
struct obj_section *osect, *best_match = NULL;
|
||||||
|
|
||||||
|
if (overlay_debugging)
|
||||||
|
- ALL_OBJSECTIONS (objfile, osect)
|
||||||
|
- if (section_is_overlay (osect))
|
||||||
|
- {
|
||||||
|
- if (pc_in_mapped_range (pc, osect))
|
||||||
|
+ {
|
||||||
|
+ ALL_OBJSECTIONS (objfile, osect)
|
||||||
|
+ if (section_is_overlay (osect))
|
||||||
|
{
|
||||||
|
- if (section_is_mapped (osect))
|
||||||
|
- return osect;
|
||||||
|
- else
|
||||||
|
+ if (pc_in_mapped_range (pc, osect))
|
||||||
|
+ {
|
||||||
|
+ if (section_is_mapped (osect))
|
||||||
|
+ return osect;
|
||||||
|
+ else
|
||||||
|
+ best_match = osect;
|
||||||
|
+ }
|
||||||
|
+ else if (pc_in_unmapped_range (pc, osect))
|
||||||
|
best_match = osect;
|
||||||
|
}
|
||||||
|
- else if (pc_in_unmapped_range (pc, osect))
|
||||||
|
- best_match = osect;
|
||||||
|
- }
|
||||||
|
+ }
|
||||||
|
return best_match;
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -3312,9 +3314,11 @@ find_pc_mapped_section (CORE_ADDR pc)
|
||||||
|
struct obj_section *osect;
|
||||||
|
|
||||||
|
if (overlay_debugging)
|
||||||
|
- ALL_OBJSECTIONS (objfile, osect)
|
||||||
|
- if (pc_in_mapped_range (pc, osect) && section_is_mapped (osect))
|
||||||
|
- return osect;
|
||||||
|
+ {
|
||||||
|
+ ALL_OBJSECTIONS (objfile, osect)
|
||||||
|
+ if (pc_in_mapped_range (pc, osect) && section_is_mapped (osect))
|
||||||
|
+ return osect;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
return NULL;
|
||||||
|
}
|
||||||
|
@@ -3330,31 +3334,33 @@ list_overlays_command (char *args, int from_tty)
|
||||||
|
struct obj_section *osect;
|
||||||
|
|
||||||
|
if (overlay_debugging)
|
||||||
|
- ALL_OBJSECTIONS (objfile, osect)
|
||||||
|
+ {
|
||||||
|
+ ALL_OBJSECTIONS (objfile, osect)
|
||||||
|
if (section_is_mapped (osect))
|
||||||
|
- {
|
||||||
|
- struct gdbarch *gdbarch = get_objfile_arch (objfile);
|
||||||
|
- const char *name;
|
||||||
|
- bfd_vma lma, vma;
|
||||||
|
- int size;
|
||||||
|
-
|
||||||
|
- vma = bfd_section_vma (objfile->obfd, osect->the_bfd_section);
|
||||||
|
- lma = bfd_section_lma (objfile->obfd, osect->the_bfd_section);
|
||||||
|
- size = bfd_get_section_size (osect->the_bfd_section);
|
||||||
|
- name = bfd_section_name (objfile->obfd, osect->the_bfd_section);
|
||||||
|
-
|
||||||
|
- printf_filtered ("Section %s, loaded at ", name);
|
||||||
|
- fputs_filtered (paddress (gdbarch, lma), gdb_stdout);
|
||||||
|
- puts_filtered (" - ");
|
||||||
|
- fputs_filtered (paddress (gdbarch, lma + size), gdb_stdout);
|
||||||
|
- printf_filtered (", mapped at ");
|
||||||
|
- fputs_filtered (paddress (gdbarch, vma), gdb_stdout);
|
||||||
|
- puts_filtered (" - ");
|
||||||
|
- fputs_filtered (paddress (gdbarch, vma + size), gdb_stdout);
|
||||||
|
- puts_filtered ("\n");
|
||||||
|
-
|
||||||
|
- nmapped++;
|
||||||
|
- }
|
||||||
|
+ {
|
||||||
|
+ struct gdbarch *gdbarch = get_objfile_arch (objfile);
|
||||||
|
+ const char *name;
|
||||||
|
+ bfd_vma lma, vma;
|
||||||
|
+ int size;
|
||||||
|
+
|
||||||
|
+ vma = bfd_section_vma (objfile->obfd, osect->the_bfd_section);
|
||||||
|
+ lma = bfd_section_lma (objfile->obfd, osect->the_bfd_section);
|
||||||
|
+ size = bfd_get_section_size (osect->the_bfd_section);
|
||||||
|
+ name = bfd_section_name (objfile->obfd, osect->the_bfd_section);
|
||||||
|
+
|
||||||
|
+ printf_filtered ("Section %s, loaded at ", name);
|
||||||
|
+ fputs_filtered (paddress (gdbarch, lma), gdb_stdout);
|
||||||
|
+ puts_filtered (" - ");
|
||||||
|
+ fputs_filtered (paddress (gdbarch, lma + size), gdb_stdout);
|
||||||
|
+ printf_filtered (", mapped at ");
|
||||||
|
+ fputs_filtered (paddress (gdbarch, vma), gdb_stdout);
|
||||||
|
+ puts_filtered (" - ");
|
||||||
|
+ fputs_filtered (paddress (gdbarch, vma + size), gdb_stdout);
|
||||||
|
+ puts_filtered ("\n");
|
||||||
|
+
|
||||||
|
+ nmapped++;
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
if (nmapped == 0)
|
||||||
|
printf_filtered (_("No sections are mapped.\n"));
|
||||||
|
}
|
||||||
|
5
gdb.spec
5
gdb.spec
@ -27,7 +27,7 @@ Version: 7.11
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 72%{?dist}
|
Release: 73%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1401,6 +1401,9 @@ then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 3 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11-73.fc24
|
||||||
|
- Fix compilation error by upstream symfile.c fix.
|
||||||
|
|
||||||
* Tue May 3 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11-72.fc24
|
* Tue May 3 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11-72.fc24
|
||||||
- Fix messages suggesting more recent RHEL gdbserver (RH BZ 1321114).
|
- Fix messages suggesting more recent RHEL gdbserver (RH BZ 1321114).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user