- Drop gdb-6.8-glibc-headers-compat.patch: GNU/Linux irrelevant (Tom Tromey).
This commit is contained in:
parent
336050181d
commit
8b8af94462
@ -1,28 +0,0 @@
|
|||||||
2005-02-14 Jeff Johnston <jjohnstn@redhat.com>
|
|
||||||
|
|
||||||
* top.c (gdb_readline_wrapper): Ensure terminal is gdb's before calling
|
|
||||||
readline.
|
|
||||||
|
|
||||||
2007-10-14 Jan Kratochvil <jan.kratochvil@redhat.com>
|
|
||||||
|
|
||||||
Port to GDB-6.7.
|
|
||||||
|
|
||||||
Index: gdb-6.7/gdb/top.c
|
|
||||||
===================================================================
|
|
||||||
--- gdb-6.7.orig/gdb/top.c 2007-09-02 23:13:56.000000000 +0200
|
|
||||||
+++ gdb-6.7/gdb/top.c 2007-10-14 23:38:27.000000000 +0200
|
|
||||||
@@ -795,6 +795,14 @@ gdb_readline_wrapper (char *prompt)
|
|
||||||
|
|
||||||
back_to = make_cleanup (gdb_readline_wrapper_cleanup, cleanup);
|
|
||||||
|
|
||||||
+ /* Before calling readline, ensure we have the terminal. If we don't
|
|
||||||
+ have the terminal and call readline, we risk the possibility of
|
|
||||||
+ gdb being thrown into the background. This problem occurs when
|
|
||||||
+ we attach to a background process on the same terminal the background
|
|
||||||
+ process was started from and then perform some action which requires
|
|
||||||
+ a page break prompt. */
|
|
||||||
+ terminal_ours ();
|
|
||||||
+
|
|
||||||
/* Display our prompt and prevent double prompt display. */
|
|
||||||
display_gdb_prompt (prompt);
|
|
||||||
rl_already_prompted = 1;
|
|
5
gdb.spec
5
gdb.spec
@ -159,10 +159,6 @@ Patch141: gdb-6.6-step-thread-exit.patch
|
|||||||
#=push
|
#=push
|
||||||
Patch259: gdb-6.3-step-thread-exit-20050211-test.patch
|
Patch259: gdb-6.3-step-thread-exit-20050211-test.patch
|
||||||
|
|
||||||
# Prevent gdb from being pushed into background
|
|
||||||
#=maybepush
|
|
||||||
Patch142: gdb-6.3-terminal-fix-20050214.patch
|
|
||||||
|
|
||||||
# Test sibling threads to set threaded watchpoints for x86 and x86-64
|
# Test sibling threads to set threaded watchpoints for x86 and x86-64
|
||||||
#=fedoratest
|
#=fedoratest
|
||||||
Patch145: gdb-6.3-threaded-watchpoints2-20050225.patch
|
Patch145: gdb-6.3-threaded-watchpoints2-20050225.patch
|
||||||
@ -706,7 +702,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
|||||||
%patch140 -p1
|
%patch140 -p1
|
||||||
%patch141 -p1
|
%patch141 -p1
|
||||||
%patch259 -p1
|
%patch259 -p1
|
||||||
%patch142 -p1
|
|
||||||
%patch145 -p1
|
%patch145 -p1
|
||||||
%patch148 -p1
|
%patch148 -p1
|
||||||
%patch153 -p1
|
%patch153 -p1
|
||||||
|
Loading…
Reference in New Issue
Block a user