- archer-jankratochvil-fedora13 commit:
5a573e8b26a2f0a6947d4c0249e43e5456610860 - Remove ExcludeArch on ia64 as it is now fixed up.
This commit is contained in:
parent
a04bc95fa3
commit
8b7a3e1875
100
gdb-archer.patch
100
gdb-archer.patch
@ -2,7 +2,7 @@ http://sourceware.org/gdb/wiki/ProjectArcher
|
||||
http://sourceware.org/gdb/wiki/ArcherBranchManagement
|
||||
|
||||
GIT snapshot:
|
||||
commit 39c5a8b75fad3acd7204903db5dee025055a4594
|
||||
commit 5a573e8b26a2f0a6947d4c0249e43e5456610860
|
||||
|
||||
branch `archer' - the merge of branches:
|
||||
archer-tromey-delayed-symfile
|
||||
@ -1544,6 +1544,104 @@ index 8da6867..8e39254 100644
|
||||
ENABLE_CFLAGS="$ENABLE_CFLAGS \$(SUBDIR_PYTHON_CFLAGS)"
|
||||
|
||||
# Flags needed to compile Python code (taken from python-config --cflags).
|
||||
diff --git a/gdb/configure.tgt b/gdb/configure.tgt
|
||||
index 62e6683..2b9bb2f 100644
|
||||
--- a/gdb/configure.tgt
|
||||
+++ b/gdb/configure.tgt
|
||||
@@ -40,7 +40,7 @@ alpha*-*-osf*)
|
||||
alpha*-*-linux*)
|
||||
# Target: Little-endian Alpha running Linux
|
||||
gdb_target_obs="alpha-tdep.o alpha-mdebug-tdep.o alpha-linux-tdep.o \
|
||||
- solib.o solib-svr4.o"
|
||||
+ solib.o solib-svr4.o linux-tdep.o"
|
||||
;;
|
||||
alpha*-*-freebsd* | alpha*-*-kfreebsd*-gnu)
|
||||
# Target: FreeBSD/alpha
|
||||
@@ -67,7 +67,7 @@ alpha*-*-*)
|
||||
am33_2.0*-*-linux*)
|
||||
# Target: Matsushita mn10300 (AM33) running Linux
|
||||
gdb_target_obs="mn10300-tdep.o mn10300-linux-tdep.o corelow.o \
|
||||
- solib.o solib-svr4.o"
|
||||
+ solib.o solib-svr4.o linux-tdep.o"
|
||||
;;
|
||||
|
||||
arm*-wince-pe | arm*-*-mingw32ce*)
|
||||
@@ -233,7 +233,7 @@ i[34567]86-*-*)
|
||||
|
||||
ia64-*-linux*)
|
||||
# Target: Intel IA-64 running GNU/Linux
|
||||
- gdb_target_obs="ia64-tdep.o ia64-linux-tdep.o \
|
||||
+ gdb_target_obs="ia64-tdep.o ia64-linux-tdep.o linux-tdep.o \
|
||||
solib.o solib-svr4.o symfile-mem.o"
|
||||
build_gdbserver=yes
|
||||
;;
|
||||
@@ -263,7 +263,8 @@ m32c-*-*)
|
||||
m32r*-*-linux*)
|
||||
# Target: Renesas M32R running GNU/Linux
|
||||
gdb_target_obs="m32r-tdep.o m32r-linux-tdep.o remote-m32r-sdi.o \
|
||||
- glibc-tdep.o solib.o solib-svr4.o symfile-mem.o"
|
||||
+ glibc-tdep.o solib.o solib-svr4.o symfile-mem.o \
|
||||
+ linux-tdep.o"
|
||||
gdb_sim=../sim/m32r/libsim.a
|
||||
build_gdbserver=yes
|
||||
;;
|
||||
@@ -317,7 +318,7 @@ microblaze*-linux-*)
|
||||
# Target: Xilinx MicroBlaze running Linux
|
||||
gdb_target_obs="microblaze-tdep.o microblaze-linux-tdep.o microblaze-rom.o \
|
||||
monitor.o dsrec.o solib.o solib-svr4.o corelow.o \
|
||||
- symfile-mem.o"
|
||||
+ symfile-mem.o linux-tdep.o"
|
||||
gdb_sim=../sim/microblaze/libsim.a
|
||||
;;
|
||||
microblaze*-xilinx-*)
|
||||
@@ -337,7 +338,8 @@ mips*-sgi-irix6*)
|
||||
mips*-*-linux*)
|
||||
# Target: Linux/MIPS
|
||||
gdb_target_obs="mips-tdep.o mips-linux-tdep.o glibc-tdep.o \
|
||||
- corelow.o solib.o solib-svr4.o symfile-mem.o"
|
||||
+ corelow.o solib.o solib-svr4.o symfile-mem.o \
|
||||
+ linux-tdep.o"
|
||||
gdb_sim=../sim/mips/libsim.a
|
||||
build_gdbserver=yes
|
||||
;;
|
||||
@@ -427,7 +429,7 @@ sh*-*-linux*)
|
||||
# Target: GNU/Linux Super-H
|
||||
gdb_target_obs="sh-tdep.o sh64-tdep.o sh-linux-tdep.o monitor.o \
|
||||
dsrec.o solib.o solib-svr4.o symfile-mem.o \
|
||||
- glibc-tdep.o corelow.o"
|
||||
+ glibc-tdep.o corelow.o linux-tdep.o"
|
||||
gdb_sim=../sim/sh/libsim.a
|
||||
build_gdbserver=yes
|
||||
;;
|
||||
@@ -455,7 +457,8 @@ sh*)
|
||||
sparc-*-linux*)
|
||||
# Target: GNU/Linux SPARC
|
||||
gdb_target_obs="sparc-tdep.o sparc-sol2-tdep.o sol2-tdep.o \
|
||||
- sparc-linux-tdep.o solib.o solib-svr4.o symfile-mem.o"
|
||||
+ sparc-linux-tdep.o solib.o solib-svr4.o symfile-mem.o \
|
||||
+ linux-tdep.o"
|
||||
if test "x$enable_64_bit_bfd" = "xyes"; then
|
||||
# Target: GNU/Linux UltraSPARC
|
||||
gdb_target_obs="sparc64-tdep.o sparc64-sol2-tdep.o \
|
||||
@@ -466,7 +469,7 @@ sparc64-*-linux*)
|
||||
# Target: GNU/Linux UltraSPARC
|
||||
gdb_target_obs="sparc64-tdep.o sparc64-sol2-tdep.o sol2-tdep.o \
|
||||
sparc64-linux-tdep.o sparc-tdep.o sparc-sol2-tdep.o \
|
||||
- sparc-linux-tdep.o solib.o solib-svr4.o"
|
||||
+ sparc-linux-tdep.o solib.o solib-svr4.o linux-tdep.o"
|
||||
build_gdbserver=yes
|
||||
;;
|
||||
sparc*-*-freebsd* | sparc*-*-kfreebsd*-gnu)
|
||||
@@ -601,7 +604,8 @@ x86_64-*-openbsd*)
|
||||
xtensa*-*-linux*) gdb_target=linux
|
||||
# Target: GNU/Linux Xtensa
|
||||
gdb_target_obs="xtensa-tdep.o xtensa-config.o xtensa-linux-tdep.o \
|
||||
- solib.o solib-svr4.o corelow.o symfile-mem.o"
|
||||
+ solib.o solib-svr4.o corelow.o symfile-mem.o \
|
||||
+ linux-tdep.o"
|
||||
build_gdbserver=yes
|
||||
;;
|
||||
xtensa*)
|
||||
diff --git a/gdb/cp-name-parser.y b/gdb/cp-name-parser.y
|
||||
index 81f6a5d..097db65 100644
|
||||
--- a/gdb/cp-name-parser.y
|
||||
|
7
gdb.spec
7
gdb.spec
@ -36,7 +36,7 @@ Version: 7.0.50.20100128
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 11%{?_with_upstream:.upstream}%{dist}
|
||||
Release: 12%{?_with_upstream:.upstream}%{dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -45,7 +45,6 @@ Group: Development/Debuggers
|
||||
Source: ftp://sourceware.org/pub/gdb/snapshots/branch/gdb-%{version}.tar.bz2
|
||||
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
URL: http://gnu.org/software/gdb/
|
||||
ExcludeArch: ia64
|
||||
|
||||
# For our convenience
|
||||
%define gdb_src gdb-%{version}
|
||||
@ -1010,6 +1009,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Feb 1 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100128-12.fc13
|
||||
- archer-jankratochvil-fedora13 commit: 5a573e8b26a2f0a6947d4c0249e43e5456610860
|
||||
- Remove ExcludeArch on ia64 as it is now fixed up.
|
||||
|
||||
* Sun Jan 31 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100128-11.fc13
|
||||
- Fix failed gdb_assert due to the PIE patchset (BZ 559414).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user