- Archer update to the snapshot: 7c250ce99c90cf6097e2ec55ea0f205830979cee
- Archer backport: c14d9ab7eef43281b2052c885f89d2db96fb5f8e - Revert a change regressing: gdb.objc/basicclass.exp - Archer backport: ebd649b96e61a1fb481801b65d827bca998c6633 1f080e897996d60ab7fde20423e2947512115667 1948198702b51b31d79793fc49434b529b4e245f e107fb9687bb1e7f74170aa3d19c4a8f6edbb10f 1e012c996e121cb35053d239a46bd5dc65b0ce60 - Update the Python API from upstream. - Archer backport: d3c83ad5ec9f7672b87af9ad29279f459e53da11 - Fix a Python branch crash.
This commit is contained in:
parent
5b24c1447a
commit
88c9a17a81
@ -7,8 +7,8 @@ Removed dwarf_expr_frame_base NULL check duplicity with *-vla.patch.
|
||||
|
||||
Index: gdb-6.8.50.20090302/gdb/NEWS
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/NEWS 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/NEWS 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/NEWS 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/NEWS 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -1,6 +1,11 @@
|
||||
What has changed in GDB?
|
||||
(Organized release by release)
|
||||
@ -23,8 +23,8 @@ Index: gdb-6.8.50.20090302/gdb/NEWS
|
||||
* GDB now has support for multi-byte and wide character sets on the
|
||||
Index: gdb-6.8.50.20090302/gdb/block.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/block.c 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/block.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/block.c 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/block.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -47,8 +47,16 @@ contained_in (const struct block *a, con
|
||||
{
|
||||
if (!a || !b)
|
||||
@ -70,7 +70,7 @@ Index: gdb-6.8.50.20090302/gdb/block.c
|
||||
Index: gdb-6.8.50.20090302/gdb/block.h
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/block.h 2009-01-03 06:57:50.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/block.h 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/block.h 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -65,7 +65,7 @@ struct block
|
||||
CORE_ADDR endaddr;
|
||||
|
||||
@ -92,7 +92,7 @@ Index: gdb-6.8.50.20090302/gdb/block.h
|
||||
Index: gdb-6.8.50.20090302/gdb/blockframe.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/blockframe.c 2009-01-03 06:57:50.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/blockframe.c 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/blockframe.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -36,6 +36,7 @@
|
||||
#include "command.h"
|
||||
#include "gdbcmd.h"
|
||||
@ -163,8 +163,8 @@ Index: gdb-6.8.50.20090302/gdb/blockframe.c
|
||||
frame = get_prev_frame (frame);
|
||||
Index: gdb-6.8.50.20090302/gdb/breakpoint.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/breakpoint.c 2009-03-27 00:14:24.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/breakpoint.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/breakpoint.c 2009-04-13 22:19:50.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/breakpoint.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -2641,19 +2641,21 @@ watchpoint_check (void *p)
|
||||
within_current_scope = 1;
|
||||
else
|
||||
@ -244,7 +244,7 @@ Index: gdb-6.8.50.20090302/gdb/breakpoint.c
|
||||
b = set_raw_breakpoint (sal, type);
|
||||
b->enable_state = bp_enabled;
|
||||
b->disposition = disp_donttouch;
|
||||
@@ -6203,7 +6213,6 @@ watch_command_1 (char *arg, int accessfl
|
||||
@@ -6208,7 +6218,6 @@ watch_command_1 (char *arg, int accessfl
|
||||
struct block *exp_valid_block;
|
||||
struct value *val, *mark, *val_chain;
|
||||
struct frame_info *frame;
|
||||
@ -252,7 +252,7 @@ Index: gdb-6.8.50.20090302/gdb/breakpoint.c
|
||||
char *exp_start = NULL;
|
||||
char *exp_end = NULL;
|
||||
char *tok, *id_tok_start, *end_tok;
|
||||
@@ -6364,34 +6373,34 @@ watch_command_1 (char *arg, int accessfl
|
||||
@@ -6369,34 +6378,34 @@ watch_command_1 (char *arg, int accessfl
|
||||
bp_type = bp_watchpoint;
|
||||
|
||||
frame = block_innermost_frame (exp_valid_block);
|
||||
@ -305,7 +305,7 @@ Index: gdb-6.8.50.20090302/gdb/breakpoint.c
|
||||
}
|
||||
|
||||
/* Now set up the breakpoint. */
|
||||
@@ -6572,7 +6581,6 @@ until_break_command (char *arg, int from
|
||||
@@ -6577,7 +6586,6 @@ until_break_command (char *arg, int from
|
||||
struct symtabs_and_lines sals;
|
||||
struct symtab_and_line sal;
|
||||
struct frame_info *frame = get_selected_frame (NULL);
|
||||
@ -313,7 +313,7 @@ Index: gdb-6.8.50.20090302/gdb/breakpoint.c
|
||||
struct breakpoint *breakpoint;
|
||||
struct breakpoint *breakpoint2 = NULL;
|
||||
struct cleanup *old_chain;
|
||||
@@ -6605,20 +6613,22 @@ until_break_command (char *arg, int from
|
||||
@@ -6610,20 +6618,22 @@ until_break_command (char *arg, int from
|
||||
we don't specify a frame at which we need to stop. */
|
||||
breakpoint = set_momentary_breakpoint (sal, null_frame_id, bp_until);
|
||||
else
|
||||
@ -344,8 +344,8 @@ Index: gdb-6.8.50.20090302/gdb/breakpoint.c
|
||||
}
|
||||
Index: gdb-6.8.50.20090302/gdb/buildsym.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/buildsym.c 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/buildsym.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/buildsym.c 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/buildsym.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -1155,6 +1155,12 @@ end_symtab (CORE_ADDR end_addr, struct o
|
||||
struct symbol *sym;
|
||||
struct dict_iterator iter;
|
||||
@ -361,8 +361,8 @@ Index: gdb-6.8.50.20090302/gdb/buildsym.c
|
||||
sym = dict_iterator_next (&iter))
|
||||
Index: gdb-6.8.50.20090302/gdb/doc/gdb.texinfo
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/doc/gdb.texinfo 2009-03-27 00:14:24.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/doc/gdb.texinfo 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/doc/gdb.texinfo 2009-04-13 22:19:50.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/doc/gdb.texinfo 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -137,6 +137,7 @@ software in general. We will miss him.
|
||||
* Stack:: Examining the stack
|
||||
* Source:: Examining source files
|
||||
@ -514,8 +514,8 @@ Index: gdb-6.8.50.20090302/gdb/doc/gdb.texinfo
|
||||
|
||||
Index: gdb-6.8.50.20090302/gdb/dwarf2loc.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/dwarf2loc.c 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/dwarf2loc.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/dwarf2loc.c 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/dwarf2loc.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -31,6 +31,7 @@
|
||||
#include "regcache.h"
|
||||
#include "objfiles.h"
|
||||
@ -538,8 +538,8 @@ Index: gdb-6.8.50.20090302/gdb/dwarf2loc.c
|
||||
some function associated with a frame. If we can't find the frame,
|
||||
Index: gdb-6.8.50.20090302/gdb/dwarf2read.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/dwarf2read.c 2009-03-27 00:14:24.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/dwarf2read.c 2009-03-27 00:16:07.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/dwarf2read.c 2009-04-13 22:19:50.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/dwarf2read.c 2009-04-13 22:22:41.000000000 +0200
|
||||
@@ -50,6 +50,7 @@
|
||||
#include "c-lang.h"
|
||||
#include "typeprint.h"
|
||||
@ -657,7 +657,7 @@ Index: gdb-6.8.50.20090302/gdb/dwarf2read.c
|
||||
Index: gdb-6.8.50.20090302/gdb/frame-unwind.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/frame-unwind.c 2009-01-03 06:57:51.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/frame-unwind.c 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/frame-unwind.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -21,6 +21,7 @@
|
||||
#include "frame.h"
|
||||
#include "frame-unwind.h"
|
||||
@ -680,8 +680,8 @@ Index: gdb-6.8.50.20090302/gdb/frame-unwind.c
|
||||
|
||||
Index: gdb-6.8.50.20090302/gdb/frame.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/frame.c 2009-03-27 00:14:21.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/frame.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/frame.c 2009-04-13 22:19:48.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/frame.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -41,8 +41,14 @@
|
||||
#include "objfiles.h"
|
||||
#include "exceptions.h"
|
||||
@ -1041,7 +1041,7 @@ Index: gdb-6.8.50.20090302/gdb/frame.c
|
||||
Index: gdb-6.8.50.20090302/gdb/frame.h
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/frame.h 2009-02-05 18:28:20.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/frame.h 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/frame.h 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -34,6 +34,9 @@
|
||||
frame_unwind_WHAT...(): Unwind THIS frame's WHAT from the NEXT
|
||||
frame.
|
||||
@ -1105,8 +1105,8 @@ Index: gdb-6.8.50.20090302/gdb/frame.h
|
||||
/* Assuming that a frame is `normal', return its base-address, or 0 if
|
||||
Index: gdb-6.8.50.20090302/gdb/gdbthread.h
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/gdbthread.h 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/gdbthread.h 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/gdbthread.h 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/gdbthread.h 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -83,6 +83,13 @@ struct thread_info
|
||||
This is how we know when we step into a subroutine call, and how
|
||||
to set the frame for the breakpoint used to step out. */
|
||||
@ -1123,8 +1123,8 @@ Index: gdb-6.8.50.20090302/gdb/gdbthread.h
|
||||
|
||||
Index: gdb-6.8.50.20090302/gdb/infcall.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/infcall.c 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/infcall.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/infcall.c 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/infcall.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -898,15 +898,8 @@ The program being debugged exited while
|
||||
|
||||
if (unwind_on_signal_p)
|
||||
@ -1145,8 +1145,8 @@ Index: gdb-6.8.50.20090302/gdb/infcall.c
|
||||
long if it's a C++ name with arguments and stuff. */
|
||||
Index: gdb-6.8.50.20090302/gdb/infcmd.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/infcmd.c 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/infcmd.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/infcmd.c 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/infcmd.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -52,6 +52,7 @@
|
||||
#include "cli/cli-decode.h"
|
||||
#include "gdbthread.h"
|
||||
@ -1250,8 +1250,8 @@ Index: gdb-6.8.50.20090302/gdb/infcmd.c
|
||||
function = find_pc_function (get_frame_pc (get_selected_frame (NULL)));
|
||||
Index: gdb-6.8.50.20090302/gdb/inferior.h
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/inferior.h 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/inferior.h 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/inferior.h 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/inferior.h 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -259,6 +259,9 @@ extern void error_is_running (void);
|
||||
/* Calls error_is_running if the current thread is running. */
|
||||
extern void ensure_not_running (void);
|
||||
@ -1264,8 +1264,8 @@ Index: gdb-6.8.50.20090302/gdb/inferior.h
|
||||
extern void tty_command (char *, int);
|
||||
Index: gdb-6.8.50.20090302/gdb/infrun.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/infrun.c 2009-03-27 00:14:23.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/infrun.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/infrun.c 2009-04-13 22:19:49.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/infrun.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -48,6 +48,7 @@
|
||||
#include "gdb_assert.h"
|
||||
#include "mi/mi-common.h"
|
||||
@ -1541,7 +1541,7 @@ Index: gdb-6.8.50.20090302/gdb/infrun.c
|
||||
Index: gdb-6.8.50.20090302/gdb/inline-frame.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090302/gdb/inline-frame.c 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/inline-frame.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -0,0 +1,382 @@
|
||||
+/* Inline frame unwinder for GDB.
|
||||
+
|
||||
@ -1928,7 +1928,7 @@ Index: gdb-6.8.50.20090302/gdb/inline-frame.c
|
||||
Index: gdb-6.8.50.20090302/gdb/inline-frame.h
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090302/gdb/inline-frame.h 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/inline-frame.h 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -0,0 +1,62 @@
|
||||
+/* Definitions for inline frame support.
|
||||
+
|
||||
@ -1994,8 +1994,8 @@ Index: gdb-6.8.50.20090302/gdb/inline-frame.h
|
||||
+#endif /* !defined (INLINE_FRAME_H) */
|
||||
Index: gdb-6.8.50.20090302/gdb/minsyms.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/minsyms.c 2009-03-27 00:14:22.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/minsyms.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/minsyms.c 2009-04-13 22:19:49.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/minsyms.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -795,7 +795,7 @@ prim_record_minimal_symbol_and_info (con
|
||||
|
||||
if (msym_bunch_index == BUNCH_SIZE)
|
||||
@ -2008,7 +2008,7 @@ Index: gdb-6.8.50.20090302/gdb/minsyms.c
|
||||
Index: gdb-6.8.50.20090302/gdb/s390-tdep.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/s390-tdep.c 2009-02-22 02:02:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/s390-tdep.c 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/s390-tdep.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -1182,6 +1182,7 @@ s390_prologue_frame_unwind_cache (struct
|
||||
CORE_ADDR prev_sp;
|
||||
int frame_pointer;
|
||||
@ -2044,8 +2044,8 @@ Index: gdb-6.8.50.20090302/gdb/s390-tdep.c
|
||||
/* See the comment in s390_in_function_epilogue_p on why this is
|
||||
Index: gdb-6.8.50.20090302/gdb/stack.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/stack.c 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/stack.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/stack.c 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/stack.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -45,6 +45,7 @@
|
||||
#include "valprint.h"
|
||||
#include "gdbthread.h"
|
||||
@ -2194,15 +2194,16 @@ Index: gdb-6.8.50.20090302/gdb/stack.c
|
||||
RETURN_VALUE to NULL, and QUERY_PREFIX to an informational
|
||||
Index: gdb-6.8.50.20090302/gdb/symtab.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/symtab.c 2009-03-27 00:14:22.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/symtab.c 2009-03-27 00:15:36.000000000 +0100
|
||||
@@ -1426,10 +1426,13 @@ lookup_symbol_aux_local (const char *nam
|
||||
return sym;
|
||||
}
|
||||
|
||||
+ if (BLOCK_FUNCTION (block_iterator) != NULL && block_inlined_p (block_iterator))
|
||||
+ break;
|
||||
--- gdb-6.8.50.20090302.orig/gdb/symtab.c 2009-04-13 22:19:49.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/symtab.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -1417,11 +1417,14 @@ lookup_symbol_aux_local (const char *nam
|
||||
sym = lookup_symbol_aux_block (name, linkage_name, block_iterator, domain);
|
||||
if (sym != NULL)
|
||||
return sym;
|
||||
+
|
||||
+ if (BLOCK_FUNCTION (block) != NULL && block_inlined_p (block))
|
||||
+ break;
|
||||
|
||||
block_iterator = BLOCK_SUPERBLOCK (block_iterator);
|
||||
}
|
||||
|
||||
@ -2211,7 +2212,7 @@ Index: gdb-6.8.50.20090302/gdb/symtab.c
|
||||
|
||||
return NULL;
|
||||
}
|
||||
@@ -2686,6 +2689,7 @@ find_function_start_sal (struct symbol *
|
||||
@@ -2678,6 +2681,7 @@ find_function_start_sal (struct symbol *
|
||||
|
||||
CORE_ADDR pc;
|
||||
struct symtab_and_line sal;
|
||||
@ -2219,7 +2220,7 @@ Index: gdb-6.8.50.20090302/gdb/symtab.c
|
||||
|
||||
pc = BLOCK_START (block);
|
||||
fixup_symbol_section (sym, objfile);
|
||||
@@ -2724,6 +2728,25 @@ find_function_start_sal (struct symbol *
|
||||
@@ -2716,6 +2720,25 @@ find_function_start_sal (struct symbol *
|
||||
|
||||
sal.pc = pc;
|
||||
|
||||
@ -2245,7 +2246,7 @@ Index: gdb-6.8.50.20090302/gdb/symtab.c
|
||||
return sal;
|
||||
}
|
||||
|
||||
@@ -3746,6 +3769,24 @@ add_macro_name (const char *name, const
|
||||
@@ -3738,6 +3761,24 @@ add_macro_name (const char *name, const
|
||||
datum->text, datum->word);
|
||||
}
|
||||
|
||||
@ -2270,7 +2271,7 @@ Index: gdb-6.8.50.20090302/gdb/symtab.c
|
||||
char **
|
||||
default_make_symbol_completion_list (char *text, char *word)
|
||||
{
|
||||
@@ -3758,9 +3799,9 @@ default_make_symbol_completion_list (cha
|
||||
@@ -3750,9 +3791,9 @@ default_make_symbol_completion_list (cha
|
||||
struct partial_symtab *ps;
|
||||
struct minimal_symbol *msymbol;
|
||||
struct objfile *objfile;
|
||||
@ -2282,7 +2283,7 @@ Index: gdb-6.8.50.20090302/gdb/symtab.c
|
||||
struct partial_symbol **psym;
|
||||
/* The symbol we are completing on. Points in same buffer as text. */
|
||||
char *sym_text;
|
||||
@@ -3870,41 +3911,43 @@ default_make_symbol_completion_list (cha
|
||||
@@ -3862,41 +3903,43 @@ default_make_symbol_completion_list (cha
|
||||
}
|
||||
|
||||
/* Search upwards from currently selected frame (so that we can
|
||||
@ -2357,7 +2358,7 @@ Index: gdb-6.8.50.20090302/gdb/symtab.c
|
||||
|
||||
/* Go through the symtabs and check the externs and statics for
|
||||
symbols which match. */
|
||||
@@ -3923,9 +3966,6 @@ default_make_symbol_completion_list (cha
|
||||
@@ -3915,9 +3958,6 @@ default_make_symbol_completion_list (cha
|
||||
{
|
||||
QUIT;
|
||||
b = BLOCKVECTOR_BLOCK (BLOCKVECTOR (s), STATIC_BLOCK);
|
||||
@ -2367,7 +2368,7 @@ Index: gdb-6.8.50.20090302/gdb/symtab.c
|
||||
ALL_BLOCK_SYMBOLS (b, iter, sym)
|
||||
{
|
||||
COMPLETION_LIST_ADD_SYMBOL (sym, sym_text, sym_text_len, text, word);
|
||||
@@ -4392,6 +4432,25 @@ skip_prologue_using_sal (CORE_ADDR func_
|
||||
@@ -4384,6 +4424,25 @@ skip_prologue_using_sal (CORE_ADDR func_
|
||||
line mark the prologue -> body transition. */
|
||||
if (sal.line >= prologue_sal.line)
|
||||
break;
|
||||
@ -2395,9 +2396,9 @@ Index: gdb-6.8.50.20090302/gdb/symtab.c
|
||||
the function looking for address ranges whose
|
||||
Index: gdb-6.8.50.20090302/gdb/symtab.h
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/symtab.h 2009-03-27 00:14:19.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/symtab.h 2009-03-27 00:14:33.000000000 +0100
|
||||
@@ -556,9 +556,18 @@ struct symbol
|
||||
--- gdb-6.8.50.20090302.orig/gdb/symtab.h 2009-04-13 22:19:47.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/symtab.h 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -562,9 +562,18 @@ struct symbol
|
||||
|
||||
unsigned is_argument : 1;
|
||||
|
||||
@ -2419,7 +2420,7 @@ Index: gdb-6.8.50.20090302/gdb/symtab.h
|
||||
|
||||
unsigned short line;
|
||||
|
||||
@@ -589,6 +598,7 @@ struct symbol
|
||||
@@ -595,6 +604,7 @@ struct symbol
|
||||
#define SYMBOL_DOMAIN(symbol) (symbol)->domain
|
||||
#define SYMBOL_CLASS(symbol) (symbol)->aclass
|
||||
#define SYMBOL_IS_ARGUMENT(symbol) (symbol)->is_argument
|
||||
@ -2430,7 +2431,7 @@ Index: gdb-6.8.50.20090302/gdb/symtab.h
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.base/break.exp
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/testsuite/gdb.base/break.exp 2009-01-19 20:05:01.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.base/break.exp 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.base/break.exp 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -880,6 +880,13 @@ gdb_expect {
|
||||
# marker4() is defined at line 46 when compiled with -DPROTOTYPES
|
||||
pass "run until breakpoint set at small function, optimized file (line bp_location14)"
|
||||
@ -2448,7 +2449,7 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.base/break.exp
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.cp/annota2.exp
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/testsuite/gdb.cp/annota2.exp 2009-01-03 06:58:04.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.cp/annota2.exp 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.cp/annota2.exp 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -119,10 +119,11 @@ gdb_expect {
|
||||
# continue until exit
|
||||
# this will test:
|
||||
@ -2465,7 +2466,7 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.cp/annota2.exp
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-bt.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-bt.c 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-bt.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -0,0 +1,47 @@
|
||||
+/* Copyright (C) 2008 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -2517,7 +2518,7 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-bt.c
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-bt.exp
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-bt.exp 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-bt.exp 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -0,0 +1,63 @@
|
||||
+# Copyright 2008 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -2585,7 +2586,7 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-bt.exp
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-cmds.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-cmds.c 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-cmds.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -0,0 +1,85 @@
|
||||
+/* Copyright (C) 2008 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -2675,7 +2676,7 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-cmds.c
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-cmds.exp
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-cmds.exp 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-cmds.exp 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -0,0 +1,279 @@
|
||||
+# Copyright 2008 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -2959,7 +2960,7 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-cmds.exp
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-locals.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-locals.c 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-locals.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -0,0 +1,52 @@
|
||||
+/* Copyright (C) 2008 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -3016,7 +3017,7 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-locals.c
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-locals.exp
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-locals.exp 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-locals.exp 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -0,0 +1,118 @@
|
||||
+# Copyright 2008 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -3139,7 +3140,7 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-locals.exp
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-markers.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-markers.c 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-markers.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -0,0 +1,36 @@
|
||||
+/* Copyright (C) 2008 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -3179,8 +3180,8 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/inline-markers.c
|
||||
+}
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/lib/gdb.exp
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/testsuite/lib/gdb.exp 2009-03-27 00:14:23.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/lib/gdb.exp 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/testsuite/lib/gdb.exp 2009-04-13 22:19:50.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/lib/gdb.exp 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -1474,6 +1474,37 @@ proc skip_hp_tests {} {
|
||||
return $skip_hp
|
||||
}
|
||||
@ -3221,8 +3222,8 @@ Index: gdb-6.8.50.20090302/gdb/testsuite/lib/gdb.exp
|
||||
set hp_cc_compiler 0
|
||||
Index: gdb-6.8.50.20090302/gdb/valops.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/valops.c 2009-03-27 00:14:20.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/valops.c 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/valops.c 2009-04-13 22:19:48.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/valops.c 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -1072,7 +1072,7 @@ value_of_variable (struct symbol *var, s
|
||||
frame = block_innermost_frame (b);
|
||||
if (!frame)
|
||||
@ -3234,8 +3235,8 @@ Index: gdb-6.8.50.20090302/gdb/valops.c
|
||||
SYMBOL_PRINT_NAME (BLOCK_FUNCTION (b)));
|
||||
Index: gdb-6.8.50.20090302/gdb/Makefile.in
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/Makefile.in 2009-03-27 00:14:23.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/Makefile.in 2009-03-27 00:14:33.000000000 +0100
|
||||
--- gdb-6.8.50.20090302.orig/gdb/Makefile.in 2009-04-13 22:19:49.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/Makefile.in 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -667,6 +667,7 @@ SFILES = ada-exp.y ada-lang.c ada-typepr
|
||||
inf-loop.c \
|
||||
infcall.c \
|
||||
@ -3255,7 +3256,7 @@ Index: gdb-6.8.50.20090302/gdb/Makefile.in
|
||||
Index: gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/Makefile.in
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090302.orig/gdb/testsuite/gdb.opt/Makefile.in 2008-04-18 01:06:54.000000000 +0200
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/Makefile.in 2009-03-27 00:14:33.000000000 +0100
|
||||
+++ gdb-6.8.50.20090302/gdb/testsuite/gdb.opt/Makefile.in 2009-04-13 22:22:01.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
VPATH = @srcdir@
|
||||
srcdir = @srcdir@
|
||||
|
823
gdb-archer.patch
823
gdb-archer.patch
File diff suppressed because it is too large
Load Diff
15
gdb.spec
15
gdb.spec
@ -13,7 +13,7 @@ Version: 6.8.50.20090302
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 16%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 17%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -851,6 +851,19 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Apr 13 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-17
|
||||
- Archer update to the snapshot: 7c250ce99c90cf6097e2ec55ea0f205830979cee
|
||||
- Archer backport: c14d9ab7eef43281b2052c885f89d2db96fb5f8e
|
||||
- Revert a change regressing: gdb.objc/basicclass.exp
|
||||
- Archer backport: ebd649b96e61a1fb481801b65d827bca998c6633
|
||||
+ 1f080e897996d60ab7fde20423e2947512115667
|
||||
+ 1948198702b51b31d79793fc49434b529b4e245f
|
||||
+ e107fb9687bb1e7f74170aa3d19c4a8f6edbb10f
|
||||
+ 1e012c996e121cb35053d239a46bd5dc65b0ce60
|
||||
- Update the Python API from upstream.
|
||||
- Archer backport: d3c83ad5ec9f7672b87af9ad29279f459e53da11
|
||||
- Fix a Python branch crash.
|
||||
|
||||
* Mon Apr 13 2009 Dennis Gilmore <dennis@ausil.us> - 6.8.50.20090302-16
|
||||
- enable gdbserver package on sparc64
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user