Rebase to FSF GDB 8.0 final.
[rhel7 dts] Rebase bundled libipt to 1.6.1.
This commit is contained in:
parent
b5e2ceba4b
commit
7e382f5dd2
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,3 +1,3 @@
|
||||
/gdb-libstdc++-v3-python-6.3.1-20170212.tar.xz
|
||||
/v1.5.tar.gz
|
||||
/gdb-7.99.90.20170420.tar.xz
|
||||
/v1.6.1.tar.gz
|
||||
/gdb-8.0.tar.xz
|
||||
|
@ -1,74 +0,0 @@
|
||||
http://sourceware.org/ml/gdb-patches/2017-04/msg00593.html
|
||||
Subject: [patch+8.0] release branch: Fix: --enable-werror
|
||||
|
||||
|
||||
--8t9RHnE3ZwKMSgU+
|
||||
Content-Type: text/plain; charset=iso-2022-jp
|
||||
Content-Disposition: inline
|
||||
|
||||
Hi,
|
||||
|
||||
gdb-8.0-branch
|
||||
./configure --enable-werror --enable-targets=all
|
||||
aarch64-tdep.c:3045:13: error: $B!F(Bvoid selftests::aarch64_process_record_test()$B!G(B declared $B!F(Bstatic$B!G(B but never defined [-Werror=unused-function]
|
||||
arm-tdep.c:9601:13: error: $B!F(Bvoid selftests::arm_record_test()$B!G(B declared $B!F(Bstatic$B!G(B but never defined [-Werror=unused-function]
|
||||
|
||||
OK for check-in?
|
||||
|
||||
Please do not tell me release branches do not support --enable-werror as this
|
||||
is due to a sourcebase bug, not due to some unexpected compiler
|
||||
incompatibility.
|
||||
|
||||
Sergio: Shouldn't it be also buildbot-tested?
|
||||
|
||||
|
||||
Jan
|
||||
|
||||
--8t9RHnE3ZwKMSgU+
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline; filename=1
|
||||
|
||||
gdb/ChangeLog
|
||||
2017-04-21 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* aarch64-tdep.c (selftests::aarch64_process_record_test): Make it #if
|
||||
GDB_SELF_TEST.
|
||||
* arm-tdep.c (selftests::arm_record_test): Likewise.
|
||||
|
||||
diff --git a/gdb/aarch64-tdep.c b/gdb/aarch64-tdep.c
|
||||
index 28c2573..6113621 100644
|
||||
--- a/gdb/aarch64-tdep.c
|
||||
+++ b/gdb/aarch64-tdep.c
|
||||
@@ -3040,10 +3040,12 @@ aarch64_dump_tdep (struct gdbarch *gdbarch, struct ui_file *file)
|
||||
paddress (gdbarch, tdep->lowest_pc));
|
||||
}
|
||||
|
||||
+#if GDB_SELF_TEST
|
||||
namespace selftests
|
||||
{
|
||||
static void aarch64_process_record_test (void);
|
||||
}
|
||||
+#endif
|
||||
|
||||
/* Suppress warning from -Wmissing-prototypes. */
|
||||
extern initialize_file_ftype _initialize_aarch64_tdep;
|
||||
diff --git a/gdb/arm-tdep.c b/gdb/arm-tdep.c
|
||||
index c8fabfb..9ac667f 100644
|
||||
--- a/gdb/arm-tdep.c
|
||||
+++ b/gdb/arm-tdep.c
|
||||
@@ -9596,10 +9596,12 @@ arm_dump_tdep (struct gdbarch *gdbarch, struct ui_file *file)
|
||||
(unsigned long) tdep->lowest_pc);
|
||||
}
|
||||
|
||||
+#if GDB_SELF_TEST
|
||||
namespace selftests
|
||||
{
|
||||
static void arm_record_test (void);
|
||||
}
|
||||
+#endif
|
||||
|
||||
extern initialize_file_ftype _initialize_arm_tdep; /* -Wmissing-prototypes */
|
||||
|
||||
|
||||
--8t9RHnE3ZwKMSgU+--
|
||||
|
@ -23,23 +23,23 @@ git diff --stat -p gdb/master...gdb/users/bheckel/fortran-vla-strings
|
||||
gdb/valprint.c | 6 --
|
||||
20 files changed, 827 insertions(+), 110 deletions(-)
|
||||
|
||||
Index: gdb-7.99.90.20170420/gdb/NEWS
|
||||
Index: gdb-8.0/gdb/NEWS
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/NEWS 2017-04-20 22:27:47.076032111 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/NEWS 2017-04-20 22:27:49.946050236 +0200
|
||||
--- gdb-8.0.orig/gdb/NEWS 2017-06-09 05:51:58.211401718 +0200
|
||||
+++ gdb-8.0/gdb/NEWS 2017-06-09 05:52:11.586504927 +0200
|
||||
@@ -1,6 +1,8 @@
|
||||
What has changed in GDB?
|
||||
(Organized release by release)
|
||||
|
||||
+* Fortran: Support pointers to dynamic types.
|
||||
+
|
||||
*** Changes since GDB 7.12
|
||||
*** Changes in GDB 8.0
|
||||
|
||||
* GDB now supports access to the PKU register on GNU/Linux. The register is
|
||||
Index: gdb-7.99.90.20170420/gdb/c-valprint.c
|
||||
Index: gdb-8.0/gdb/c-valprint.c
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/c-valprint.c 2017-04-20 22:27:47.077032118 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/c-valprint.c 2017-04-20 22:27:49.947050243 +0200
|
||||
--- gdb-8.0.orig/gdb/c-valprint.c 2017-06-09 05:51:55.838383406 +0200
|
||||
+++ gdb-8.0/gdb/c-valprint.c 2017-06-09 05:51:58.212401726 +0200
|
||||
@@ -650,6 +650,28 @@
|
||||
else
|
||||
{
|
||||
@ -69,10 +69,10 @@ Index: gdb-7.99.90.20170420/gdb/c-valprint.c
|
||||
fprintf_filtered (stream, "(");
|
||||
type_print (value_type (val), "", stream, -1);
|
||||
fprintf_filtered (stream, ") ");
|
||||
Index: gdb-7.99.90.20170420/gdb/dwarf2read.c
|
||||
Index: gdb-8.0/gdb/dwarf2read.c
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/dwarf2read.c 2017-04-20 22:27:47.091032206 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/dwarf2read.c 2017-04-20 22:28:28.878296105 +0200
|
||||
--- gdb-8.0.orig/gdb/dwarf2read.c 2017-06-09 05:51:55.859383569 +0200
|
||||
+++ gdb-8.0/gdb/dwarf2read.c 2017-06-09 05:51:58.218401772 +0200
|
||||
@@ -1872,7 +1872,8 @@
|
||||
|
||||
static int attr_to_dynamic_prop (const struct attribute *attr,
|
||||
@ -333,10 +333,10 @@ Index: gdb-7.99.90.20170420/gdb/dwarf2read.c
|
||||
add_dyn_prop (DYN_PROP_DATA_LOCATION, prop, type, objfile);
|
||||
|
||||
if (dwarf2_per_objfile->die_type_hash == NULL)
|
||||
Index: gdb-7.99.90.20170420/gdb/f-typeprint.c
|
||||
Index: gdb-8.0/gdb/f-typeprint.c
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/f-typeprint.c 2017-04-20 22:27:26.288900835 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/f-typeprint.c 2017-04-20 22:27:49.953050280 +0200
|
||||
--- gdb-8.0.orig/gdb/f-typeprint.c 2017-06-09 05:51:39.273255581 +0200
|
||||
+++ gdb-8.0/gdb/f-typeprint.c 2017-06-09 05:51:58.218401772 +0200
|
||||
@@ -37,7 +37,7 @@
|
||||
#endif
|
||||
|
||||
@ -486,11 +486,11 @@ Index: gdb-7.99.90.20170420/gdb/f-typeprint.c
|
||||
fputs_filtered ("\n", stream);
|
||||
}
|
||||
fprintfi_filtered (level, stream, "End Type ");
|
||||
Index: gdb-7.99.90.20170420/gdb/gdbtypes.c
|
||||
Index: gdb-8.0/gdb/gdbtypes.c
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/gdbtypes.c 2017-04-20 22:27:47.093032219 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/gdbtypes.c 2017-04-20 22:27:49.954050287 +0200
|
||||
@@ -1840,7 +1840,8 @@
|
||||
--- gdb-8.0.orig/gdb/gdbtypes.c 2017-06-09 05:51:55.864383607 +0200
|
||||
+++ gdb-8.0/gdb/gdbtypes.c 2017-06-09 05:51:58.219401780 +0200
|
||||
@@ -1839,7 +1839,8 @@
|
||||
type = check_typedef (type);
|
||||
|
||||
/* We only want to recognize references at the outermost level. */
|
||||
@ -500,7 +500,7 @@ Index: gdb-7.99.90.20170420/gdb/gdbtypes.c
|
||||
type = check_typedef (TYPE_TARGET_TYPE (type));
|
||||
|
||||
/* Types that have a dynamic TYPE_DATA_LOCATION are considered
|
||||
@@ -1874,6 +1875,7 @@
|
||||
@@ -1873,6 +1874,7 @@
|
||||
}
|
||||
|
||||
case TYPE_CODE_ARRAY:
|
||||
@ -508,7 +508,7 @@ Index: gdb-7.99.90.20170420/gdb/gdbtypes.c
|
||||
{
|
||||
gdb_assert (TYPE_NFIELDS (type) == 1);
|
||||
|
||||
@@ -1986,7 +1988,8 @@
|
||||
@@ -1985,7 +1987,8 @@
|
||||
struct type *ary_dim;
|
||||
struct dynamic_prop *prop;
|
||||
|
||||
@ -518,7 +518,7 @@ Index: gdb-7.99.90.20170420/gdb/gdbtypes.c
|
||||
|
||||
type = copy_type (type);
|
||||
|
||||
@@ -2011,13 +2014,17 @@
|
||||
@@ -2010,13 +2013,17 @@
|
||||
|
||||
ary_dim = check_typedef (TYPE_TARGET_TYPE (elt_type));
|
||||
|
||||
@ -539,7 +539,7 @@ Index: gdb-7.99.90.20170420/gdb/gdbtypes.c
|
||||
}
|
||||
|
||||
/* Resolve dynamic bounds of members of the union TYPE to static
|
||||
@@ -2147,6 +2154,28 @@
|
||||
@@ -2146,6 +2153,28 @@
|
||||
return resolved_type;
|
||||
}
|
||||
|
||||
@ -568,7 +568,7 @@ Index: gdb-7.99.90.20170420/gdb/gdbtypes.c
|
||||
/* Worker for resolved_dynamic_type. */
|
||||
|
||||
static struct type *
|
||||
@@ -2195,7 +2224,12 @@
|
||||
@@ -2194,7 +2223,12 @@
|
||||
break;
|
||||
}
|
||||
|
||||
@ -581,10 +581,10 @@ Index: gdb-7.99.90.20170420/gdb/gdbtypes.c
|
||||
resolved_type = resolve_dynamic_array (type, addr_stack);
|
||||
break;
|
||||
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.cp/vla-cxx.cc
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.cp/vla-cxx.cc
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/testsuite/gdb.cp/vla-cxx.cc 2017-04-20 22:27:47.094032225 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.cp/vla-cxx.cc 2017-04-20 22:27:49.955050293 +0200
|
||||
--- gdb-8.0.orig/gdb/testsuite/gdb.cp/vla-cxx.cc 2017-06-09 05:51:55.864383607 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.cp/vla-cxx.cc 2017-06-09 05:51:58.219401780 +0200
|
||||
@@ -15,6 +15,10 @@
|
||||
You should have received a copy of the GNU General Public License
|
||||
along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||
@ -613,10 +613,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.cp/vla-cxx.cc
|
||||
+
|
||||
return vla[2];
|
||||
}
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.cp/vla-cxx.exp
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.cp/vla-cxx.exp
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/testsuite/gdb.cp/vla-cxx.exp 2017-04-20 22:27:47.094032225 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.cp/vla-cxx.exp 2017-04-20 22:27:49.955050293 +0200
|
||||
--- gdb-8.0.orig/gdb/testsuite/gdb.cp/vla-cxx.exp 2017-06-09 05:51:55.864383607 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.cp/vla-cxx.exp 2017-06-09 05:51:58.220401787 +0200
|
||||
@@ -23,6 +23,12 @@
|
||||
return -1
|
||||
}
|
||||
@ -637,10 +637,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.cp/vla-cxx.exp
|
||||
+gdb_test "ptype ptr" "int \\(\\*\\)\\\[3\\\]"
|
||||
+gdb_test "print ptr" "\\(int \\(\\*\\)\\\[3\\\]\\) $hex"
|
||||
+gdb_test "print *ptr" " = \\{5, 7, 9\\}"
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/pointers.exp
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.fortran/pointers.exp
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/pointers.exp 2017-04-20 22:27:49.955050293 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.fortran/pointers.exp 2017-06-09 05:51:58.220401787 +0200
|
||||
@@ -0,0 +1,143 @@
|
||||
+# Copyright 2016 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -785,10 +785,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/pointers.exp
|
||||
+gdb_test "print *((integer*) &inta + 2)" "= 3" "print temporary pointer, array"
|
||||
+gdb_test "print *((integer*) &intvla + 3)" "= 4" "print temporary pointer, allocated vla"
|
||||
+gdb_test "print \$pc" "= \\(PTR TO -> \\( void \\(\\)\\(\\)\\)\\) $hex <pointers\\+\\d+>" "Print program counter"
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/pointers.f90
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.fortran/pointers.f90
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/pointers.f90 2017-04-20 22:27:49.955050293 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.fortran/pointers.f90 2017-06-09 05:51:58.220401787 +0200
|
||||
@@ -0,0 +1,109 @@
|
||||
+! Copyright 2016 Free Software Foundation, Inc.
|
||||
+!
|
||||
@ -899,10 +899,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/pointers.f90
|
||||
+ intv = intv + 1 ! After value assignment
|
||||
+
|
||||
+end program pointers
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/print_type.exp
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.fortran/print_type.exp
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/print_type.exp 2017-04-20 22:27:49.956050299 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.fortran/print_type.exp 2017-06-09 05:51:58.220401787 +0200
|
||||
@@ -0,0 +1,100 @@
|
||||
+# Copyright 2016 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -1004,10 +1004,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/print_type.exp
|
||||
+ }
|
||||
+}
|
||||
+gdb_test "ptype realp" "type = PTR TO -> \\( $real \\)"
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-ptype.exp
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.fortran/vla-ptype.exp
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/testsuite/gdb.fortran/vla-ptype.exp 2017-04-20 22:27:47.094032225 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-ptype.exp 2017-04-20 22:27:49.956050299 +0200
|
||||
--- gdb-8.0.orig/gdb/testsuite/gdb.fortran/vla-ptype.exp 2017-06-09 05:51:55.865383615 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.fortran/vla-ptype.exp 2017-06-09 05:51:58.221401795 +0200
|
||||
@@ -32,9 +32,9 @@
|
||||
# Check the ptype of various VLA states and pointer to VLA's.
|
||||
gdb_breakpoint [gdb_get_line_number "vla1-init"]
|
||||
@ -1045,10 +1045,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-ptype.exp
|
||||
gdb_test "ptype vla2(5, 45, 20)" \
|
||||
"no such vector element \\\(vector not allocated\\\)" \
|
||||
"ptype vla2(5, 45, 20) not allocated"
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-strings.exp
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.fortran/vla-strings.exp
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-strings.exp 2017-04-20 22:27:49.956050299 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.fortran/vla-strings.exp 2017-06-09 05:51:58.221401795 +0200
|
||||
@@ -0,0 +1,103 @@
|
||||
+# Copyright 2016 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -1153,10 +1153,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-strings.exp
|
||||
+ pass $test
|
||||
+ }
|
||||
+}
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-strings.f90
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.fortran/vla-strings.f90
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-strings.f90 2017-04-20 22:27:49.956050299 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.fortran/vla-strings.f90 2017-06-09 05:51:58.221401795 +0200
|
||||
@@ -0,0 +1,39 @@
|
||||
+! Copyright 2016 Free Software Foundation, Inc.
|
||||
+!
|
||||
@ -1197,10 +1197,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-strings.f90
|
||||
+ var_char_p => null()
|
||||
+ l = associated(var_char_p) ! var_char_p-not-associated
|
||||
+end program vla_strings
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-type.exp
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.fortran/vla-type.exp
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/testsuite/gdb.fortran/vla-type.exp 2017-04-20 22:27:47.094032225 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-type.exp 2017-04-20 22:27:49.956050299 +0200
|
||||
--- gdb-8.0.orig/gdb/testsuite/gdb.fortran/vla-type.exp 2017-06-09 05:51:55.866383622 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.fortran/vla-type.exp 2017-06-09 05:51:58.221401795 +0200
|
||||
@@ -132,7 +132,10 @@
|
||||
"End Type one" ]
|
||||
|
||||
@ -1222,10 +1222,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-type.exp
|
||||
"End Type one" ] \
|
||||
"ptype fivedynarr(2)%tone, not allocated"
|
||||
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-value.exp
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.fortran/vla-value.exp
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/testsuite/gdb.fortran/vla-value.exp 2017-04-20 22:27:47.095032231 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-value.exp 2017-04-20 22:27:49.957050306 +0200
|
||||
--- gdb-8.0.orig/gdb/testsuite/gdb.fortran/vla-value.exp 2017-06-09 05:51:55.866383622 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.fortran/vla-value.exp 2017-06-09 05:51:58.221401795 +0200
|
||||
@@ -14,6 +14,7 @@
|
||||
# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
|
||||
@ -1278,10 +1278,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.fortran/vla-value.exp
|
||||
"print associated &pvla"
|
||||
gdb_test "print pvla(3, 6, 9)" " = 42" "print associated pvla(3,6,9)"
|
||||
gdb_test "print pvla(1, 3, 8)" " = 1001" "print associated pvla(1,3,8)"
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.mi/mi-var-child-f.exp
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.mi/mi-var-child-f.exp
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/testsuite/gdb.mi/mi-var-child-f.exp 2017-04-20 22:27:47.095032231 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.mi/mi-var-child-f.exp 2017-04-20 22:27:49.957050306 +0200
|
||||
--- gdb-8.0.orig/gdb/testsuite/gdb.mi/mi-var-child-f.exp 2017-06-09 05:51:55.867383630 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.mi/mi-var-child-f.exp 2017-06-09 05:51:58.222401803 +0200
|
||||
@@ -17,6 +17,7 @@
|
||||
|
||||
load_lib mi-support.exp
|
||||
@ -1303,10 +1303,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.mi/mi-var-child-f.exp
|
||||
|
||||
set children [list [list "array.-1" "-1" 2 "$int4 \\(2\\)"] \
|
||||
[list "array.0" "0" 2 "$int4 \\(2\\)"] \
|
||||
Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.mi/mi-vla-fortran.exp
|
||||
Index: gdb-8.0/gdb/testsuite/gdb.mi/mi-vla-fortran.exp
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/testsuite/gdb.mi/mi-vla-fortran.exp 2017-04-20 22:27:47.095032231 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/testsuite/gdb.mi/mi-vla-fortran.exp 2017-04-20 22:27:49.957050306 +0200
|
||||
--- gdb-8.0.orig/gdb/testsuite/gdb.mi/mi-vla-fortran.exp 2017-06-09 05:51:55.867383630 +0200
|
||||
+++ gdb-8.0/gdb/testsuite/gdb.mi/mi-vla-fortran.exp 2017-06-09 05:51:58.222401803 +0200
|
||||
@@ -17,7 +17,9 @@
|
||||
# Array (VLA).
|
||||
|
||||
@ -1405,10 +1405,10 @@ Index: gdb-7.99.90.20170420/gdb/testsuite/gdb.mi/mi-vla-fortran.exp
|
||||
"info type variable pvla2_associated"
|
||||
mi_gdb_test "592-var-show-format pvla2_associated" \
|
||||
"592\\^done,format=\"natural\"" \
|
||||
Index: gdb-7.99.90.20170420/gdb/typeprint.c
|
||||
Index: gdb-8.0/gdb/typeprint.c
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/typeprint.c 2017-04-20 22:27:47.095032231 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/typeprint.c 2017-04-20 22:27:49.957050306 +0200
|
||||
--- gdb-8.0.orig/gdb/typeprint.c 2017-06-09 05:51:55.867383630 +0200
|
||||
+++ gdb-8.0/gdb/typeprint.c 2017-06-09 05:51:58.222401803 +0200
|
||||
@@ -474,6 +474,25 @@
|
||||
printf_filtered (" */\n");
|
||||
}
|
||||
@ -1435,10 +1435,10 @@ Index: gdb-7.99.90.20170420/gdb/typeprint.c
|
||||
LA_PRINT_TYPE (type, "", gdb_stdout, show, 0, &flags);
|
||||
printf_filtered ("\n");
|
||||
|
||||
Index: gdb-7.99.90.20170420/gdb/valops.c
|
||||
Index: gdb-8.0/gdb/valops.c
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/valops.c 2017-04-20 22:27:47.096032238 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/valops.c 2017-04-20 22:27:49.958050312 +0200
|
||||
--- gdb-8.0.orig/gdb/valops.c 2017-06-09 05:51:55.869383646 +0200
|
||||
+++ gdb-8.0/gdb/valops.c 2017-06-09 05:51:58.223401811 +0200
|
||||
@@ -1574,6 +1574,19 @@
|
||||
if (TYPE_CODE (base_type) == TYPE_CODE_PTR)
|
||||
{
|
||||
@ -1469,10 +1469,10 @@ Index: gdb-7.99.90.20170420/gdb/valops.c
|
||||
|
||||
enc_type = value_type (arg2);
|
||||
return readjust_indirect_value_type (arg2, enc_type, base_type, arg1);
|
||||
Index: gdb-7.99.90.20170420/gdb/valprint.c
|
||||
Index: gdb-8.0/gdb/valprint.c
|
||||
===================================================================
|
||||
--- gdb-7.99.90.20170420.orig/gdb/valprint.c 2017-04-20 22:25:38.224218378 +0200
|
||||
+++ gdb-7.99.90.20170420/gdb/valprint.c 2017-04-20 22:27:49.959050318 +0200
|
||||
--- gdb-8.0.orig/gdb/valprint.c 2017-06-04 17:51:27.000000000 +0200
|
||||
+++ gdb-8.0/gdb/valprint.c 2017-06-09 05:51:58.224401818 +0200
|
||||
@@ -1166,12 +1166,6 @@
|
||||
return 0;
|
||||
}
|
||||
|
15
gdb.spec
15
gdb.spec
@ -22,11 +22,11 @@ Name: %{?scl_prefix}gdb
|
||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||
%global snapgnulib 20150822
|
||||
%global tarname gdb-%{version}
|
||||
Version: 7.99.90.%{snapsrc}
|
||||
Version: 8.0
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 12%{?dist}
|
||||
Release: 13%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -156,7 +156,7 @@ Source5: %{libstdcxxpython}.tar.xz
|
||||
Source6: gdbtui
|
||||
|
||||
# libipt: Intel Processor Trace Decoder Library
|
||||
%global libipt_version 1.5
|
||||
%global libipt_version 1.6.1
|
||||
#=fedora
|
||||
Source7: v%{libipt_version}.tar.gz
|
||||
#=fedora
|
||||
@ -672,10 +672,6 @@ Patch1153: gdb-add-index-chmod.patch
|
||||
#=fedoratest
|
||||
Patch1155: gdb-rhbz1398387-tab-crash-test.patch
|
||||
|
||||
# Release branch: Fix: --enable-werror
|
||||
#=push+jan
|
||||
Patch1170: gdb-release-werror.patch
|
||||
|
||||
%if 0%{!?rhel:1} || 0%{?rhel} > 6
|
||||
# RL_STATE_FEDORA_GDB would not be found for:
|
||||
# Patch642: gdb-readline62-ask-more-rh.patch
|
||||
@ -1047,7 +1043,6 @@ done
|
||||
%patch1152 -p1
|
||||
%patch1153 -p1
|
||||
%patch1155 -p1
|
||||
%patch1170 -p1
|
||||
|
||||
%patch1075 -p1
|
||||
%if 0%{?rhel:1} && 0%{?rhel} <= 7
|
||||
@ -1615,6 +1610,10 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Fri Jun 9 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.0-13.fc26
|
||||
- Rebase to FSF GDB 8.0 final.
|
||||
- [rhel7 dts] Rebase bundled libipt to 1.6.1.
|
||||
|
||||
* Sat May 20 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.99.90.20170420-12.fc26
|
||||
- Move 'dnf-command(debuginfo-install)' gdb-headless -> gdb (RH BZ 1452335).
|
||||
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gdb-libstdc++-v3-python-6.3.1-20170212.tar.xz) = 22ad4187d6bb9851ecf389c3ff4c68f33ccf5602d8f51bc337215c700d56c9073b3fb40ece3f58901315161f76a4fd1d6463c623650317ad96fd9e3f4aba7252
|
||||
SHA512 (v1.5.tar.gz) = ea3e76291d5b077d5b42061898a1f70af6cbdbccb7d05c59904f322ca1c03f7596cac6a966b80b12d2c2d86212f17d6bde02b1daf92be62e49abcb234e2bacbd
|
||||
SHA512 (gdb-7.99.90.20170420.tar.xz) = 8fe8e2a69a94d3ea8861a2aaeb46cd3e3e8423efe0a74a7bb336ee0df301321f693f360166518b3f595c94bfad893fb708c92962f79bae13b6564db027a1516f
|
||||
SHA512 (v1.6.1.tar.gz) = c7c9c8ba78021fff3fde12a216f5729c6031114e5a727f49b7ff1a31c53b5ddba24d1b3aee252d8278ecd1fafe78a44ed059c12b9eb29eca33093e0720673468
|
||||
SHA512 (gdb-8.0.tar.xz) = e4044bdd162cbf95044ec1eaa44d2fa62a33e051bdbbacbc97afd4dfb07bae1bea514381fc1966aede89d6796ef2377a15748a93d95e2ad494c8497db489e886
|
||||
|
Loading…
Reference in New Issue
Block a user