Rebase to 7.9-branch snapshot 7.8.90.20150214.
This commit is contained in:
parent
21fb199a6f
commit
7cbf529231
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
/gdb-libstdc++-v3-python-r155978.tar.bz2
|
/gdb-libstdc++-v3-python-r155978.tar.bz2
|
||||||
/gdb-7.8.90.20150202.tar.xz
|
/gdb-7.8.90.20150214.tar.xz
|
||||||
|
@ -3,9 +3,11 @@ printed, but a default backtrace will occur in this case.
|
|||||||
|
|
||||||
--
|
--
|
||||||
|
|
||||||
--- gdb-7.7.90.20140613/gdb/python/py-framefilter.c-orig 2014-06-13 03:59:37.000000000 +0200
|
Index: gdb-7.8.90.20150214/gdb/python/py-framefilter.c
|
||||||
+++ gdb-7.7.90.20140613/gdb/python/py-framefilter.c 2014-06-27 17:20:00.945271945 +0200
|
===================================================================
|
||||||
@@ -1475,6 +1475,7 @@ gdbpy_apply_frame_filter (const struct e
|
--- gdb-7.8.90.20150214.orig/gdb/python/py-framefilter.c 2015-02-14 17:35:12.277653200 +0100
|
||||||
|
+++ gdb-7.8.90.20150214/gdb/python/py-framefilter.c 2015-02-14 17:36:15.737953789 +0100
|
||||||
|
@@ -1506,6 +1506,7 @@ gdbpy_apply_frame_filter (const struct e
|
||||||
volatile struct gdb_exception except;
|
volatile struct gdb_exception except;
|
||||||
PyObject *item;
|
PyObject *item;
|
||||||
htab_t levels_printed;
|
htab_t levels_printed;
|
||||||
@ -13,7 +15,7 @@ printed, but a default backtrace will occur in this case.
|
|||||||
|
|
||||||
if (!gdb_python_initialized)
|
if (!gdb_python_initialized)
|
||||||
return EXT_LANG_BT_NO_FILTERS;
|
return EXT_LANG_BT_NO_FILTERS;
|
||||||
@@ -1494,24 +1495,7 @@ gdbpy_apply_frame_filter (const struct e
|
@@ -1525,24 +1526,7 @@ gdbpy_apply_frame_filter (const struct e
|
||||||
iterable = bootstrap_python_frame_filters (frame, frame_low, frame_high);
|
iterable = bootstrap_python_frame_filters (frame, frame_low, frame_high);
|
||||||
|
|
||||||
if (iterable == NULL)
|
if (iterable == NULL)
|
||||||
@ -39,10 +41,11 @@ printed, but a default backtrace will occur in this case.
|
|||||||
|
|
||||||
/* If iterable is None, then there are no frame filters registered.
|
/* If iterable is None, then there are no frame filters registered.
|
||||||
If this is the case, defer to default GDB printing routines in MI
|
If this is the case, defer to default GDB printing routines in MI
|
||||||
@@ -1540,15 +1524,39 @@ gdbpy_apply_frame_filter (const struct e
|
@@ -1573,15 +1557,40 @@ gdbpy_apply_frame_filter (const struct e
|
||||||
|
error and continue with other frames. */
|
||||||
|
if (success == EXT_LANG_BT_ERROR)
|
||||||
gdbpy_print_stack ();
|
gdbpy_print_stack ();
|
||||||
|
+
|
||||||
Py_DECREF (item);
|
|
||||||
+ count_printed++;
|
+ count_printed++;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
7
gdb.spec
7
gdb.spec
@ -22,11 +22,11 @@ Name: %{?scl_prefix}gdb
|
|||||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||||
%global snapgnulib 20121213
|
%global snapgnulib 20121213
|
||||||
%global tarname gdb-%{version}
|
%global tarname gdb-%{version}
|
||||||
Version: 7.8.90.20150202
|
Version: 7.8.90.20150214
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1315,6 +1315,9 @@ then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 14 2015 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.8.90.20150214-6.fc22
|
||||||
|
- Rebase to 7.9-branch snapshot 7.8.90.20150214.
|
||||||
|
|
||||||
* Wed Feb 11 2015 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.8.90.20150202-5.fc22
|
* Wed Feb 11 2015 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.8.90.20150202-5.fc22
|
||||||
- Enable guile support.
|
- Enable guile support.
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
4981307aa9619bbec5b73261e4e41c8d gdb-libstdc++-v3-python-r155978.tar.bz2
|
4981307aa9619bbec5b73261e4e41c8d gdb-libstdc++-v3-python-r155978.tar.bz2
|
||||||
3821d055a639644d09bd9734e59b051c gdb-7.8.90.20150202.tar.xz
|
fab37432102631ff7984c905fe2fc968 gdb-7.8.90.20150214.tar.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user