Make adjustments to gdb-6.6-buildid-locate.patch, provided by Tom de Vries.
This commit is contained in:
parent
39bde43193
commit
76962235f8
@ -911,10 +911,10 @@ diff --git a/gdb/build-id.c b/gdb/build-id.c
|
|||||||
return std::string ();
|
return std::string ();
|
||||||
}
|
}
|
||||||
+
|
+
|
||||||
+extern void _initialize_build_id (void);
|
+void _initialize_build_id ();
|
||||||
+
|
+
|
||||||
+void
|
+void
|
||||||
+_initialize_build_id (void)
|
+_initialize_build_id ()
|
||||||
+{
|
+{
|
||||||
+ add_setshow_zinteger_cmd ("build-id-verbose", no_class, &build_id_verbose,
|
+ add_setshow_zinteger_cmd ("build-id-verbose", no_class, &build_id_verbose,
|
||||||
+ _("\
|
+ _("\
|
||||||
@ -1381,7 +1381,17 @@ diff --git a/gdb/testsuite/gdb.base/new-ui-pending-input.exp b/gdb/testsuite/gdb
|
|||||||
diff --git a/gdb/testsuite/lib/gdb.exp b/gdb/testsuite/lib/gdb.exp
|
diff --git a/gdb/testsuite/lib/gdb.exp b/gdb/testsuite/lib/gdb.exp
|
||||||
--- a/gdb/testsuite/lib/gdb.exp
|
--- a/gdb/testsuite/lib/gdb.exp
|
||||||
+++ b/gdb/testsuite/lib/gdb.exp
|
+++ b/gdb/testsuite/lib/gdb.exp
|
||||||
@@ -2130,6 +2130,17 @@ proc default_gdb_start { } {
|
@@ -130,7 +130,8 @@ if ![info exists INTERNAL_GDBFLAGS] {
|
||||||
|
"-nx" \
|
||||||
|
"-data-directory $BUILD_DATA_DIRECTORY" \
|
||||||
|
{-iex "set height 0"} \
|
||||||
|
- {-iex "set width 0"}]]
|
||||||
|
+ {-iex "set width 0"} \
|
||||||
|
+ {-iex "set build-id-verbose 0"}]]
|
||||||
|
}
|
||||||
|
|
||||||
|
# The variable gdb_prompt is a regexp which matches the gdb prompt.
|
||||||
|
@@ -2130,6 +2131,17 @@ proc default_gdb_start { } {
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
|
5
gdb.spec
5
gdb.spec
@ -37,7 +37,7 @@ Version: 11.1
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||||
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
||||||
@ -1143,6 +1143,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 3 2021 Kevin Buettner - 11.1-3
|
||||||
|
- Make adjustments to gdb-6.6-buildid-locate.patch, provided by Tom de Vries.
|
||||||
|
|
||||||
* Mon Oct 11 2021 Kevin Buettner - 11.1-2
|
* Mon Oct 11 2021 Kevin Buettner - 11.1-2
|
||||||
- Backport upstream patch which papers over Fortran lexical analyzer
|
- Backport upstream patch which papers over Fortran lexical analyzer
|
||||||
bug (RHBZ 2012976, Tom de Vries).
|
bug (RHBZ 2012976, Tom de Vries).
|
||||||
|
Loading…
Reference in New Issue
Block a user