Merge libunwind testsuite, and signal patches.
This commit is contained in:
parent
5185b7b341
commit
75eaddb190
76
gdb-6.3-rh-testlibunwind-20041202.patch
Normal file
76
gdb-6.3-rh-testlibunwind-20041202.patch
Normal file
@ -0,0 +1,76 @@
|
||||
2003-11-17 Elena Zannoni <ezannoni@redhat.com>
|
||||
|
||||
From Jeff Johnston <jjohnstn@redhat.com>
|
||||
* gdb.arch/ia64-libunwind.exp: New file.
|
||||
* gdb.arch/ia64-libunwind.c: New file.
|
||||
|
||||
--- /dev/null Thu Apr 11 10:25:15 2002
|
||||
+++ gdb+dejagnu-20040223/gdb/testsuite/gdb.arch/ia64-libunwind.exp Mon Nov 17 15:57:04 2003
|
||||
@@ -0,0 +1,55 @@
|
||||
+# Copyright 2003 Free Software Foundation, Inc.
|
||||
+
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 2 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program; if not, write to the Free Software
|
||||
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+
|
||||
+# Please email any bugs, comments, and/or additions to this file to:
|
||||
+# bug-gdb@prep.ai.mit.edu
|
||||
+
|
||||
+# This file was written by Jeff Johnston (jjohnstn@redhat.com)
|
||||
+
|
||||
+if $tracelevel then {
|
||||
+ strace $tracelevel
|
||||
+}
|
||||
+
|
||||
+#
|
||||
+# test running programs
|
||||
+#
|
||||
+set prms_id 0
|
||||
+set bug_id 0
|
||||
+
|
||||
+if ![istarget "ia64-*-*"] then {
|
||||
+ return
|
||||
+}
|
||||
+
|
||||
+set testfile "ia64-libunwind"
|
||||
+set srcfile ${testfile}.c
|
||||
+set binfile ${objdir}/${subdir}/${testfile}
|
||||
+
|
||||
+if { [gdb_compile "${srcdir}/${subdir}/${srcfile}" "${binfile}" executable {debug additional_flags=-w}] != "" } {
|
||||
+ gdb_suppress_entire_file "Testcase compile failed, so all tests in this file will automatically fail."
|
||||
+}
|
||||
+
|
||||
+if [get_compiler_info ${binfile}] {
|
||||
+ return -1
|
||||
+}
|
||||
+
|
||||
+gdb_exit
|
||||
+gdb_start
|
||||
+gdb_reinitialize_dir $srcdir/$subdir
|
||||
+gdb_load ${binfile}
|
||||
+send_gdb "set debug arch 1\n"
|
||||
+send_gdb "break main\n"
|
||||
+gdb_test "run" ".*acquire_unwind_info.*"
|
||||
+
|
||||
--- /dev/null Thu Apr 11 10:25:15 2002
|
||||
+++ gdb+dejagnu-20040223/gdb/testsuite/gdb.arch/ia64-libunwind.c Mon Nov 17 15:58:27 2003
|
||||
@@ -0,0 +1,9 @@
|
||||
+#include <stdio.h>
|
||||
+
|
||||
+int main()
|
||||
+{
|
||||
+ printf ("hello world\n");
|
||||
+
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
14
gdb-6.3-rh-testlibunwind1fix-20041202.patch
Normal file
14
gdb-6.3-rh-testlibunwind1fix-20041202.patch
Normal file
@ -0,0 +1,14 @@
|
||||
2004-08-03 Jeff Johnston <jjohnstn@redhat.com>
|
||||
|
||||
* gdb.arch/ia64-libunwind.exp: Fix test string to match
|
||||
current code base.
|
||||
|
||||
--- gdb+dejagnu-20040607/gdb/testsuite/gdb.arch/ia64-libunwind.exp.fix Tue Aug 3 18:29:22 2004
|
||||
+++ gdb+dejagnu-20040607/gdb/testsuite/gdb.arch/ia64-libunwind.exp Tue Aug 3 18:41:01 2004
|
||||
@@ -51,5 +51,5 @@ gdb_reinitialize_dir $srcdir/$subdir
|
||||
gdb_load ${binfile}
|
||||
send_gdb "set debug arch 1\n"
|
||||
send_gdb "break main\n"
|
||||
-gdb_test "run" ".*acquire_unwind_info.*"
|
||||
+gdb_test "run" ".*ia64_find_proc_info_x.*"
|
||||
|
58
gdb-6.3-sigx86-20040621.patch
Normal file
58
gdb-6.3-sigx86-20040621.patch
Normal file
@ -0,0 +1,58 @@
|
||||
2004-06-21 Andrew Cagney <cagney@gnu.org>
|
||||
|
||||
* i386-tdep.c (i386_gdbarch_init): Move the the dwarf2-frame
|
||||
sniffer registration to after the signal trampoline frame sniffer.
|
||||
* amd64-tdep.c (amd64_init_abi): Include "dwarf2-frame.h".
|
||||
Register the dwarf2-frame sniffer, but after the signal trampoline
|
||||
sniffer.
|
||||
|
||||
Index: ./gdb/amd64-tdep.c
|
||||
===================================================================
|
||||
RCS file: /cvs/src/src/gdb/amd64-tdep.c,v
|
||||
retrieving revision 1.15
|
||||
diff -p -u -r1.15 amd64-tdep.c
|
||||
--- ./gdb/amd64-tdep.c 7 Jun 2004 02:02:45 -0000 1.15
|
||||
+++ ./gdb/amd64-tdep.c 21 Jun 2004 20:16:34 -0000
|
||||
@@ -34,7 +34,7 @@
|
||||
#include "regcache.h"
|
||||
#include "regset.h"
|
||||
#include "symfile.h"
|
||||
-
|
||||
+#include "dwarf2-frame.h"
|
||||
#include "gdb_assert.h"
|
||||
|
||||
#include "amd64-tdep.h"
|
||||
@@ -1171,6 +1171,8 @@ amd64_init_abi (struct gdbarch_info info
|
||||
set_gdbarch_in_solib_call_trampoline (gdbarch, in_plt_section);
|
||||
|
||||
frame_unwind_append_sniffer (gdbarch, amd64_sigtramp_frame_sniffer);
|
||||
+ /* Hook in the DWARF CFI frame unwinder after sigtramp. */
|
||||
+ frame_unwind_append_sniffer (gdbarch, dwarf2_frame_sniffer);
|
||||
frame_unwind_append_sniffer (gdbarch, amd64_frame_sniffer);
|
||||
frame_base_set_default (gdbarch, &amd64_frame_base);
|
||||
|
||||
Index: ./gdb/i386-tdep.c
|
||||
===================================================================
|
||||
RCS file: /cvs/src/src/gdb/i386-tdep.c,v
|
||||
retrieving revision 1.197
|
||||
diff -p -u -r1.197 i386-tdep.c
|
||||
--- ./gdb/i386-tdep.c 18 Jun 2004 16:06:24 -0000 1.197
|
||||
+++ ./gdb/i386-tdep.c 21 Jun 2004 20:16:34 -0000
|
||||
@@ -2131,15 +2131,14 @@ i386_gdbarch_init (struct gdbarch_info i
|
||||
/* Helper for function argument information. */
|
||||
set_gdbarch_fetch_pointer_argument (gdbarch, i386_fetch_pointer_argument);
|
||||
|
||||
- /* Hook in the DWARF CFI frame unwinder. */
|
||||
- frame_unwind_append_sniffer (gdbarch, dwarf2_frame_sniffer);
|
||||
-
|
||||
frame_base_set_default (gdbarch, &i386_frame_base);
|
||||
|
||||
/* Hook in ABI-specific overrides, if they have been registered. */
|
||||
gdbarch_init_osabi (info, gdbarch);
|
||||
|
||||
frame_unwind_append_sniffer (gdbarch, i386_sigtramp_frame_sniffer);
|
||||
+ /* Hook in the DWARF CFI frame unwinder after sigtramp. */
|
||||
+ frame_unwind_append_sniffer (gdbarch, dwarf2_frame_sniffer);
|
||||
frame_unwind_append_sniffer (gdbarch, i386_frame_sniffer);
|
||||
|
||||
/* If we have a register mapping, enable the generic core file
|
31
gdb.spec
31
gdb.spec
@ -38,17 +38,13 @@ Patch0: gdb-6.3-rh-changelogs-20041202.patch
|
||||
Patch1: gdb-6.3-rh-dummykfail-20041202.patch
|
||||
# Match Red Hat's version info
|
||||
Patch2: gdb-6.3-rh-testversion-20041202.patch
|
||||
# Check that libunwind works - new test then fix
|
||||
Patch3: gdb-6.3-rh-testlibunwind-20041202.patch
|
||||
Patch4: gdb-6.3-rh-testlibunwind1fix-20041202.patch
|
||||
|
||||
|
||||
# ------------------------------------------
|
||||
|
||||
# ChangeLogs patches.
|
||||
#N/A: Patch0: gdb-6.1post-ChangeLog.patch
|
||||
# ChangeLogs patches for doc.
|
||||
#N/A: Patch2: gdb-6.1post-ChangeLog-doc.patch
|
||||
|
||||
####### end patches from the previous RPM.
|
||||
|
||||
# Fix watchpoint support.
|
||||
#Patch5: gdb-6.1post-watchpoint-fix.patch
|
||||
Patch5: broken.patch
|
||||
@ -62,12 +58,6 @@ Patch8: broken.patch
|
||||
#Patch9: gdb-6.1post-linlwp-aug2004.patch
|
||||
Patch9: broken.patch
|
||||
|
||||
####### Signal trampoline fixes
|
||||
#Patch10: gdb-6.1post-sig-ppc-jun2004.patch
|
||||
Patch10: broken.patch
|
||||
Patch11: gdb-6.1post-sig-symtramp-jun2004.patch
|
||||
Patch12: gdb-6.1post-sig-x86-jun2004.patch
|
||||
|
||||
####### ABI fixes and updates
|
||||
#Patch19: gdb-6.1post-abi-ppccfi-nov2004.patch
|
||||
Patch19: broken.patch
|
||||
@ -85,9 +75,6 @@ Patch28: gdb-6.1post-abi-ppc64section-oct2004.patch
|
||||
# Get selftest working with sep-debug-info
|
||||
#Patch33: gdb-6.1post-test-self-jul2004.patch
|
||||
Patch33: broken.patch
|
||||
# Check that libunwind works - new test then fix
|
||||
Patch34: gdb-6.1post-test-rh-libunwind.patch
|
||||
Patch35: gdb-6.1post-test-rh-libunwindfix1.patch
|
||||
#Patch37: gdb-6.1post-test-bigcore64-sep2004.patch
|
||||
Patch37: broken.patch
|
||||
|
||||
@ -143,6 +130,9 @@ Patch87: gdb-6.1post-remove-bp-nov2004.patch
|
||||
|
||||
# Add fixes starting at 100
|
||||
Patch100: gdb-6.3-dwoppiecewarning-20041202.patch
|
||||
Patch101: gdb-6.3-sigx86-20040621.patch
|
||||
Patch102: gdb-6.3-sigsymtramp-20040621.patch
|
||||
Patch103: gdb-6.3-sigppc-20040621.patch
|
||||
|
||||
%ifarch ia64
|
||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu libunwind >= 0.96-3
|
||||
@ -173,17 +163,18 @@ and printing their data.
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
%patch100 -p1
|
||||
%patch101 -p1
|
||||
%patch102 -p1
|
||||
|
||||
# Apply patches defined above.
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
|
||||
%patch19 -p1
|
||||
%patch20 -p1
|
||||
@ -195,8 +186,6 @@ and printing their data.
|
||||
%patch28 -p1
|
||||
|
||||
%patch33 -p1
|
||||
%patch34 -p1
|
||||
%patch35 -p1
|
||||
%patch37 -p1
|
||||
|
||||
%patch50 -p1
|
||||
|
Loading…
Reference in New Issue
Block a user