- Update gdb.arch/powerpc-power7.exp for current binutils HEAD.
This commit is contained in:
parent
9291de59d7
commit
755bb6f90b
@ -1,6 +1,6 @@
|
||||
--- /dev/null
|
||||
+++ b/gdb/testsuite/gdb.arch/powerpc-power7.exp
|
||||
@@ -0,0 +1,175 @@
|
||||
@@ -0,0 +1,182 @@
|
||||
+# Copyright 2009 Free Software Foundation, Inc.
|
||||
+
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
@ -73,13 +73,20 @@
|
||||
+}
|
||||
+
|
||||
+func_check 0x0 "lxvd2x vs3,r4,r5"
|
||||
+func_check 0x4 "lxvd2ux vs3,r4,r5"
|
||||
+# [PATCH] Remove support for POWER7 VSX load/store with update instructions
|
||||
+# http://sourceware.org/ml/binutils/2009-09/msg00680.html
|
||||
+# http://sourceware.org/ml/binutils-cvs/2009-09/msg00331.html
|
||||
+# lxvd2ux vs3,r4,r5
|
||||
+func_check 0x4 ".long 0x7c642ed8"
|
||||
+func_check 0x8 "lxvd2x vs43,r4,r5"
|
||||
+func_check 0xc "lxvd2ux vs43,r4,r5"
|
||||
+# lxvd2ux vs43,r4,r5
|
||||
+func_check 0xc ".long 0x7d642ed9"
|
||||
+func_check 0x10 "stxvd2x vs3,r4,r5"
|
||||
+func_check 0x14 "stxvd2ux vs3,r4,r5"
|
||||
+# stxvd2ux vs3,r4,r5
|
||||
+func_check 0x14 ".long 0x7c642fd8"
|
||||
+func_check 0x18 "stxvd2x vs43,r4,r5"
|
||||
+func_check 0x1c "stxvd2ux vs43,r4,r5"
|
||||
+# stxvd2ux vs43,r4,r5
|
||||
+func_check 0x1c ".long 0x7d642fd9"
|
||||
+func_check 0x20 "xxmrghd vs3,vs4,vs5"
|
||||
+func_check 0x24 "xxmrghd vs43,vs44,vs45"
|
||||
+func_check 0x28 "xxmrgld vs3,vs4,vs5"
|
||||
|
5
gdb.spec
5
gdb.spec
@ -36,7 +36,7 @@ Version: 7.0.50.20100121
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 6%{?_with_upstream:.upstream}%{dist}
|
||||
Release: 7%{?_with_upstream:.upstream}%{dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -1018,6 +1018,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Jan 24 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100121-7.fc13
|
||||
- Update gdb.arch/powerpc-power7.exp for current binutils HEAD.
|
||||
|
||||
* Fri Jan 22 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100121-6.fc13
|
||||
- Disable addon (finish) due to inline-cmds.exp: up from outer_inline2 assert.
|
||||
- Fix gdb.arch/powerpc-power7.exp compatibility.
|
||||
|
Loading…
Reference in New Issue
Block a user