Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/gdb.git#0426a1ed0353d4bf12f51aa219c458f1050191de
This commit is contained in:
parent
6a3daf7366
commit
73a24f6823
@ -37,6 +37,10 @@ Patch009: gdb-6.3-test-movedir-20050125.patch
|
||||
#=fedoratest
|
||||
Patch010: gdb-6.3-threaded-watchpoints2-20050225.patch
|
||||
|
||||
# Notify observers that the inferior has been created
|
||||
#=fedoratest
|
||||
Patch011: gdb-6.3-inferior-notification-20050721.patch
|
||||
|
||||
# Verify printing of inherited members test
|
||||
#=fedoratest
|
||||
Patch012: gdb-6.3-inheritancetest-20050726.patch
|
||||
@ -98,6 +102,10 @@ Patch025: gdb-6.6-testsuite-timeouts.patch
|
||||
#=fedoratest
|
||||
Patch026: gdb-6.6-bz237572-ppc-atomic-sequence-test.patch
|
||||
|
||||
# Test kernel VDSO decoding while attaching to an i386 process.
|
||||
#=fedoratest
|
||||
Patch027: gdb-6.3-attach-see-vdso-test.patch
|
||||
|
||||
# Test leftover zombie process (BZ 243845).
|
||||
#=fedoratest
|
||||
Patch028: gdb-6.5-bz243845-stale-testing-zombie-test.patch
|
||||
@ -131,6 +139,14 @@ Patch034: gdb-6.7-testsuite-stable-results.patch
|
||||
#=fedoratest
|
||||
Patch035: gdb-6.5-ia64-libunwind-leak-test.patch
|
||||
|
||||
# Test hiding unexpected breakpoints on intentional step commands.
|
||||
#=fedoratest
|
||||
Patch036: gdb-6.5-missed-trap-on-step-test.patch
|
||||
|
||||
# Test gcore memory and time requirements for large inferiors.
|
||||
#=fedoratest
|
||||
Patch037: gdb-6.5-gcore-buffer-limit-test.patch
|
||||
|
||||
# Test GCORE for shmid 0 shared memory mappings.
|
||||
#=fedoratest: But it is broken anyway, sometimes the case being tested is not reproducible.
|
||||
Patch038: gdb-6.3-mapping-zero-inode-test.patch
|
||||
@ -383,3 +399,14 @@ Patch097: gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
# =fedoratest
|
||||
Patch098: gdb-rhbz1905996-fix-off-by-one-error-in-ada_fold_name.patch
|
||||
|
||||
# Backport fix for libstdc++ assert when performing tab completion
|
||||
# (RH BZ 1912985).
|
||||
Patch099: gdb-rhbz1912985-libstdc++-assert.patch
|
||||
|
||||
# Backport fix for rawhide build error (RH BZ 1930528).
|
||||
Patch100: gdb-rhbz1930528-fix-gnulib-build-error.patch
|
||||
|
||||
# [aarch64] Backport fix for aarch64-linux-hw-point.c build problem
|
||||
# (RH BZ 1932645).
|
||||
Patch101: gdb-rhbz1932645-aarch64-ptrace-header-order.patch
|
||||
|
||||
|
@ -8,6 +8,7 @@
|
||||
%patch008 -p1
|
||||
%patch009 -p1
|
||||
%patch010 -p1
|
||||
%patch011 -p1
|
||||
%patch012 -p1
|
||||
%patch013 -p1
|
||||
%patch014 -p1
|
||||
@ -23,6 +24,7 @@
|
||||
%patch024 -p1
|
||||
%patch025 -p1
|
||||
%patch026 -p1
|
||||
%patch027 -p1
|
||||
%patch028 -p1
|
||||
%patch029 -p1
|
||||
%patch030 -p1
|
||||
@ -31,6 +33,8 @@
|
||||
%patch033 -p1
|
||||
%patch034 -p1
|
||||
%patch035 -p1
|
||||
%patch036 -p1
|
||||
%patch037 -p1
|
||||
%patch038 -p1
|
||||
%patch039 -p1
|
||||
%patch040 -p1
|
||||
@ -92,3 +96,6 @@
|
||||
%patch096 -p1
|
||||
%patch097 -p1
|
||||
%patch098 -p1
|
||||
%patch099 -p1
|
||||
%patch100 -p1
|
||||
%patch101 -p1
|
||||
|
@ -96,3 +96,6 @@ gdb-archer.patch
|
||||
gdb-vla-intel-fix-print-char-array.patch
|
||||
gdb-rhbz1553104-s390x-arch12-test.patch
|
||||
gdb-rhbz1905996-fix-off-by-one-error-in-ada_fold_name.patch
|
||||
gdb-rhbz1912985-libstdc++-assert.patch
|
||||
gdb-rhbz1930528-fix-gnulib-build-error.patch
|
||||
gdb-rhbz1932645-aarch64-ptrace-header-order.patch
|
||||
|
64
gdb-rhbz1912985-libstdc++-assert.patch
Normal file
64
gdb-rhbz1912985-libstdc++-assert.patch
Normal file
@ -0,0 +1,64 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Buettner <kevinb@redhat.com>
|
||||
Date: Wed, 17 Feb 2021 17:58:54 -0700
|
||||
Subject: gdb-rhbz1912985-libstdc++-assert.patch
|
||||
|
||||
;; Backport fix for libstdc++ assert when performing tab completion
|
||||
;; (RH BZ 1912985).
|
||||
|
||||
Fix completion related libstdc++ assert when using -D_GLIBCXX_DEBUG
|
||||
|
||||
This commit fixes a libstdc++ assertion failure encountered when
|
||||
running gdb.base/completion.exp. In order to see this problem,
|
||||
GDB must be built with the follow CFLAGS and CXXFLAGS as part
|
||||
of the configure line:
|
||||
|
||||
CFLAGS='-D_GLIBCXX_DEBUG' CXXFLAGS='-D_GLIBCXX_DEBUG'
|
||||
|
||||
(Also, this problem was encountered using Fedora rawhide. It might
|
||||
not be reproducible in Fedora versions prior to Fedora 34.)
|
||||
|
||||
Using the gdb.base/completion.exp test program, the problem can be
|
||||
observed as follows:
|
||||
|
||||
[kev@rawhide-1 gdb]$ ./gdb -q testsuite/outputs/gdb.base/completion/completion
|
||||
Reading symbols from testsuite/outputs/gdb.base/completion/completion...
|
||||
(gdb) start
|
||||
Temporary breakpoint 1 at 0x401179: file ../../worktree-master/gdb/testsuite/gdb.base/break.c, line 43.
|
||||
Starting program: testsuite/outputs/gdb.base/completion/completion
|
||||
|
||||
Temporary breakpoint 1, main (argc=1, argv=0x7fffffffd718, envp=0x7fffffffd728) at ../../worktree-master/gdb/testsuite/gdb.base/break.c:43
|
||||
43 if (argc == 12345) { /* an unlikely value < 2^16, in case uninited */ /* set breakpoint 6 here */
|
||||
(gdb) p <TAB>/usr/include/c++/11/string_view:211: constexpr const value_type& std::basic_string_view<_CharT, _Traits>::operator[](std::basic_string_view<_CharT, _Traits>::size_type) const [with _CharT = char; _Traits = std::char_traits<char>; std::basic_string_view<_CharT, _Traits>::const_reference = const char&; std::basic_string_view<_CharT, _Traits>::size_type = long unsigned int]: Assertion '__pos < this->_M_len' failed.
|
||||
Aborted (core dumped)
|
||||
|
||||
(Note that I added "<TAB>" to make it clear where the tab key was
|
||||
pressed.)
|
||||
|
||||
gdb/ChangeLog:
|
||||
|
||||
* ada-lang.c (ada_fold_name): Check for non-empty string prior
|
||||
to accessing it.
|
||||
(ada_lookup_name_info): Likewise.
|
||||
|
||||
diff --git a/gdb/ada-lang.c b/gdb/ada-lang.c
|
||||
--- a/gdb/ada-lang.c
|
||||
+++ b/gdb/ada-lang.c
|
||||
@@ -997,7 +997,7 @@ ada_fold_name (gdb::string_view name)
|
||||
int len = name.size ();
|
||||
GROW_VECT (fold_buffer, fold_buffer_size, len + 1);
|
||||
|
||||
- if (name[0] == '\'')
|
||||
+ if (!name.empty () && name[0] == '\'')
|
||||
{
|
||||
strncpy (fold_buffer, name.data () + 1, len - 2);
|
||||
fold_buffer[len - 2] = '\000';
|
||||
@@ -13592,7 +13592,7 @@ ada_lookup_name_info::ada_lookup_name_info (const lookup_name_info &lookup_name)
|
||||
{
|
||||
gdb::string_view user_name = lookup_name.name ();
|
||||
|
||||
- if (user_name[0] == '<')
|
||||
+ if (!user_name.empty () && user_name[0] == '<')
|
||||
{
|
||||
if (user_name.back () == '>')
|
||||
m_encoded_name
|
54
gdb-rhbz1930528-fix-gnulib-build-error.patch
Normal file
54
gdb-rhbz1930528-fix-gnulib-build-error.patch
Normal file
@ -0,0 +1,54 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Buettner <kevinb@redhat.com>
|
||||
Date: Thu, 18 Feb 2021 23:04:29 -0700
|
||||
Subject: gdb-rhbz1930528-fix-gnulib-build-error.patch
|
||||
|
||||
;; Backport fix for rawhide build error (RH BZ 1930528).
|
||||
|
||||
amd64-linux-siginfo.c: Adjust include order to avoid gnulib error
|
||||
|
||||
On Fedora rawhide, after updating to glibc-2.33, I'm seeing the
|
||||
following build failure:
|
||||
|
||||
CXX nat/amd64-linux-siginfo.o
|
||||
In file included from /usr/include/bits/sigstksz.h:24,
|
||||
from /usr/include/signal.h:315,
|
||||
from ../gnulib/import/signal.h:52,
|
||||
from /ironwood1/sourceware-git/rawhide-gnulib/bld/../../worktree-gnulib/gdbserver/../gdb/nat/amd64-linux-siginfo.c:20:
|
||||
../gnulib/import/unistd.h:663:3: error: #error "Please include config.h first."
|
||||
663 | #error "Please include config.h first."
|
||||
| ^~~~~
|
||||
|
||||
glibc-2.33 has changed signal.h to now include <bits/sigstksz.h> which,
|
||||
in turn, includes <unistd.h>. For a gdb build, this causes the gnulib
|
||||
version of unistd.h to be pulled in first. The build failure shown
|
||||
above happens because gnulib's config.h has not been included before
|
||||
the include of <signal.h>.
|
||||
|
||||
The fix is simple - we just rearrange the order of the header file
|
||||
includes to make sure that gdbsupport/commondefs.h is included before
|
||||
attempting to include signal.h. Note that gdbsupport/commondefs.h
|
||||
includes <gnulib/config.h>.
|
||||
|
||||
Build and regression tested on Fedora 33. On Fedora rawhide, GDB
|
||||
builds again.
|
||||
|
||||
gdb/ChangeLog:
|
||||
|
||||
* nat/amd64-linux-siginfo.c: Include "gdbsupport/common-defs.h"
|
||||
(which in turn includes <gnulib/config.h>) before include
|
||||
of <signal.h>.
|
||||
|
||||
diff --git a/gdb/nat/amd64-linux-siginfo.c b/gdb/nat/amd64-linux-siginfo.c
|
||||
--- a/gdb/nat/amd64-linux-siginfo.c
|
||||
+++ b/gdb/nat/amd64-linux-siginfo.c
|
||||
@@ -17,8 +17,8 @@
|
||||
You should have received a copy of the GNU General Public License
|
||||
along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||
|
||||
-#include <signal.h>
|
||||
#include "gdbsupport/common-defs.h"
|
||||
+#include <signal.h>
|
||||
#include "amd64-linux-siginfo.h"
|
||||
|
||||
#define GDB_SI_SIZE 128
|
69
gdb-rhbz1932645-aarch64-ptrace-header-order.patch
Normal file
69
gdb-rhbz1932645-aarch64-ptrace-header-order.patch
Normal file
@ -0,0 +1,69 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Buettner <kevinb@redhat.com>
|
||||
Date: Wed, 24 Feb 2021 13:19:08 -0700
|
||||
Subject: gdb-rhbz1932645-aarch64-ptrace-header-order.patch
|
||||
|
||||
;; [aarch64] Backport fix for aarch64-linux-hw-point.c build problem
|
||||
;; (RH BZ 1932645).
|
||||
|
||||
Fix aarch64-linux-hw-point.c build problem
|
||||
|
||||
Due to a recent glibc header file change, the file
|
||||
nat/aarch64-linux-hw-point.c no longer builds on Fedora rawhide.
|
||||
|
||||
An enum for PTRACE_SYSEMU is now provided by <sys/ptrace.h>. In the
|
||||
past, PTRACE_SYSEMU was defined only in <asm/ptrace.h>. This is
|
||||
what it looks like...
|
||||
|
||||
In <asm/ptrace.h>:
|
||||
|
||||
#define PTRACE_SYSEMU 31
|
||||
|
||||
In <sys/ptrace.h>:
|
||||
|
||||
enum __ptrace_request
|
||||
{
|
||||
...
|
||||
PTRACE_SYSEMU = 31,
|
||||
#define PT_SYSEMU PTRACE_SYSEMU
|
||||
|
||||
...
|
||||
}
|
||||
|
||||
When <asm/ptrace.h> and <sys/ptrace.h> are both included in a source
|
||||
file, we run into the following build problem when the former is
|
||||
included before the latter:
|
||||
|
||||
In file included from nat/aarch64-linux-hw-point.c:26:
|
||||
/usr/include/sys/ptrace.h:86:3: error: expected identifier before numeric constant
|
||||
86 | PTRACE_SYSEMU = 31,
|
||||
| ^~~~~~~~~~~~~
|
||||
|
||||
(There are more errors after this one too.)
|
||||
|
||||
The file builds without error when <asm/ptrace.h> is included after
|
||||
<sys/ptrace.h>. I found that this is already done in
|
||||
nat/aarch64-sve-linux-ptrace.h (which is included by
|
||||
nat/aarch64-linux-ptrace.c).
|
||||
|
||||
I've tested this change on Fedora rawhide and Fedora 33, both
|
||||
running on an aarch64 machine.
|
||||
|
||||
gdb/ChangeLog:
|
||||
|
||||
* nat/aarch64-linux-hw-point.c: Include <asm/ptrace.h> after
|
||||
<sys/ptrace.h>.
|
||||
|
||||
diff --git a/gdb/nat/aarch64-linux-hw-point.c b/gdb/nat/aarch64-linux-hw-point.c
|
||||
--- a/gdb/nat/aarch64-linux-hw-point.c
|
||||
+++ b/gdb/nat/aarch64-linux-hw-point.c
|
||||
@@ -23,8 +23,8 @@
|
||||
#include "aarch64-linux-hw-point.h"
|
||||
|
||||
#include <sys/uio.h>
|
||||
-#include <asm/ptrace.h>
|
||||
#include <sys/ptrace.h>
|
||||
+#include <asm/ptrace.h>
|
||||
#include <elf.h>
|
||||
|
||||
/* Number of hardware breakpoints/watchpoints the target supports.
|
18
gdb.spec
18
gdb.spec
@ -37,7 +37,7 @@ Version: 10.1
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
||||
@ -1195,7 +1195,21 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Feb 17 20201 Keith Seitz <keiths@redhat.com> - 10.1-6
|
||||
* Wed Feb 24 2021 Kevin Buettner <kevinb@redhat.com> - 10.1-7
|
||||
- Fix aarch64 build problem (RHBZ 1932645, Kevin Buettner).
|
||||
|
||||
* Fri Feb 19 2021 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
- Fix gdb-vla-intel-fortran-vla-strings.patch for compatiblity with GraalVM.
|
||||
|
||||
* Thu Feb 18 2021 Kevin Buettner <kevinb@redhat.com>
|
||||
- Fix gnulib related build problem (RHBZ 1930528, Kevin Buettner).
|
||||
|
||||
* Wed Feb 17 2021 Kevin Buettner <kevinb@redhat.com>
|
||||
- Fix libstdc++ assert when performing tab completion; build must be made
|
||||
with -D_GLIBCXX_DEBUG flag in order to trigger assert (RHBZ 1912985,
|
||||
Kevin Buettner).
|
||||
|
||||
* Wed Feb 17 2021 Keith Seitz <keiths@redhat.com> - 10.1-6
|
||||
- NVR bump to disable guile support.
|
||||
|
||||
* Thu Feb 11 2021 Keith Seitz
|
||||
|
Loading…
Reference in New Issue
Block a user