- Upgrade to the FSF GDB snapshot: 7.0.50.20100118
- Upgrade libstdc++-v3-python to r155978 (Phil Muldoon).
This commit is contained in:
parent
8c4c91efd9
commit
626a9059b8
@ -1,2 +1,2 @@
|
||||
gdb-7.0.50.20100116.tar.bz2
|
||||
libstdc++-v3-python-r151798.tar.bz2
|
||||
gdb-7.0.50.20100118.tar.bz2
|
||||
libstdc++-v3-python-r155978.tar.bz2
|
||||
|
152
gdb-testsuite-lineno.patch
Normal file
152
gdb-testsuite-lineno.patch
Normal file
@ -0,0 +1,152 @@
|
||||
http://sourceware.org/ml/gdb-patches/2010-01/msg00461.html
|
||||
Subject: [patch] testsuite: Fix misplaced line numbers
|
||||
|
||||
Hi,
|
||||
|
||||
commit 7a82dfb2a9be66f0230229642cbee54ebda3b0da
|
||||
Author: Joel Brobecker <brobecker@gnat.com>
|
||||
Date: Fri Jan 1 07:31:28 2010 +0000
|
||||
|
||||
Update copyright year in most headers.
|
||||
|
||||
Automatic update by copyright.sh.
|
||||
|
||||
regressed:
|
||||
|
||||
-PASS: gdb.mi/mi-break.exp: run to breakpoint with ignore count
|
||||
+FAIL: gdb.mi/mi-break.exp: run to breakpoint with ignore count (stopped at wrong place)
|
||||
-PASS: gdb.mi/mi-cli.exp: continue to callee4
|
||||
+FAIL: gdb.mi/mi-cli.exp: continue to callee4 (stopped at wrong place)
|
||||
-PASS: gdb.mi/mi-cli.exp: check *stopped from CLI command
|
||||
+FAIL: gdb.mi/mi-cli.exp: check *stopped from CLI command (stopped at wrong place)
|
||||
-PASS: gdb.mi/mi2-cli.exp: continue to callee4
|
||||
+FAIL: gdb.mi/mi2-cli.exp: continue to callee4 (stopped at wrong place)
|
||||
|
||||
due to:
|
||||
|
||||
#--- a/gdb/testsuite/gdb.mi/basics.c
|
||||
#+++ b/gdb/testsuite/gdb.mi/basics.c
|
||||
#@@ -1,4 +1,5 @@
|
||||
#-/* Copyright 1999, 2000, 2004, 2007, 2008, 2009 Free Software Foundation, Inc.
|
||||
#+/* Copyright 1999, 2000, 2004, 2007, 2008, 2009, 2010
|
||||
#+Free Software Foundation, Inc.
|
||||
|
||||
|
||||
Tested on x86_64-fedora12-linux-gnu.
|
||||
|
||||
|
||||
Thanks,
|
||||
Jan
|
||||
|
||||
|
||||
2010-01-18 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* gdb.mi/mi-break.exp (set line_callme_head, set line_callme_body): New.
|
||||
(test_ignore_count): Declare line_callme_body global.
|
||||
(run to breakpoint with ignore count): Use line_callme_body.
|
||||
* gdb.mi/mi-cli.exp (set line_main_head, set line_main_body)
|
||||
(set line_main_hello, set line_main_return): Reindent.
|
||||
(set line_callee4_head, set line_callee4_body, set line_callee4_next):
|
||||
New.
|
||||
(continue to callee4): Use line_callee4_body.
|
||||
(check *stopped from CLI command): Use line_callee4_next.
|
||||
* gdb.mi/mi2-cli.exp (set line_main_head, set line_main_body)
|
||||
(set line_main_hello, set line_main_return): Reindent.
|
||||
(set line_callee4_head, set line_callee4_body): New.
|
||||
(continue to callee4): Use line_callee4_body.
|
||||
|
||||
--- a/gdb/testsuite/gdb.mi/mi-break.exp
|
||||
+++ b/gdb/testsuite/gdb.mi/mi-break.exp
|
||||
@@ -56,6 +56,8 @@ set line_callee1_head [gdb_get_line_number "callee1 ("]
|
||||
set line_callee1_body [expr $line_callee1_head + 2]
|
||||
set line_main_head [gdb_get_line_number "main ("]
|
||||
set line_main_body [expr $line_main_head + 2]
|
||||
+set line_callme_head [gdb_get_line_number "callme ("]
|
||||
+set line_callme_body [expr $line_callme_head + 2]
|
||||
|
||||
set fullname "fullname=\"${fullname_syntax}${srcfile}\""
|
||||
|
||||
@@ -152,6 +154,7 @@ proc test_rbreak_creation_and_listing {} {
|
||||
|
||||
proc test_ignore_count {} {
|
||||
global mi_gdb_prompt
|
||||
+ global line_callme_body
|
||||
|
||||
mi_gdb_test "-break-insert -i 1 callme" \
|
||||
"\\^done.*ignore=\"1\".*" \
|
||||
@@ -159,7 +162,7 @@ proc test_ignore_count {} {
|
||||
|
||||
mi_run_cmd
|
||||
|
||||
- mi_expect_stop "breakpoint-hit" "callme" "\{name=\"i\",value=\"2\"\}" ".*basics.c" "52" \
|
||||
+ mi_expect_stop "breakpoint-hit" "callme" "\{name=\"i\",value=\"2\"\}" ".*basics.c" $line_callme_body \
|
||||
{"" "disp=\"keep\"" } "run to breakpoint with ignore count"
|
||||
}
|
||||
|
||||
--- a/gdb/testsuite/gdb.mi/mi-cli.exp
|
||||
+++ b/gdb/testsuite/gdb.mi/mi-cli.exp
|
||||
@@ -63,10 +63,13 @@ mi_gdb_test "-interpreter-exec console \"file $binfile\"" \
|
||||
|
||||
mi_run_to_main
|
||||
|
||||
-set line_main_head [gdb_get_line_number "main ("]
|
||||
-set line_main_body [expr $line_main_head + 2]
|
||||
-set line_main_hello [gdb_get_line_number "Hello, World!"]
|
||||
-set line_main_return [expr $line_main_hello + 2]
|
||||
+set line_main_head [gdb_get_line_number "main ("]
|
||||
+set line_main_body [expr $line_main_head + 2]
|
||||
+set line_main_hello [gdb_get_line_number "Hello, World!"]
|
||||
+set line_main_return [expr $line_main_hello + 2]
|
||||
+set line_callee4_head [gdb_get_line_number "callee4 ("]
|
||||
+set line_callee4_body [expr $line_callee4_head + 2]
|
||||
+set line_callee4_next [expr $line_callee4_body + 1]
|
||||
|
||||
mi_gdb_test "-interpreter-exec console \"set args foobar\"" \
|
||||
{\^done} \
|
||||
@@ -97,7 +100,7 @@ mi_gdb_test "-interpreter-exec console \"list\"" \
|
||||
".*\~\"$line_main_body\[\\\\t \]*callee1.*;\\\\n\".*\\^done" \
|
||||
"-interpreter-exec console \"list\""
|
||||
|
||||
-mi_execute_to "exec-continue" "breakpoint-hit" "callee4" "" ".*basics.c" "28" \
|
||||
+mi_execute_to "exec-continue" "breakpoint-hit" "callee4" "" ".*basics.c" $line_callee4_body \
|
||||
{ "" "disp=\"keep\"" } "continue to callee4"
|
||||
|
||||
# NOTE: cagney/2003-02-03: Not yet.
|
||||
@@ -155,7 +158,7 @@ if {$async} {
|
||||
set reason ""
|
||||
}
|
||||
|
||||
-mi_execute_to "interpreter-exec console step" $reason "callee4" "" ".*basics.c" "29" \
|
||||
+mi_execute_to "interpreter-exec console step" $reason "callee4" "" ".*basics.c" $line_callee4_next \
|
||||
"" "check *stopped from CLI command"
|
||||
|
||||
# NOTE: cagney/2003-02-03: Not yet.
|
||||
--- a/gdb/testsuite/gdb.mi/mi2-cli.exp
|
||||
+++ b/gdb/testsuite/gdb.mi/mi2-cli.exp
|
||||
@@ -63,10 +63,12 @@ mi_gdb_test "-interpreter-exec console \"file $binfile\"" \
|
||||
|
||||
mi_run_to_main
|
||||
|
||||
-set line_main_head [gdb_get_line_number "main ("]
|
||||
-set line_main_body [expr $line_main_head + 2]
|
||||
-set line_main_hello [gdb_get_line_number "Hello, World!"]
|
||||
-set line_main_return [expr $line_main_hello + 2]
|
||||
+set line_main_head [gdb_get_line_number "main ("]
|
||||
+set line_main_body [expr $line_main_head + 2]
|
||||
+set line_main_hello [gdb_get_line_number "Hello, World!"]
|
||||
+set line_main_return [expr $line_main_hello + 2]
|
||||
+set line_callee4_head [gdb_get_line_number "callee4 ("]
|
||||
+set line_callee4_body [expr $line_callee4_head + 2]
|
||||
|
||||
mi_gdb_test "-interpreter-exec console \"set args foobar\"" \
|
||||
{\^done} \
|
||||
@@ -97,7 +100,7 @@ mi_gdb_test "-interpreter-exec console \"list\"" \
|
||||
".*\~\"$line_main_body\[\\\\t \]*callee1.*;\\\\n\".*\\^done" \
|
||||
"-interpreter-exec console \"list\""
|
||||
|
||||
-mi_execute_to "exec-continue" "breakpoint-hit" "callee4" "" ".*basics.c" "28" \
|
||||
+mi_execute_to "exec-continue" "breakpoint-hit" "callee4" "" ".*basics.c" $line_callee4_body \
|
||||
{ "" "disp=\"keep\"" } \
|
||||
"continue to callee4"
|
||||
|
||||
|
@ -1,221 +0,0 @@
|
||||
Re: cvs tracepoint.c build error
|
||||
http://sourceware.org/ml/gdb/2010-01/msg00150.html
|
||||
|
||||
--- a/gdb/tracepoint.c
|
||||
+++ b/gdb/tracepoint.c
|
||||
@@ -1647,8 +1647,8 @@ trace_status_command (char *args, int from_tty)
|
||||
|
||||
if (ts->buffer_free)
|
||||
{
|
||||
- printf_filtered (_("Trace buffer has %d bytes free.\n"),
|
||||
- ts->buffer_free);
|
||||
+ printf_filtered (_("Trace buffer has %lld bytes free.\n"),
|
||||
+ (long long) ts->buffer_free);
|
||||
}
|
||||
|
||||
/* Now report on what we're doing with tfind. */
|
||||
@@ -2389,7 +2389,7 @@ trace_save_command (char *args, int from_tty)
|
||||
/* Write a file header, with a high-bit-set char to indicate a
|
||||
binary file, plus a hint as what this file is, and a version
|
||||
number in case of future needs. */
|
||||
- fwrite ("\x7fTRACE0\n", 8, 1, fp);
|
||||
+ 1 || fwrite ("\x7fTRACE0\n", 8, 1, fp);
|
||||
|
||||
/* Write descriptive info. */
|
||||
|
||||
@@ -2473,12 +2473,12 @@ trace_save_command (char *args, int from_tty)
|
||||
/* No more data is forthcoming, we're done. */
|
||||
if (gotten == 0)
|
||||
break;
|
||||
- fwrite (buf, gotten, 1, fp);
|
||||
+ 1 || fwrite (buf, gotten, 1, fp);
|
||||
offset += gotten;
|
||||
}
|
||||
|
||||
/* Mark the end of trace data. */
|
||||
- fwrite (&gotten, 4, 1, fp);
|
||||
+ 1 || fwrite (&gotten, 4, 1, fp);
|
||||
|
||||
do_cleanups (cleanup);
|
||||
if (from_tty)
|
||||
@@ -2785,7 +2785,7 @@ tfile_open (char *filename, int from_tty)
|
||||
int scratch_chan;
|
||||
char header[TRACE_HEADER_SIZE];
|
||||
char linebuf[1000]; /* should be max remote packet size or so */
|
||||
- char byte;
|
||||
+ char byte = 0;
|
||||
int bytes, i;
|
||||
struct trace_status *ts;
|
||||
struct uploaded_tp *uploaded_tps = NULL;
|
||||
@@ -2823,7 +2823,7 @@ tfile_open (char *filename, int from_tty)
|
||||
|
||||
bytes = 0;
|
||||
/* Read the file header and test for validity. */
|
||||
- read (trace_fd, &header, TRACE_HEADER_SIZE);
|
||||
+ 1 || read (trace_fd, &header, TRACE_HEADER_SIZE);
|
||||
bytes += TRACE_HEADER_SIZE;
|
||||
if (!(header[0] == 0x7f
|
||||
&& (strncmp (header + 1, "TRACE0\n", 7) == 0)))
|
||||
@@ -2844,7 +2844,7 @@ tfile_open (char *filename, int from_tty)
|
||||
i = 0;
|
||||
while (1)
|
||||
{
|
||||
- read (trace_fd, &byte, 1);
|
||||
+ 1 || read (trace_fd, &byte, 1);
|
||||
++bytes;
|
||||
if (byte == '\n')
|
||||
{
|
||||
@@ -3141,7 +3141,7 @@ static ULONGEST
|
||||
tfile_get_traceframe_address (off_t tframe_offset)
|
||||
{
|
||||
ULONGEST addr = 0;
|
||||
- short tpnum;
|
||||
+ short tpnum = 0;
|
||||
struct breakpoint *tp;
|
||||
off_t saved_offset = cur_offset;
|
||||
|
||||
@@ -3149,7 +3149,7 @@ tfile_get_traceframe_address (off_t tframe_offset)
|
||||
|
||||
/* Fall back to using tracepoint address. */
|
||||
lseek (trace_fd, tframe_offset, SEEK_SET);
|
||||
- read (trace_fd, &tpnum, 2);
|
||||
+ 1 || read (trace_fd, &tpnum, 2);
|
||||
tp = get_tracepoint_by_number_on_target (tpnum);
|
||||
if (tp && tp->loc)
|
||||
addr = tp->loc->address;
|
||||
@@ -3169,7 +3169,7 @@ static int
|
||||
tfile_trace_find (enum trace_find_type type, int num,
|
||||
ULONGEST addr1, ULONGEST addr2, int *tpp)
|
||||
{
|
||||
- short tpnum;
|
||||
+ short tpnum = 0;
|
||||
int tfnum = 0, found = 0;
|
||||
int data_size;
|
||||
struct breakpoint *tp;
|
||||
@@ -3181,11 +3181,11 @@ tfile_trace_find (enum trace_find_type type, int num,
|
||||
while (1)
|
||||
{
|
||||
tframe_offset = offset;
|
||||
- read (trace_fd, &tpnum, 2);
|
||||
+ 1 || read (trace_fd, &tpnum, 2);
|
||||
offset += 2;
|
||||
if (tpnum == 0)
|
||||
break;
|
||||
- read (trace_fd, &data_size, 4);
|
||||
+ 1 || read (trace_fd, &data_size, 4);
|
||||
offset += 4;
|
||||
switch (type)
|
||||
{
|
||||
@@ -3245,9 +3245,9 @@ tfile_fetch_registers (struct target_ops *ops,
|
||||
struct regcache *regcache, int regno)
|
||||
{
|
||||
struct gdbarch *gdbarch = get_regcache_arch (regcache);
|
||||
- char block_type;
|
||||
+ char block_type = 0;
|
||||
int i, pos, offset, regn, regsize;
|
||||
- unsigned short mlen;
|
||||
+ unsigned short mlen = 0;
|
||||
char *regs;
|
||||
|
||||
/* An uninitialized reg size says we're not going to be
|
||||
@@ -3261,12 +3261,12 @@ tfile_fetch_registers (struct target_ops *ops,
|
||||
pos = 0;
|
||||
while (pos < cur_data_size)
|
||||
{
|
||||
- read (trace_fd, &block_type, 1);
|
||||
+ 1 || read (trace_fd, &block_type, 1);
|
||||
++pos;
|
||||
switch (block_type)
|
||||
{
|
||||
case 'R':
|
||||
- read (trace_fd, regs, trace_regblock_size);
|
||||
+ 1 || read (trace_fd, regs, trace_regblock_size);
|
||||
/* Assume the block is laid out in GDB register number order,
|
||||
each register with the size that it has in GDB. */
|
||||
offset = 0;
|
||||
@@ -3293,7 +3293,7 @@ tfile_fetch_registers (struct target_ops *ops,
|
||||
return;
|
||||
case 'M':
|
||||
lseek (trace_fd, 8, SEEK_CUR);
|
||||
- read (trace_fd, &mlen, 2);
|
||||
+ 1 || read (trace_fd, &mlen, 2);
|
||||
lseek (trace_fd, mlen, SEEK_CUR);
|
||||
pos += (8 + 2 + mlen);
|
||||
break;
|
||||
@@ -3314,10 +3314,10 @@ tfile_xfer_partial (struct target_ops *ops, enum target_object object,
|
||||
const char *annex, gdb_byte *readbuf,
|
||||
const gdb_byte *writebuf, ULONGEST offset, LONGEST len)
|
||||
{
|
||||
- char block_type;
|
||||
+ char block_type = 0;
|
||||
int pos;
|
||||
- ULONGEST maddr;
|
||||
- unsigned short mlen;
|
||||
+ ULONGEST maddr = 0;
|
||||
+ unsigned short mlen = 0;
|
||||
|
||||
/* We're only doing regular memory for now. */
|
||||
if (object != TARGET_OBJECT_MEMORY)
|
||||
@@ -3330,7 +3330,7 @@ tfile_xfer_partial (struct target_ops *ops, enum target_object object,
|
||||
pos = 0;
|
||||
while (pos < cur_data_size)
|
||||
{
|
||||
- read (trace_fd, &block_type, 1);
|
||||
+ 1 || read (trace_fd, &block_type, 1);
|
||||
++pos;
|
||||
switch (block_type)
|
||||
{
|
||||
@@ -3339,11 +3339,11 @@ tfile_xfer_partial (struct target_ops *ops, enum target_object object,
|
||||
pos += trace_regblock_size;
|
||||
break;
|
||||
case 'M':
|
||||
- read (trace_fd, &maddr, 8);
|
||||
- read (trace_fd, &mlen, 2);
|
||||
+ 1 || read (trace_fd, &maddr, 8);
|
||||
+ 1 || read (trace_fd, &mlen, 2);
|
||||
if (maddr <= offset && (offset + len) <= (maddr + mlen))
|
||||
{
|
||||
- read (trace_fd, readbuf, mlen);
|
||||
+ 1 || read (trace_fd, readbuf, mlen);
|
||||
return mlen;
|
||||
}
|
||||
lseek (trace_fd, mlen, SEEK_CUR);
|
||||
@@ -3369,15 +3369,15 @@ tfile_xfer_partial (struct target_ops *ops, enum target_object object,
|
||||
static int
|
||||
tfile_get_trace_state_variable_value (int tsvnum, LONGEST *val)
|
||||
{
|
||||
- char block_type;
|
||||
- int pos, vnum;
|
||||
- unsigned short mlen;
|
||||
+ char block_type = 0;
|
||||
+ int pos, vnum = 0;
|
||||
+ unsigned short mlen = 0;
|
||||
|
||||
lseek (trace_fd, cur_offset, SEEK_SET);
|
||||
pos = 0;
|
||||
while (pos < cur_data_size)
|
||||
{
|
||||
- read (trace_fd, &block_type, 1);
|
||||
+ 1 || read (trace_fd, &block_type, 1);
|
||||
++pos;
|
||||
switch (block_type)
|
||||
{
|
||||
@@ -3387,15 +3387,15 @@ tfile_get_trace_state_variable_value (int tsvnum, LONGEST *val)
|
||||
break;
|
||||
case 'M':
|
||||
lseek (trace_fd, 8, SEEK_CUR);
|
||||
- read (trace_fd, &mlen, 2);
|
||||
+ 1 || read (trace_fd, &mlen, 2);
|
||||
lseek (trace_fd, mlen, SEEK_CUR);
|
||||
pos += (8 + 2 + mlen);
|
||||
break;
|
||||
case 'V':
|
||||
- read (trace_fd, &vnum, 4);
|
||||
+ 1 || read (trace_fd, &vnum, 4);
|
||||
if (tsvnum == vnum)
|
||||
{
|
||||
- read (trace_fd, val, 8);
|
||||
+ 1 || read (trace_fd, val, 8);
|
||||
return 1;
|
||||
}
|
||||
lseek (trace_fd, 8, SEEK_CUR);
|
18
gdb.spec
18
gdb.spec
@ -32,7 +32,7 @@ Name: gdb%{?_with_debug:-debug}
|
||||
# Set version to contents of gdb/version.in.
|
||||
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
|
||||
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
|
||||
Version: 7.0.50.20100116
|
||||
Version: 7.0.50.20100118
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
@ -81,7 +81,7 @@ Source2: gdb-orphanripper.c
|
||||
Source3: gdb-gstack.man
|
||||
|
||||
# libstdc++ pretty printers from GCC SVN HEAD (4.5 experimental).
|
||||
%define libstdcxxpython libstdc++-v3-python-r151798
|
||||
%define libstdcxxpython libstdc++-v3-python-r155978
|
||||
Source4: %{libstdcxxpython}.tar.bz2
|
||||
|
||||
# Work around out-of-date dejagnu that does not have KFAIL
|
||||
@ -378,9 +378,6 @@ Patch349: gdb-archer.patch
|
||||
# - Turn on 64-bit BFD support, globally enable AC_SYS_LARGEFILE.
|
||||
Patch360: gdb-6.8-bz457187-largefile-test.patch
|
||||
|
||||
# Fix python pretty printers lookup on x86_64.
|
||||
Patch376: libstdc++-v3-python-common-prefix.patch
|
||||
|
||||
# New test for step-resume breakpoint placed in multiple threads at once.
|
||||
Patch381: gdb-simultaneous-step-resume-breakpoint-test.patch
|
||||
|
||||
@ -431,8 +428,8 @@ Patch407: gdb-lineno-makeup-test.patch
|
||||
# Test power7 ppc disassembly.
|
||||
Patch408: gdb-ppc-power7-test.patch
|
||||
|
||||
# Fix tracepoint.c compilation warnings.
|
||||
Patch409: gdb-tracepoint-warning.patch
|
||||
# [patch] testsuite: Fix misplaced line numbers
|
||||
Patch410: gdb-testsuite-lineno.patch
|
||||
|
||||
BuildRequires: ncurses-devel%{?_isa} texinfo gettext flex bison expat-devel%{?_isa}
|
||||
Requires: readline%{?_isa}
|
||||
@ -662,7 +659,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch343 -p1
|
||||
%patch348 -p1
|
||||
%patch360 -p1
|
||||
%patch376 -p1
|
||||
%patch381 -p1
|
||||
%patch382 -p1
|
||||
%patch387 -p1
|
||||
@ -680,7 +676,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch406 -p1
|
||||
%patch407 -p1
|
||||
%patch408 -p1
|
||||
%patch409 -p1
|
||||
%patch410 -p1
|
||||
# Always verify its applicability.
|
||||
%patch393 -p1
|
||||
%patch335 -p1
|
||||
@ -1006,6 +1002,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Jan 19 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100118-1.fc13
|
||||
- Upgrade to the FSF GDB snapshot: 7.0.50.20100118
|
||||
- Upgrade libstdc++-v3-python to r155978 (Phil Muldoon).
|
||||
|
||||
* Sat Jan 16 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100116-1.fc13
|
||||
- Upgrade to the FSF GDB snapshot: 7.0.50.20100116
|
||||
- archer-jankratochvil-fedora13 commit: 81810a20b2d2c3bf18e151de3cddfc96445b3c46
|
||||
|
@ -1,18 +0,0 @@
|
||||
On x86_64 host with:
|
||||
pythondir: /usr/lib/python2.6/site-packages/gdb
|
||||
libdir: /usr/lib64
|
||||
|
||||
prefix got set to "/usr/lib" but the code expects a trailing "/" (missing then
|
||||
one "../" path component).
|
||||
|
||||
--- ./libstdc++-v3-python-r151798/hook.in-orig 2009-06-18 21:12:37.000000000 +0200
|
||||
+++ ./libstdc++-v3-python-r151798/hook.in 2009-09-17 23:37:35.000000000 +0200
|
||||
@@ -40,7 +40,7 @@ if gdb.current_objfile () is not None:
|
||||
# In some bizarre configuration we might have found a match in the
|
||||
# middle of a directory name.
|
||||
if prefix[-1] != '/':
|
||||
- prefix = os.path.dirname (prefix)
|
||||
+ prefix = os.path.dirname (prefix) + '/'
|
||||
|
||||
# Strip off the prefix.
|
||||
pythondir = pythondir[len (prefix):]
|
Loading…
Reference in New Issue
Block a user