[RHELs] Drop simulation of legacy behavior - new GDB should behave as new GDB.
This commit is contained in:
parent
750e47124c
commit
5c4cedb759
@ -1,40 +0,0 @@
|
|||||||
gdb/linux-nat.c:
|
|
||||||
- Workaround RHEL-5 kernels for detaching SIGSTOPped processes (BZ 498595).
|
|
||||||
|
|
||||||
Index: gdb-7.4.50.20111218/gdb/elfread.c
|
|
||||||
===================================================================
|
|
||||||
--- gdb-7.4.50.20111218.orig/gdb/elfread.c 2011-12-19 01:41:31.000000000 +0100
|
|
||||||
+++ gdb-7.4.50.20111218/gdb/elfread.c 2011-12-19 02:31:30.998241760 +0100
|
|
||||||
@@ -1053,7 +1053,7 @@ elf_gnu_ifunc_resolver_return_stop (stru
|
|
||||||
#define BUILD_ID_VERBOSE_NONE 0
|
|
||||||
#define BUILD_ID_VERBOSE_FILENAMES 1
|
|
||||||
#define BUILD_ID_VERBOSE_BINARY_PARSE 2
|
|
||||||
-static int build_id_verbose = BUILD_ID_VERBOSE_FILENAMES;
|
|
||||||
+static int build_id_verbose = BUILD_ID_VERBOSE_NONE;
|
|
||||||
static void
|
|
||||||
show_build_id_verbose (struct ui_file *file, int from_tty,
|
|
||||||
struct cmd_list_element *c, const char *value)
|
|
||||||
@@ -2172,8 +2172,10 @@ find_separate_debug_file_by_buildid (str
|
|
||||||
if (build_id_name != NULL
|
|
||||||
&& filename_cmp (build_id_name, objfile->name) == 0)
|
|
||||||
{
|
|
||||||
+#if 0 /* RHEL-5 backward behavior compatibility. */
|
|
||||||
warning (_("\"%s\": separate debug info file has no debug info"),
|
|
||||||
build_id_name);
|
|
||||||
+#endif
|
|
||||||
xfree (build_id_name);
|
|
||||||
}
|
|
||||||
else if (build_id_name != NULL)
|
|
||||||
Index: gdb-7.4.50.20111218/gdb/corelow.c
|
|
||||||
===================================================================
|
|
||||||
--- gdb-7.4.50.20111218.orig/gdb/corelow.c 2011-12-19 01:16:15.000000000 +0100
|
|
||||||
+++ gdb-7.4.50.20111218/gdb/corelow.c 2011-12-19 02:31:30.998241760 +0100
|
|
||||||
@@ -282,7 +282,7 @@ add_to_thread_list (bfd *abfd, asection
|
|
||||||
inferior_ptid = ptid; /* Yes, make it current. */
|
|
||||||
}
|
|
||||||
|
|
||||||
-static int build_id_core_loads = 1;
|
|
||||||
+static int build_id_core_loads = 0;
|
|
||||||
|
|
||||||
static void
|
|
||||||
build_id_locate_exec (int from_tty)
|
|
38
gdb.spec
38
gdb.spec
@ -26,7 +26,7 @@ Version: 7.4.50.%{snap}
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 15%{?dist}
|
Release: 16%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -49,12 +49,6 @@ URL: http://gnu.org/software/gdb/
|
|||||||
Obsoletes: gdb64 < 5.3.91
|
Obsoletes: gdb64 < 5.3.91
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if 0%{!?el5:1}
|
|
||||||
# The last Rawhide release was (no dist tag) pstack-1.2-7.2.2
|
|
||||||
Obsoletes: pstack < 1.2-7.2.2.1
|
|
||||||
Provides: pstack = 1.2-7.2.2.1
|
|
||||||
%endif # 0%{!?el5:1}
|
|
||||||
|
|
||||||
# eu-strip: -g recognizes .gdb_index as a debugging section. (#631997)
|
# eu-strip: -g recognizes .gdb_index as a debugging section. (#631997)
|
||||||
Conflicts: elfutils < 0.149
|
Conflicts: elfutils < 0.149
|
||||||
|
|
||||||
@ -394,11 +388,6 @@ Patch392: gdb-bz533176-fortran-omp-step.patch
|
|||||||
#=fedoratest
|
#=fedoratest
|
||||||
Patch393: gdb-rhel5-gcc44.patch
|
Patch393: gdb-rhel5-gcc44.patch
|
||||||
|
|
||||||
# Disable warning messages new for gdb-6.8+ for RHEL-5 backward compatibility.
|
|
||||||
# Workaround RHEL-5 kernels for detaching SIGSTOPped processes (BZ 498595).
|
|
||||||
#=fedoratest
|
|
||||||
Patch335: gdb-rhel5-compat.patch
|
|
||||||
|
|
||||||
# Fix regression by python on ia64 due to stale current frame.
|
# Fix regression by python on ia64 due to stale current frame.
|
||||||
#=push
|
#=push
|
||||||
Patch397: gdb-follow-child-stale-parent.patch
|
Patch397: gdb-follow-child-stale-parent.patch
|
||||||
@ -631,7 +620,6 @@ GDB, the GNU debugger, allows you to debug programs written in C, C++,
|
|||||||
Java, and other languages, by executing them in a controlled fashion
|
Java, and other languages, by executing them in a controlled fashion
|
||||||
and printing their data.
|
and printing their data.
|
||||||
|
|
||||||
%if 0%{!?el5:1}
|
|
||||||
%package gdbserver
|
%package gdbserver
|
||||||
Summary: A standalone server for GDB (the GNU source-level debugger)
|
Summary: A standalone server for GDB (the GNU source-level debugger)
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -643,7 +631,6 @@ and printing their data.
|
|||||||
|
|
||||||
This package provides a program that allows you to run GDB on a different
|
This package provides a program that allows you to run GDB on a different
|
||||||
machine than the one which is running the program being debugged.
|
machine than the one which is running the program being debugged.
|
||||||
%endif # 0%{!?el5:1}
|
|
||||||
|
|
||||||
%package doc
|
%package doc
|
||||||
Summary: Documentation for GDB (the GNU source-level debugger)
|
Summary: Documentation for GDB (the GNU source-level debugger)
|
||||||
@ -787,10 +774,8 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
|||||||
%patch644 -p1
|
%patch644 -p1
|
||||||
|
|
||||||
%patch393 -p1
|
%patch393 -p1
|
||||||
%patch335 -p1
|
|
||||||
%if 0%{!?el5:1}
|
%if 0%{!?el5:1}
|
||||||
%patch393 -p1 -R
|
%patch393 -p1 -R
|
||||||
%patch335 -p1 -R
|
|
||||||
%endif
|
%endif
|
||||||
%if 0%{?rhel:1} && 0%{?rhel} <= 6
|
%if 0%{?rhel:1} && 0%{?rhel} <= 6
|
||||||
%patch487 -p1
|
%patch487 -p1
|
||||||
@ -1028,12 +1013,7 @@ gcc -o ./orphanripper %{SOURCE2} -Wall -lutil -ggdb2
|
|||||||
# See also: gdb-runtest-pie-override.exp
|
# See also: gdb-runtest-pie-override.exp
|
||||||
CHECK="$(echo $CHECK|sed 's#check//unix/[^ ]*#& &/-fPIC/-pie#g')"
|
CHECK="$(echo $CHECK|sed 's#check//unix/[^ ]*#& &/-fPIC/-pie#g')"
|
||||||
|
|
||||||
./orphanripper make %{?_smp_mflags} -k $CHECK \
|
./orphanripper make %{?_smp_mflags} -k $CHECK || :
|
||||||
$(: Serialize the output to keep the order for regression checks. ) \
|
|
||||||
%if 0%{?el5:1}
|
|
||||||
RUNTESTFLAGS="--tool gdb" \
|
|
||||||
%endif
|
|
||||||
|| :
|
|
||||||
)
|
)
|
||||||
for t in sum log
|
for t in sum log
|
||||||
do
|
do
|
||||||
@ -1073,8 +1053,13 @@ do
|
|||||||
touch -r $RPM_BUILD_DIR/%{gdb_src}/gdb/ChangeLog $i
|
touch -r $RPM_BUILD_DIR/%{gdb_src}/gdb/ChangeLog $i
|
||||||
done
|
done
|
||||||
|
|
||||||
|
# RHEL-5: error: Installed (but unpackaged) file(s) found:
|
||||||
|
# /usr/lib/debug/usr/bin/gdb-gdb.pyc
|
||||||
|
# /usr/lib/debug/usr/bin/gdb-gdb.pyo
|
||||||
|
%if 0%{!?el5:1}
|
||||||
mkdir -p $RPM_BUILD_ROOT/usr/lib/debug%{_bindir}
|
mkdir -p $RPM_BUILD_ROOT/usr/lib/debug%{_bindir}
|
||||||
cp -p $RPM_BUILD_DIR/%{gdb_src}/gdb/gdb-gdb.py $RPM_BUILD_ROOT/usr/lib/debug%{_bindir}/
|
cp -p $RPM_BUILD_DIR/%{gdb_src}/gdb/gdb-gdb.py $RPM_BUILD_ROOT/usr/lib/debug%{_bindir}/
|
||||||
|
%endif # 0%{!?el5:1}
|
||||||
|
|
||||||
%if 0%{?rhel:1} && 0%{?rhel} <= 6
|
%if 0%{?rhel:1} && 0%{?rhel} <= 6
|
||||||
%if 0%{!?_without_python:1}
|
%if 0%{!?_without_python:1}
|
||||||
@ -1116,10 +1101,8 @@ rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
|||||||
# pstack obsoletion
|
# pstack obsoletion
|
||||||
|
|
||||||
cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
|
cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man1/gstack.1
|
||||||
%if 0%{!?el5:1}
|
|
||||||
ln -s gstack.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/pstack.1.gz
|
ln -s gstack.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/pstack.1.gz
|
||||||
ln -s gstack $RPM_BUILD_ROOT%{_bindir}/pstack
|
ln -s gstack $RPM_BUILD_ROOT%{_bindir}/pstack
|
||||||
%endif # 0%{!?el5:1}
|
|
||||||
|
|
||||||
# Packaged GDB is not a cross-target one.
|
# Packaged GDB is not a cross-target one.
|
||||||
(cd $RPM_BUILD_ROOT%{_datadir}/gdb/syscalls
|
(cd $RPM_BUILD_ROOT%{_datadir}/gdb/syscalls
|
||||||
@ -1174,19 +1157,15 @@ fi
|
|||||||
%{_bindir}/gstack
|
%{_bindir}/gstack
|
||||||
%{_mandir}/*/gstack.1*
|
%{_mandir}/*/gstack.1*
|
||||||
%{_bindir}/gdb-add-index
|
%{_bindir}/gdb-add-index
|
||||||
%if 0%{!?el5:1}
|
|
||||||
%{_bindir}/pstack
|
%{_bindir}/pstack
|
||||||
%{_mandir}/*/pstack.1*
|
%{_mandir}/*/pstack.1*
|
||||||
%endif # 0%{!?el5:1}
|
|
||||||
%{_datadir}/gdb
|
%{_datadir}/gdb
|
||||||
|
|
||||||
# don't include the files in include, they are part of binutils
|
# don't include the files in include, they are part of binutils
|
||||||
|
|
||||||
%ifnarch sparc sparcv9
|
%ifnarch sparc sparcv9
|
||||||
%if 0%{!?el5:1}
|
|
||||||
%files gdbserver
|
%files gdbserver
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%endif
|
|
||||||
%{_bindir}/gdbserver
|
%{_bindir}/gdbserver
|
||||||
%{_mandir}/*/gdbserver.1*
|
%{_mandir}/*/gdbserver.1*
|
||||||
%ifarch %{ix86} x86_64
|
%ifarch %{ix86} x86_64
|
||||||
@ -1201,6 +1180,9 @@ fi
|
|||||||
%{_infodir}/gdb.info*
|
%{_infodir}/gdb.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 10 2012 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.4.50.20120120-16.fc17
|
||||||
|
- [RHELs] Drop simulation of legacy behavior - new GDB should behave as new GDB.
|
||||||
|
|
||||||
* Fri Feb 10 2012 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.4.50.20120120-15.fc17
|
* Fri Feb 10 2012 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.4.50.20120120-15.fc17
|
||||||
- Simplify %%setup .spec rule.
|
- Simplify %%setup .spec rule.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user