[testsuite] [ppc*,s390*] Do not FAIL rhbz1261564-aarch64-watchpoint.exp
(RH BZ 1352563).
This commit is contained in:
parent
dbc649db15
commit
5b3c4903f6
@ -2,7 +2,7 @@ Index: gdb-7.6.1/gdb/testsuite/gdb.base/rhbz1261564-aarch64-watchpoint.exp
|
|||||||
===================================================================
|
===================================================================
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
+++ gdb-7.6.1/gdb/testsuite/gdb.base/rhbz1261564-aarch64-watchpoint.exp 2016-03-10 22:31:31.152094080 +0100
|
+++ gdb-7.6.1/gdb/testsuite/gdb.base/rhbz1261564-aarch64-watchpoint.exp 2016-03-10 22:31:31.152094080 +0100
|
||||||
@@ -0,0 +1,43 @@
|
@@ -0,0 +1,53 @@
|
||||||
+# Copyright (C) 2016 Free Software Foundation, Inc.
|
+# Copyright (C) 2016 Free Software Foundation, Inc.
|
||||||
+
|
+
|
||||||
+# This program is free software; you can redistribute it and/or modify
|
+# This program is free software; you can redistribute it and/or modify
|
||||||
@ -24,7 +24,13 @@ Index: gdb-7.6.1/gdb/testsuite/gdb.base/rhbz1261564-aarch64-watchpoint.exp
|
|||||||
+
|
+
|
||||||
+if { ! [ runto main ] } then { return 0 }
|
+if { ! [ runto main ] } then { return 0 }
|
||||||
+
|
+
|
||||||
+gdb_test "rwatch aligned.var4" "Hardware read watchpoint \[0-9\]+: aligned.var4"
|
+set test "rwatch aligned.var4"
|
||||||
|
+if [istarget "s390*-*-*"] {
|
||||||
|
+ gdb_test $test {Target does not support this type of hardware watchpoint\.}
|
||||||
|
+ untested "s390* does not support hw read watchpoint"
|
||||||
|
+ return
|
||||||
|
+}
|
||||||
|
+gdb_test $test "Hardware read watchpoint \[0-9\]+: aligned.var4"
|
||||||
+
|
+
|
||||||
+proc checkvar { address } {
|
+proc checkvar { address } {
|
||||||
+ global gdb_prompt
|
+ global gdb_prompt
|
||||||
@ -45,6 +51,10 @@ Index: gdb-7.6.1/gdb/testsuite/gdb.base/rhbz1261564-aarch64-watchpoint.exp
|
|||||||
+if ![checkvar "4"] { return }
|
+if ![checkvar "4"] { return }
|
||||||
+if ![checkvar "8"] { return }
|
+if ![checkvar "8"] { return }
|
||||||
+
|
+
|
||||||
|
+# Assumes: PPC_PTRACE_GETHWDBGINFO::data_bp_alignment == 8
|
||||||
|
+# 'lwz' does read only 4 bytes but the hw watchpoint is 8 bytes wide.
|
||||||
|
+setup_xfail "powerpc*-*-*"
|
||||||
|
+
|
||||||
+gdb_continue_to_end
|
+gdb_continue_to_end
|
||||||
Index: gdb-7.6.1/gdb/testsuite/gdb.base/rhbz1261564-aarch64-watchpoint.c
|
Index: gdb-7.6.1/gdb/testsuite/gdb.base/rhbz1261564-aarch64-watchpoint.c
|
||||||
===================================================================
|
===================================================================
|
||||||
|
6
gdb.spec
6
gdb.spec
@ -26,7 +26,7 @@ Version: 7.12.50.%{snapsrc}
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1578,6 +1578,10 @@ then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 10 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170309-6.fc26
|
||||||
|
- [testsuite] [ppc*,s390*] Do not FAIL rhbz1261564-aarch64-watchpoint.exp
|
||||||
|
(RH BZ 1352563).
|
||||||
|
|
||||||
* Thu Mar 9 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170309-5.fc26
|
* Thu Mar 9 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12.50.20170309-5.fc26
|
||||||
- Rebase to pre-7.13 FSF GDB trunk.
|
- Rebase to pre-7.13 FSF GDB trunk.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user