From 52db67646defacd2523203ed9440ade499626c41 Mon Sep 17 00:00:00 2001
From: Keith Seitz <keiths@redhat.com>
Date: Tue, 19 Sep 2023 09:24:27 -0700
Subject: [PATCH] Remove gdb-rhbz1553104-s390x-arch12-test.patch

This patch adds an s390x/arch12 binary file to disassemble, checking
for the appearance of two arch12 insns. Remove this patch in favor
of binutil's version, which is much more complete with much more
coverage.
---
 _gdb.spec.Patch.include                 | 18 +++---
 _gdb.spec.patch.include                 |  1 -
 _patch_order                            |  1 -
 gdb-rhbz1553104-s390x-arch12-test.patch | 81 -------------------------
 gdb.spec                                |  4 ++
 5 files changed, 11 insertions(+), 94 deletions(-)
 delete mode 100644 gdb-rhbz1553104-s390x-arch12-test.patch

diff --git a/_gdb.spec.Patch.include b/_gdb.spec.Patch.include
index b963415..c8848b2 100644
--- a/_gdb.spec.Patch.include
+++ b/_gdb.spec.Patch.include
@@ -186,36 +186,32 @@ Patch041: gdb-linux_perf-bundle.patch
 #=fedora
 Patch042: gdb-add-index.patch
 
-# [s390x] Backport arch12 instructions decoding (RH BZ 1553104).
-# =fedoratest
-Patch043: gdb-rhbz1553104-s390x-arch12-test.patch
-
 # Backport "Fix a potential illegal memory access in the BFD library..."
 # (Nick Clifton, binutils/29988)
-Patch044: gdb-binutils29988-read_indexed_address.patch
+Patch043: gdb-binutils29988-read_indexed_address.patch
 
 # Backport upstream patch fixing a "dangling pointer" build problem
 # first seen when building with GCC 13.1.1 20230426 (Red Hat ;; 13.1.1-1).
-Patch045: gdb-rhbz2192105-ftbs-dangling-pointer
+Patch044: gdb-rhbz2192105-ftbs-dangling-pointer
 
 # Backport two commits, 0ad504dd464 and ea70f941f9b, from Lancelot SIX
 # which prevent repeated warnings from being printed while loading a
 # core file. (RH BZ 2160211)
-Patch046: gdb-rhbz2160211-excessive-core-file-warnings.patch
+Patch045: gdb-rhbz2160211-excessive-core-file-warnings.patch
 
 # Backport upstream commit f3eee5861743d635 to fix a crash triggered
 # when debuginfod makes use of particular openssl settings.
-Patch047: gdb-bz2196395-debuginfod-legacy-openssl-crash.patch
+Patch046: gdb-bz2196395-debuginfod-legacy-openssl-crash.patch
 
 # Backport upstream commit f96328accde1e63 to fix a potential double
 # free issue in the debuginfod code.
-Patch048: gdb-bz2237515-debuginfod-double-free.patch
+Patch047: gdb-bz2237515-debuginfod-double-free.patch
 
 # Backport upstream commit 54392c4df604f20 to fix an incorrect
 # obstack allocation that wold lead to memory corruption.
-Patch049: gdb-bz2237392-dwarf-obstack-allocation.patch
+Patch048: gdb-bz2237392-dwarf-obstack-allocation.patch
 
 # Backport PR29922, SHT_NOBITS section
 # avoids section size sanity check.
-Patch050: gdb-rhbz2233961-CVE-2022-4806.patch
+Patch049: gdb-rhbz2233961-CVE-2022-4806.patch
 
diff --git a/_gdb.spec.patch.include b/_gdb.spec.patch.include
index f84adba..2ca0c1f 100644
--- a/_gdb.spec.patch.include
+++ b/_gdb.spec.patch.include
@@ -47,4 +47,3 @@
 %patch -p1 -P047
 %patch -p1 -P048
 %patch -p1 -P049
-%patch -p1 -P050
diff --git a/_patch_order b/_patch_order
index 2d9e7f8..202863e 100644
--- a/_patch_order
+++ b/_patch_order
@@ -40,7 +40,6 @@ gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
 gdb-container-rh-pkg.patch
 gdb-linux_perf-bundle.patch
 gdb-add-index.patch
-gdb-rhbz1553104-s390x-arch12-test.patch
 gdb-binutils29988-read_indexed_address.patch
 gdb-rhbz2192105-ftbs-dangling-pointer
 gdb-rhbz2160211-excessive-core-file-warnings.patch
diff --git a/gdb-rhbz1553104-s390x-arch12-test.patch b/gdb-rhbz1553104-s390x-arch12-test.patch
deleted file mode 100644
index 2cb15e5..0000000
--- a/gdb-rhbz1553104-s390x-arch12-test.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
-From: Jan Kratochvil <jan.kratochvil@redhat.com>
-Date: Fri, 23 Mar 2018 20:42:44 +0100
-Subject: gdb-rhbz1553104-s390x-arch12-test.patch
-
-;; [s390x] Backport arch12 instructions decoding (RH BZ 1553104).
-;; =fedoratest
-
-diff --git a/gdb/testsuite/gdb.arch/s390x-arch12.S b/gdb/testsuite/gdb.arch/s390x-arch12.S
-new file mode 100644
---- /dev/null
-+++ b/gdb/testsuite/gdb.arch/s390x-arch12.S
-@@ -0,0 +1,4 @@
-+.text
-+.globl load_guarded
-+load_guarded:
-+.byte 0xeb,0xbf,0xf0,0x58,0x00,0x24,0xe3,0xf0,0xff,0x50,0xff,0x71,0xb9,0x04,0x00,0xbf,0xe3,0x20,0xb0,0xa0,0x00,0x24,0xe3,0x10,0xb0,0xa0,0x00,0x04,0xe3,0x10,0x10,0x00,0x00,0x4c,0xe3,0x10,0xb0,0xa8,0x00,0x24,0xe3,0x10,0xb0,0xa8,0x00,0x04,0xb9,0x04,0x00,0x21,0xe3,0x40,0xb1,0x20,0x00,0x04,0xeb,0xbf,0xb1,0x08,0x00,0x04,0x07,0xf4
-diff --git a/gdb/testsuite/gdb.arch/s390x-arch12.exp b/gdb/testsuite/gdb.arch/s390x-arch12.exp
-new file mode 100644
---- /dev/null
-+++ b/gdb/testsuite/gdb.arch/s390x-arch12.exp
-@@ -0,0 +1,34 @@
-+# Copyright 2018 Free Software Foundation, Inc.
-+
-+# This program is free software; you can redistribute it and/or modify
-+# it under the terms of the GNU General Public License as published by
-+# the Free Software Foundation; either version 3 of the License, or
-+# (at your option) any later version.
-+#
-+# This program is distributed in the hope that it will be useful,
-+# but WITHOUT ANY WARRANTY; without even the implied warranty of
-+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-+# GNU General Public License for more details.
-+#
-+# You should have received a copy of the GNU General Public License
-+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
-+
-+#if { ![istarget s390x-*linux-*] || ![is_lp64_target] } {
-+#    verbose "Skipping s390x-prologue-skip.exp"
-+#    return
-+#}
-+
-+set testfile "s390x-arch12"
-+set uufile "${srcdir}/${subdir}/${testfile}.o.uu"
-+set ofile "${srcdir}/${subdir}/${testfile}.o"
-+
-+if { [catch "system \"uudecode -o ${ofile} ${uufile}\"" ] != 0 } {
-+    untested "failed uudecode"
-+    return -1
-+}
-+
-+gdb_exit
-+gdb_start
-+gdb_load $ofile
-+
-+gdb_test "disas load_guarded" " <\\+28>:\tlgg\t%r1,0\\(%r1\\)\r\n\[^\r\n\]* <\\+34>:\tstg\t%r1,168\\(%r11\\)\r\n.*"
-diff --git a/gdb/testsuite/gdb.arch/s390x-arch12.o.uu b/gdb/testsuite/gdb.arch/s390x-arch12.o.uu
-new file mode 100644
---- /dev/null
-+++ b/gdb/testsuite/gdb.arch/s390x-arch12.o.uu
-@@ -0,0 +1,20 @@
-+begin 644 s390x-arch12.o
-+M?T5,1@("`0`````````````!`!8````!````````````````````````````
-+M``$X``````!```````!```<`!.N_\%@`)./P_U#_<;D$`+_C(+"@`"3C$+"@
-+M``3C$!```$SC$+"H`"3C$+"H``2Y!``AXT"Q(``$Z[^Q"``$!_0`+G-Y;71A
-+M8@`N<W1R=&%B`"YS:'-T<G1A8@`N=&5X=``N9&%T80`N8G-S````````````
-+M`````````````````````````````````P```0``````````````````````
-+M`````P```@```````````````````````````P```P``````````````````
-+M```````!$````0``````````````````````;&]A9%]G=6%R9&5D````````
-+M````````````````````````````````````````````````````````````
-+M`````````````````````````!L````!``````````8`````````````````
-+M``!``````````$`````````````````````$```````````````A`````0``
-+M```````#````````````````````@```````````````````````````````
-+M!```````````````)P````@``````````P```````````````````(``````
-+M``````````````````````````0``````````````!$````#````````````
-+M``````````````````"``````````"P````````````````````!````````
-+M```````!`````@``````````````````````````````L`````````!X````
-+M!@````0`````````"``````````8````"0````,`````````````````````
-+H`````````2@`````````#@````````````````````$`````````````
-+`
-+end
diff --git a/gdb.spec b/gdb.spec
index 5b18eec..1354efc 100644
--- a/gdb.spec
+++ b/gdb.spec
@@ -1252,6 +1252,10 @@ fi
 %endif
 
 %changelog
+* Tue Sep 19 2023 Keith Seitz <keiths@redhat.com>
+- Remove gdb-rhbz1553104-s390x-arch12-test.patch, which is more thoroughly tested
+  by binutils.
+
 * Mon Sep 18 2023 Alexandra Hájková <ahajkova@redhat.com> - 13.2-8
 - Bump release to 13.2-9.