Remove gdb-6.5-ia64-libunwind-leak-test.patch.
The patch doesn't include any actual fixes, the architecture is end of life and the kernel is planning to drop IA64 support.
This commit is contained in:
parent
87ade3a000
commit
52a4dabc57
@ -55,111 +55,107 @@ Patch013: gdb-6.6-buildid-locate-rpm.patch
|
||||
#=fedoratest
|
||||
Patch014: gdb-6.7-ppc-clobbered-registers-O2-test.patch
|
||||
|
||||
# Test ia64 memory leaks of the code using libunwind.
|
||||
#=fedoratest
|
||||
Patch015: gdb-6.5-ia64-libunwind-leak-test.patch
|
||||
|
||||
# Test hiding unexpected breakpoints on intentional step commands.
|
||||
#=fedoratest
|
||||
Patch016: gdb-6.5-missed-trap-on-step-test.patch
|
||||
Patch015: gdb-6.5-missed-trap-on-step-test.patch
|
||||
|
||||
# Test gcore memory and time requirements for large inferiors.
|
||||
#=fedoratest
|
||||
Patch017: gdb-6.5-gcore-buffer-limit-test.patch
|
||||
Patch016: gdb-6.5-gcore-buffer-limit-test.patch
|
||||
|
||||
# Test GCORE for shmid 0 shared memory mappings.
|
||||
#=fedoratest: But it is broken anyway, sometimes the case being tested is not reproducible.
|
||||
Patch018: gdb-6.3-mapping-zero-inode-test.patch
|
||||
Patch017: gdb-6.3-mapping-zero-inode-test.patch
|
||||
|
||||
# Test a crash on libraries missing the .text section.
|
||||
#=fedoratest
|
||||
Patch019: gdb-6.5-section-num-fixup-test.patch
|
||||
Patch018: gdb-6.5-section-num-fixup-test.patch
|
||||
|
||||
# Fix resolving of variables at locations lists in prelinked libs (BZ 466901).
|
||||
#=fedoratest
|
||||
Patch020: gdb-6.8-bz466901-backtrace-full-prelinked.patch
|
||||
Patch019: gdb-6.8-bz466901-backtrace-full-prelinked.patch
|
||||
|
||||
# New test for step-resume breakpoint placed in multiple threads at once.
|
||||
#=fedoratest
|
||||
Patch021: gdb-simultaneous-step-resume-breakpoint-test.patch
|
||||
Patch020: gdb-simultaneous-step-resume-breakpoint-test.patch
|
||||
|
||||
# Fix GNU/Linux core open: Can't read pathname for load map: Input/output error.
|
||||
# Fix regression of undisplayed missing shared libraries caused by a fix for.
|
||||
#=fedoratest: It should be in glibc: libc-alpha: <20091004161706.GA27450@.*>
|
||||
Patch022: gdb-core-open-vdso-warning.patch
|
||||
Patch021: gdb-core-open-vdso-warning.patch
|
||||
|
||||
# Fix follow-exec for C++ programs (bugreported by Martin Stransky).
|
||||
#=fedoratest
|
||||
Patch023: gdb-archer-next-over-throw-cxx-exec.patch
|
||||
Patch022: gdb-archer-next-over-throw-cxx-exec.patch
|
||||
|
||||
# Workaround librpm BZ 643031 due to its unexpected exit() calls (BZ 642879).
|
||||
#=push+jan
|
||||
Patch024: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
|
||||
Patch023: gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
|
||||
|
||||
# [delayed-symfile] Test a backtrace regression on CFIs without DIE (BZ 614604).
|
||||
#=fedoratest
|
||||
Patch025: gdb-test-bt-cfi-without-die.patch
|
||||
Patch024: gdb-test-bt-cfi-without-die.patch
|
||||
|
||||
# Verify GDB Python built-in function gdb.solib_address exists (BZ # 634108).
|
||||
#=fedoratest
|
||||
Patch026: gdb-bz634108-solib_address.patch
|
||||
Patch025: gdb-bz634108-solib_address.patch
|
||||
|
||||
# [archer-tromey-delayed-symfile] New test gdb.dwarf2/dw2-aranges.exp.
|
||||
#=fedoratest
|
||||
Patch027: gdb-test-dw2-aranges.patch
|
||||
Patch026: gdb-test-dw2-aranges.patch
|
||||
|
||||
# Workaround PR libc/14166 for inferior calls of strstr.
|
||||
#=fedoratest: Compatibility with RHELs (unchecked which ones).
|
||||
Patch028: gdb-glibc-strstr-workaround.patch
|
||||
Patch027: gdb-glibc-strstr-workaround.patch
|
||||
|
||||
# Testcase for `Setting solib-absolute-prefix breaks vDSO' (BZ 818343).
|
||||
#=fedoratest
|
||||
Patch029: gdb-rhbz-818343-set-solib-absolute-prefix-testcase.patch
|
||||
Patch028: gdb-rhbz-818343-set-solib-absolute-prefix-testcase.patch
|
||||
|
||||
# Import regression test for `gdb/findvar.c:417: internal-error:
|
||||
# read_var_value: Assertion `frame' failed.' (RH BZ 947564) from RHEL 6.5.
|
||||
#=fedoratest
|
||||
Patch030: gdb-rhbz947564-findvar-assertion-frame-failed-testcase.patch
|
||||
Patch029: gdb-rhbz947564-findvar-assertion-frame-failed-testcase.patch
|
||||
|
||||
# Fix 'memory leak in infpy_read_memory()' (RH BZ 1007614)
|
||||
#=fedoratest
|
||||
Patch031: gdb-rhbz1007614-memleak-infpy_read_memory-test.patch
|
||||
Patch030: gdb-rhbz1007614-memleak-infpy_read_memory-test.patch
|
||||
|
||||
# Fix 'gdb gives highly misleading error when debuginfo pkg is present,
|
||||
# but not corresponding binary pkg' (RH BZ 981154).
|
||||
#=push+jan
|
||||
Patch032: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
|
||||
Patch031: gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
|
||||
|
||||
# Testcase for '[SAP] Recursive dlopen causes SAP HANA installer to
|
||||
# crash.' (RH BZ 1156192).
|
||||
#=fedoratest
|
||||
Patch033: gdb-rhbz1156192-recursive-dlopen-test.patch
|
||||
Patch032: gdb-rhbz1156192-recursive-dlopen-test.patch
|
||||
|
||||
# Fix '`catch syscall' doesn't work for parent after `fork' is called'
|
||||
# (Philippe Waroquiers, RH BZ 1149205).
|
||||
#=fedoratest
|
||||
Patch034: gdb-rhbz1149205-catch-syscall-after-fork-test.patch
|
||||
Patch033: gdb-rhbz1149205-catch-syscall-after-fork-test.patch
|
||||
|
||||
# Fix '[ppc64] and [s390x] wrong prologue skip on -O2 -g code' (Jan
|
||||
# Kratochvil, RH BZ 1084404).
|
||||
#=fedoratest
|
||||
Patch035: gdb-rhbz1084404-ppc64-s390x-wrong-prologue-skip-O2-g-3of3.patch
|
||||
Patch034: gdb-rhbz1084404-ppc64-s390x-wrong-prologue-skip-O2-g-3of3.patch
|
||||
|
||||
# Force libncursesw over libncurses to match the includes (RH BZ 1270534).
|
||||
#=push+jan
|
||||
Patch036: gdb-fedora-libncursesw.patch
|
||||
Patch035: gdb-fedora-libncursesw.patch
|
||||
|
||||
# [aarch64] Fix hardware watchpoints (RH BZ 1261564).
|
||||
#=fedoratest
|
||||
Patch037: gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
|
||||
Patch036: gdb-rhbz1261564-aarch64-hw-watchpoint-test.patch
|
||||
|
||||
# Add messages suggesting more recent RHEL gdbserver (RH BZ 1321114).
|
||||
#=fedora
|
||||
Patch038: gdb-container-rh-pkg.patch
|
||||
Patch037: gdb-container-rh-pkg.patch
|
||||
|
||||
# [dts+el7] [x86*] Bundle linux_perf.h for libipt (RH BZ 1256513).
|
||||
#=fedora
|
||||
Patch039: gdb-linux_perf-bundle.patch
|
||||
Patch038: gdb-linux_perf-bundle.patch
|
||||
|
||||
# Update gdb-add-index.sh such that, when the GDB environment
|
||||
# variable is not set, the script is smarter than just looking for
|
||||
@ -173,41 +169,41 @@ Patch039: gdb-linux_perf-bundle.patch
|
||||
# https://fedoraproject.org/wiki/Changes/Minimal_GDB_in_buildroot
|
||||
#
|
||||
#=fedora
|
||||
Patch040: gdb-add-index.patch
|
||||
Patch039: gdb-add-index.patch
|
||||
|
||||
# Backport "Fix a potential illegal memory access in the BFD library..."
|
||||
# (Nick Clifton, binutils/29988)
|
||||
Patch041: gdb-binutils29988-read_indexed_address.patch
|
||||
Patch040: gdb-binutils29988-read_indexed_address.patch
|
||||
|
||||
# Backport upstream patch fixing a "dangling pointer" build problem
|
||||
# first seen when building with GCC 13.1.1 20230426 (Red Hat ;; 13.1.1-1).
|
||||
Patch042: gdb-rhbz2192105-ftbs-dangling-pointer
|
||||
Patch041: gdb-rhbz2192105-ftbs-dangling-pointer
|
||||
|
||||
# Backport two commits, 0ad504dd464 and ea70f941f9b, from Lancelot SIX
|
||||
# which prevent repeated warnings from being printed while loading a
|
||||
# core file. (RH BZ 2160211)
|
||||
Patch043: gdb-rhbz2160211-excessive-core-file-warnings.patch
|
||||
Patch042: gdb-rhbz2160211-excessive-core-file-warnings.patch
|
||||
|
||||
# Backport upstream commit f3eee5861743d635 to fix a crash triggered
|
||||
# when debuginfod makes use of particular openssl settings.
|
||||
Patch044: gdb-bz2196395-debuginfod-legacy-openssl-crash.patch
|
||||
Patch043: gdb-bz2196395-debuginfod-legacy-openssl-crash.patch
|
||||
|
||||
# Backport upstream commit f96328accde1e63 to fix a potential double
|
||||
# free issue in the debuginfod code.
|
||||
Patch045: gdb-bz2237515-debuginfod-double-free.patch
|
||||
Patch044: gdb-bz2237515-debuginfod-double-free.patch
|
||||
|
||||
# Backport upstream commit 54392c4df604f20 to fix an incorrect
|
||||
# obstack allocation that wold lead to memory corruption.
|
||||
Patch046: gdb-bz2237392-dwarf-obstack-allocation.patch
|
||||
Patch045: gdb-bz2237392-dwarf-obstack-allocation.patch
|
||||
|
||||
# Backport PR29922, SHT_NOBITS section
|
||||
# avoids section size sanity check.
|
||||
Patch047: gdb-rhbz2233961-CVE-2022-4806.patch
|
||||
Patch046: gdb-rhbz2233961-CVE-2022-4806.patch
|
||||
|
||||
# Backport PR29925, Memory leak in find_abstract_instance
|
||||
Patch048: gdb-rhbz2233965-memory-leak.patch
|
||||
Patch047: gdb-rhbz2233965-memory-leak.patch
|
||||
|
||||
# Backport upstream patch which prevents internal error when
|
||||
# generating a gdb-index file (RH BZ 1773651).
|
||||
Patch049: gdb-rhbz1773651-gdb-index-internal-error.patch
|
||||
Patch048: gdb-rhbz1773651-gdb-index-internal-error.patch
|
||||
|
||||
|
@ -46,4 +46,3 @@
|
||||
%patch -p1 -P046
|
||||
%patch -p1 -P047
|
||||
%patch -p1 -P048
|
||||
%patch -p1 -P049
|
||||
|
@ -12,7 +12,6 @@ gdb-6.6-buildid-locate.patch
|
||||
gdb-6.6-buildid-locate-solib-missing-ids.patch
|
||||
gdb-6.6-buildid-locate-rpm.patch
|
||||
gdb-6.7-ppc-clobbered-registers-O2-test.patch
|
||||
gdb-6.5-ia64-libunwind-leak-test.patch
|
||||
gdb-6.5-missed-trap-on-step-test.patch
|
||||
gdb-6.5-gcore-buffer-limit-test.patch
|
||||
gdb-6.3-mapping-zero-inode-test.patch
|
||||
|
@ -1,135 +0,0 @@
|
||||
From FEDORA_PATCHES Mon Sep 17 00:00:00 2001
|
||||
From: Fedora GDB patches <invalid@email.com>
|
||||
Date: Fri, 27 Oct 2017 21:07:50 +0200
|
||||
Subject: gdb-6.5-ia64-libunwind-leak-test.patch
|
||||
|
||||
;; Test ia64 memory leaks of the code using libunwind.
|
||||
;;=fedoratest
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.base/unwind-leak.c b/gdb/testsuite/gdb.base/unwind-leak.c
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/gdb/testsuite/gdb.base/unwind-leak.c
|
||||
@@ -0,0 +1,29 @@
|
||||
+/* This testcase is part of GDB, the GNU debugger.
|
||||
+
|
||||
+ Copyright 2007 Free Software Foundation, Inc.
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 2 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program; if not, write to the Free Software
|
||||
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+
|
||||
+ Please email any bugs, comments, and/or additions to this file to:
|
||||
+ bug-gdb@prep.ai.mit.edu */
|
||||
+
|
||||
+#include <unistd.h>
|
||||
+
|
||||
+int main()
|
||||
+{
|
||||
+ for (;;)
|
||||
+ alarm (0);
|
||||
+ return 0;
|
||||
+}
|
||||
diff --git a/gdb/testsuite/gdb.base/unwind-leak.exp b/gdb/testsuite/gdb.base/unwind-leak.exp
|
||||
new file mode 100644
|
||||
--- /dev/null
|
||||
+++ b/gdb/testsuite/gdb.base/unwind-leak.exp
|
||||
@@ -0,0 +1,88 @@
|
||||
+# Copyright 2007 Free Software Foundation, Inc.
|
||||
+
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 2 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program; if not, write to the Free Software
|
||||
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
||||
+
|
||||
+if {[use_gdb_stub]} {
|
||||
+ untested "skipping test because of use_gdb_stub"
|
||||
+ return -1
|
||||
+}
|
||||
+
|
||||
+set testfile unwind-leak
|
||||
+set srcfile ${testfile}.c
|
||||
+set shfile [standard_output_file ${testfile}-gdb.sh]
|
||||
+set binfile [standard_output_file ${testfile}]
|
||||
+if { [gdb_compile "${srcdir}/${subdir}/${srcfile}" "${binfile}" executable {debug}] != "" } {
|
||||
+ untested "Couldn't compile test program"
|
||||
+ return -1
|
||||
+}
|
||||
+
|
||||
+# Get things started.
|
||||
+
|
||||
+gdb_exit
|
||||
+gdb_start
|
||||
+gdb_reinitialize_dir $srcdir/$subdir
|
||||
+gdb_load ${binfile}
|
||||
+
|
||||
+set pid [exp_pid -i [board_info host fileid]]
|
||||
+
|
||||
+# For C programs, "start" should stop in main().
|
||||
+
|
||||
+gdb_test "start" \
|
||||
+ "main \\(\\) at .*$srcfile.*" \
|
||||
+ "start"
|
||||
+
|
||||
+set loc [gdb_get_line_number "alarm"]
|
||||
+gdb_breakpoint $loc
|
||||
+
|
||||
+proc memory_get {} {
|
||||
+ global pid
|
||||
+ set fd [open "/proc/$pid/statm"]
|
||||
+ gets $fd line
|
||||
+ close $fd
|
||||
+ # number of pages of data/stack
|
||||
+ scan $line "%*d%*d%*d%*d%*d%d" drs
|
||||
+ return $drs
|
||||
+}
|
||||
+
|
||||
+set cycles 100
|
||||
+# For 100 cycles it was 1308: from = 363 KB, to = 1671 KB
|
||||
+set permit_kb 100
|
||||
+verbose -log "cycles = $cycles, permit_kb = $permit_kb"
|
||||
+
|
||||
+set fail 0
|
||||
+set test "breakpoint stop/continue cycles"
|
||||
+for {set i $cycles} {$i > 0} {set i [expr {$i - 1}]} {
|
||||
+ gdb_test_multiple "continue" $test {
|
||||
+ -re "Breakpoint 2, main .*alarm .*.*${gdb_prompt} $" {
|
||||
+ }
|
||||
+ -re "Segmentation fault" {
|
||||
+ fail $test
|
||||
+ set i 0
|
||||
+ set fail 1
|
||||
+ }
|
||||
+ }
|
||||
+ if ![info exists from] {
|
||||
+ set from [memory_get]
|
||||
+ }
|
||||
+}
|
||||
+set to [memory_get]
|
||||
+if {!$fail} {
|
||||
+ verbose -log "from = $from KB, to = $to KB"
|
||||
+ if {$from > 0 && $to > 10 && $to < $from + $permit_kb} {
|
||||
+ pass $test
|
||||
+ } else {
|
||||
+ fail $test
|
||||
+ }
|
||||
+}
|
5
gdb.spec
5
gdb.spec
@ -1252,6 +1252,11 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Oct 19 2023 Alexandra Hájková <ahajkova@redhat.com>
|
||||
- Remove gdb-6.5-ia64-libunwind-leak-test.patch.
|
||||
The patch doesn't include any actual fixes, the architecture
|
||||
is end of life and the kernel is planning to drop IA64 support.
|
||||
|
||||
* Wed Oct 11 2022 Guinevere Larsen <blarsen@redhat.com>
|
||||
- Remove gdb-rhbz1186476-internal-error-unqualified-name-re-set-test.patch
|
||||
as it was upstreamed back in 2010 with a different test name.
|
||||
|
Loading…
Reference in New Issue
Block a user