Performance fix of gcore to use --readnever (for RH BZ 1493675).
This commit is contained in:
parent
1b69fa99d4
commit
5210cb945e
@ -94,3 +94,14 @@ Index: gdb-7.99.90.20170420/gdb/top.h
|
||||
|
||||
/* Perform _initialize initialization. */
|
||||
extern void gdb_init (char *);
|
||||
--- gdb-8.0.1/gdb/gcore.in-orig 2017-06-04 17:51:26.000000000 +0200
|
||||
+++ gdb-8.0.1/gdb/gcore.in 2017-09-28 19:46:49.335407827 +0200
|
||||
@@ -85,7 +85,7 @@ for pid in $*
|
||||
do
|
||||
# `</dev/null' to avoid touching interactive terminal if it is
|
||||
# available but not accessible as GDB would get stopped on SIGTTIN.
|
||||
- $binary_path/@GDB_TRANSFORM_NAME@ </dev/null --nx --batch \
|
||||
+ $binary_path/@GDB_TRANSFORM_NAME@ </dev/null --nx --batch --readnever \
|
||||
-ex "set pagination off" -ex "set height 0" -ex "set width 0" \
|
||||
-ex "attach $pid" -ex "gcore $name.$pid" -ex detach -ex quit
|
||||
|
||||
|
7
gdb.spec
7
gdb.spec
@ -26,7 +26,7 @@ Version: 8.0.1
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 27%{?dist}
|
||||
Release: 28%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1715,7 +1715,10 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Tue Sep 26 2017 Troy Dawson <tdawson@redhat.com> - 8.0.1-27.fc28
|
||||
* Thu Sep 28 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.0.1-28.fc26
|
||||
- Performance fix of gcore to use --readnever (for RH BZ 1493675).
|
||||
|
||||
* Tue Sep 26 2017 Troy Dawson <tdawson@redhat.com> - 8.0.1-27.fc26
|
||||
- Cleanup spec file conditionals
|
||||
|
||||
* Tue Sep 12 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.0.1-26.fc26
|
||||
|
Loading…
Reference in New Issue
Block a user