Fix false gcc6 compilation warning for: bfd/elf64-s390.c
This commit is contained in:
parent
5a2431c246
commit
4f2557176f
28
gdb-bfd-s390-indent-warning.patch
Normal file
28
gdb-bfd-s390-indent-warning.patch
Normal file
@ -0,0 +1,28 @@
|
||||
https://kojipkgs.fedoraproject.org//work/tasks/8536/12758536/build.log
|
||||
../../bfd/elf64-s390.c: In function 'elf_s390_reloc_name_lookup':
|
||||
../../bfd/elf64-s390.c:340:5: error: statement is indented as if it were guarded by... [-Werror=misleading-indentation]
|
||||
if (strcasecmp (elf64_s390_vtinherit_howto.name, r_name) == 0)
|
||||
^~
|
||||
../../bfd/elf64-s390.c:333:3: note: ...this 'for' clause, but it is not
|
||||
for (i = 0;
|
||||
^~~
|
||||
|
||||
diff --git a/bfd/elf64-s390.c b/bfd/elf64-s390.c
|
||||
index 3887e8d..1261044 100644
|
||||
--- a/bfd/elf64-s390.c
|
||||
+++ b/bfd/elf64-s390.c
|
||||
@@ -337,10 +337,10 @@ elf_s390_reloc_name_lookup (bfd *abfd ATTRIBUTE_UNUSED,
|
||||
&& strcasecmp (elf_howto_table[i].name, r_name) == 0)
|
||||
return &elf_howto_table[i];
|
||||
|
||||
- if (strcasecmp (elf64_s390_vtinherit_howto.name, r_name) == 0)
|
||||
- return &elf64_s390_vtinherit_howto;
|
||||
- if (strcasecmp (elf64_s390_vtentry_howto.name, r_name) == 0)
|
||||
- return &elf64_s390_vtentry_howto;
|
||||
+ if (strcasecmp (elf64_s390_vtinherit_howto.name, r_name) == 0)
|
||||
+ return &elf64_s390_vtinherit_howto;
|
||||
+ if (strcasecmp (elf64_s390_vtentry_howto.name, r_name) == 0)
|
||||
+ return &elf64_s390_vtentry_howto;
|
||||
|
||||
return NULL;
|
||||
}
|
9
gdb.spec
9
gdb.spec
@ -27,7 +27,7 @@ Version: 7.10.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 47%{?dist}
|
||||
Release: 48%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -558,6 +558,9 @@ Patch1074: gdb-testsuite-guile.patch
|
||||
# [testsuite] Fix false selftest.exp FAIL from system readline-6.3+ (Patrick Palka).
|
||||
Patch1075: gdb-testsuite-readline63-sigint.patch
|
||||
|
||||
# Fix false gcc6 compilation warning for: bfd/elf64-s390.c
|
||||
Patch1076: gdb-bfd-s390-indent-warning.patch
|
||||
|
||||
%if 0%{!?rhel:1} || 0%{?rhel} > 6
|
||||
# RL_STATE_FEDORA_GDB would not be found for:
|
||||
# Patch642: gdb-readline62-ask-more-rh.patch
|
||||
@ -872,6 +875,7 @@ find -name "*.info*"|xargs rm -f
|
||||
%patch331 -p1
|
||||
%patch1075 -p1
|
||||
%patch1074 -p1
|
||||
%patch1076 -p1
|
||||
|
||||
%if 0%{?rhel:1} && 0%{?rhel} <= 7
|
||||
%patch1044 -p1
|
||||
@ -1389,6 +1393,9 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Sun Jan 31 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20160121-48.fc24
|
||||
- Fix false gcc6 compilation warning for: bfd/elf64-s390.c
|
||||
|
||||
* Sun Jan 31 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20160121-47.fc24
|
||||
- [testsuite] Fix false selftest.exp FAIL from system readline-6.3+ (Patrick Palka).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user