- Fix to allow ia64 gdb to backtrace from syscalls in a corefile.
- Bugzilla 145092.
This commit is contained in:
parent
f1c5dfd5e0
commit
4bf80fb89a
25
gdb-6.3-ia64-corefile-fix-20050127.patch
Normal file
25
gdb-6.3-ia64-corefile-fix-20050127.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
2005-01-25 Jeff Johnston <jjohnstn@redhat.com>
|
||||||
|
|
||||||
|
* ia64-tdep.c (getunwind_table): Call the low-level xfer
|
||||||
|
unwind table syscall to support backtracing from syscalls in
|
||||||
|
a corefile.
|
||||||
|
|
||||||
|
--- gdb-6.3/gdb/ia64-tdep.c.fix Thu Jan 27 12:03:40 2005
|
||||||
|
+++ gdb-6.3/gdb/ia64-tdep.c Thu Jan 27 12:06:23 2005
|
||||||
|
@@ -2357,8 +2357,14 @@ static int
|
||||||
|
getunwind_table (void *buf, size_t len)
|
||||||
|
{
|
||||||
|
LONGEST x;
|
||||||
|
- x = target_read_partial (¤t_target, TARGET_OBJECT_UNWIND_TABLE, NULL,
|
||||||
|
- buf, 0, len);
|
||||||
|
+
|
||||||
|
+ /* FIXME: This is a temporary solution to backtracing syscalls in corefiles.
|
||||||
|
+ To do this properly, the AUXV section should be used. This
|
||||||
|
+ fix will work as long as the kernel used to generate the corefile
|
||||||
|
+ is equivalent to the kernel used to debug the corefile. */
|
||||||
|
+ x = ia64_linux_xfer_unwind_table (¤t_target,
|
||||||
|
+ TARGET_OBJECT_UNWIND_TABLE, NULL,
|
||||||
|
+ buf, NULL, 0, len);
|
||||||
|
|
||||||
|
return (int)x;
|
||||||
|
}
|
10
gdb.spec
10
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
|||||||
Version: 6.3.0.0
|
Version: 6.3.0.0
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 0.
|
# The release always contains a leading reserved number, start it at 0.
|
||||||
Release: 0.12
|
Release: 0.13
|
||||||
|
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -169,6 +169,9 @@ Patch133: gdb-6.3-ia64fix-20050121.patch
|
|||||||
# Fix to support executable moving
|
# Fix to support executable moving
|
||||||
Patch134: gdb-6.3-movedir-20050125.patch
|
Patch134: gdb-6.3-movedir-20050125.patch
|
||||||
|
|
||||||
|
# Fix to support unwinding syscalls in ia64 corefiles
|
||||||
|
Patch135: gdb-6.3-ia64-corefile-fix-20050127.patch
|
||||||
|
|
||||||
%ifarch ia64
|
%ifarch ia64
|
||||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu libunwind >= 0.96-3
|
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu libunwind >= 0.96-3
|
||||||
%else
|
%else
|
||||||
@ -242,6 +245,7 @@ and printing their data.
|
|||||||
%patch132 -p1
|
%patch132 -p1
|
||||||
%patch133 -p1
|
%patch133 -p1
|
||||||
%patch134 -p1
|
%patch134 -p1
|
||||||
|
%patch135 -p1
|
||||||
|
|
||||||
# Change the version that gets printed at GDB startup, so it is RedHat
|
# Change the version that gets printed at GDB startup, so it is RedHat
|
||||||
# specific.
|
# specific.
|
||||||
@ -410,6 +414,10 @@ fi
|
|||||||
# don't include the files in include, they are part of binutils
|
# don't include the files in include, they are part of binutils
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 27 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.13
|
||||||
|
- Fix to allow ia64 gdb to backtrace from syscalls in a corefile.
|
||||||
|
- Bugzilla 145092.
|
||||||
|
|
||||||
* Wed Jan 26 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.12
|
* Wed Jan 26 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.12
|
||||||
- Fix to support examining files even when the executable moves
|
- Fix to support examining files even when the executable moves
|
||||||
- Bugzilla 142122
|
- Bugzilla 142122
|
||||||
|
Loading…
Reference in New Issue
Block a user