- Fix `errno' printing on nonthreaded non-g3 inferiors (TLS minsym is
absolute).
This commit is contained in:
parent
3a094fb8da
commit
4bbd3a23f8
@ -196,6 +196,18 @@ Index: gdb-6.8cvs20080219/gdb/target.c
|
||||
|
||||
return addr;
|
||||
}
|
||||
--- ./gdb/elfread.c 2008-08-03 11:02:10.000000000 +0200
|
||||
+++ ./gdb/elfread.c 2008-08-03 11:01:21.000000000 +0200
|
||||
@@ -318,7 +318,8 @@ elf_symtab_read (struct objfile *objfile
|
||||
/* Bfd symbols are section relative. */
|
||||
symaddr = sym->value + sym->section->vma;
|
||||
/* Relocate all non-absolute symbols by the section offset. */
|
||||
- if (sym->section != &bfd_abs_section)
|
||||
+ if (sym->section != &bfd_abs_section
|
||||
+ && (sym->section->flags & SEC_THREAD_LOCAL) == 0)
|
||||
{
|
||||
symaddr += offset;
|
||||
}
|
||||
Index: gdb-6.8cvs20080219/gdb/testsuite/gdb.dwarf2/dw2-errno.c
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
|
5
gdb.spec
5
gdb.spec
@ -13,7 +13,7 @@ Version: 6.8
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 18%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 19%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -843,6 +843,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Aug 4 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-19
|
||||
- Fix `errno' printing on nonthreaded non-g3 inferiors (TLS minsym is absolute).
|
||||
|
||||
* Fri Aug 1 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-18
|
||||
- Fix powerpc recent secure PLTs handling (shared library calls) (BZ 452960).
|
||||
- Fix the testsuite .spec runner to run biarch also on ppc.
|
||||
|
Loading…
Reference in New Issue
Block a user