Rebase to FSF GDB 7.6.
This commit is contained in:
parent
f8a4995541
commit
46f79e2112
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
/gdb-libstdc++-v3-python-r155978.tar.bz2
|
/gdb-libstdc++-v3-python-r155978.tar.bz2
|
||||||
/gdb-7.5.91.20130423.tar.bz2
|
/gdb-7.6.tar.bz2
|
||||||
|
@ -47,10 +47,10 @@ http://sourceware.org/ml/gdb-cvs/2013-04/msg00109.html
|
|||||||
2013-04-10 Pedro Alves <palves@redhat.com>
|
2013-04-10 Pedro Alves <palves@redhat.com>
|
||||||
|
|
||||||
* gdb.texinfo (Process Record and Replay): Document that "set
|
* gdb.texinfo (Process Record and Replay): Document that "set
|
||||||
Index: gdb-7.5.91.20130407/gdb/gcore.in
|
Index: gdb-7.6/gdb/gcore.in
|
||||||
===================================================================
|
===================================================================
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
+++ gdb-7.5.91.20130407/gdb/gcore.in 2013-04-11 16:50:33.189286930 +0200
|
+++ gdb-7.6/gdb/gcore.in 2013-04-26 15:33:01.171049247 +0200
|
||||||
@@ -0,0 +1,69 @@
|
@@ -0,0 +1,69 @@
|
||||||
+#!/bin/sh
|
+#!/bin/sh
|
||||||
+
|
+
|
||||||
@ -121,9 +121,9 @@ Index: gdb-7.5.91.20130407/gdb/gcore.in
|
|||||||
+done
|
+done
|
||||||
+
|
+
|
||||||
+exit $rc
|
+exit $rc
|
||||||
Index: gdb-7.5.91.20130407/gdb/gdb_gcore.sh
|
Index: gdb-7.6/gdb/gdb_gcore.sh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/gdb_gcore.sh 2013-01-01 07:32:42.000000000 +0100
|
--- gdb-7.6.orig/gdb/gdb_gcore.sh 2013-01-01 07:32:42.000000000 +0100
|
||||||
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
|
+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
@@ -1,70 +0,0 @@
|
@@ -1,70 +0,0 @@
|
||||||
-#!/bin/sh
|
-#!/bin/sh
|
||||||
@ -196,10 +196,10 @@ Index: gdb-7.5.91.20130407/gdb/gdb_gcore.sh
|
|||||||
-done
|
-done
|
||||||
-
|
-
|
||||||
-exit $rc
|
-exit $rc
|
||||||
Index: gdb-7.5.91.20130407/gdb/Makefile.in
|
Index: gdb-7.6/gdb/Makefile.in
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/Makefile.in 2013-04-11 16:50:14.000000000 +0200
|
--- gdb-7.6.orig/gdb/Makefile.in 2013-04-26 15:32:58.000000000 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/Makefile.in 2013-04-11 16:50:33.191286929 +0200
|
+++ gdb-7.6/gdb/Makefile.in 2013-04-26 15:33:01.172049246 +0200
|
||||||
@@ -414,6 +414,7 @@ CONFIG_ALL= @CONFIG_ALL@
|
@@ -414,6 +414,7 @@ CONFIG_ALL= @CONFIG_ALL@
|
||||||
CONFIG_CLEAN= @CONFIG_CLEAN@
|
CONFIG_CLEAN= @CONFIG_CLEAN@
|
||||||
CONFIG_INSTALL = @CONFIG_INSTALL@
|
CONFIG_INSTALL = @CONFIG_INSTALL@
|
||||||
@ -265,10 +265,10 @@ Index: gdb-7.5.91.20130407/gdb/Makefile.in
|
|||||||
config.h: stamp-h ; @true
|
config.h: stamp-h ; @true
|
||||||
stamp-h: $(srcdir)/config.in config.status
|
stamp-h: $(srcdir)/config.in config.status
|
||||||
CONFIG_HEADERS=config.h:config.in \
|
CONFIG_HEADERS=config.h:config.in \
|
||||||
Index: gdb-7.5.91.20130407/gdb/NEWS
|
Index: gdb-7.6/gdb/NEWS
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/NEWS 2013-04-03 20:29:52.000000000 +0200
|
--- gdb-7.6.orig/gdb/NEWS 2013-04-26 13:43:30.000000000 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/NEWS 2013-04-11 16:51:06.905285030 +0200
|
+++ gdb-7.6/gdb/NEWS 2013-04-26 15:33:19.784032404 +0200
|
||||||
@@ -1,6 +1,9 @@
|
@@ -1,6 +1,9 @@
|
||||||
What has changed in GDB?
|
What has changed in GDB?
|
||||||
(Organized release by release)
|
(Organized release by release)
|
||||||
@ -276,13 +276,13 @@ Index: gdb-7.5.91.20130407/gdb/NEWS
|
|||||||
+* Newly installed $prefix/bin/gcore acts as a shell interface for the
|
+* Newly installed $prefix/bin/gcore acts as a shell interface for the
|
||||||
+ GDB command gcore.
|
+ GDB command gcore.
|
||||||
+
|
+
|
||||||
*** Changes since GDB 7.5
|
*** Changes in GDB 7.6
|
||||||
|
|
||||||
* Target record has been renamed to record-full.
|
* Target record has been renamed to record-full.
|
||||||
Index: gdb-7.5.91.20130407/gdb/configure
|
Index: gdb-7.6/gdb/configure
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/configure 2013-03-12 23:25:32.000000000 +0100
|
--- gdb-7.6.orig/gdb/configure 2013-03-12 23:25:32.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/configure 2013-04-11 16:50:50.182285829 +0200
|
+++ gdb-7.6/gdb/configure 2013-04-26 15:33:01.179049240 +0200
|
||||||
@@ -591,6 +591,8 @@ ac_includes_default="\
|
@@ -591,6 +591,8 @@ ac_includes_default="\
|
||||||
enable_option_checking=no
|
enable_option_checking=no
|
||||||
ac_subst_vars='LTLIBOBJS
|
ac_subst_vars='LTLIBOBJS
|
||||||
@ -367,10 +367,10 @@ Index: gdb-7.5.91.20130407/gdb/configure
|
|||||||
"default":C)
|
"default":C)
|
||||||
case x$CONFIG_HEADERS in
|
case x$CONFIG_HEADERS in
|
||||||
xconfig.h:config.in)
|
xconfig.h:config.in)
|
||||||
Index: gdb-7.5.91.20130407/gdb/configure.ac
|
Index: gdb-7.6/gdb/configure.ac
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/configure.ac 2013-03-12 23:25:32.000000000 +0100
|
--- gdb-7.6.orig/gdb/configure.ac 2013-03-12 23:25:32.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/configure.ac 2013-04-11 16:50:33.200286929 +0200
|
+++ gdb-7.6/gdb/configure.ac 2013-04-26 15:33:01.180049239 +0200
|
||||||
@@ -203,6 +203,7 @@ fi
|
@@ -203,6 +203,7 @@ fi
|
||||||
|
|
||||||
TARGET_OBS=
|
TARGET_OBS=
|
||||||
@ -421,10 +421,10 @@ Index: gdb-7.5.91.20130407/gdb/configure.ac
|
|||||||
AC_OUTPUT(Makefile gdb-gdb.gdb doc/Makefile data-directory/Makefile,
|
AC_OUTPUT(Makefile gdb-gdb.gdb doc/Makefile data-directory/Makefile,
|
||||||
[
|
[
|
||||||
case x$CONFIG_HEADERS in
|
case x$CONFIG_HEADERS in
|
||||||
Index: gdb-7.5.91.20130407/gdb/configure.tgt
|
Index: gdb-7.6/gdb/configure.tgt
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/configure.tgt 2013-03-05 14:37:10.000000000 +0100
|
--- gdb-7.6.orig/gdb/configure.tgt 2013-03-05 14:37:10.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/configure.tgt 2013-04-11 16:50:33.200286929 +0200
|
+++ gdb-7.6/gdb/configure.tgt 2013-04-26 15:33:01.180049239 +0200
|
||||||
@@ -6,6 +6,7 @@
|
@@ -6,6 +6,7 @@
|
||||||
# gdb_sim simulator library for target
|
# gdb_sim simulator library for target
|
||||||
# gdb_osabi default OS ABI to use with target
|
# gdb_osabi default OS ABI to use with target
|
||||||
@ -448,20 +448,20 @@ Index: gdb-7.5.91.20130407/gdb/configure.tgt
|
|||||||
+ gdb_have_gcore=false
|
+ gdb_have_gcore=false
|
||||||
+ ;;
|
+ ;;
|
||||||
+esac
|
+esac
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/alpha/alpha-osf3.mh
|
Index: gdb-7.6/gdb/config/alpha/alpha-osf3.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/alpha/alpha-osf3.mh 2012-01-10 17:30:44.000000000 +0100
|
--- gdb-7.6.orig/gdb/config/alpha/alpha-osf3.mh 2012-01-10 17:30:44.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/alpha/alpha-osf3.mh 2013-04-11 16:50:33.200286929 +0200
|
+++ gdb-7.6/gdb/config/alpha/alpha-osf3.mh 2013-04-26 15:33:01.181049238 +0200
|
||||||
@@ -3,4 +3,5 @@ NAT_FILE= nm-osf3.h
|
@@ -3,4 +3,5 @@ NAT_FILE= nm-osf3.h
|
||||||
NATDEPFILES= alpha-nat.o fork-child.o \
|
NATDEPFILES= alpha-nat.o fork-child.o \
|
||||||
solib-osf.o procfs.o proc-api.o proc-events.o proc-flags.o \
|
solib-osf.o procfs.o proc-api.o proc-events.o proc-flags.o \
|
||||||
proc-why.o dec-thread.o
|
proc-why.o dec-thread.o
|
||||||
+HAVE_NATIVE_GCORE_HOST = 1
|
+HAVE_NATIVE_GCORE_HOST = 1
|
||||||
NAT_CLIBS= -lpthreaddebug
|
NAT_CLIBS= -lpthreaddebug
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/i386/fbsd.mh
|
Index: gdb-7.6/gdb/config/i386/fbsd.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/i386/fbsd.mh 2009-10-26 19:28:13.000000000 +0100
|
--- gdb-7.6.orig/gdb/config/i386/fbsd.mh 2009-10-26 19:28:13.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/i386/fbsd.mh 2013-04-11 16:50:33.200286929 +0200
|
+++ gdb-7.6/gdb/config/i386/fbsd.mh 2013-04-26 15:33:01.181049238 +0200
|
||||||
@@ -3,5 +3,6 @@ NATDEPFILES= fork-child.o inf-ptrace.o \
|
@@ -3,5 +3,6 @@ NATDEPFILES= fork-child.o inf-ptrace.o \
|
||||||
fbsd-nat.o i386-nat.o i386bsd-nat.o i386fbsd-nat.o \
|
fbsd-nat.o i386-nat.o i386bsd-nat.o i386fbsd-nat.o \
|
||||||
bsd-kvm.o
|
bsd-kvm.o
|
||||||
@ -469,10 +469,10 @@ Index: gdb-7.5.91.20130407/gdb/config/i386/fbsd.mh
|
|||||||
+HAVE_NATIVE_GCORE_HOST = 1
|
+HAVE_NATIVE_GCORE_HOST = 1
|
||||||
|
|
||||||
LOADLIBES= -lkvm
|
LOADLIBES= -lkvm
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/i386/fbsd64.mh
|
Index: gdb-7.6/gdb/config/i386/fbsd64.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/i386/fbsd64.mh 2012-02-09 17:06:44.000000000 +0100
|
--- gdb-7.6.orig/gdb/config/i386/fbsd64.mh 2012-02-09 17:06:44.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/i386/fbsd64.mh 2013-04-11 16:50:33.201286929 +0200
|
+++ gdb-7.6/gdb/config/i386/fbsd64.mh 2013-04-26 15:33:01.181049238 +0200
|
||||||
@@ -2,5 +2,6 @@
|
@@ -2,5 +2,6 @@
|
||||||
NATDEPFILES= fork-child.o inf-ptrace.o \
|
NATDEPFILES= fork-child.o inf-ptrace.o \
|
||||||
fbsd-nat.o amd64-nat.o amd64bsd-nat.o amd64fbsd-nat.o \
|
fbsd-nat.o amd64-nat.o amd64bsd-nat.o amd64fbsd-nat.o \
|
||||||
@ -480,10 +480,10 @@ Index: gdb-7.5.91.20130407/gdb/config/i386/fbsd64.mh
|
|||||||
+HAVE_NATIVE_GCORE_HOST = 1
|
+HAVE_NATIVE_GCORE_HOST = 1
|
||||||
|
|
||||||
LOADLIBES= -lkvm
|
LOADLIBES= -lkvm
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/i386/i386gnu.mh
|
Index: gdb-7.6/gdb/config/i386/i386gnu.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/i386/i386gnu.mh 2012-01-10 17:30:44.000000000 +0100
|
--- gdb-7.6.orig/gdb/config/i386/i386gnu.mh 2012-01-10 17:30:44.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/i386/i386gnu.mh 2013-04-11 16:50:33.201286929 +0200
|
+++ gdb-7.6/gdb/config/i386/i386gnu.mh 2013-04-26 15:33:01.181049238 +0200
|
||||||
@@ -2,6 +2,7 @@
|
@@ -2,6 +2,7 @@
|
||||||
NATDEPFILES= i386gnu-nat.o gnu-nat.o core-regset.o fork-child.o \
|
NATDEPFILES= i386gnu-nat.o gnu-nat.o core-regset.o fork-child.o \
|
||||||
notify_S.o process_reply_S.o msg_reply_S.o \
|
notify_S.o process_reply_S.o msg_reply_S.o \
|
||||||
@ -492,46 +492,46 @@ Index: gdb-7.5.91.20130407/gdb/config/i386/i386gnu.mh
|
|||||||
|
|
||||||
NAT_FILE= nm-i386gnu.h
|
NAT_FILE= nm-i386gnu.h
|
||||||
MH_CFLAGS = -D_GNU_SOURCE
|
MH_CFLAGS = -D_GNU_SOURCE
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/i386/i386sol2.mh
|
Index: gdb-7.6/gdb/config/i386/i386sol2.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/i386/i386sol2.mh 2010-04-26 15:53:56.000000000 +0200
|
--- gdb-7.6.orig/gdb/config/i386/i386sol2.mh 2010-04-26 15:53:56.000000000 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/i386/i386sol2.mh 2013-04-11 16:50:33.201286929 +0200
|
+++ gdb-7.6/gdb/config/i386/i386sol2.mh 2013-04-26 15:33:01.181049238 +0200
|
||||||
@@ -1,3 +1,4 @@
|
@@ -1,3 +1,4 @@
|
||||||
# Host: Solaris x86
|
# Host: Solaris x86
|
||||||
NATDEPFILES= fork-child.o i386v4-nat.o i386-sol2-nat.o \
|
NATDEPFILES= fork-child.o i386v4-nat.o i386-sol2-nat.o \
|
||||||
procfs.o proc-api.o proc-events.o proc-flags.o proc-why.o
|
procfs.o proc-api.o proc-events.o proc-flags.o proc-why.o
|
||||||
+HAVE_NATIVE_GCORE_HOST = 1
|
+HAVE_NATIVE_GCORE_HOST = 1
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/i386/sol2-64.mh
|
Index: gdb-7.6/gdb/config/i386/sol2-64.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/i386/sol2-64.mh 2010-04-26 15:53:57.000000000 +0200
|
--- gdb-7.6.orig/gdb/config/i386/sol2-64.mh 2010-04-26 15:53:57.000000000 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/i386/sol2-64.mh 2013-04-11 16:50:33.201286929 +0200
|
+++ gdb-7.6/gdb/config/i386/sol2-64.mh 2013-04-26 15:33:01.182049237 +0200
|
||||||
@@ -1,3 +1,4 @@
|
@@ -1,3 +1,4 @@
|
||||||
# Host: Solaris x86_64
|
# Host: Solaris x86_64
|
||||||
NATDEPFILES= fork-child.o amd64-nat.o i386v4-nat.o i386-sol2-nat.o \
|
NATDEPFILES= fork-child.o amd64-nat.o i386v4-nat.o i386-sol2-nat.o \
|
||||||
procfs.o proc-api.o proc-events.o proc-flags.o proc-why.o
|
procfs.o proc-api.o proc-events.o proc-flags.o proc-why.o
|
||||||
+HAVE_NATIVE_GCORE_HOST = 1
|
+HAVE_NATIVE_GCORE_HOST = 1
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/mips/irix5.mh
|
Index: gdb-7.6/gdb/config/mips/irix5.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/mips/irix5.mh 2012-01-10 17:30:45.000000000 +0100
|
--- gdb-7.6.orig/gdb/config/mips/irix5.mh 2012-01-10 17:30:45.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/mips/irix5.mh 2013-04-11 16:50:33.201286929 +0200
|
+++ gdb-7.6/gdb/config/mips/irix5.mh 2013-04-26 15:33:01.182049237 +0200
|
||||||
@@ -1,3 +1,4 @@
|
@@ -1,3 +1,4 @@
|
||||||
# Host: SGI Iris running irix 5.x
|
# Host: SGI Iris running irix 5.x
|
||||||
NATDEPFILES= fork-child.o irix5-nat.o procfs.o \
|
NATDEPFILES= fork-child.o irix5-nat.o procfs.o \
|
||||||
proc-api.o proc-events.o proc-flags.o proc-why.o
|
proc-api.o proc-events.o proc-flags.o proc-why.o
|
||||||
+HAVE_NATIVE_GCORE_HOST = 1
|
+HAVE_NATIVE_GCORE_HOST = 1
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/mips/irix6.mh
|
Index: gdb-7.6/gdb/config/mips/irix6.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/mips/irix6.mh 2012-01-10 17:30:45.000000000 +0100
|
--- gdb-7.6.orig/gdb/config/mips/irix6.mh 2012-01-10 17:30:45.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/mips/irix6.mh 2013-04-11 16:50:33.201286929 +0200
|
+++ gdb-7.6/gdb/config/mips/irix6.mh 2013-04-26 15:33:01.182049237 +0200
|
||||||
@@ -1,3 +1,4 @@
|
@@ -1,3 +1,4 @@
|
||||||
# Host: SGI Iris running irix 6.x
|
# Host: SGI Iris running irix 6.x
|
||||||
NATDEPFILES= fork-child.o irix5-nat.o procfs.o \
|
NATDEPFILES= fork-child.o irix5-nat.o procfs.o \
|
||||||
proc-api.o proc-events.o proc-flags.o proc-why.o
|
proc-api.o proc-events.o proc-flags.o proc-why.o
|
||||||
+HAVE_NATIVE_GCORE_HOST = 1
|
+HAVE_NATIVE_GCORE_HOST = 1
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/powerpc/fbsd.mh
|
Index: gdb-7.6/gdb/config/powerpc/fbsd.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/powerpc/fbsd.mh 2013-02-04 21:48:53.000000000 +0100
|
--- gdb-7.6.orig/gdb/config/powerpc/fbsd.mh 2013-02-04 21:48:53.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/powerpc/fbsd.mh 2013-04-11 16:50:33.202286928 +0200
|
+++ gdb-7.6/gdb/config/powerpc/fbsd.mh 2013-04-26 15:33:01.182049237 +0200
|
||||||
@@ -18,6 +18,7 @@
|
@@ -18,6 +18,7 @@
|
||||||
# along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
# along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||||
|
|
||||||
@ -540,10 +540,10 @@ Index: gdb-7.5.91.20130407/gdb/config/powerpc/fbsd.mh
|
|||||||
|
|
||||||
LOADLIBES= -lkvm
|
LOADLIBES= -lkvm
|
||||||
|
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/sparc/fbsd.mh
|
Index: gdb-7.6/gdb/config/sparc/fbsd.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/sparc/fbsd.mh 2009-10-26 19:28:15.000000000 +0100
|
--- gdb-7.6.orig/gdb/config/sparc/fbsd.mh 2009-10-26 19:28:15.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/sparc/fbsd.mh 2013-04-11 16:50:33.202286928 +0200
|
+++ gdb-7.6/gdb/config/sparc/fbsd.mh 2013-04-26 15:33:01.182049237 +0200
|
||||||
@@ -2,5 +2,6 @@
|
@@ -2,5 +2,6 @@
|
||||||
NATDEPFILES= fork-child.o inf-ptrace.o \
|
NATDEPFILES= fork-child.o inf-ptrace.o \
|
||||||
fbsd-nat.o sparc-nat.o sparc64-nat.o sparc64fbsd-nat.o \
|
fbsd-nat.o sparc-nat.o sparc64-nat.o sparc64fbsd-nat.o \
|
||||||
@ -551,19 +551,19 @@ Index: gdb-7.5.91.20130407/gdb/config/sparc/fbsd.mh
|
|||||||
+HAVE_NATIVE_GCORE_HOST = 1
|
+HAVE_NATIVE_GCORE_HOST = 1
|
||||||
|
|
||||||
LOADLIBES= -lkvm
|
LOADLIBES= -lkvm
|
||||||
Index: gdb-7.5.91.20130407/gdb/config/sparc/sol2.mh
|
Index: gdb-7.6/gdb/config/sparc/sol2.mh
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config/sparc/sol2.mh 2012-01-10 17:30:49.000000000 +0100
|
--- gdb-7.6.orig/gdb/config/sparc/sol2.mh 2012-01-10 17:30:49.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config/sparc/sol2.mh 2013-04-11 16:50:33.202286928 +0200
|
+++ gdb-7.6/gdb/config/sparc/sol2.mh 2013-04-26 15:33:01.182049237 +0200
|
||||||
@@ -3,3 +3,4 @@ NAT_FILE= nm-sol2.h
|
@@ -3,3 +3,4 @@ NAT_FILE= nm-sol2.h
|
||||||
NATDEPFILES= sparc-sol2-nat.o \
|
NATDEPFILES= sparc-sol2-nat.o \
|
||||||
core-regset.o fork-child.o \
|
core-regset.o fork-child.o \
|
||||||
procfs.o proc-api.o proc-events.o proc-flags.o proc-why.o
|
procfs.o proc-api.o proc-events.o proc-flags.o proc-why.o
|
||||||
+HAVE_NATIVE_GCORE_HOST = 1
|
+HAVE_NATIVE_GCORE_HOST = 1
|
||||||
Index: gdb-7.5.91.20130407/gdb/doc/Makefile.in
|
Index: gdb-7.6/gdb/doc/Makefile.in
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/doc/Makefile.in 2013-04-11 16:50:14.000000000 +0200
|
--- gdb-7.6.orig/gdb/doc/Makefile.in 2013-04-26 15:32:58.000000000 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/doc/Makefile.in 2013-04-11 16:50:33.202286928 +0200
|
+++ gdb-7.6/gdb/doc/Makefile.in 2013-04-26 15:33:01.183049235 +0200
|
||||||
@@ -177,11 +177,15 @@ POD2MAN5 = pod2man --center="GNU Develop
|
@@ -177,11 +177,15 @@ POD2MAN5 = pod2man --center="GNU Develop
|
||||||
--release="gdb-`sed q $(srcdir)/../version.in`" --section=5
|
--release="gdb-`sed q $(srcdir)/../version.in`" --section=5
|
||||||
|
|
||||||
@ -622,11 +622,11 @@ Index: gdb-7.5.91.20130407/gdb/doc/Makefile.in
|
|||||||
gdbinit.5: $(GDB_DOC_FILES)
|
gdbinit.5: $(GDB_DOC_FILES)
|
||||||
touch $@
|
touch $@
|
||||||
-$(TEXI2POD) $(MANCONF) -Dgdbinit < $(srcdir)/gdb.texinfo > gdbinit.pod
|
-$(TEXI2POD) $(MANCONF) -Dgdbinit < $(srcdir)/gdb.texinfo > gdbinit.pod
|
||||||
Index: gdb-7.5.91.20130407/gdb/doc/gdb.texinfo
|
Index: gdb-7.6/gdb/doc/gdb.texinfo
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/doc/gdb.texinfo 2013-04-11 16:50:14.000000000 +0200
|
--- gdb-7.6.orig/gdb/doc/gdb.texinfo 2013-04-26 15:32:58.000000000 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/doc/gdb.texinfo 2013-04-11 16:50:33.209286928 +0200
|
+++ gdb-7.6/gdb/doc/gdb.texinfo 2013-04-26 15:33:01.191049229 +0200
|
||||||
@@ -41701,6 +41701,7 @@ switch (die->tag)
|
@@ -41709,6 +41709,7 @@ switch (die->tag)
|
||||||
@menu
|
@menu
|
||||||
* gdb man:: The GNU Debugger man page
|
* gdb man:: The GNU Debugger man page
|
||||||
* gdbserver man:: Remote Server for the GNU Debugger man page
|
* gdbserver man:: Remote Server for the GNU Debugger man page
|
||||||
@ -634,7 +634,7 @@ Index: gdb-7.5.91.20130407/gdb/doc/gdb.texinfo
|
|||||||
* gdbinit man:: gdbinit scripts
|
* gdbinit man:: gdbinit scripts
|
||||||
@end menu
|
@end menu
|
||||||
|
|
||||||
@@ -42222,6 +42223,53 @@ info gdb
|
@@ -42230,6 +42231,53 @@ info gdb
|
||||||
should give you access to the complete manual.
|
should give you access to the complete manual.
|
||||||
|
|
||||||
@cite{Using GDB: A Guide to the GNU Source-Level Debugger},
|
@cite{Using GDB: A Guide to the GNU Source-Level Debugger},
|
||||||
|
9
gdb.spec
9
gdb.spec
@ -27,16 +27,16 @@
|
|||||||
Summary: A GNU source-level debugger for C, C++, Fortran, Go and other languages
|
Summary: A GNU source-level debugger for C, C++, Fortran, Go and other languages
|
||||||
Name: %{?scl_prefix}gdb
|
Name: %{?scl_prefix}gdb
|
||||||
|
|
||||||
%global snap 20130423
|
#global snap 20130423
|
||||||
# Freeze it when GDB gets branched
|
# Freeze it when GDB gets branched
|
||||||
%global snapsrc 20130312
|
%global snapsrc 20130312
|
||||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||||
%global snapgnulib 20121213
|
%global snapgnulib 20121213
|
||||||
Version: 7.5.91.%{snap}
|
Version: 7.6
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 23%{?dist}
|
Release: 24%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1390,6 +1390,9 @@ fi
|
|||||||
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Apr 26 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.6-24.fc19
|
||||||
|
- Rebase to FSF GDB 7.6.
|
||||||
|
|
||||||
* Wed Apr 24 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.5.91.20130423-23.fc19
|
* Wed Apr 24 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.5.91.20130423-23.fc19
|
||||||
- Fix man page BuildRequires (for BZ 881892).
|
- Fix man page BuildRequires (for BZ 881892).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user