Rebase to FSF GDB 7.2.50.20110328 (which is a 7.3 pre-release).
Bundle %{libstdcxxpython}.tar.bz2 unconditionally - for rebulds on RHELs.
This commit is contained in:
parent
5752ad02c2
commit
46a1caf62e
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
/libstdc++-v3-python-r155978.tar.bz2
|
||||
/gdb-7.2.50.20110320.tar.bz2
|
||||
/gdb-7.2.50.20110328.tar.bz2
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: gdb-7.2.50.20110320/gdb/corelow.c
|
||||
Index: gdb-7.2.50.20110328/gdb/corelow.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/corelow.c 2011-02-26 03:07:07.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/corelow.c 2011-03-20 15:19:52.000000000 +0100
|
||||
--- gdb-7.2.50.20110328.orig/gdb/corelow.c 2011-02-26 03:07:07.000000000 +0100
|
||||
+++ gdb-7.2.50.20110328/gdb/corelow.c 2011-03-28 18:41:20.000000000 +0200
|
||||
@@ -47,6 +47,9 @@
|
||||
#include "filenames.h"
|
||||
#include "progspace.h"
|
||||
@ -90,11 +90,11 @@ Index: gdb-7.2.50.20110320/gdb/corelow.c
|
||||
+ NULL, NULL, NULL,
|
||||
+ &setlist, &showlist);
|
||||
}
|
||||
Index: gdb-7.2.50.20110320/gdb/doc/gdb.texinfo
|
||||
Index: gdb-7.2.50.20110328/gdb/doc/gdb.texinfo
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/doc/gdb.texinfo 2011-03-20 15:17:44.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/doc/gdb.texinfo 2011-03-20 15:19:52.000000000 +0100
|
||||
@@ -15343,6 +15343,27 @@ information files.
|
||||
--- gdb-7.2.50.20110328.orig/gdb/doc/gdb.texinfo 2011-03-28 18:40:15.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/doc/gdb.texinfo 2011-03-28 18:41:20.000000000 +0200
|
||||
@@ -15346,6 +15346,27 @@ information files.
|
||||
|
||||
@end table
|
||||
|
||||
@ -122,10 +122,10 @@ Index: gdb-7.2.50.20110320/gdb/doc/gdb.texinfo
|
||||
@cindex @code{.gnu_debuglink} sections
|
||||
@cindex debug link sections
|
||||
A debug link is a special section of the executable file named
|
||||
Index: gdb-7.2.50.20110320/gdb/solib-svr4.c
|
||||
Index: gdb-7.2.50.20110328/gdb/solib-svr4.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/solib-svr4.c 2011-03-20 15:17:43.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/solib-svr4.c 2011-03-20 15:19:52.000000000 +0100
|
||||
--- gdb-7.2.50.20110328.orig/gdb/solib-svr4.c 2011-03-28 18:40:14.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/solib-svr4.c 2011-03-28 18:41:20.000000000 +0200
|
||||
@@ -1179,9 +1179,49 @@ svr4_current_sos (void)
|
||||
safe_strerror (errcode));
|
||||
else
|
||||
@ -179,14 +179,14 @@ Index: gdb-7.2.50.20110320/gdb/solib-svr4.c
|
||||
}
|
||||
xfree (buffer);
|
||||
|
||||
Index: gdb-7.2.50.20110320/gdb/elfread.c
|
||||
Index: gdb-7.2.50.20110328/gdb/elfread.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/elfread.c 2011-03-20 15:17:42.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/elfread.c 2011-03-20 15:22:34.000000000 +0100
|
||||
--- gdb-7.2.50.20110328.orig/gdb/elfread.c 2011-03-28 18:40:14.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/elfread.c 2011-03-28 18:45:39.000000000 +0200
|
||||
@@ -45,6 +45,10 @@
|
||||
#include "regcache.h"
|
||||
#include "stap-probe.h"
|
||||
#include "arch-utils.h"
|
||||
#include "gdbtypes.h"
|
||||
+#include "libbfd.h"
|
||||
+#include "gdbcore.h"
|
||||
+#include "gdbcmd.h"
|
||||
@ -858,8 +858,8 @@ Index: gdb-7.2.50.20110320/gdb/elfread.c
|
||||
+ 1);
|
||||
xfree (build_id);
|
||||
/* Prevent looping on a stripped .debug file. */
|
||||
if (build_id_name != NULL && strcmp (build_id_name, objfile->name) == 0)
|
||||
@@ -1209,7 +1784,7 @@ find_separate_debug_file_by_buildid (str
|
||||
if (build_id_name != NULL
|
||||
@@ -1210,7 +1785,7 @@ find_separate_debug_file_by_buildid (str
|
||||
xfree (build_id_name);
|
||||
}
|
||||
else if (build_id_name != NULL)
|
||||
@ -868,7 +868,7 @@ Index: gdb-7.2.50.20110320/gdb/elfread.c
|
||||
}
|
||||
return NULL;
|
||||
}
|
||||
@@ -1407,9 +1982,10 @@ elf_symfile_read (struct objfile *objfil
|
||||
@@ -1408,9 +1983,10 @@ elf_symfile_read (struct objfile *objfil
|
||||
`.note.gnu.build-id'. */
|
||||
else if (!objfile_has_partial_symbols (objfile))
|
||||
{
|
||||
@ -881,7 +881,7 @@ Index: gdb-7.2.50.20110320/gdb/elfread.c
|
||||
|
||||
if (debugfile == NULL)
|
||||
debugfile = find_separate_debug_file_by_debuglink (objfile);
|
||||
@@ -1421,6 +1997,12 @@ elf_symfile_read (struct objfile *objfil
|
||||
@@ -1422,6 +1998,12 @@ elf_symfile_read (struct objfile *objfil
|
||||
symbol_file_add_separate (abfd, symfile_flags, objfile);
|
||||
xfree (debugfile);
|
||||
}
|
||||
@ -894,7 +894,7 @@ Index: gdb-7.2.50.20110320/gdb/elfread.c
|
||||
}
|
||||
}
|
||||
|
||||
@@ -1879,4 +2461,16 @@ _initialize_elfread (void)
|
||||
@@ -1873,4 +2455,16 @@ _initialize_elfread (void)
|
||||
|
||||
elf_objfile_gnu_ifunc_cache_data = register_objfile_data ();
|
||||
gnu_ifunc_fns_p = &elf_gnu_ifunc_fns;
|
||||
@ -911,10 +911,10 @@ Index: gdb-7.2.50.20110320/gdb/elfread.c
|
||||
+
|
||||
+ observer_attach_executable_changed (debug_print_executable_changed);
|
||||
}
|
||||
Index: gdb-7.2.50.20110320/gdb/symfile.h
|
||||
Index: gdb-7.2.50.20110328/gdb/symfile.h
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/symfile.h 2011-03-20 15:17:43.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/symfile.h 2011-03-20 15:19:52.000000000 +0100
|
||||
--- gdb-7.2.50.20110328.orig/gdb/symfile.h 2011-03-28 18:40:14.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/symfile.h 2011-03-28 18:41:20.000000000 +0200
|
||||
@@ -611,6 +611,13 @@ void free_symfile_segment_data (struct s
|
||||
|
||||
extern struct cleanup *increment_reading_symtab (void);
|
||||
@ -929,11 +929,11 @@ Index: gdb-7.2.50.20110320/gdb/symfile.h
|
||||
/* From dwarf2read.c */
|
||||
|
||||
extern int dwarf2_has_info (struct objfile *);
|
||||
Index: gdb-7.2.50.20110320/gdb/testsuite/lib/gdb.exp
|
||||
Index: gdb-7.2.50.20110328/gdb/testsuite/lib/gdb.exp
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/testsuite/lib/gdb.exp 2011-03-20 15:17:43.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/testsuite/lib/gdb.exp 2011-03-20 15:19:52.000000000 +0100
|
||||
@@ -1397,6 +1397,16 @@ proc default_gdb_start { } {
|
||||
--- gdb-7.2.50.20110328.orig/gdb/testsuite/lib/gdb.exp 2011-03-28 18:40:14.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/testsuite/lib/gdb.exp 2011-03-28 18:41:20.000000000 +0200
|
||||
@@ -1381,6 +1381,16 @@ proc default_gdb_start { } {
|
||||
warning "Couldn't set the width to 0."
|
||||
}
|
||||
}
|
||||
@ -950,10 +950,10 @@ Index: gdb-7.2.50.20110320/gdb/testsuite/lib/gdb.exp
|
||||
return 0;
|
||||
}
|
||||
|
||||
Index: gdb-7.2.50.20110320/gdb/testsuite/lib/mi-support.exp
|
||||
Index: gdb-7.2.50.20110328/gdb/testsuite/lib/mi-support.exp
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/testsuite/lib/mi-support.exp 2011-03-07 17:03:04.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/testsuite/lib/mi-support.exp 2011-03-20 15:19:52.000000000 +0100
|
||||
--- gdb-7.2.50.20110328.orig/gdb/testsuite/lib/mi-support.exp 2011-03-07 17:03:04.000000000 +0100
|
||||
+++ gdb-7.2.50.20110328/gdb/testsuite/lib/mi-support.exp 2011-03-28 18:41:20.000000000 +0200
|
||||
@@ -221,6 +221,16 @@ proc default_mi_gdb_start { args } {
|
||||
}
|
||||
}
|
||||
@ -971,10 +971,10 @@ Index: gdb-7.2.50.20110320/gdb/testsuite/lib/mi-support.exp
|
||||
|
||||
detect_async
|
||||
|
||||
Index: gdb-7.2.50.20110320/gdb/objfiles.h
|
||||
Index: gdb-7.2.50.20110328/gdb/objfiles.h
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/objfiles.h 2011-03-07 17:17:29.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/objfiles.h 2011-03-20 15:20:29.000000000 +0100
|
||||
--- gdb-7.2.50.20110328.orig/gdb/objfiles.h 2011-03-07 17:17:29.000000000 +0100
|
||||
+++ gdb-7.2.50.20110328/gdb/objfiles.h 2011-03-28 18:41:20.000000000 +0200
|
||||
@@ -441,6 +441,10 @@ struct objfile
|
||||
|
||||
#define OBJF_PSYMTABS_READ (1 << 4)
|
||||
|
@ -1,49 +0,0 @@
|
||||
http://sourceware.org/ml/gdb-patches/2011-03/msg00946.html
|
||||
Subject: [patch] ada: Fix rashes on gdbarch garbage
|
||||
|
||||
Hi Joel,
|
||||
|
||||
for gdb.ada/str_ref_cmp.exp on x86_64-fedora15-linux-gnu it turns:
|
||||
|
||||
(gdb) print String_Var (1 .. 3) = "Hel"
|
||||
ERROR: Process no longer exists
|
||||
UNRESOLVED: gdb.ada/str_ref_cmp.exp: print String_Var (1 .. 3) = "Hel"
|
||||
->
|
||||
(gdb) print String_Var (1 .. 3) = "Hel"
|
||||
$1 = false
|
||||
(gdb) FAIL: gdb.ada/str_ref_cmp.exp: print String_Var (1 .. 3) = "Hel"
|
||||
|
||||
GDB crashes the former way without this fix on:
|
||||
gcc-gnat-4.6.0-0.14.fc15.x86_64
|
||||
gcc-gnat-4.5.1-4.fc14.x86_64
|
||||
|
||||
I cannot test FSF gcc <=4.5 myself as its Ada build errors out for me on:
|
||||
uintp.adb:242:22: expect type "Hnum" defined at line 91
|
||||
|
||||
GDB PASSes on these GNATs even without this fix but that is not the point:
|
||||
GNAT 4.7.0 20110320 (experimental)
|
||||
GNAT 4.6.0 20110320 (prerelease)
|
||||
|
||||
This is only a suggestion, I do not know much about the ada-* code.
|
||||
|
||||
|
||||
Thanks,
|
||||
Jan
|
||||
|
||||
|
||||
gdb/
|
||||
2011-03-20 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* ada-lang.c (replace_operator_with_call): Copy also GDBARCH.
|
||||
|
||||
--- a/gdb/ada-lang.c
|
||||
+++ b/gdb/ada-lang.c
|
||||
@@ -3661,6 +3661,7 @@ replace_operator_with_call (struct expression **expp, int pc, int nargs,
|
||||
|
||||
newexp->nelts = exp->nelts + 7 - oplen;
|
||||
newexp->language_defn = exp->language_defn;
|
||||
+ newexp->gdbarch = exp->gdbarch;
|
||||
memcpy (newexp->elts, exp->elts, EXP_ELEM_TO_BYTES (pc));
|
||||
memcpy (newexp->elts + pc + 7, exp->elts + pc + oplen,
|
||||
EXP_ELEM_TO_BYTES (exp->nelts - pc - oplen));
|
||||
|
@ -1,8 +1,8 @@
|
||||
Index: gdb-7.2.50.20110320/gdb/breakpoint.c
|
||||
Index: gdb-7.2.50.20110328/gdb/breakpoint.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/breakpoint.c 2011-03-20 15:17:42.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/breakpoint.c 2011-03-20 15:28:48.000000000 +0100
|
||||
@@ -10678,6 +10678,50 @@ update_breakpoint_locations (struct brea
|
||||
--- gdb-7.2.50.20110328.orig/gdb/breakpoint.c 2011-03-28 18:40:14.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/breakpoint.c 2011-03-28 18:45:57.000000000 +0200
|
||||
@@ -10707,6 +10707,50 @@ update_breakpoint_locations (struct brea
|
||||
update_global_location_list (1);
|
||||
}
|
||||
|
||||
@ -53,22 +53,22 @@ Index: gdb-7.2.50.20110320/gdb/breakpoint.c
|
||||
/* Reset a breakpoint given it's struct breakpoint * BINT.
|
||||
The value we return ends up being the return value from catch_errors.
|
||||
Unused in this case. */
|
||||
Index: gdb-7.2.50.20110320/gdb/breakpoint.h
|
||||
Index: gdb-7.2.50.20110328/gdb/breakpoint.h
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/breakpoint.h 2011-03-20 15:17:42.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/breakpoint.h 2011-03-20 15:29:33.000000000 +0100
|
||||
@@ -1210,4 +1210,7 @@ extern struct breakpoint *iterate_over_b
|
||||
--- gdb-7.2.50.20110328.orig/gdb/breakpoint.h 2011-03-28 18:40:14.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/breakpoint.h 2011-03-28 18:46:07.000000000 +0200
|
||||
@@ -1219,4 +1219,7 @@ extern int user_breakpoint_p (struct bre
|
||||
|
||||
extern int user_breakpoint_p (struct breakpoint *);
|
||||
extern void modify_semaphore (struct bp_location *location, int set);
|
||||
|
||||
+extern void breakpoints_relocate (struct objfile *objfile,
|
||||
+ struct section_offsets *delta);
|
||||
+
|
||||
#endif /* !defined (BREAKPOINT_H) */
|
||||
Index: gdb-7.2.50.20110320/gdb/objfiles.c
|
||||
Index: gdb-7.2.50.20110328/gdb/objfiles.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110320.orig/gdb/objfiles.c 2011-03-20 15:17:42.000000000 +0100
|
||||
+++ gdb-7.2.50.20110320/gdb/objfiles.c 2011-03-20 15:29:05.000000000 +0100
|
||||
--- gdb-7.2.50.20110328.orig/gdb/objfiles.c 2011-03-28 18:40:14.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/objfiles.c 2011-03-28 18:45:57.000000000 +0200
|
||||
@@ -851,6 +851,11 @@ objfile_relocate1 (struct objfile *objfi
|
||||
objfile->sf->sym_probe_fns->sym_relocate_probe (objfile,
|
||||
new_offsets, delta);
|
||||
|
875
gdb-archer.patch
875
gdb-archer.patch
File diff suppressed because it is too large
Load Diff
@ -1,11 +1,11 @@
|
||||
gdb/linux-nat.c:
|
||||
- Workaround RHEL-5 kernels for detaching SIGSTOPped processes (BZ 498595).
|
||||
|
||||
Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
Index: gdb-7.2.50.20110328/gdb/elfread.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/elfread.c 2011-01-04 06:15:59.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/elfread.c 2011-01-04 06:17:54.000000000 +0100
|
||||
@@ -832,7 +832,7 @@ resolve_gnu_ifunc (const char *function_
|
||||
--- gdb-7.2.50.20110328.orig/gdb/elfread.c 2011-03-28 18:46:16.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/elfread.c 2011-03-28 18:48:19.000000000 +0200
|
||||
@@ -1083,7 +1083,7 @@ elf_gnu_ifunc_resolver_return_stop (stru
|
||||
#define BUILD_ID_VERBOSE_NONE 0
|
||||
#define BUILD_ID_VERBOSE_FILENAMES 1
|
||||
#define BUILD_ID_VERBOSE_BINARY_PARSE 2
|
||||
@ -14,9 +14,9 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
static void
|
||||
show_build_id_verbose (struct ui_file *file, int from_tty,
|
||||
struct cmd_list_element *c, const char *value)
|
||||
@@ -1920,8 +1920,10 @@ find_separate_debug_file_by_buildid (str
|
||||
/* Prevent looping on a stripped .debug file. */
|
||||
if (build_id_name != NULL && strcmp (build_id_name, objfile->name) == 0)
|
||||
@@ -2173,8 +2173,10 @@ find_separate_debug_file_by_buildid (str
|
||||
if (build_id_name != NULL
|
||||
&& filename_cmp (build_id_name, objfile->name) == 0)
|
||||
{
|
||||
+#if 0 /* RHEL-5 backward behavior compatibility. */
|
||||
warning (_("\"%s\": separate debug info file has no debug info"),
|
||||
@ -25,11 +25,11 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
xfree (build_id_name);
|
||||
}
|
||||
else if (build_id_name != NULL)
|
||||
Index: gdb-7.2.50.20110104/gdb/corelow.c
|
||||
Index: gdb-7.2.50.20110328/gdb/corelow.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/corelow.c 2011-01-04 06:15:57.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/corelow.c 2011-01-04 06:18:08.000000000 +0100
|
||||
@@ -280,7 +280,7 @@ add_to_thread_list (bfd *abfd, asection
|
||||
--- gdb-7.2.50.20110328.orig/gdb/corelow.c 2011-03-28 18:46:16.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/corelow.c 2011-03-28 18:47:56.000000000 +0200
|
||||
@@ -282,7 +282,7 @@ add_to_thread_list (bfd *abfd, asection
|
||||
inferior_ptid = ptid; /* Yes, make it current. */
|
||||
}
|
||||
|
||||
@ -38,11 +38,11 @@ Index: gdb-7.2.50.20110104/gdb/corelow.c
|
||||
|
||||
static void
|
||||
build_id_locate_exec (int from_tty)
|
||||
Index: gdb-7.2.50.20110104/gdb/linux-nat.c
|
||||
Index: gdb-7.2.50.20110328/gdb/linux-nat.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/linux-nat.c 2011-01-04 06:15:59.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/linux-nat.c 2011-01-04 06:17:54.000000000 +0100
|
||||
@@ -1762,8 +1762,22 @@ GPT: lwp %s had signal %s, but it is in
|
||||
--- gdb-7.2.50.20110328.orig/gdb/linux-nat.c 2011-03-28 18:46:16.000000000 +0200
|
||||
+++ gdb-7.2.50.20110328/gdb/linux-nat.c 2011-03-28 18:47:56.000000000 +0200
|
||||
@@ -1774,8 +1774,22 @@ get_pending_status (struct lwp_info *lp,
|
||||
target_signal_to_string (signo));
|
||||
}
|
||||
|
||||
|
@ -1,59 +0,0 @@
|
||||
http://sourceware.org/ml/archer/2011-q1/msg00136.html
|
||||
Subject: archer-sergiodj-stap -O2 -Wall warnings=errors
|
||||
|
||||
Hi Sergio,
|
||||
|
||||
with -O2 (+some -Wall or so options possibly - what applies for Fedora builds)
|
||||
one gets:
|
||||
|
||||
gcc-4.6.0-0.14.fc15.x86_64
|
||||
stap-probe.c: In function $B!F(Bstap_fetch_reg_value$B!G(B:
|
||||
stap-probe.c:923:12: error: $B!F(Baop$B!G(B may be used uninitialized in this function [-Werror=uninitialized]
|
||||
stap-probe.c:919:10: error: $B!F(Bret$B!G(B may be used uninitialized in this function [-Werror=uninitialized]
|
||||
stap-probe.c: In function $B!F(Bstap_evaluate_conditionally$B!G(B:
|
||||
stap-probe.c:1184:3: error: $B!F(Bres$B!G(B may be used uninitialized in this function [-Werror=uninitialized]
|
||||
|
||||
The attached patch needs a review, I have only briefly checked it is not
|
||||
completely bogus.
|
||||
|
||||
|
||||
Thanks,
|
||||
Jan
|
||||
|
||||
|
||||
--- a/gdb/stap-probe.c
|
||||
+++ b/gdb/stap-probe.c
|
||||
@@ -780,7 +780,9 @@ stap_fetch_reg_value (struct stap_evaluation_info *eval_info,
|
||||
#define REG_NAME_MAX_SIZE 20
|
||||
char regname[REG_NAME_MAX_SIZE + 1];
|
||||
int len, regnum, indirect_p = 0;
|
||||
- struct value *ret;
|
||||
+ /* GCC false warning: $B!F(Bret$B!G(B may be used uninitialized in this function
|
||||
+ */
|
||||
+ struct value *ret = NULL;
|
||||
|
||||
/* The function which called us did not check if the expression
|
||||
buffer was empty. */
|
||||
@@ -851,7 +853,9 @@ stap_fetch_reg_value (struct stap_evaluation_info *eval_info,
|
||||
if (indirect_p)
|
||||
{
|
||||
struct type *t = NULL;
|
||||
- enum agent_op aop;
|
||||
+ /* GCC false warning: $B!F(Baop$B!G(B may be used uninitialized in this function.
|
||||
+ */
|
||||
+ enum agent_op aop = 0;
|
||||
|
||||
/* If the user has specified that the register must be indirected,
|
||||
we should know what's the correct type to cast it before making
|
||||
@@ -949,7 +953,9 @@ stap_evaluate_single_operand (struct stap_evaluation_info *eval_info)
|
||||
struct gdbarch *gdbarch = eval_info->gdbarch;
|
||||
struct frame_info *frame = eval_info->frame;
|
||||
enum stap_arg_bitness bitness = eval_info->bitness;
|
||||
- struct value *res;
|
||||
+ /* GCC false warning: $B!F(Bres$B!G(B may be used uninitialized in this function
|
||||
+ */
|
||||
+ struct value *res = NULL;
|
||||
|
||||
switch (*eval_info->exp_buf)
|
||||
{
|
||||
|
22
gdb.spec
22
gdb.spec
@ -23,11 +23,11 @@ Name: gdb%{?_with_debug:-debug}
|
||||
# Set version to contents of gdb/version.in.
|
||||
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
|
||||
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
|
||||
Version: 7.2.50.20110320
|
||||
Version: 7.2.50.20110328
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 30%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 31%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||
Group: Development/Debuggers
|
||||
@ -92,11 +92,9 @@ Source3: gdb-gstack.man
|
||||
#=fedora
|
||||
Source4: gdbinit
|
||||
|
||||
%if 0%{?rhel:1}
|
||||
# libstdc++ pretty printers from GCC SVN HEAD (4.5 experimental).
|
||||
%define libstdcxxpython libstdc++-v3-python-r155978
|
||||
Source4: %{libstdcxxpython}.tar.bz2
|
||||
%endif # 0%{?rhel:1}
|
||||
Source5: %{libstdcxxpython}.tar.bz2
|
||||
|
||||
# Work around out-of-date dejagnu that does not have KFAIL
|
||||
#=drop: That dejagnu is too old to be supported.
|
||||
@ -558,12 +556,6 @@ Patch572: gdb-core-thread-internalerr-1of3.patch
|
||||
Patch573: gdb-core-thread-internalerr-2of3.patch
|
||||
Patch574: gdb-core-thread-internalerr-3of3.patch
|
||||
|
||||
# [stap] Fix -O2 warnings.
|
||||
Patch576: gdb-stap-warnings.patch
|
||||
|
||||
# Fix Ada support crash on uninitialized gdbarch.
|
||||
Patch577: gdb-ada-gdbarch-crash.patch
|
||||
|
||||
BuildRequires: ncurses-devel%{?_isa} texinfo gettext flex bison expat-devel%{?_isa}
|
||||
Requires: readline%{?_isa}
|
||||
BuildRequires: readline-devel%{?_isa}
|
||||
@ -706,7 +698,7 @@ This package provides INFO, HTML and PDF user manual for GDB.
|
||||
|
||||
%if 0%{?rhel:1}
|
||||
# libstdc++ pretty printers.
|
||||
tar xjf %{SOURCE4}
|
||||
tar xjf %{SOURCE5}
|
||||
%endif # 0%{?rhel:1}
|
||||
|
||||
# Files have `# <number> <file>' statements breaking VPATH / find-debuginfo.sh .
|
||||
@ -835,8 +827,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch572 -p1
|
||||
%patch573 -p1
|
||||
%patch574 -p1
|
||||
%patch576 -p1
|
||||
%patch577 -p1
|
||||
|
||||
%patch390 -p1
|
||||
%patch393 -p1
|
||||
@ -1262,6 +1252,10 @@ fi
|
||||
%{_infodir}/gdb.info*
|
||||
|
||||
%changelog
|
||||
* Mon Mar 28 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20110328-31.fc15
|
||||
- Rebase to FSF GDB 7.2.50.20110328 (which is a 7.3 pre-release).
|
||||
- Bundle %%{libstdcxxpython}.tar.bz2 unconditionally - for rebulds on RHELs.
|
||||
|
||||
* Sun Mar 20 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20110320-30.fc15
|
||||
- Fix threading internal error on corrupted memory (BZ 677654).
|
||||
- Fix i386 rwatch+awatch before run (BZ 688788, on top of BZ 541866).
|
||||
|
Loading…
Reference in New Issue
Block a user