Remove --disablerepo='*' from BZ 554152 as it conflicts with BZ 981154.
This commit is contained in:
parent
752ff760ca
commit
44de066dfd
@ -1,7 +1,7 @@
|
|||||||
Index: gdb-7.5.91.20130407/gdb/event-top.c
|
Index: gdb-7.6/gdb/event-top.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/event-top.c 2013-01-31 19:37:37.000000000 +0100
|
--- gdb-7.6.orig/gdb/event-top.c 2013-01-31 19:37:37.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/event-top.c 2013-04-11 16:53:03.230280376 +0200
|
+++ gdb-7.6/gdb/event-top.c 2013-07-17 19:51:02.679357656 +0200
|
||||||
@@ -36,6 +36,7 @@
|
@@ -36,6 +36,7 @@
|
||||||
#include "continuations.h"
|
#include "continuations.h"
|
||||||
#include "gdbcmd.h" /* for dont_repeat() */
|
#include "gdbcmd.h" /* for dont_repeat() */
|
||||||
@ -28,10 +28,10 @@ Index: gdb-7.5.91.20130407/gdb/event-top.c
|
|||||||
/* Each interpreter has its own rules on displaying the command
|
/* Each interpreter has its own rules on displaying the command
|
||||||
prompt. */
|
prompt. */
|
||||||
if (!current_interp_display_prompt_p ())
|
if (!current_interp_display_prompt_p ())
|
||||||
Index: gdb-7.5.91.20130407/gdb/elfread.c
|
Index: gdb-7.6/gdb/elfread.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/elfread.c 2013-04-11 16:53:00.000000000 +0200
|
--- gdb-7.6.orig/gdb/elfread.c 2013-07-17 19:51:02.639357629 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/elfread.c 2013-04-11 16:53:03.231280376 +0200
|
+++ gdb-7.6/gdb/elfread.c 2013-07-17 19:51:50.738390068 +0200
|
||||||
@@ -49,6 +49,7 @@
|
@@ -49,6 +49,7 @@
|
||||||
#include "gdbcore.h"
|
#include "gdbcore.h"
|
||||||
#include "gdbcmd.h"
|
#include "gdbcmd.h"
|
||||||
@ -40,7 +40,7 @@ Index: gdb-7.5.91.20130407/gdb/elfread.c
|
|||||||
#include <sys/stat.h>
|
#include <sys/stat.h>
|
||||||
|
|
||||||
extern void _initialize_elfread (void);
|
extern void _initialize_elfread (void);
|
||||||
@@ -1629,8 +1630,361 @@ build_id_to_filename (const struct elf_b
|
@@ -1682,8 +1683,360 @@ build_id_to_filename (const struct elf_b
|
||||||
return retval;
|
return retval;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -258,8 +258,7 @@ Index: gdb-7.5.91.20130407/gdb/elfread.c
|
|||||||
+
|
+
|
||||||
+ /* Base package name for `debuginfo-install'. We do not use the
|
+ /* Base package name for `debuginfo-install'. We do not use the
|
||||||
+ `yum' command directly as the line
|
+ `yum' command directly as the line
|
||||||
+ yum --disablerepo='*' --enablerepo='*debug*' \
|
+ yum --enablerepo='*debug*' install NAME-debuginfo.ARCH
|
||||||
+ install NAME-debuginfo.ARCH
|
|
||||||
+ would be more complicated than just:
|
+ would be more complicated than just:
|
||||||
+ debuginfo-install NAME-VERSION-RELEASE.ARCH
|
+ debuginfo-install NAME-VERSION-RELEASE.ARCH
|
||||||
+ Do not supply the rpm base name (derived from .src.rpm name) as
|
+ Do not supply the rpm base name (derived from .src.rpm name) as
|
||||||
@ -399,11 +398,11 @@ Index: gdb-7.5.91.20130407/gdb/elfread.c
|
|||||||
+
|
+
|
||||||
/* This MISSING_FILEPAIR_HASH tracker is used only for the duplicite messages
|
/* This MISSING_FILEPAIR_HASH tracker is used only for the duplicite messages
|
||||||
- Try to install the hash file ...
|
- Try to install the hash file ...
|
||||||
+ yum --disablerepo='*' --enablerepo='*debug*' install ...
|
+ yum --enablerepo='*debug*' install ...
|
||||||
avoidance. */
|
avoidance. */
|
||||||
|
|
||||||
struct missing_filepair
|
struct missing_filepair
|
||||||
@@ -1684,11 +2038,17 @@ missing_filepair_change (void)
|
@@ -1737,11 +2090,17 @@ missing_filepair_change (void)
|
||||||
/* All their memory came just from missing_filepair_OBSTACK. */
|
/* All their memory came just from missing_filepair_OBSTACK. */
|
||||||
missing_filepair_hash = NULL;
|
missing_filepair_hash = NULL;
|
||||||
}
|
}
|
||||||
@ -421,7 +420,7 @@ Index: gdb-7.5.91.20130407/gdb/elfread.c
|
|||||||
missing_filepair_change ();
|
missing_filepair_change ();
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -1755,14 +2115,35 @@ debug_print_missing (const char *binary,
|
@@ -1808,14 +2167,34 @@ debug_print_missing (const char *binary,
|
||||||
|
|
||||||
*slot = missing_filepair;
|
*slot = missing_filepair;
|
||||||
|
|
||||||
@ -458,16 +457,15 @@ Index: gdb-7.5.91.20130407/gdb/elfread.c
|
|||||||
+ _("Missing separate debuginfo for %s\n"), binary);
|
+ _("Missing separate debuginfo for %s\n"), binary);
|
||||||
+ if (debug != NULL)
|
+ if (debug != NULL)
|
||||||
+ fprintf_unfiltered (gdb_stdlog, _("Try: %s %s\n"),
|
+ fprintf_unfiltered (gdb_stdlog, _("Try: %s %s\n"),
|
||||||
+ "yum --disablerepo='*' --enablerepo='*debug*'"
|
+ "yum --enablerepo='*debug*' install", debug);
|
||||||
+ " install", debug);
|
|
||||||
+ }
|
+ }
|
||||||
}
|
}
|
||||||
|
|
||||||
static char *
|
static char *
|
||||||
Index: gdb-7.5.91.20130407/gdb/symfile.h
|
Index: gdb-7.6/gdb/symfile.h
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/symfile.h 2013-04-11 16:53:00.000000000 +0200
|
--- gdb-7.6.orig/gdb/symfile.h 2013-07-17 19:51:02.639357629 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/symfile.h 2013-04-11 16:53:03.231280376 +0200
|
+++ gdb-7.6/gdb/symfile.h 2013-07-17 19:51:02.687357661 +0200
|
||||||
@@ -598,6 +598,8 @@ extern struct elf_build_id *build_id_add
|
@@ -598,6 +598,8 @@ extern struct elf_build_id *build_id_add
|
||||||
extern char *build_id_to_filename (const struct elf_build_id *build_id,
|
extern char *build_id_to_filename (const struct elf_build_id *build_id,
|
||||||
char **link_return, int add_debug_suffix);
|
char **link_return, int add_debug_suffix);
|
||||||
@ -477,10 +475,10 @@ Index: gdb-7.5.91.20130407/gdb/symfile.h
|
|||||||
|
|
||||||
/* From dwarf2read.c */
|
/* From dwarf2read.c */
|
||||||
|
|
||||||
Index: gdb-7.5.91.20130407/gdb/testsuite/lib/gdb.exp
|
Index: gdb-7.6/gdb/testsuite/lib/gdb.exp
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/testsuite/lib/gdb.exp 2013-04-11 16:53:00.000000000 +0200
|
--- gdb-7.6.orig/gdb/testsuite/lib/gdb.exp 2013-07-17 19:51:02.640357629 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/testsuite/lib/gdb.exp 2013-04-11 16:53:03.232280376 +0200
|
+++ gdb-7.6/gdb/testsuite/lib/gdb.exp 2013-07-17 19:51:02.688357662 +0200
|
||||||
@@ -1482,7 +1482,7 @@ proc default_gdb_start { } {
|
@@ -1482,7 +1482,7 @@ proc default_gdb_start { } {
|
||||||
warning "Couldn't set the width to 0."
|
warning "Couldn't set the width to 0."
|
||||||
}
|
}
|
||||||
@ -490,10 +488,10 @@ Index: gdb-7.5.91.20130407/gdb/testsuite/lib/gdb.exp
|
|||||||
send_gdb "set build-id-verbose 0\n"
|
send_gdb "set build-id-verbose 0\n"
|
||||||
gdb_expect 10 {
|
gdb_expect 10 {
|
||||||
-re "$gdb_prompt $" {
|
-re "$gdb_prompt $" {
|
||||||
Index: gdb-7.5.91.20130407/gdb/testsuite/lib/mi-support.exp
|
Index: gdb-7.6/gdb/testsuite/lib/mi-support.exp
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/testsuite/lib/mi-support.exp 2013-04-11 16:53:00.000000000 +0200
|
--- gdb-7.6.orig/gdb/testsuite/lib/mi-support.exp 2013-07-17 19:51:02.656357640 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/testsuite/lib/mi-support.exp 2013-04-11 16:53:03.233280376 +0200
|
+++ gdb-7.6/gdb/testsuite/lib/mi-support.exp 2013-07-17 19:51:02.689357663 +0200
|
||||||
@@ -212,7 +212,7 @@ proc default_mi_gdb_start { args } {
|
@@ -212,7 +212,7 @@ proc default_mi_gdb_start { args } {
|
||||||
warning "Couldn't set the width to 0."
|
warning "Couldn't set the width to 0."
|
||||||
}
|
}
|
||||||
@ -503,10 +501,10 @@ Index: gdb-7.5.91.20130407/gdb/testsuite/lib/mi-support.exp
|
|||||||
send_gdb "190-gdb-set build-id-verbose 0\n"
|
send_gdb "190-gdb-set build-id-verbose 0\n"
|
||||||
gdb_expect 10 {
|
gdb_expect 10 {
|
||||||
-re ".*190-gdb-set build-id-verbose 0\r\n190\\\^done\r\n$mi_gdb_prompt$" {
|
-re ".*190-gdb-set build-id-verbose 0\r\n190\\\^done\r\n$mi_gdb_prompt$" {
|
||||||
Index: gdb-7.5.91.20130407/gdb/tui/tui-interp.c
|
Index: gdb-7.6/gdb/tui/tui-interp.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/tui/tui-interp.c 2013-01-01 07:41:30.000000000 +0100
|
--- gdb-7.6.orig/gdb/tui/tui-interp.c 2013-01-01 07:41:30.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/tui/tui-interp.c 2013-04-11 16:53:03.233280376 +0200
|
+++ gdb-7.6/gdb/tui/tui-interp.c 2013-07-17 19:51:02.689357663 +0200
|
||||||
@@ -30,6 +30,7 @@
|
@@ -30,6 +30,7 @@
|
||||||
#include "tui/tui.h"
|
#include "tui/tui.h"
|
||||||
#include "tui/tui-io.h"
|
#include "tui/tui-io.h"
|
||||||
@ -515,10 +513,10 @@ Index: gdb-7.5.91.20130407/gdb/tui/tui-interp.c
|
|||||||
|
|
||||||
/* Set to 1 when the TUI mode must be activated when we first start
|
/* Set to 1 when the TUI mode must be activated when we first start
|
||||||
gdb. */
|
gdb. */
|
||||||
Index: gdb-7.5.91.20130407/gdb/aclocal.m4
|
Index: gdb-7.6/gdb/aclocal.m4
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/aclocal.m4 2013-01-17 12:06:26.000000000 +0100
|
--- gdb-7.6.orig/gdb/aclocal.m4 2013-01-17 12:06:26.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/aclocal.m4 2013-04-11 16:53:03.234280376 +0200
|
+++ gdb-7.6/gdb/aclocal.m4 2013-07-17 19:51:02.689357663 +0200
|
||||||
@@ -11,6 +11,164 @@
|
@@ -11,6 +11,164 @@
|
||||||
# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
|
# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
|
||||||
# PARTICULAR PURPOSE.
|
# PARTICULAR PURPOSE.
|
||||||
@ -684,10 +682,10 @@ Index: gdb-7.5.91.20130407/gdb/aclocal.m4
|
|||||||
# AM_CONDITIONAL -*- Autoconf -*-
|
# AM_CONDITIONAL -*- Autoconf -*-
|
||||||
|
|
||||||
# Copyright (C) 1997, 2000, 2001, 2003, 2004, 2005, 2006, 2008
|
# Copyright (C) 1997, 2000, 2001, 2003, 2004, 2005, 2006, 2008
|
||||||
Index: gdb-7.5.91.20130407/gdb/config.in
|
Index: gdb-7.6/gdb/config.in
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/config.in 2012-12-09 19:39:58.000000000 +0100
|
--- gdb-7.6.orig/gdb/config.in 2012-12-09 19:39:58.000000000 +0100
|
||||||
+++ gdb-7.5.91.20130407/gdb/config.in 2013-04-11 16:53:03.234280376 +0200
|
+++ gdb-7.6/gdb/config.in 2013-07-17 19:51:02.689357663 +0200
|
||||||
@@ -33,6 +33,9 @@
|
@@ -33,6 +33,9 @@
|
||||||
/* Define to BFD's default target vector. */
|
/* Define to BFD's default target vector. */
|
||||||
#undef DEFAULT_BFD_VEC
|
#undef DEFAULT_BFD_VEC
|
||||||
@ -708,10 +706,10 @@ Index: gdb-7.5.91.20130407/gdb/config.in
|
|||||||
/* Define to 1 if you have the <libunwind-ia64.h> header file. */
|
/* Define to 1 if you have the <libunwind-ia64.h> header file. */
|
||||||
#undef HAVE_LIBUNWIND_IA64_H
|
#undef HAVE_LIBUNWIND_IA64_H
|
||||||
|
|
||||||
Index: gdb-7.5.91.20130407/gdb/configure
|
Index: gdb-7.6/gdb/configure
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/configure 2013-04-11 16:50:50.000000000 +0200
|
--- gdb-7.6.orig/gdb/configure 2013-07-17 19:51:01.665356963 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/configure 2013-04-11 16:53:13.077280119 +0200
|
+++ gdb-7.6/gdb/configure 2013-07-17 19:51:02.691357664 +0200
|
||||||
@@ -686,6 +686,11 @@ PKGVERSION
|
@@ -686,6 +686,11 @@ PKGVERSION
|
||||||
HAVE_NATIVE_GCORE_TARGET
|
HAVE_NATIVE_GCORE_TARGET
|
||||||
TARGET_OBS
|
TARGET_OBS
|
||||||
@ -1259,10 +1257,10 @@ Index: gdb-7.5.91.20130407/gdb/configure
|
|||||||
|
|
||||||
|
|
||||||
subdirs="$subdirs testsuite"
|
subdirs="$subdirs testsuite"
|
||||||
Index: gdb-7.5.91.20130407/gdb/configure.ac
|
Index: gdb-7.6/gdb/configure.ac
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/configure.ac 2013-04-11 16:50:33.000000000 +0200
|
--- gdb-7.6.orig/gdb/configure.ac 2013-07-17 19:51:01.666356964 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/configure.ac 2013-04-11 16:53:03.240280376 +0200
|
+++ gdb-7.6/gdb/configure.ac 2013-07-17 19:51:02.692357665 +0200
|
||||||
@@ -166,6 +166,199 @@ AC_DEFINE_DIR(AUTO_LOAD_SAFE_PATH, escap
|
@@ -166,6 +166,199 @@ AC_DEFINE_DIR(AUTO_LOAD_SAFE_PATH, escap
|
||||||
[Directories safe to hold auto-loaded files.])
|
[Directories safe to hold auto-loaded files.])
|
||||||
AC_MSG_RESULT([$with_auto_load_safe_path])
|
AC_MSG_RESULT([$with_auto_load_safe_path])
|
||||||
@ -1463,10 +1461,10 @@ Index: gdb-7.5.91.20130407/gdb/configure.ac
|
|||||||
AC_CONFIG_SUBDIRS(testsuite)
|
AC_CONFIG_SUBDIRS(testsuite)
|
||||||
|
|
||||||
# Check whether to support alternative target configurations
|
# Check whether to support alternative target configurations
|
||||||
Index: gdb-7.5.91.20130407/gdb/corelow.c
|
Index: gdb-7.6/gdb/corelow.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.5.91.20130407.orig/gdb/corelow.c 2013-04-11 16:53:00.000000000 +0200
|
--- gdb-7.6.orig/gdb/corelow.c 2013-07-17 19:51:02.608357607 +0200
|
||||||
+++ gdb-7.5.91.20130407/gdb/corelow.c 2013-04-11 16:53:03.240280376 +0200
|
+++ gdb-7.6/gdb/corelow.c 2013-07-17 19:51:02.692357665 +0200
|
||||||
@@ -314,7 +314,7 @@ build_id_locate_exec (int from_tty)
|
@@ -314,7 +314,7 @@ build_id_locate_exec (int from_tty)
|
||||||
symfile_objfile->flags |= OBJF_BUILD_ID_CORE_LOADED;
|
symfile_objfile->flags |= OBJF_BUILD_ID_CORE_LOADED;
|
||||||
}
|
}
|
||||||
|
5
gdb.spec
5
gdb.spec
@ -36,7 +36,7 @@ Version: 7.6
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 33%{?dist}
|
Release: 34%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1417,6 +1417,9 @@ fi
|
|||||||
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 17 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.6-34.fc20
|
||||||
|
- Remove --disablerepo='*' from BZ 554152 as it conflicts with BZ 981154.
|
||||||
|
|
||||||
* Wed Jul 17 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.6-33.fc20
|
* Wed Jul 17 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.6-33.fc20
|
||||||
- Fix yum install command output when the binary RPM is missing (BZ 981154).
|
- Fix yum install command output when the binary RPM is missing (BZ 981154).
|
||||||
- Fix the changlog entry formatting for 6.3.0.0-0.1.
|
- Fix the changlog entry formatting for 6.3.0.0-0.1.
|
||||||
|
Loading…
Reference in New Issue
Block a user