[aarch64] Fix build regression (RH BZ 1278902, bugreport by Peter Robinson).
This commit is contained in:
parent
23f398e61a
commit
41e6c203a2
@ -96,10 +96,10 @@ Content-Type: text/x-patch
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Content-Disposition: attachment; filename=bitpos-wp.patch
|
||||
|
||||
Index: gdb-7.10.50.20151022/gdb/arm-linux-nat.c
|
||||
Index: gdb-7.10.50.20151027/gdb/arm-linux-nat.c
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151022.orig/gdb/arm-linux-nat.c 2015-10-24 23:13:24.617686121 +0200
|
||||
+++ gdb-7.10.50.20151022/gdb/arm-linux-nat.c 2015-10-24 23:13:32.051735501 +0200
|
||||
--- gdb-7.10.50.20151027.orig/gdb/arm-linux-nat.c 2015-11-08 10:36:33.050071812 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/arm-linux-nat.c 2015-11-08 10:36:33.094072110 +0100
|
||||
@@ -1209,7 +1209,7 @@ arm_linux_stopped_by_watchpoint (struct
|
||||
static int
|
||||
arm_linux_watchpoint_addr_within_range (struct target_ops *target,
|
||||
@ -109,10 +109,10 @@ Index: gdb-7.10.50.20151022/gdb/arm-linux-nat.c
|
||||
{
|
||||
return start <= addr && start + length - 1 >= addr;
|
||||
}
|
||||
Index: gdb-7.10.50.20151022/gdb/ppc-linux-nat.c
|
||||
Index: gdb-7.10.50.20151027/gdb/ppc-linux-nat.c
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151022.orig/gdb/ppc-linux-nat.c 2015-10-24 23:13:24.617686121 +0200
|
||||
+++ gdb-7.10.50.20151022/gdb/ppc-linux-nat.c 2015-10-24 23:13:32.051735501 +0200
|
||||
--- gdb-7.10.50.20151027.orig/gdb/ppc-linux-nat.c 2015-11-08 10:36:33.064071907 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/ppc-linux-nat.c 2015-11-08 10:36:33.095072117 +0100
|
||||
@@ -1807,11 +1807,11 @@ can_use_watchpoint_cond_accel (void)
|
||||
CONDITION_VALUE will hold the value which should be put in the
|
||||
DVC register. */
|
||||
@ -164,10 +164,10 @@ Index: gdb-7.10.50.20151022/gdb/ppc-linux-nat.c
|
||||
{
|
||||
int mask;
|
||||
|
||||
Index: gdb-7.10.50.20151022/gdb/procfs.c
|
||||
Index: gdb-7.10.50.20151027/gdb/procfs.c
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151022.orig/gdb/procfs.c 2015-10-24 23:13:24.617686121 +0200
|
||||
+++ gdb-7.10.50.20151022/gdb/procfs.c 2015-10-24 23:13:32.052735507 +0200
|
||||
--- gdb-7.10.50.20151027.orig/gdb/procfs.c 2015-11-08 10:36:33.065071913 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/procfs.c 2015-11-08 10:36:33.096072123 +0100
|
||||
@@ -2427,7 +2427,7 @@ procfs_address_to_host_pointer (CORE_ADD
|
||||
#endif
|
||||
|
||||
@ -186,10 +186,10 @@ Index: gdb-7.10.50.20151022/gdb/procfs.c
|
||||
int after)
|
||||
{
|
||||
#ifndef AIX5
|
||||
Index: gdb-7.10.50.20151022/gdb/remote.c
|
||||
Index: gdb-7.10.50.20151027/gdb/remote.c
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151022.orig/gdb/remote.c 2015-10-24 23:13:24.617686121 +0200
|
||||
+++ gdb-7.10.50.20151022/gdb/remote.c 2015-10-24 23:13:32.054735521 +0200
|
||||
--- gdb-7.10.50.20151027.orig/gdb/remote.c 2015-11-08 10:36:33.067071927 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/remote.c 2015-11-08 10:36:33.097072130 +0100
|
||||
@@ -9085,7 +9085,7 @@ remote_insert_watchpoint (struct target_
|
||||
p = strchr (rs->buf, '\0');
|
||||
addr = remote_address_masked (addr);
|
||||
@ -217,10 +217,10 @@ Index: gdb-7.10.50.20151022/gdb/remote.c
|
||||
putpkt (rs->buf);
|
||||
getpkt (&rs->buf, &rs->buf_size, 0);
|
||||
|
||||
Index: gdb-7.10.50.20151022/gdb/target.c
|
||||
Index: gdb-7.10.50.20151027/gdb/target.c
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151022.orig/gdb/target.c 2015-10-24 23:13:24.617686121 +0200
|
||||
+++ gdb-7.10.50.20151022/gdb/target.c 2015-10-24 23:13:32.054735521 +0200
|
||||
--- gdb-7.10.50.20151027.orig/gdb/target.c 2015-11-08 10:36:33.069071941 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/target.c 2015-11-08 10:36:33.098072137 +0100
|
||||
@@ -51,7 +51,7 @@ static void generic_tls_error (void) ATT
|
||||
static void default_terminal_info (struct target_ops *, const char *, int);
|
||||
|
||||
@ -239,10 +239,10 @@ Index: gdb-7.10.50.20151022/gdb/target.c
|
||||
{
|
||||
return addr >= start && addr < start + length;
|
||||
}
|
||||
Index: gdb-7.10.50.20151022/gdb/target.h
|
||||
Index: gdb-7.10.50.20151027/gdb/target.h
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151022.orig/gdb/target.h 2015-10-24 23:13:24.617686121 +0200
|
||||
+++ gdb-7.10.50.20151022/gdb/target.h 2015-10-24 23:13:32.055735527 +0200
|
||||
--- gdb-7.10.50.20151027.orig/gdb/target.h 2015-11-08 10:36:33.069071941 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/target.h 2015-11-08 10:36:33.098072137 +0100
|
||||
@@ -543,7 +543,7 @@ struct target_ops
|
||||
int (*to_stopped_data_address) (struct target_ops *, CORE_ADDR *)
|
||||
TARGET_DEFAULT_RETURN (0);
|
||||
@ -261,10 +261,10 @@ Index: gdb-7.10.50.20151022/gdb/target.h
|
||||
struct expression *)
|
||||
TARGET_DEFAULT_RETURN (0);
|
||||
int (*to_masked_watch_num_registers) (struct target_ops *,
|
||||
Index: gdb-7.10.50.20151022/gdb/aarch64-linux-nat.c
|
||||
Index: gdb-7.10.50.20151027/gdb/aarch64-linux-nat.c
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151022.orig/gdb/aarch64-linux-nat.c 2015-10-24 23:13:24.617686121 +0200
|
||||
+++ gdb-7.10.50.20151022/gdb/aarch64-linux-nat.c 2015-10-24 23:13:32.055735527 +0200
|
||||
--- gdb-7.10.50.20151027.orig/gdb/aarch64-linux-nat.c 2015-11-08 10:36:33.074071975 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/aarch64-linux-nat.c 2015-11-08 10:36:33.098072137 +0100
|
||||
@@ -795,7 +795,7 @@ aarch64_linux_stopped_by_watchpoint (str
|
||||
static int
|
||||
aarch64_linux_watchpoint_addr_within_range (struct target_ops *target,
|
||||
@ -274,10 +274,10 @@ Index: gdb-7.10.50.20151022/gdb/aarch64-linux-nat.c
|
||||
{
|
||||
return start <= addr && start + length - 1 >= addr;
|
||||
}
|
||||
Index: gdb-7.10.50.20151022/gdb/target-delegates.c
|
||||
Index: gdb-7.10.50.20151027/gdb/target-delegates.c
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151022.orig/gdb/target-delegates.c 2015-10-24 23:13:24.617686121 +0200
|
||||
+++ gdb-7.10.50.20151022/gdb/target-delegates.c 2015-10-24 23:13:32.055735527 +0200
|
||||
--- gdb-7.10.50.20151027.orig/gdb/target-delegates.c 2015-11-08 10:36:33.073071968 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/target-delegates.c 2015-11-08 10:36:33.099072144 +0100
|
||||
@@ -709,14 +709,14 @@ debug_stopped_data_address (struct targe
|
||||
}
|
||||
|
||||
@ -337,10 +337,10 @@ Index: gdb-7.10.50.20151022/gdb/target-delegates.c
|
||||
fputs_unfiltered (", ", gdb_stdlog);
|
||||
target_debug_print_int (arg3);
|
||||
fputs_unfiltered (", ", gdb_stdlog);
|
||||
Index: gdb-7.10.50.20151022/gdb/nat/aarch64-linux-hw-point.c
|
||||
Index: gdb-7.10.50.20151027/gdb/nat/aarch64-linux-hw-point.c
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151022.orig/gdb/nat/aarch64-linux-hw-point.c 2015-10-22 03:48:33.000000000 +0200
|
||||
+++ gdb-7.10.50.20151022/gdb/nat/aarch64-linux-hw-point.c 2015-10-24 23:12:29.927322845 +0200
|
||||
--- gdb-7.10.50.20151027.orig/gdb/nat/aarch64-linux-hw-point.c 2015-10-27 02:48:31.000000000 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/nat/aarch64-linux-hw-point.c 2015-11-08 10:36:33.099072144 +0100
|
||||
@@ -111,7 +111,7 @@ aarch64_point_encode_ctrl_reg (enum targ
|
||||
Return 0 for any non-compliant ADDR and/or LEN; return 1 otherwise. */
|
||||
|
||||
@ -411,3 +411,25 @@ Index: gdb-7.10.50.20151022/gdb/nat/aarch64-linux-hw-point.c
|
||||
type == hw_write ? "hw-write-watchpoint"
|
||||
: (type == hw_read ? "hw-read-watchpoint"
|
||||
: (type == hw_access ? "hw-access-watchpoint"
|
||||
Index: gdb-7.10.50.20151027/gdb/nat/aarch64-linux-hw-point.h
|
||||
===================================================================
|
||||
--- gdb-7.10.50.20151027.orig/gdb/nat/aarch64-linux-hw-point.h 2015-10-27 02:48:31.000000000 +0100
|
||||
+++ gdb-7.10.50.20151027/gdb/nat/aarch64-linux-hw-point.h 2015-11-08 10:36:47.656170839 +0100
|
||||
@@ -168,7 +168,7 @@ int aarch64_handle_breakpoint (enum targ
|
||||
int len, int is_insert,
|
||||
struct aarch64_debug_reg_state *state);
|
||||
int aarch64_handle_watchpoint (enum target_hw_bp_type type, CORE_ADDR addr,
|
||||
- int len, int is_insert,
|
||||
+ LONGEST len, int is_insert,
|
||||
struct aarch64_debug_reg_state *state);
|
||||
|
||||
void aarch64_linux_set_debug_regs (const struct aarch64_debug_reg_state *state,
|
||||
@@ -176,7 +176,7 @@ void aarch64_linux_set_debug_regs (const
|
||||
|
||||
void aarch64_show_debug_reg_state (struct aarch64_debug_reg_state *state,
|
||||
const char *func, CORE_ADDR addr,
|
||||
- int len, enum target_hw_bp_type type);
|
||||
+ LONGEST len, enum target_hw_bp_type type);
|
||||
|
||||
void aarch64_linux_get_debug_reg_capacity (int tid);
|
||||
|
||||
|
5
gdb.spec
5
gdb.spec
@ -27,7 +27,7 @@ Version: 7.10.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 30%{?dist}
|
||||
Release: 31%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1363,6 +1363,9 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Sun Nov 8 2015 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20151027-31.fc24
|
||||
- [aarch64] Fix build regression (RH BZ 1278902, bugreport by Peter Robinson).
|
||||
|
||||
* Tue Nov 3 2015 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.50.20151027-30.fc24
|
||||
- Rebase to FSF GDB 7.10.50.20151027 (trunk snapshot).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user