- Rediff gdb-6.8-bz254229-gcore-prpsinfo.patch for older patch(1)
compatibility.
This commit is contained in:
parent
aee5861550
commit
3b3433b0b0
@ -1,7 +1,7 @@
|
|||||||
Index: gdb-7.0.50.20100115/bfd/elf-bfd.h
|
Index: gdb-7.0.50.20100203/bfd/elf-bfd.h
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.0.50.20100115.orig/bfd/elf-bfd.h 2009-11-23 15:41:29.000000000 +0100
|
--- gdb-7.0.50.20100203.orig/bfd/elf-bfd.h 2010-02-02 13:37:39.000000000 +0100
|
||||||
+++ gdb-7.0.50.20100115/bfd/elf-bfd.h 2010-01-15 11:53:21.000000000 +0100
|
+++ gdb-7.0.50.20100203/bfd/elf-bfd.h 2010-02-03 07:28:20.000000000 +0100
|
||||||
@@ -2140,7 +2140,7 @@ extern Elf_Internal_Phdr * _bfd_elf_find
|
@@ -2140,7 +2140,7 @@ extern Elf_Internal_Phdr * _bfd_elf_find
|
||||||
extern char *elfcore_write_note
|
extern char *elfcore_write_note
|
||||||
(bfd *, char *, int *, const char *, int, const void *, int);
|
(bfd *, char *, int *, const char *, int, const void *, int);
|
||||||
@ -11,11 +11,11 @@ Index: gdb-7.0.50.20100115/bfd/elf-bfd.h
|
|||||||
extern char *elfcore_write_prstatus
|
extern char *elfcore_write_prstatus
|
||||||
(bfd *, char *, int *, long, int, const void *);
|
(bfd *, char *, int *, long, int, const void *);
|
||||||
extern char * elfcore_write_pstatus
|
extern char * elfcore_write_pstatus
|
||||||
Index: gdb-7.0.50.20100115/bfd/elf.c
|
Index: gdb-7.0.50.20100203/bfd/elf.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.0.50.20100115.orig/bfd/elf.c 2010-01-05 01:40:07.000000000 +0100
|
--- gdb-7.0.50.20100203.orig/bfd/elf.c 2010-02-02 13:37:39.000000000 +0100
|
||||||
+++ gdb-7.0.50.20100115/bfd/elf.c 2010-01-15 11:53:21.000000000 +0100
|
+++ gdb-7.0.50.20100203/bfd/elf.c 2010-02-03 07:28:20.000000000 +0100
|
||||||
@@ -8439,6 +8439,7 @@ char *
|
@@ -8459,6 +8459,7 @@ char *
|
||||||
elfcore_write_prpsinfo (bfd *abfd,
|
elfcore_write_prpsinfo (bfd *abfd,
|
||||||
char *buf,
|
char *buf,
|
||||||
int *bufsiz,
|
int *bufsiz,
|
||||||
@ -23,7 +23,7 @@ Index: gdb-7.0.50.20100115/bfd/elf.c
|
|||||||
const char *fname,
|
const char *fname,
|
||||||
const char *psargs)
|
const char *psargs)
|
||||||
{
|
{
|
||||||
@@ -8465,9 +8466,15 @@ elfcore_write_prpsinfo (bfd *abfd,
|
@@ -8485,9 +8486,15 @@ elfcore_write_prpsinfo (bfd *abfd,
|
||||||
int note_type = NT_PRPSINFO;
|
int note_type = NT_PRPSINFO;
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -42,7 +42,7 @@ Index: gdb-7.0.50.20100115/bfd/elf.c
|
|||||||
return elfcore_write_note (abfd, buf, bufsiz,
|
return elfcore_write_note (abfd, buf, bufsiz,
|
||||||
note_name, note_type, &data, sizeof (data));
|
note_name, note_type, &data, sizeof (data));
|
||||||
}
|
}
|
||||||
@@ -8482,9 +8489,15 @@ elfcore_write_prpsinfo (bfd *abfd,
|
@@ -8502,9 +8509,15 @@ elfcore_write_prpsinfo (bfd *abfd,
|
||||||
int note_type = NT_PRPSINFO;
|
int note_type = NT_PRPSINFO;
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -61,10 +61,10 @@ Index: gdb-7.0.50.20100115/bfd/elf.c
|
|||||||
return elfcore_write_note (abfd, buf, bufsiz,
|
return elfcore_write_note (abfd, buf, bufsiz,
|
||||||
note_name, note_type, &data, sizeof (data));
|
note_name, note_type, &data, sizeof (data));
|
||||||
}
|
}
|
||||||
Index: gdb-7.0.50.20100115/gdb/amd64-linux-nat.c
|
Index: gdb-7.0.50.20100203/gdb/amd64-linux-nat.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.0.50.20100115.orig/gdb/amd64-linux-nat.c 2010-01-15 11:46:29.000000000 +0100
|
--- gdb-7.0.50.20100203.orig/gdb/amd64-linux-nat.c 2010-02-03 07:28:20.000000000 +0100
|
||||||
+++ gdb-7.0.50.20100115/gdb/amd64-linux-nat.c 2010-01-15 11:53:21.000000000 +0100
|
+++ gdb-7.0.50.20100203/gdb/amd64-linux-nat.c 2010-02-03 07:28:20.000000000 +0100
|
||||||
@@ -140,6 +140,7 @@ static int amd64_linux_gregset32_reg_off
|
@@ -140,6 +140,7 @@ static int amd64_linux_gregset32_reg_off
|
||||||
|
|
||||||
static char *
|
static char *
|
||||||
@ -98,10 +98,10 @@ Index: gdb-7.0.50.20100115/gdb/amd64-linux-nat.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
static void
|
static void
|
||||||
Index: gdb-7.0.50.20100115/gdb/fbsd-nat.c
|
Index: gdb-7.0.50.20100203/gdb/fbsd-nat.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.0.50.20100115.orig/gdb/fbsd-nat.c 2010-01-01 08:31:31.000000000 +0100
|
--- gdb-7.0.50.20100203.orig/gdb/fbsd-nat.c 2010-01-01 08:31:31.000000000 +0100
|
||||||
+++ gdb-7.0.50.20100115/gdb/fbsd-nat.c 2010-01-15 11:53:21.000000000 +0100
|
+++ gdb-7.0.50.20100203/gdb/fbsd-nat.c 2010-02-03 07:28:20.000000000 +0100
|
||||||
@@ -211,6 +211,7 @@ fbsd_make_corefile_notes (bfd *obfd, int
|
@@ -211,6 +211,7 @@ fbsd_make_corefile_notes (bfd *obfd, int
|
||||||
psargs = reconcat (psargs, psargs, " ", get_inferior_args (), NULL);
|
psargs = reconcat (psargs, psargs, " ", get_inferior_args (), NULL);
|
||||||
|
|
||||||
@ -110,10 +110,10 @@ Index: gdb-7.0.50.20100115/gdb/fbsd-nat.c
|
|||||||
fname, psargs);
|
fname, psargs);
|
||||||
}
|
}
|
||||||
|
|
||||||
Index: gdb-7.0.50.20100115/gdb/linux-nat.c
|
Index: gdb-7.0.50.20100203/gdb/linux-nat.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.0.50.20100115.orig/gdb/linux-nat.c 2010-01-15 03:23:50.000000000 +0100
|
--- gdb-7.0.50.20100203.orig/gdb/linux-nat.c 2010-02-03 07:28:20.000000000 +0100
|
||||||
+++ gdb-7.0.50.20100115/gdb/linux-nat.c 2010-01-15 11:53:34.000000000 +0100
|
+++ gdb-7.0.50.20100203/gdb/linux-nat.c 2010-02-03 07:28:20.000000000 +0100
|
||||||
@@ -56,6 +56,7 @@
|
@@ -56,6 +56,7 @@
|
||||||
#include "terminal.h"
|
#include "terminal.h"
|
||||||
#include <sys/vfs.h>
|
#include <sys/vfs.h>
|
||||||
@ -131,7 +131,7 @@ Index: gdb-7.0.50.20100115/gdb/linux-nat.c
|
|||||||
char *(*linux_elfcore_write_prstatus)
|
char *(*linux_elfcore_write_prstatus)
|
||||||
(bfd *, char *, int *, long, int, const void *) = elfcore_write_prstatus;
|
(bfd *, char *, int *, long, int, const void *) = elfcore_write_prstatus;
|
||||||
static char *
|
static char *
|
||||||
@@ -4441,6 +4442,159 @@ linux_spu_make_corefile_notes (bfd *obfd
|
@@ -4422,6 +4423,159 @@ linux_spu_make_corefile_notes (bfd *obfd
|
||||||
return args.note_data;
|
return args.note_data;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -291,7 +291,7 @@ Index: gdb-7.0.50.20100115/gdb/linux-nat.c
|
|||||||
/* Fills the "to_make_corefile_note" target vector. Builds the note
|
/* Fills the "to_make_corefile_note" target vector. Builds the note
|
||||||
section for a corefile, and returns it in a malloc buffer. */
|
section for a corefile, and returns it in a malloc buffer. */
|
||||||
|
|
||||||
@@ -4461,8 +4615,14 @@ linux_nat_make_corefile_notes (bfd *obfd
|
@@ -4442,8 +4596,14 @@ linux_nat_make_corefile_notes (bfd *obfd
|
||||||
|
|
||||||
if (get_exec_file (0))
|
if (get_exec_file (0))
|
||||||
{
|
{
|
||||||
@ -306,7 +306,7 @@ Index: gdb-7.0.50.20100115/gdb/linux-nat.c
|
|||||||
if (get_inferior_args ())
|
if (get_inferior_args ())
|
||||||
{
|
{
|
||||||
char *string_end;
|
char *string_end;
|
||||||
@@ -4478,9 +4638,15 @@ linux_nat_make_corefile_notes (bfd *obfd
|
@@ -4459,9 +4619,15 @@ linux_nat_make_corefile_notes (bfd *obfd
|
||||||
psargs_end - string_end);
|
psargs_end - string_end);
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
@ -324,10 +324,10 @@ Index: gdb-7.0.50.20100115/gdb/linux-nat.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
/* Dump information for threads. */
|
/* Dump information for threads. */
|
||||||
Index: gdb-7.0.50.20100115/gdb/linux-nat.h
|
Index: gdb-7.0.50.20100203/gdb/linux-nat.h
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.0.50.20100115.orig/gdb/linux-nat.h 2010-01-15 03:22:31.000000000 +0100
|
--- gdb-7.0.50.20100203.orig/gdb/linux-nat.h 2010-02-03 07:28:19.000000000 +0100
|
||||||
+++ gdb-7.0.50.20100115/gdb/linux-nat.h 2010-01-15 11:53:21.000000000 +0100
|
+++ gdb-7.0.50.20100203/gdb/linux-nat.h 2010-02-03 07:28:20.000000000 +0100
|
||||||
@@ -173,7 +173,7 @@ int linux_nat_core_of_thread_1 (ptid_t p
|
@@ -173,7 +173,7 @@ int linux_nat_core_of_thread_1 (ptid_t p
|
||||||
/* These functions make elfcore note sections.
|
/* These functions make elfcore note sections.
|
||||||
They may get overriden by code adjusting data for multi-target builds. */
|
They may get overriden by code adjusting data for multi-target builds. */
|
||||||
@ -337,10 +337,10 @@ Index: gdb-7.0.50.20100115/gdb/linux-nat.h
|
|||||||
extern char *(*linux_elfcore_write_prstatus)
|
extern char *(*linux_elfcore_write_prstatus)
|
||||||
(bfd *, char *, int *, long, int, const void *);
|
(bfd *, char *, int *, long, int, const void *);
|
||||||
extern char *(*linux_elfcore_write_prfpreg)
|
extern char *(*linux_elfcore_write_prfpreg)
|
||||||
Index: gdb-7.0.50.20100115/gdb/procfs.c
|
Index: gdb-7.0.50.20100203/gdb/procfs.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.0.50.20100115.orig/gdb/procfs.c 2010-01-14 22:15:00.000000000 +0100
|
--- gdb-7.0.50.20100203.orig/gdb/procfs.c 2010-01-28 09:19:29.000000000 +0100
|
||||||
+++ gdb-7.0.50.20100115/gdb/procfs.c 2010-01-15 11:53:21.000000000 +0100
|
+++ gdb-7.0.50.20100203/gdb/procfs.c 2010-02-03 07:28:20.000000000 +0100
|
||||||
@@ -6186,6 +6186,7 @@ procfs_make_note_section (bfd *obfd, int
|
@@ -6186,6 +6186,7 @@ procfs_make_note_section (bfd *obfd, int
|
||||||
note_data = (char *) elfcore_write_prpsinfo (obfd,
|
note_data = (char *) elfcore_write_prpsinfo (obfd,
|
||||||
note_data,
|
note_data,
|
||||||
|
5
gdb.spec
5
gdb.spec
@ -36,7 +36,7 @@ Version: 7.0.50.20100203
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 13%{?_with_upstream:.upstream}%{dist}
|
Release: 14%{?_with_upstream:.upstream}%{dist}
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1005,6 +1005,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 3 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100203-14.fc13
|
||||||
|
- Rediff gdb-6.8-bz254229-gcore-prpsinfo.patch for older patch(1) compatibility.
|
||||||
|
|
||||||
* Wed Feb 3 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100203-13.fc13
|
* Wed Feb 3 2010 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.0.50.20100203-13.fc13
|
||||||
- archer-jankratochvil-fedora13 commit: 59c35a31f0981a0f0b884b32c91ae6325b2126cd
|
- archer-jankratochvil-fedora13 commit: 59c35a31f0981a0f0b884b32c91ae6325b2126cd
|
||||||
- Fortran: Fix regression on setting breakpoint at toplevel symbols (BZ 559291;
|
- Fortran: Fix regression on setting breakpoint at toplevel symbols (BZ 559291;
|
||||||
|
Loading…
Reference in New Issue
Block a user