[rhel dts libipt] Fix#2 [-Werror=implicit-fallthrough=] with gcc-7.1.1.
This commit is contained in:
parent
80d902f397
commit
39868f2076
5
gdb.spec
5
gdb.spec
@ -26,7 +26,7 @@ Version: 8.0
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 14%{?dist}
|
||||
Release: 15%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -1615,6 +1615,9 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Fri Jun 9 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.0-15.fc26
|
||||
- [rhel dts libipt] Fix#2 [-Werror=implicit-fallthrough=] with gcc-7.1.1.
|
||||
|
||||
* Fri Jun 9 2017 Jan Kratochvil <jan.kratochvil@redhat.com> - 8.0-14.fc26
|
||||
- [rhel dts libipt] Fix [-Werror=implicit-fallthrough=] with gcc-7.1.1.
|
||||
|
||||
|
@ -7,13 +7,17 @@ gcc-7.1.1-1.fc27.x86_64
|
||||
case ptbq_decode: {
|
||||
^~~~
|
||||
|
||||
--- processor-trace-1.6.1-orig/libipt/src/pt_block_decoder.c 2017-05-31 13:30:32.000000000 +0200
|
||||
+++ processor-trace-1.6.1/libipt/src/pt_block_decoder.c 2017-06-09 07:24:12.644587611 +0200
|
||||
@@ -2324,6 +2324,7 @@ static int pt_blk_proceed_no_event_cache
|
||||
diff --git a/libipt/src/pt_block_decoder.c b/libipt/src/pt_block_decoder.c
|
||||
index 21783a6..91d5bb3 100644
|
||||
--- a/libipt/src/pt_block_decoder.c
|
||||
+++ b/libipt/src/pt_block_decoder.c
|
||||
@@ -2095,6 +2095,9 @@ static int pt_blk_proceed_no_event_cached(struct pt_block_decoder *decoder,
|
||||
}
|
||||
|
||||
/* Fall through to ptbq_decode. */
|
||||
+#if __GNUC__ >= 7
|
||||
+ __attribute__ ((fallthrough));
|
||||
+#endif
|
||||
|
||||
case ptbq_decode: {
|
||||
struct pt_insn_ext iext;
|
||||
|
Loading…
Reference in New Issue
Block a user