- Fix the testsuite results broken in 6.5-26, stop invalid testsuite runs.
This commit is contained in:
parent
4dddad4251
commit
376c4280d4
@ -51,7 +51,7 @@ diff -u -rupN gdb-6.5-ppc/gdb/testsuite/gdb.base/bt-ppc.c gdb-6.5/gdb/testsuite/
|
||||
diff -u -rupN gdb-6.5-ppc/gdb/testsuite/gdb.base/bt-ppc.exp gdb-6.5/gdb/testsuite/gdb.base/bt-ppc.exp
|
||||
--- gdb-6.5-ppc/gdb/testsuite/gdb.base/bt-ppc.exp 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ gdb-6.5/gdb/testsuite/gdb.base/bt-ppc.exp 2007-01-12 21:27:25.000000000 -0500
|
||||
@@ -0,0 +1,86 @@
|
||||
@@ -0,0 +1,87 @@
|
||||
+# Copyright 2006, 2007 Free Software Foundation, Inc.
|
||||
+
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
|
@ -18,3 +18,26 @@ diff -u -rupN gdb-6.5-ppc/gdb/testsuite/lib/gdb.exp gdb-6.5/gdb/testsuite/lib/gd
|
||||
|
||||
# Eval the output.
|
||||
set unknown 0
|
||||
|
||||
|
||||
2007-01-14 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* lib/gdb.exp: Abort on missing `site.exp'.
|
||||
|
||||
|
||||
diff -u -rup gdb-6.5-orig/gdb/testsuite/lib/gdb.exp gdb-6.5/gdb/testsuite/lib/gdb.exp
|
||||
--- gdb-6.5-orig/gdb/testsuite/lib/gdb.exp 2006-12-17 11:59:42.000000000 +0100
|
||||
+++ gdb-6.5/gdb/testsuite/lib/gdb.exp 2007-01-14 16:27:03.000000000 +0100
|
||||
@@ -22,6 +22,12 @@
|
||||
# need to be modified for any target, it can be done with a variable
|
||||
# or by passing arguments.
|
||||
|
||||
+if {$tool == ""} {
|
||||
+ # Tests would fail, logs on get_compiler_info() would be missing.
|
||||
+ send_error "`site.exp' not found, run `make site.exp'!\n"
|
||||
+ exit 2
|
||||
+}
|
||||
+
|
||||
load_lib libgloss.exp
|
||||
|
||||
global GDB
|
||||
|
5
gdb.spec
5
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
||||
Version: 6.5
|
||||
|
||||
# The release always contains a leading reserved number, start it at 0.
|
||||
Release: 26%{?dist}
|
||||
Release: 27%{?dist}
|
||||
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
@ -625,6 +625,9 @@ fi
|
||||
# don't include the files in include, they are part of binutils
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.5-27
|
||||
- Fix the testsuite results broken in 6.5-26, stop invalid testsuite runs.
|
||||
|
||||
* Fri Jan 13 2007 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.5-26
|
||||
- Fix unwinding of non-debug (.eh_frame) PPC code, Andreas Schwab (BZ 140532).
|
||||
- Fix unwinding of debug (.debug_frame) PPC code, workaround GCC (BZ 140532).
|
||||
|
Loading…
Reference in New Issue
Block a user