- Rebase to FSF GDB 7.2.50.20110107 (which is a 7.3 pre-release).
- Import archer-tromey-python (BZ 666177, branch update by Phil Muldoon).
This commit is contained in:
parent
278e869a86
commit
33ff7091ac
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/gdb-7.2.50.20110104.tar.bz2
|
||||
/gdb-7.2.50.20110107.tar.bz2
|
||||
|
@ -1,8 +1,8 @@
|
||||
Index: gdb-6.8.50.20090802/gdb/gcore.c
|
||||
Index: gdb-7.2.50.20110107/gdb/gcore.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090802.orig/gdb/gcore.c 2009-08-03 12:27:55.000000000 +0200
|
||||
+++ gdb-6.8.50.20090802/gdb/gcore.c 2009-08-03 12:28:56.000000000 +0200
|
||||
@@ -479,8 +479,14 @@ gcore_copy_callback (bfd *obfd, asection
|
||||
--- gdb-7.2.50.20110107.orig/gdb/gcore.c 2011-01-05 23:22:49.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/gcore.c 2011-01-07 09:04:28.000000000 +0100
|
||||
@@ -534,8 +534,14 @@ gcore_copy_callback (bfd *obfd, asection
|
||||
if (size > total_size)
|
||||
size = total_size;
|
||||
|
||||
@ -16,5 +16,5 @@ Index: gdb-6.8.50.20090802/gdb/gcore.c
|
||||
+ "ia64")
|
||||
+ || bfd_section_vma (obfd, osec) != 0))
|
||||
{
|
||||
warning (_("Memory read failed for corefile section, %s bytes at %s."),
|
||||
plongest (size),
|
||||
warning (_("Memory read failed for corefile "
|
||||
"section, %s bytes at %s."),
|
||||
|
@ -11,10 +11,10 @@
|
||||
|
||||
* gdb.texinfo (File Options): Document --readnever.
|
||||
|
||||
Index: gdb-7.2.50.20101231/gdb/doc/gdb.texinfo
|
||||
Index: gdb-7.2.50.20110107/gdb/doc/gdb.texinfo
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20101231.orig/gdb/doc/gdb.texinfo 2010-12-29 09:01:31.000000000 +0100
|
||||
+++ gdb-7.2.50.20101231/gdb/doc/gdb.texinfo 2011-01-01 00:54:07.000000000 +0100
|
||||
--- gdb-7.2.50.20110107.orig/gdb/doc/gdb.texinfo 2011-01-07 09:03:38.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/doc/gdb.texinfo 2011-01-07 09:04:48.000000000 +0100
|
||||
@@ -1007,6 +1007,12 @@ Read each symbol file's entire symbol ta
|
||||
the default, which is to read it incrementally as it is needed.
|
||||
This makes startup slower, but makes future operations faster.
|
||||
@ -28,11 +28,11 @@ Index: gdb-7.2.50.20101231/gdb/doc/gdb.texinfo
|
||||
@end table
|
||||
|
||||
@node Mode Options
|
||||
Index: gdb-7.2.50.20101231/gdb/main.c
|
||||
Index: gdb-7.2.50.20110107/gdb/main.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20101231.orig/gdb/main.c 2011-01-01 00:53:09.000000000 +0100
|
||||
+++ gdb-7.2.50.20101231/gdb/main.c 2011-01-01 00:54:07.000000000 +0100
|
||||
@@ -391,6 +391,7 @@ captured_main (void *data)
|
||||
--- gdb-7.2.50.20110107.orig/gdb/main.c 2011-01-07 09:04:39.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/main.c 2011-01-07 09:05:02.000000000 +0100
|
||||
@@ -395,6 +395,7 @@ captured_main (void *data)
|
||||
{"xdb", no_argument, &xdb_commands, 1},
|
||||
{"dbx", no_argument, &dbx_commands, 1},
|
||||
{"readnow", no_argument, &readnow_symbol_files, 1},
|
||||
@ -40,19 +40,19 @@ Index: gdb-7.2.50.20101231/gdb/main.c
|
||||
{"r", no_argument, &readnow_symbol_files, 1},
|
||||
{"quiet", no_argument, &quiet, 1},
|
||||
{"q", no_argument, &quiet, 1},
|
||||
@@ -993,6 +994,7 @@ Options:\n\n\
|
||||
fputs_unfiltered (_(" file.\n\
|
||||
@@ -1060,6 +1061,7 @@ Options:\n\n\
|
||||
fputs_unfiltered (_("\
|
||||
--quiet Do not print version number on startup.\n\
|
||||
--readnow Fully read symbol files on first access.\n\
|
||||
+ --readnever Do not read symbol files.\n\
|
||||
"), stream);
|
||||
fputs_unfiltered (_("\
|
||||
--se=FILE Use FILE as symbol file and executable file.\n\
|
||||
Index: gdb-7.2.50.20101231/gdb/symfile.c
|
||||
Index: gdb-7.2.50.20110107/gdb/symfile.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20101231.orig/gdb/symfile.c 2010-11-23 01:59:58.000000000 +0100
|
||||
+++ gdb-7.2.50.20101231/gdb/symfile.c 2011-01-01 00:54:07.000000000 +0100
|
||||
@@ -80,6 +80,7 @@ static void clear_symtab_users_cleanup (
|
||||
--- gdb-7.2.50.20110107.orig/gdb/symfile.c 2011-01-05 23:22:50.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/symfile.c 2011-01-07 09:04:48.000000000 +0100
|
||||
@@ -81,6 +81,7 @@ static void clear_symtab_users_cleanup (
|
||||
|
||||
/* Global variables owned by this file */
|
||||
int readnow_symbol_files; /* Read full symbols immediately */
|
||||
@ -60,10 +60,10 @@ Index: gdb-7.2.50.20101231/gdb/symfile.c
|
||||
|
||||
/* External variables and functions referenced. */
|
||||
|
||||
Index: gdb-7.2.50.20101231/gdb/dwarf2read.c
|
||||
Index: gdb-7.2.50.20110107/gdb/dwarf2read.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20101231.orig/gdb/dwarf2read.c 2011-01-01 00:41:51.000000000 +0100
|
||||
+++ gdb-7.2.50.20101231/gdb/dwarf2read.c 2011-01-01 00:54:07.000000000 +0100
|
||||
--- gdb-7.2.50.20110107.orig/gdb/dwarf2read.c 2011-01-07 09:03:38.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/dwarf2read.c 2011-01-07 09:04:48.000000000 +0100
|
||||
@@ -57,6 +57,7 @@
|
||||
#include "vec.h"
|
||||
#include "c-lang.h"
|
||||
@ -72,7 +72,7 @@ Index: gdb-7.2.50.20101231/gdb/dwarf2read.c
|
||||
|
||||
#include <fcntl.h>
|
||||
#include "gdb_string.h"
|
||||
@@ -1345,8 +1346,9 @@ dwarf2_has_info (struct objfile *objfile
|
||||
@@ -1350,8 +1351,9 @@ dwarf2_has_info (struct objfile *objfile
|
||||
bfd_map_over_sections (objfile->obfd, dwarf2_locate_sections, NULL);
|
||||
dwarf2_per_objfile->objfile = objfile;
|
||||
}
|
||||
@ -84,10 +84,10 @@ Index: gdb-7.2.50.20101231/gdb/dwarf2read.c
|
||||
}
|
||||
|
||||
/* When loading sections, we can either look for ".<name>", or for
|
||||
Index: gdb-7.2.50.20101231/gdb/top.h
|
||||
Index: gdb-7.2.50.20110107/gdb/top.h
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20101231.orig/gdb/top.h 2010-12-29 01:58:14.000000000 +0100
|
||||
+++ gdb-7.2.50.20101231/gdb/top.h 2011-01-01 00:54:21.000000000 +0100
|
||||
--- gdb-7.2.50.20110107.orig/gdb/top.h 2011-01-01 16:33:18.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/top.h 2011-01-07 09:04:48.000000000 +0100
|
||||
@@ -61,6 +61,7 @@ extern void set_prompt (char *);
|
||||
|
||||
/* From random places. */
|
||||
|
@ -1,13 +1,13 @@
|
||||
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=218379
|
||||
|
||||
|
||||
Index: gdb-6.8.50.20090803/gdb/symtab.c
|
||||
Index: gdb-7.2.50.20110107/gdb/symtab.c
|
||||
===================================================================
|
||||
--- gdb-6.8.50.20090803.orig/gdb/symtab.c 2009-08-03 16:09:36.000000000 +0200
|
||||
+++ gdb-6.8.50.20090803/gdb/symtab.c 2009-08-03 16:13:13.000000000 +0200
|
||||
@@ -2261,6 +2261,13 @@ find_pc_sect_line (CORE_ADDR pc, struct
|
||||
/* See above comment about why warning is commented out */
|
||||
/* warning ("In stub for %s; unable to find real function/line info", SYMBOL_LINKAGE_NAME (msymbol)) */ ;
|
||||
--- gdb-7.2.50.20110107.orig/gdb/symtab.c 2011-01-07 09:03:38.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/symtab.c 2011-01-07 09:06:32.000000000 +0100
|
||||
@@ -2014,6 +2014,13 @@ find_pc_sect_line (CORE_ADDR pc, struct
|
||||
/* warning ("In stub for %s; unable to find real function/line info",
|
||||
SYMBOL_LINKAGE_NAME (msymbol)) */ ;
|
||||
/* fall through */
|
||||
+ /* `msymbol' trampoline may be located before its .text symbol
|
||||
+ but this text symbol may be the address we were looking for.
|
||||
|
@ -58,10 +58,10 @@ Http://sourceware.org/ml/gdb-patches/2010-01/msg00517.html
|
||||
* exec.c (exec_file_attach): Print a more useful error message if the
|
||||
user did "gdb core".
|
||||
|
||||
Index: gdb-7.2.50.20101231/gdb/exceptions.h
|
||||
Index: gdb-7.2.50.20110107/gdb/exceptions.h
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20101231.orig/gdb/exceptions.h 2010-05-03 01:52:14.000000000 +0200
|
||||
+++ gdb-7.2.50.20101231/gdb/exceptions.h 2011-01-01 01:10:44.000000000 +0100
|
||||
--- gdb-7.2.50.20110107.orig/gdb/exceptions.h 2011-01-05 23:22:48.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/exceptions.h 2011-01-07 09:09:18.000000000 +0100
|
||||
@@ -78,6 +78,9 @@ enum errors {
|
||||
/* Feature is not supported in this copy of GDB. */
|
||||
UNSUPPORTED_ERROR,
|
||||
@ -72,10 +72,10 @@ Index: gdb-7.2.50.20101231/gdb/exceptions.h
|
||||
/* Add more errors here. */
|
||||
NR_ERRORS
|
||||
};
|
||||
Index: gdb-7.2.50.20101231/gdb/exec.c
|
||||
Index: gdb-7.2.50.20110107/gdb/exec.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20101231.orig/gdb/exec.c 2010-08-31 20:08:43.000000000 +0200
|
||||
+++ gdb-7.2.50.20101231/gdb/exec.c 2011-01-01 01:10:44.000000000 +0100
|
||||
--- gdb-7.2.50.20110107.orig/gdb/exec.c 2011-01-05 23:22:48.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/exec.c 2011-01-07 09:09:18.000000000 +0100
|
||||
@@ -34,6 +34,7 @@
|
||||
#include "arch-utils.h"
|
||||
#include "gdbthread.h"
|
||||
@ -115,11 +115,11 @@ Index: gdb-7.2.50.20101231/gdb/exec.c
|
||||
}
|
||||
|
||||
/* FIXME - This should only be run for RS6000, but the ifdef is a poor
|
||||
Index: gdb-7.2.50.20101231/gdb/main.c
|
||||
Index: gdb-7.2.50.20110107/gdb/main.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20101231.orig/gdb/main.c 2011-01-01 01:00:54.000000000 +0100
|
||||
+++ gdb-7.2.50.20101231/gdb/main.c 2011-01-01 01:11:48.000000000 +0100
|
||||
@@ -242,6 +242,36 @@ captured_command_loop (void *data)
|
||||
--- gdb-7.2.50.20110107.orig/gdb/main.c 2011-01-07 09:05:02.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/main.c 2011-01-07 09:10:14.000000000 +0100
|
||||
@@ -243,6 +243,36 @@ captured_command_loop (void *data)
|
||||
return 1;
|
||||
}
|
||||
|
||||
@ -156,7 +156,7 @@ Index: gdb-7.2.50.20101231/gdb/main.c
|
||||
static int
|
||||
captured_main (void *data)
|
||||
{
|
||||
@@ -688,6 +718,8 @@ captured_main (void *data)
|
||||
@@ -726,6 +756,8 @@ captured_main (void *data)
|
||||
{
|
||||
symarg = argv[optind];
|
||||
execarg = argv[optind];
|
||||
@ -165,7 +165,7 @@ Index: gdb-7.2.50.20101231/gdb/main.c
|
||||
optind++;
|
||||
}
|
||||
|
||||
@@ -828,10 +860,25 @@ Excess command line arguments ignored. (
|
||||
@@ -867,11 +899,25 @@ captured_main (void *data)
|
||||
&& symarg != NULL
|
||||
&& strcmp (execarg, symarg) == 0)
|
||||
{
|
||||
@ -184,12 +184,13 @@ Index: gdb-7.2.50.20101231/gdb/main.c
|
||||
/* The exec file and the symbol-file are the same. If we can't
|
||||
open it, better only print one error message.
|
||||
- catch_command_errors returns non-zero on success! */
|
||||
- if (catch_command_errors (exec_file_attach, execarg, !batch_flag, RETURN_MASK_ALL))
|
||||
- if (catch_command_errors (exec_file_attach, execarg,
|
||||
- !batch_flag, RETURN_MASK_ALL))
|
||||
+ catch_command_errors returns non-zero on success!
|
||||
+ Do not load EXECARG as a symbol file if it has been already processed
|
||||
+ as a core file. */
|
||||
+ if (catch_command_errors (func, execarg, !batch_flag, RETURN_MASK_ALL)
|
||||
+ && core_bfd == NULL)
|
||||
catch_command_errors (symbol_file_add_main, symarg, !batch_flag, RETURN_MASK_ALL);
|
||||
catch_command_errors (symbol_file_add_main, symarg,
|
||||
!batch_flag, RETURN_MASK_ALL);
|
||||
}
|
||||
else
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: gdb-7.2.50.20110104/gdb/corelow.c
|
||||
Index: gdb-7.2.50.20110107/gdb/corelow.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/corelow.c 2011-01-01 16:32:59.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/corelow.c 2011-01-04 06:15:49.000000000 +0100
|
||||
--- gdb-7.2.50.20110107.orig/gdb/corelow.c 2011-01-05 23:22:47.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/corelow.c 2011-01-07 09:07:01.000000000 +0100
|
||||
@@ -47,6 +47,9 @@
|
||||
#include "filenames.h"
|
||||
#include "progspace.h"
|
||||
@ -12,7 +12,7 @@ Index: gdb-7.2.50.20110104/gdb/corelow.c
|
||||
|
||||
|
||||
#ifndef O_LARGEFILE
|
||||
@@ -277,6 +280,52 @@ add_to_thread_list (bfd *abfd, asection
|
||||
@@ -278,6 +281,52 @@ add_to_thread_list (bfd *abfd, asection
|
||||
inferior_ptid = ptid; /* Yes, make it current. */
|
||||
}
|
||||
|
||||
@ -65,7 +65,7 @@ Index: gdb-7.2.50.20110104/gdb/corelow.c
|
||||
/* This routine opens and sets up the core file bfd. */
|
||||
|
||||
static void
|
||||
@@ -377,6 +426,12 @@ core_open (char *filename, int from_tty)
|
||||
@@ -379,6 +428,12 @@ core_open (char *filename, int from_tty)
|
||||
push_target (&core_ops);
|
||||
discard_cleanups (old_chain);
|
||||
|
||||
@ -78,7 +78,7 @@ Index: gdb-7.2.50.20110104/gdb/corelow.c
|
||||
/* Do this before acknowledging the inferior, so if
|
||||
post_create_inferior throws (can happen easilly if you're loading
|
||||
a core file with the wrong exec), we aren't left with threads
|
||||
@@ -930,4 +985,11 @@ _initialize_corelow (void)
|
||||
@@ -932,4 +987,11 @@ _initialize_corelow (void)
|
||||
init_core_ops ();
|
||||
|
||||
add_target (&core_ops);
|
||||
@ -90,11 +90,11 @@ Index: gdb-7.2.50.20110104/gdb/corelow.c
|
||||
+ NULL, NULL, NULL,
|
||||
+ &setlist, &showlist);
|
||||
}
|
||||
Index: gdb-7.2.50.20110104/gdb/doc/gdb.texinfo
|
||||
Index: gdb-7.2.50.20110107/gdb/doc/gdb.texinfo
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/doc/gdb.texinfo 2011-01-04 06:15:02.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/doc/gdb.texinfo 2011-01-04 06:15:14.000000000 +0100
|
||||
@@ -15267,6 +15267,27 @@ information files.
|
||||
--- gdb-7.2.50.20110107.orig/gdb/doc/gdb.texinfo 2011-01-07 09:04:48.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/doc/gdb.texinfo 2011-01-07 09:07:01.000000000 +0100
|
||||
@@ -15277,6 +15277,27 @@ information files.
|
||||
|
||||
@end table
|
||||
|
||||
@ -122,10 +122,10 @@ Index: gdb-7.2.50.20110104/gdb/doc/gdb.texinfo
|
||||
@cindex @code{.gnu_debuglink} sections
|
||||
@cindex debug link sections
|
||||
A debug link is a special section of the executable file named
|
||||
Index: gdb-7.2.50.20110104/gdb/solib-svr4.c
|
||||
Index: gdb-7.2.50.20110107/gdb/solib-svr4.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/solib-svr4.c 2011-01-04 06:15:01.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/solib-svr4.c 2011-01-04 06:15:14.000000000 +0100
|
||||
--- gdb-7.2.50.20110107.orig/gdb/solib-svr4.c 2011-01-07 09:03:38.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/solib-svr4.c 2011-01-07 09:07:01.000000000 +0100
|
||||
@@ -1179,9 +1179,49 @@ svr4_current_sos (void)
|
||||
safe_strerror (errcode));
|
||||
else
|
||||
@ -179,10 +179,10 @@ Index: gdb-7.2.50.20110104/gdb/solib-svr4.c
|
||||
}
|
||||
xfree (buffer);
|
||||
|
||||
Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
Index: gdb-7.2.50.20110107/gdb/elfread.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/elfread.c 2011-01-04 06:15:01.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/elfread.c 2011-01-04 06:15:14.000000000 +0100
|
||||
--- gdb-7.2.50.20110107.orig/gdb/elfread.c 2011-01-07 09:03:38.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/elfread.c 2011-01-07 09:07:33.000000000 +0100
|
||||
@@ -38,6 +38,10 @@
|
||||
#include "demangle.h"
|
||||
#include "psympriv.h"
|
||||
@ -194,7 +194,7 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
|
||||
extern void _initialize_elfread (void);
|
||||
|
||||
@@ -821,16 +825,65 @@ resolve_gnu_ifunc (const char *function_
|
||||
@@ -823,16 +827,65 @@ resolve_gnu_ifunc (const char *function_
|
||||
return 0;
|
||||
}
|
||||
|
||||
@ -262,7 +262,7 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
{
|
||||
struct build_id *retval;
|
||||
|
||||
@@ -846,6 +899,348 @@ build_id_bfd_get (bfd *abfd)
|
||||
@@ -848,6 +901,348 @@ build_id_bfd_get (bfd *abfd)
|
||||
return retval;
|
||||
}
|
||||
|
||||
@ -611,7 +611,7 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
/* Return if FILENAME has NT_GNU_BUILD_ID matching the CHECK value. */
|
||||
|
||||
static int
|
||||
@@ -860,7 +1255,7 @@ build_id_verify (const char *filename, s
|
||||
@@ -862,7 +1257,7 @@ build_id_verify (const char *filename, s
|
||||
if (abfd == NULL)
|
||||
return 0;
|
||||
|
||||
@ -620,7 +620,7 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
|
||||
if (found == NULL)
|
||||
warning (_("File \"%s\" has no build-id, file skipped"), filename);
|
||||
@@ -877,14 +1272,16 @@ build_id_verify (const char *filename, s
|
||||
@@ -880,14 +1275,16 @@ build_id_verify (const char *filename, s
|
||||
return retval;
|
||||
}
|
||||
|
||||
@ -641,7 +641,7 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
|
||||
/* Keep backward compatibility so that DEBUG_FILE_DIRECTORY being "" will
|
||||
cause "/.build-id/..." lookups. */
|
||||
@@ -915,7 +1312,10 @@ build_id_to_debug_filename (struct build
|
||||
@@ -918,7 +1315,10 @@ build_id_to_debug_filename (struct build
|
||||
*s++ = '/';
|
||||
while (size-- > 0)
|
||||
s += sprintf (s, "%02x", (unsigned) *data++);
|
||||
@ -653,7 +653,7 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
|
||||
/* lrealpath() is expensive even for the usually non-existent files. */
|
||||
if (access (link, F_OK) == 0)
|
||||
@@ -928,26 +1328,201 @@ build_id_to_debug_filename (struct build
|
||||
@@ -931,26 +1331,201 @@ build_id_to_debug_filename (struct build
|
||||
}
|
||||
|
||||
if (retval != NULL)
|
||||
@ -859,7 +859,7 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
xfree (build_id);
|
||||
/* Prevent looping on a stripped .debug file. */
|
||||
if (build_id_name != NULL && strcmp (build_id_name, objfile->name) == 0)
|
||||
@@ -957,7 +1532,7 @@ find_separate_debug_file_by_buildid (str
|
||||
@@ -960,7 +1535,7 @@ find_separate_debug_file_by_buildid (str
|
||||
xfree (build_id_name);
|
||||
}
|
||||
else if (build_id_name != NULL)
|
||||
@ -868,8 +868,8 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
}
|
||||
return NULL;
|
||||
}
|
||||
@@ -1138,9 +1713,10 @@ elf_symfile_read (struct objfile *objfil
|
||||
`.gnu_debuglink' may no longer be present with `.note.gnu.build-id'. */
|
||||
@@ -1148,9 +1723,10 @@ elf_symfile_read (struct objfile *objfil
|
||||
`.note.gnu.build-id'. */
|
||||
if (!objfile_has_partial_symbols (objfile))
|
||||
{
|
||||
- char *debugfile;
|
||||
@ -881,7 +881,7 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
|
||||
if (debugfile == NULL)
|
||||
debugfile = find_separate_debug_file_by_debuglink (objfile);
|
||||
@@ -1152,6 +1728,12 @@ elf_symfile_read (struct objfile *objfil
|
||||
@@ -1162,6 +1738,12 @@ elf_symfile_read (struct objfile *objfil
|
||||
symbol_file_add_separate (abfd, symfile_flags, objfile);
|
||||
xfree (debugfile);
|
||||
}
|
||||
@ -894,7 +894,7 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
}
|
||||
}
|
||||
|
||||
@@ -1327,4 +1909,16 @@ void
|
||||
@@ -1337,4 +1919,16 @@ void
|
||||
_initialize_elfread (void)
|
||||
{
|
||||
add_symtab_fns (&elf_sym_fns);
|
||||
@ -911,11 +911,11 @@ Index: gdb-7.2.50.20110104/gdb/elfread.c
|
||||
+
|
||||
+ observer_attach_executable_changed (debug_print_executable_changed);
|
||||
}
|
||||
Index: gdb-7.2.50.20110104/gdb/symfile.h
|
||||
Index: gdb-7.2.50.20110107/gdb/symfile.h
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/symfile.h 2011-01-01 16:33:16.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/symfile.h 2011-01-04 06:15:14.000000000 +0100
|
||||
@@ -553,6 +553,13 @@ void free_symfile_segment_data (struct s
|
||||
--- gdb-7.2.50.20110107.orig/gdb/symfile.h 2011-01-05 23:22:53.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/symfile.h 2011-01-07 09:07:01.000000000 +0100
|
||||
@@ -554,6 +554,13 @@ void free_symfile_segment_data (struct s
|
||||
|
||||
extern struct cleanup *increment_reading_symtab (void);
|
||||
|
||||
@ -929,11 +929,11 @@ Index: gdb-7.2.50.20110104/gdb/symfile.h
|
||||
/* From dwarf2read.c */
|
||||
|
||||
extern int dwarf2_has_info (struct objfile *);
|
||||
Index: gdb-7.2.50.20110104/gdb/testsuite/lib/gdb.exp
|
||||
Index: gdb-7.2.50.20110107/gdb/testsuite/lib/gdb.exp
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/testsuite/lib/gdb.exp 2011-01-04 06:15:01.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/testsuite/lib/gdb.exp 2011-01-04 06:15:14.000000000 +0100
|
||||
@@ -1390,6 +1390,16 @@ proc default_gdb_start { } {
|
||||
--- gdb-7.2.50.20110107.orig/gdb/testsuite/lib/gdb.exp 2011-01-07 09:03:38.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/testsuite/lib/gdb.exp 2011-01-07 09:07:01.000000000 +0100
|
||||
@@ -1391,6 +1391,16 @@ proc default_gdb_start { } {
|
||||
warning "Couldn't set the width to 0."
|
||||
}
|
||||
}
|
||||
@ -950,10 +950,10 @@ Index: gdb-7.2.50.20110104/gdb/testsuite/lib/gdb.exp
|
||||
return 0;
|
||||
}
|
||||
|
||||
Index: gdb-7.2.50.20110104/gdb/testsuite/lib/mi-support.exp
|
||||
Index: gdb-7.2.50.20110107/gdb/testsuite/lib/mi-support.exp
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/testsuite/lib/mi-support.exp 2011-01-01 16:33:52.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/testsuite/lib/mi-support.exp 2011-01-04 06:15:14.000000000 +0100
|
||||
--- gdb-7.2.50.20110107.orig/gdb/testsuite/lib/mi-support.exp 2011-01-01 16:33:52.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/testsuite/lib/mi-support.exp 2011-01-07 09:07:01.000000000 +0100
|
||||
@@ -221,6 +221,16 @@ proc default_mi_gdb_start { args } {
|
||||
}
|
||||
}
|
||||
@ -971,11 +971,11 @@ Index: gdb-7.2.50.20110104/gdb/testsuite/lib/mi-support.exp
|
||||
|
||||
detect_async
|
||||
|
||||
Index: gdb-7.2.50.20110104/gdb/objfiles.h
|
||||
Index: gdb-7.2.50.20110107/gdb/objfiles.h
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110104.orig/gdb/objfiles.h 2011-01-01 16:33:12.000000000 +0100
|
||||
+++ gdb-7.2.50.20110104/gdb/objfiles.h 2011-01-04 06:15:14.000000000 +0100
|
||||
@@ -433,6 +433,10 @@ struct objfile
|
||||
--- gdb-7.2.50.20110107.orig/gdb/objfiles.h 2011-01-05 23:22:49.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/objfiles.h 2011-01-07 09:07:01.000000000 +0100
|
||||
@@ -434,6 +434,10 @@ struct objfile
|
||||
|
||||
#define OBJF_USERLOADED (1 << 3) /* User loaded */
|
||||
|
||||
|
2436
gdb-archer.patch
2436
gdb-archer.patch
File diff suppressed because it is too large
Load Diff
@ -1,8 +1,8 @@
|
||||
Index: gdb-7.1.90.20100711/gdb/f-lang.c
|
||||
Index: gdb-7.2.50.20110107/gdb/f-lang.c
|
||||
===================================================================
|
||||
--- gdb-7.1.90.20100711.orig/gdb/f-lang.c 2010-06-03 00:41:55.000000000 +0200
|
||||
+++ gdb-7.1.90.20100711/gdb/f-lang.c 2010-07-13 00:24:04.000000000 +0200
|
||||
@@ -56,20 +56,6 @@ typedef struct saved_bf_symnum SAVED_BF,
|
||||
--- gdb-7.2.50.20110107.orig/gdb/f-lang.c 2011-01-05 23:22:48.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/f-lang.c 2011-01-07 09:08:52.000000000 +0100
|
||||
@@ -57,20 +57,6 @@ typedef struct saved_bf_symnum SAVED_BF,
|
||||
/* Local functions */
|
||||
|
||||
extern void _initialize_f_language (void);
|
||||
@ -23,7 +23,7 @@ Index: gdb-7.1.90.20100711/gdb/f-lang.c
|
||||
|
||||
static void f_printchar (int c, struct type *type, struct ui_file * stream);
|
||||
static void f_emit_char (int c, struct type *type,
|
||||
@@ -458,185 +444,7 @@ _initialize_f_language (void)
|
||||
@@ -461,185 +447,7 @@ _initialize_f_language (void)
|
||||
add_language (&f_language_defn);
|
||||
}
|
||||
|
||||
@ -73,8 +73,8 @@ Index: gdb-7.1.90.20100711/gdb/f-lang.c
|
||||
-static SAVED_BF_PTR saved_bf_list = NULL; /* Ptr to (.bf,function)
|
||||
- list */
|
||||
-static SAVED_BF_PTR saved_bf_list_end = NULL; /* Ptr to above list's end */
|
||||
-static SAVED_BF_PTR current_head_bf_list = NULL; /* Current head of above list
|
||||
- */
|
||||
-static SAVED_BF_PTR current_head_bf_list = NULL; /* Current head of
|
||||
- above list. */
|
||||
-
|
||||
-static SAVED_BF_PTR tmp_bf_ptr; /* Generic temporary for use
|
||||
- in macros */
|
||||
@ -209,7 +209,7 @@ Index: gdb-7.1.90.20100711/gdb/f-lang.c
|
||||
|
||||
/* This routine finds the first encountred COMMON block named "name"
|
||||
that belongs to function funcname */
|
||||
@@ -659,193 +467,3 @@ find_common_for_function (char *name, ch
|
||||
@@ -662,193 +470,3 @@ find_common_for_function (char *name, ch
|
||||
}
|
||||
return (NULL);
|
||||
}
|
||||
@ -403,10 +403,10 @@ Index: gdb-7.1.90.20100711/gdb/f-lang.c
|
||||
- saved_function_list = NULL;
|
||||
-}
|
||||
-#endif
|
||||
Index: gdb-7.1.90.20100711/gdb/f-lang.h
|
||||
Index: gdb-7.2.50.20110107/gdb/f-lang.h
|
||||
===================================================================
|
||||
--- gdb-7.1.90.20100711.orig/gdb/f-lang.h 2010-07-12 23:07:33.000000000 +0200
|
||||
+++ gdb-7.1.90.20100711/gdb/f-lang.h 2010-07-13 00:24:04.000000000 +0200
|
||||
--- gdb-7.2.50.20110107.orig/gdb/f-lang.h 2011-01-07 09:03:38.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/f-lang.h 2011-01-07 09:07:58.000000000 +0100
|
||||
@@ -76,14 +76,9 @@ typedef struct saved_f77_common SAVED_F7
|
||||
typedef struct common_entry COMMON_ENTRY, *COMMON_ENTRY_PTR;
|
||||
|
||||
@ -422,10 +422,10 @@ Index: gdb-7.1.90.20100711/gdb/f-lang.h
|
||||
#define BLANK_COMMON_NAME_ORIGINAL "#BLNK_COM" /* XLF assigned */
|
||||
#define BLANK_COMMON_NAME_MF77 "__BLNK__" /* MF77 assigned */
|
||||
#define BLANK_COMMON_NAME_LOCAL "__BLANK" /* Local GDB */
|
||||
Index: gdb-7.1.90.20100711/gdb/f-valprint.c
|
||||
Index: gdb-7.2.50.20110107/gdb/f-valprint.c
|
||||
===================================================================
|
||||
--- gdb-7.1.90.20100711.orig/gdb/f-valprint.c 2010-07-12 23:07:33.000000000 +0200
|
||||
+++ gdb-7.1.90.20100711/gdb/f-valprint.c 2010-07-13 00:24:25.000000000 +0200
|
||||
--- gdb-7.2.50.20110107.orig/gdb/f-valprint.c 2011-01-07 09:03:38.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/f-valprint.c 2011-01-07 09:07:58.000000000 +0100
|
||||
@@ -35,10 +35,6 @@
|
||||
#include "command.h"
|
||||
#include "block.h"
|
||||
@ -437,7 +437,7 @@ Index: gdb-7.1.90.20100711/gdb/f-valprint.c
|
||||
extern void _initialize_f_valprint (void);
|
||||
static void info_common_command (char *, int);
|
||||
static void list_all_visible_commons (char *);
|
||||
@@ -601,67 +597,6 @@ info_common_command (char *comname, int
|
||||
@@ -604,67 +600,6 @@ info_common_command (char *comname, int
|
||||
comname, funname);
|
||||
}
|
||||
|
||||
|
@ -27,8 +27,10 @@ gdb/testsuite/
|
||||
* gdb.python/py-prettyprint.py (class pp_hint_error): New.
|
||||
(register_pretty_printers): Register it.
|
||||
|
||||
--- a/gdb/testsuite/gdb.python/py-prettyprint.c
|
||||
+++ b/gdb/testsuite/gdb.python/py-prettyprint.c
|
||||
Index: gdb-7.2.50.20110107/gdb/testsuite/gdb.python/py-prettyprint.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110107.orig/gdb/testsuite/gdb.python/py-prettyprint.c 2011-01-01 16:33:49.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/testsuite/gdb.python/py-prettyprint.c 2011-01-07 09:11:18.000000000 +0100
|
||||
@@ -44,6 +44,10 @@ struct lazystring {
|
||||
const char *lazy_str;
|
||||
};
|
||||
@ -48,8 +50,10 @@ gdb/testsuite/
|
||||
|
||||
nstype.elements = narray;
|
||||
nstype.len = 0;
|
||||
--- a/gdb/testsuite/gdb.python/py-prettyprint.exp
|
||||
+++ b/gdb/testsuite/gdb.python/py-prettyprint.exp
|
||||
Index: gdb-7.2.50.20110107/gdb/testsuite/gdb.python/py-prettyprint.exp
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110107.orig/gdb/testsuite/gdb.python/py-prettyprint.exp 2011-01-07 09:03:38.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/testsuite/gdb.python/py-prettyprint.exp 2011-01-07 09:11:32.000000000 +0100
|
||||
@@ -97,6 +97,8 @@ proc run_lang_tests {lang} {
|
||||
gdb_test_no_output "python pp_ls_encoding = 'UTF-8'"
|
||||
gdb_test "print estring2" "\"embedded \", <incomplete sequence \\\\302>"
|
||||
@ -58,9 +62,11 @@ gdb/testsuite/
|
||||
+
|
||||
gdb_test "print c" " = container \"container\" with 2 elements = {$nl *.0. = 23,$nl *.1. = 72$nl}"
|
||||
|
||||
gdb_test "print nstype" " = {$nl *.0. = 7,$nl *.1. = 42$nl}"
|
||||
--- a/gdb/testsuite/gdb.python/py-prettyprint.py
|
||||
+++ b/gdb/testsuite/gdb.python/py-prettyprint.py
|
||||
gdb_test "print nullstr" "RuntimeError: Error reading string from inferior.*"
|
||||
Index: gdb-7.2.50.20110107/gdb/testsuite/gdb.python/py-prettyprint.py
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110107.orig/gdb/testsuite/gdb.python/py-prettyprint.py 2011-01-01 16:33:49.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/testsuite/gdb.python/py-prettyprint.py 2011-01-07 09:11:18.000000000 +0100
|
||||
@@ -156,6 +156,18 @@ class pp_ls:
|
||||
def display_hint (self):
|
||||
return 'string'
|
||||
@ -90,4 +96,3 @@ gdb/testsuite/
|
||||
pretty_printers_dict = {}
|
||||
|
||||
register_pretty_printers ()
|
||||
|
||||
|
8
gdb.spec
8
gdb.spec
@ -23,11 +23,11 @@ Name: gdb%{?_with_debug:-debug}
|
||||
# Set version to contents of gdb/version.in.
|
||||
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
|
||||
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
|
||||
Version: 7.2.50.20110104
|
||||
Version: 7.2.50.20110107
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 7%{?_with_upstream:.upstream}%{dist}
|
||||
Release: 8%{?_with_upstream:.upstream}%{dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and GFDL and BSD and Public Domain
|
||||
Group: Development/Debuggers
|
||||
@ -1132,6 +1132,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jan 7 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20110107-8.fc15
|
||||
- Rebase to FSF GDB 7.2.50.20110107 (which is a 7.3 pre-release).
|
||||
- Import archer-tromey-python (BZ 666177, branch update by Phil Muldoon).
|
||||
|
||||
* Tue Jan 4 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20110104-7.fc15
|
||||
- Rebase to FSF GDB 7.2.50.20110104 (which is a 7.3 pre-release).
|
||||
- New testcase py-prettyprint.exp:print hint_error (for BZ 611569, BZ 629236).
|
||||
|
Loading…
Reference in New Issue
Block a user