Rebase to FSF GDB 7.10.90.20160216 (pre-7.11 branch snapshot).
This commit is contained in:
parent
22d1e60a36
commit
32b1677f0e
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
/gdb-libstdc++-v3-python-r225521.tar.xz
|
||||
/gdb-7.10.90.20160211.tar.xz
|
||||
/gdb-7.10.90.20160216.tar.xz
|
||||
|
@ -1,123 +0,0 @@
|
||||
http://sourceware.org/ml/gdb-patches/2016-02/msg00441.html
|
||||
Subject: [testsuite patch] Fix false Fortran regressions with recent gcc
|
||||
|
||||
|
||||
--pWyiEgJYm5f9v55/
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline
|
||||
|
||||
Hi,
|
||||
|
||||
gcc-4.9.2-6.fc21.x86_64 -> gcc-5.3.1-2.fc23.x86_64
|
||||
|
||||
-PASS: gdb.fortran/vla-ptype.exp: ptype pvla not initialized
|
||||
+FAIL: gdb.fortran/vla-ptype.exp: ptype pvla not initialized
|
||||
-PASS: gdb.fortran/vla-history.exp: print vla1 allocated
|
||||
+FAIL: gdb.fortran/vla-history.exp: print vla1 allocated
|
||||
-PASS: gdb.fortran/vla-history.exp: print $2
|
||||
+FAIL: gdb.fortran/vla-history.exp: print $2
|
||||
-PASS: gdb.fortran/vla-value.exp: print undefined pvla
|
||||
+FAIL: gdb.fortran/vla-value.exp: print undefined pvla
|
||||
-PASS: gdb.fortran/vla-value.exp: print non-associated &pvla
|
||||
+FAIL: gdb.fortran/vla-value.exp: print non-associated &pvla
|
||||
-PASS: gdb.fortran/vla-value.exp: print undefined pvla(1,3,8)
|
||||
+FAIL: gdb.fortran/vla-value.exp: print undefined pvla(1,3,8)
|
||||
|
||||
These issues get fixed (or removed if no longer applicable) by attached patch.
|
||||
|
||||
It is based on Googled:
|
||||
http://www.cs.rpi.edu/~szymansk/OOF90/bugs.html#5
|
||||
When a pointer is declared its status is undefined, and cannot be
|
||||
safely queried with the associated intrinsic.
|
||||
-> nullify(VARNAME)
|
||||
+
|
||||
https://software.intel.com/en-us/forums/intel-fortran-compiler-for-linux-and-mac-os-x/topic/268786
|
||||
ALLOCATE is not supposed to initialize the array.
|
||||
-> Remove checks like an initial print is: \\( *0, *0, *0...\\)
|
||||
|
||||
These regressions remain:
|
||||
-PASS: gdb.fortran/library-module.exp: print var_i in lib
|
||||
+FAIL: gdb.fortran/library-module.exp: print var_i in lib
|
||||
-PASS: gdb.fortran/library-module.exp: print var_i in main
|
||||
+FAIL: gdb.fortran/library-module.exp: print var_i in main
|
||||
I believe it is more a GDB bug (in a code contributed by me), filed:
|
||||
gdb.fortran/library-module.exp false regression on GCC upgrade
|
||||
https://sourceware.org/bugzilla/show_bug.cgi?id=19635
|
||||
|
||||
OK for check-in?
|
||||
|
||||
|
||||
Thanks,
|
||||
Jan
|
||||
|
||||
--pWyiEgJYm5f9v55/
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline; filename=1
|
||||
|
||||
gdb/testsuite/ChangeLog
|
||||
2016-02-13 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
Fix compatibility with recent gfortran-5.3.1.
|
||||
* gdb.fortran/vla-history.exp (print vla1 allocated)
|
||||
(print vla2 allocated, print $2, print $3): Remove
|
||||
(print $4): Rename to ...
|
||||
(print $2): ... here.
|
||||
(print $9): Rename to ...
|
||||
(print $5): ... here.
|
||||
(print $10): Rename to ...
|
||||
(print $6): ... here.
|
||||
* gdb.fortran/vla.f90: Add pvla initialization.
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.fortran/vla-history.exp b/gdb/testsuite/gdb.fortran/vla-history.exp
|
||||
index 315c61a..1478e6b 100644
|
||||
--- a/gdb/testsuite/gdb.fortran/vla-history.exp
|
||||
+++ b/gdb/testsuite/gdb.fortran/vla-history.exp
|
||||
@@ -32,10 +32,6 @@ gdb_test "print vla1" " = <not allocated>" "print non-allocated vla1"
|
||||
|
||||
gdb_breakpoint [gdb_get_line_number "vla2-allocated"]
|
||||
gdb_continue_to_breakpoint "vla2-allocated"
|
||||
-gdb_test "print vla1" " = \\( *\\( *\\( *0, *0, *0,\[()0, .\]*\\)" \
|
||||
- "print vla1 allocated"
|
||||
-gdb_test "print vla2" " = \\( *\\( *\\( *0, *0, *0,\[()0, .\]*\\)" \
|
||||
- "print vla2 allocated"
|
||||
|
||||
gdb_breakpoint [gdb_get_line_number "vla1-filled"]
|
||||
gdb_continue_to_breakpoint "vla1-filled"
|
||||
@@ -45,12 +41,8 @@ gdb_test "print vla1" \
|
||||
|
||||
# Try to access history values for full vla prints.
|
||||
gdb_test "print \$1" " = <not allocated>" "print \$1"
|
||||
-gdb_test "print \$2" " = \\( *\\( *\\( *0, *0, *0,\[()0, .\]*\\)" \
|
||||
- "print \$2"
|
||||
-gdb_test "print \$3" " = \\( *\\( *\\( *0, *0, *0,\[()0, .\]*\\)" \
|
||||
- "print \$3"
|
||||
-gdb_test "print \$4" \
|
||||
- " = \\( *\\( *\\( *1311, *1311, *1311,\[()1311, .\]*\\)" "print \$4"
|
||||
+gdb_test "print \$2" \
|
||||
+ " = \\( *\\( *\\( *1311, *1311, *1311,\[()1311, .\]*\\)" "print \$2"
|
||||
|
||||
gdb_breakpoint [gdb_get_line_number "vla2-filled"]
|
||||
gdb_continue_to_breakpoint "vla2-filled"
|
||||
@@ -58,5 +50,5 @@ gdb_test "print vla2(1,43,20)" " = 1311" "print vla2(1,43,20)"
|
||||
gdb_test "print vla1(1,3,8)" " = 1001" "print vla2(1,3,8)"
|
||||
|
||||
# Try to access history values for vla values.
|
||||
-gdb_test "print \$9" " = 1311" "print \$9"
|
||||
-gdb_test "print \$10" " = 1001" "print \$10"
|
||||
+gdb_test "print \$5" " = 1311" "print \$5"
|
||||
+gdb_test "print \$6" " = 1001" "print \$6"
|
||||
diff --git a/gdb/testsuite/gdb.fortran/vla.f90 b/gdb/testsuite/gdb.fortran/vla.f90
|
||||
index 6a96635..c76d24c 100644
|
||||
--- a/gdb/testsuite/gdb.fortran/vla.f90
|
||||
+++ b/gdb/testsuite/gdb.fortran/vla.f90
|
||||
@@ -19,6 +19,7 @@ program vla
|
||||
real, target, allocatable :: vla3 (:, :)
|
||||
real, pointer :: pvla (:, :, :)
|
||||
logical :: l
|
||||
+ nullify(pvla)
|
||||
|
||||
allocate (vla1 (10,10,10)) ! vla1-init
|
||||
l = allocated(vla1)
|
||||
|
||||
--pWyiEgJYm5f9v55/--
|
||||
|
@ -1,67 +0,0 @@
|
||||
http://sourceware.org/ml/gdb-patches/2016-02/msg00442.html
|
||||
Subject: [testsuite patch] testsuite regression: gdb.fortran/vla-value-sub.exp gdb.fortran/vla-value-sub-finish.exp [Re: [PATCH 1/3] gdb: New set/show max-value-size command.]
|
||||
|
||||
|
||||
--u3/rZRmxL6MmkK24
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline
|
||||
|
||||
On Wed, 06 Jan 2016 12:40:50 +0100, Andrew Burgess wrote:
|
||||
> +static int max_value_size = 65536; /* 64k bytes */
|
||||
|
||||
FAIL: gdb.fortran/vla-value-sub.exp: print array2 in foo after it was filled (passed fixed array)
|
||||
FAIL: gdb.fortran/vla-value-sub.exp: print array2 in foo after it was mofified in debugger (passed fixed array)
|
||||
FAIL: gdb.fortran/vla-value-sub-finish.exp: print array2 in foo after it was filled
|
||||
FAIL: gdb.fortran/vla-value-sub-finish.exp: print array2 in foo after it was mofified in debugger
|
||||
|
||||
print array2
|
||||
value requires 296352 bytes, which is more than max-value-size
|
||||
(gdb) FAIL: gdb.fortran/vla-value-sub.exp: print array2 in foo after it was filled (passed fixed array)
|
||||
|
||||
OK for check-in?
|
||||
|
||||
Tested on x86_64-fedora23-linux-gnu.
|
||||
|
||||
|
||||
Jan
|
||||
|
||||
--u3/rZRmxL6MmkK24
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline; filename=1
|
||||
|
||||
gdb/testsuite/ChangeLog
|
||||
2016-02-13 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* gdb.fortran/vla-value-sub-finish.exp (set max-value-size 1024*1024):
|
||||
New test.
|
||||
* gdb.fortran/vla-value-sub.exp: Likewise.
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.fortran/vla-value-sub-finish.exp b/gdb/testsuite/gdb.fortran/vla-value-sub-finish.exp
|
||||
index c47ef2c..fde6c9f 100644
|
||||
--- a/gdb/testsuite/gdb.fortran/vla-value-sub-finish.exp
|
||||
+++ b/gdb/testsuite/gdb.fortran/vla-value-sub-finish.exp
|
||||
@@ -32,6 +32,8 @@ if ![runto_main] {
|
||||
|
||||
gdb_breakpoint [gdb_get_line_number "array2-almost-filled"]
|
||||
gdb_continue_to_breakpoint "array2-almost-filled"
|
||||
+# array2 size is 296352 bytes.
|
||||
+gdb_test_no_output "set max-value-size 1024*1024"
|
||||
gdb_test "print array2" " = \\( *\\( *\\( *30, *3, *3,\[()3, .\]*\\)" \
|
||||
"print array2 in foo after it was filled"
|
||||
gdb_test "print array2(2,1,1)=20" " = 20" \
|
||||
diff --git a/gdb/testsuite/gdb.fortran/vla-value-sub.exp b/gdb/testsuite/gdb.fortran/vla-value-sub.exp
|
||||
index 361d7a9..179683d 100644
|
||||
--- a/gdb/testsuite/gdb.fortran/vla-value-sub.exp
|
||||
+++ b/gdb/testsuite/gdb.fortran/vla-value-sub.exp
|
||||
@@ -42,6 +42,8 @@ gdb_test "print array1(1, 1)" " = 30" \
|
||||
|
||||
gdb_breakpoint [gdb_get_line_number "array2-almost-filled"]
|
||||
gdb_continue_to_breakpoint "array2-almost-filled (1st)"
|
||||
+# array2 size is 296352 bytes.
|
||||
+gdb_test_no_output "set max-value-size 1024*1024"
|
||||
gdb_test "print array2" " = \\( *\\( *\\( *30, *3, *3,\[()3, .\]*\\)" \
|
||||
"print array2 in foo after it was filled (passed fixed array)"
|
||||
gdb_test "print array2(2,1,1)=20" " = 20" \
|
||||
|
||||
--u3/rZRmxL6MmkK24--
|
||||
|
@ -1,247 +0,0 @@
|
||||
http://sourceware.org/ml/gdb-patches/2016-02/msg00423.html
|
||||
Subject: Re: [testsuite 7.11] Regression for i386-biarch-core.exp and others [Re: [PATCH] Always organize test artifacts in a directory hierarchy]
|
||||
|
||||
On 16-02-11 04:22 PM, Jan Kratochvil wrote:
|
||||
> On Mon, 08 Feb 2016 20:26:41 +0100, Simon Marchi wrote:
|
||||
>> Ok, I pushed this patch. I am now waiting to know what I broke.
|
||||
>
|
||||
> Running /home/jkratoch/redhat/gdb-clean/gdb/testsuite/gdb.arch/i386-biarch-core.exp ...
|
||||
> PASS: gdb.arch/i386-biarch-core.exp: complete set gnutarget
|
||||
> PASS: gdb.arch/i386-biarch-core.exp: core-file
|
||||
> PASS: gdb.arch/i386-biarch-core.exp: .text is readable
|
||||
> ->
|
||||
> Running /home/jkratoch/redhat/gdb-clean/gdb/testsuite/gdb.arch/i386-biarch-core.exp ...
|
||||
> PASS: gdb.arch/i386-biarch-core.exp: complete set gnutarget
|
||||
> UNTESTED: gdb.arch/i386-biarch-core.exp: failed bzip2
|
||||
>
|
||||
> Reproducible with:
|
||||
> tar xJf gdb-7.10.90.20160211.tar.xz;cd gdb-7.10.90.20160211;./configure;make;make -C gdb check//unix/-m64 RUNTESTFLAGS=gdb.arch/i386-biarch-core.exp
|
||||
> Running /tmp/gdb-7.10.90.20160211/gdb/testsuite/gdb.arch/i386-biarch-core.exp ...
|
||||
> sh: /tmp/gdb-7.10.90.20160211/gdb/testsuite.unix.-m64/gdb.arch/i386-biarch-core.core: No such file or directory
|
||||
> === gdb Summary ===
|
||||
> # of expected passes 1
|
||||
> # of untested testcases 1
|
||||
>
|
||||
> I have not debugged it more yet.
|
||||
>
|
||||
>
|
||||
> Jan
|
||||
|
||||
Hi Jan,
|
||||
|
||||
I think this patch should fix it. It simply makes the test use standard_output_file
|
||||
for its output directory.
|
||||
|
||||
Simon
|
||||
|
||||
|
||||
>From c643fde26ecdc63c399ac4f26fd31920148fae77 Mon Sep 17 00:00:00 2001
|
||||
From: Simon Marchi <simon.marchi@ericsson.com>
|
||||
Date: Fri, 12 Feb 2016 13:17:32 -0500
|
||||
Subject: [PATCH] i386-biarch-core.exp: Use standard_output_file
|
||||
Subject: [PATCH] i386-biarch-core.exp: Use standard_output_file
|
||||
|
||||
Fix the core file path to use the standard output directory.
|
||||
|
||||
gdb/testsuite/ChangeLog:
|
||||
|
||||
* i386-biarch-core.exp: Define corefile using
|
||||
standard_output_file.
|
||||
---
|
||||
gdb/testsuite/gdb.arch/i386-biarch-core.exp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.arch/i386-biarch-core.exp b/gdb/testsuite/gdb.arch/i386-biarch-core.exp
|
||||
index 607b947..4dc5ba6 100644
|
||||
--- a/gdb/testsuite/gdb.arch/i386-biarch-core.exp
|
||||
+++ b/gdb/testsuite/gdb.arch/i386-biarch-core.exp
|
||||
@@ -40,7 +40,7 @@ gdb_test_multiple "complete set gnutarget " $test {
|
||||
}
|
||||
|
||||
set corebz2file ${srcdir}/${subdir}/${testfile}.core.bz2
|
||||
-set corefile ${objdir}/${subdir}/${testfile}.core
|
||||
+set corefile [standard_output_file ${testfile}.core]
|
||||
# Entry point of the original executable.
|
||||
set address 0x400078
|
||||
|
||||
--
|
||||
2.5.1
|
||||
|
||||
|
||||
|
||||
http://sourceware.org/ml/gdb-patches/2016-02/msg00468.html
|
||||
Subject: [testsuite obv+7.11] Fix more testcases with standard_output_file [Re: [testsuite 7.11] Regression for i386-biarch-core.exp and others]
|
||||
|
||||
|
||||
--AhhlLboLdkugWU4S
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline
|
||||
|
||||
On Fri, 12 Feb 2016 19:47:10 +0100, Jan Kratochvil wrote:
|
||||
> (gdb.base/corefile.exp gdb.base/execl-update-breakpoints.exp listed there do
|
||||
> not reproduce it for me locally now, I will re-check those.)
|
||||
|
||||
I have rechecked it and fixed these.
|
||||
|
||||
trunk:
|
||||
c99dbb4246fedd500dbdd50514589fc7f95d80c0
|
||||
7.11:
|
||||
8b6bd5aca63189590498195a7a2696cde021c9cd
|
||||
|
||||
|
||||
Jan
|
||||
|
||||
--AhhlLboLdkugWU4S
|
||||
Content-Type: message/rfc822
|
||||
Content-Disposition: inline
|
||||
|
||||
From: Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
Date: Mon, 15 Feb 2016 18:54:03 +0100
|
||||
Subject: [PATCH] Fix more testcases with standard_output_file.
|
||||
Subject: [PATCH] Fix more testcases with standard_output_file.
|
||||
|
||||
Since
|
||||
commit 2151ccc56c74b55a8f0debf0724a495368f92591
|
||||
Author: Simon Marchi <simon.marchi@ericsson.com>
|
||||
Date: Mon Feb 8 14:02:36 2016 -0500
|
||||
Always organize test artifacts in a directory hierarchy
|
||||
these testfiles could not build.
|
||||
|
||||
gdb/testsuite/ChangeLog
|
||||
2016-02-15 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* gdb.arch/i386-gnu-cfi.exp: Use standard_output_file.
|
||||
* gdb.arch/i386-prologue.exp: Likewise.
|
||||
* gdb.arch/i386-size.exp: Likewise.
|
||||
---
|
||||
gdb/testsuite/ChangeLog | 6 ++++++
|
||||
gdb/testsuite/gdb.arch/i386-gnu-cfi.exp | 2 +-
|
||||
gdb/testsuite/gdb.arch/i386-prologue.exp | 2 +-
|
||||
gdb/testsuite/gdb.arch/i386-size.exp | 2 +-
|
||||
4 files changed, 9 insertions(+), 3 deletions(-)
|
||||
|
||||
### a/gdb/testsuite/ChangeLog
|
||||
### b/gdb/testsuite/ChangeLog
|
||||
## -1,3 +1,9 @@
|
||||
+2016-02-15 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
+
|
||||
+ * gdb.arch/i386-gnu-cfi.exp: Use standard_output_file.
|
||||
+ * gdb.arch/i386-prologue.exp: Likewise.
|
||||
+ * gdb.arch/i386-size.exp: Likewise.
|
||||
+
|
||||
2016-02-15 Simon Marchi <simon.marchi@ericsson.com>
|
||||
|
||||
* gdb.base/wrong_frame_bt_full.exp: Use standard_output_file to
|
||||
--- a/gdb/testsuite/gdb.arch/i386-gnu-cfi.exp
|
||||
+++ b/gdb/testsuite/gdb.arch/i386-gnu-cfi.exp
|
||||
@@ -31,7 +31,7 @@ if { ![is_x86_like_target] } then {
|
||||
set testfile "i386-gnu-cfi"
|
||||
set srcfilec ${testfile}.c
|
||||
set srcfileasm ${testfile}-asm.S
|
||||
-set binfile ${objdir}/${subdir}/${testfile}
|
||||
+set binfile [standard_output_file ${testfile}]
|
||||
|
||||
# some targets have leading underscores on assembly symbols.
|
||||
set additional_flags [gdb_target_symbol_prefix_flags]
|
||||
--- a/gdb/testsuite/gdb.arch/i386-prologue.exp
|
||||
+++ b/gdb/testsuite/gdb.arch/i386-prologue.exp
|
||||
@@ -28,7 +28,7 @@ if { ![is_x86_like_target] } then {
|
||||
|
||||
set testfile "i386-prologue"
|
||||
set srcfile ${testfile}.c
|
||||
-set binfile ${objdir}/${subdir}/${testfile}
|
||||
+set binfile [standard_output_file ${testfile}]
|
||||
|
||||
# some targets have leading underscores on assembly symbols.
|
||||
set additional_flags [gdb_target_symbol_prefix_flags]
|
||||
--- a/gdb/testsuite/gdb.arch/i386-size.exp
|
||||
+++ b/gdb/testsuite/gdb.arch/i386-size.exp
|
||||
@@ -27,7 +27,7 @@ if { ![is_x86_like_target] } then {
|
||||
|
||||
set testfile "i386-size"
|
||||
set srcfile ${testfile}.c
|
||||
-set binfile ${objdir}/${subdir}/${testfile}
|
||||
+set binfile [standard_output_file ${testfile}]
|
||||
|
||||
# some targets have leading underscores on assembly symbols.
|
||||
set additional_flags [gdb_target_symbol_prefix_flags]
|
||||
--
|
||||
2.5.0
|
||||
|
||||
--AhhlLboLdkugWU4S--
|
||||
|
||||
http://sourceware.org/ml/gdb-patches/2016-02/msg00469.html
|
||||
Subject: [testsuite obv+7.11] Add missing gdb.arch/i386-prologue.c prototypes
|
||||
|
||||
|
||||
--EVF5PPMfhYS0aIcm
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline
|
||||
|
||||
trunk:
|
||||
a7a0a6a95bc111776129374c46edec3c3c2785cc
|
||||
7.11:
|
||||
906c69d06a46cec2f55941f7dc3a5323261796d5
|
||||
|
||||
--EVF5PPMfhYS0aIcm
|
||||
Content-Type: message/rfc822
|
||||
Content-Disposition: inline
|
||||
|
||||
From: Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
Date: Mon, 15 Feb 2016 19:01:03 +0100
|
||||
Subject: [PATCH] Add missing gdb.arch/i386-prologue.c prototypes
|
||||
Subject: [PATCH] Add missing gdb.arch/i386-prologue.c prototypes
|
||||
|
||||
The testfile has not ran because:
|
||||
gdb.arch/i386-prologue.c:34:3: warning: implicit declaration of function 'standard' [-Wimplicit-function-declaration]
|
||||
standard ();
|
||||
^
|
||||
gdb.arch/i386-prologue.c:35:3: warning: implicit declaration of function 'stack_align_ecx' [-Wimplicit-function-declaration]
|
||||
stack_align_ecx ();
|
||||
^
|
||||
gdb.arch/i386-prologue.c:36:3: warning: implicit declaration of function 'stack_align_edx' [-Wimplicit-function-declaration]
|
||||
stack_align_edx ();
|
||||
^
|
||||
gdb.arch/i386-prologue.c:37:3: warning: implicit declaration of function 'stack_align_eax' [-Wimplicit-function-declaration]
|
||||
stack_align_eax ();
|
||||
^
|
||||
|
||||
gdb/testsuite/ChangeLog
|
||||
2016-02-15 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* gdb.arch/i386-prologue.c: Add missing prototypes.
|
||||
---
|
||||
gdb/testsuite/ChangeLog | 4 ++++
|
||||
gdb/testsuite/gdb.arch/i386-prologue.c | 4 ++++
|
||||
2 files changed, 8 insertions(+)
|
||||
|
||||
### a/gdb/testsuite/ChangeLog
|
||||
### b/gdb/testsuite/ChangeLog
|
||||
## -1,5 +1,9 @@
|
||||
2016-02-15 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
+ * gdb.arch/i386-prologue.c: Add missing prototypes.
|
||||
+
|
||||
+2016-02-15 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
+
|
||||
* gdb.arch/i386-gnu-cfi.exp: Use standard_output_file.
|
||||
* gdb.arch/i386-prologue.exp: Likewise.
|
||||
* gdb.arch/i386-size.exp: Likewise.
|
||||
--- a/gdb/testsuite/gdb.arch/i386-prologue.c
|
||||
+++ b/gdb/testsuite/gdb.arch/i386-prologue.c
|
||||
@@ -27,6 +27,10 @@ void gdb1253 (void);
|
||||
void gdb1718 (void);
|
||||
void gdb1338 (void);
|
||||
void jump_at_beginning (void);
|
||||
+void standard (void);
|
||||
+void stack_align_ecx (void);
|
||||
+void stack_align_edx (void);
|
||||
+void stack_align_eax (void);
|
||||
|
||||
int
|
||||
main (void)
|
||||
--
|
||||
2.5.0
|
||||
|
||||
--EVF5PPMfhYS0aIcm--
|
||||
|
19
gdb.spec
19
gdb.spec
@ -23,11 +23,11 @@ Name: %{?scl_prefix}gdb
|
||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||
%global snapgnulib 20150822
|
||||
%global tarname gdb-%{version}
|
||||
Version: 7.10.90.20160211
|
||||
Version: 7.10.90.20160216
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 53%{?dist}
|
||||
Release: 54%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -245,7 +245,7 @@ Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
||||
|
||||
# Backported fixups post the source tarball.
|
||||
#Xdrop: Just backports.
|
||||
Patch232: gdb-upstream.patch
|
||||
#Patch232: gdb-upstream.patch
|
||||
|
||||
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
||||
#=fedoratest+ppc
|
||||
@ -555,12 +555,6 @@ Patch1073: gdb-opcodes-clflushopt-test.patch
|
||||
# [testsuite] Fix false selftest.exp FAIL from system readline-6.3+ (Patrick Palka).
|
||||
Patch1075: gdb-testsuite-readline63-sigint.patch
|
||||
|
||||
# [testsuite] Fix false Fortran regressions with recent gcc.
|
||||
Patch1078: gdb-testsuite-fortran-gcc5.patch
|
||||
|
||||
# [testsuite] Fix new set/show max-value-size regression.
|
||||
Patch1079: gdb-testsuite-fortran-max-value-size.patch
|
||||
|
||||
%if 0%{!?rhel:1} || 0%{?rhel} > 6
|
||||
# RL_STATE_FEDORA_GDB would not be found for:
|
||||
# Patch642: gdb-readline62-ask-more-rh.patch
|
||||
@ -756,7 +750,7 @@ find -name "*.info*"|xargs rm -f
|
||||
# Match the Fedora's version info.
|
||||
%patch2 -p1
|
||||
|
||||
%patch232 -p1
|
||||
#patch232 -p1
|
||||
%patch349 -p1
|
||||
%patch1058 -p1
|
||||
%patch1059 -p1
|
||||
@ -875,8 +869,6 @@ find -name "*.info*"|xargs rm -f
|
||||
%patch337 -p1
|
||||
%patch331 -p1
|
||||
%patch1075 -p1
|
||||
%patch1078 -p1
|
||||
%patch1079 -p1
|
||||
|
||||
%if 0%{?rhel:1} && 0%{?rhel} <= 7
|
||||
%patch1044 -p1
|
||||
@ -1394,6 +1386,9 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Tue Feb 16 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.90.20160216-54.fc24
|
||||
- Rebase to FSF GDB 7.10.90.20160216 (pre-7.11 branch snapshot).
|
||||
|
||||
* Tue Feb 16 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.10.90.20160211-53.fc24
|
||||
- Drop gdb-testsuite-subdirs-revert.patch.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user