Include testcase for BZ 818343.
This commit is contained in:
parent
a930df3ffb
commit
31a43c2209
75
gdb-rhbz-818343-set-solib-absolute-prefix-testcase.patch
Normal file
75
gdb-rhbz-818343-set-solib-absolute-prefix-testcase.patch
Normal file
@ -0,0 +1,75 @@
|
|||||||
|
Index: gdb-7.0.1/gdb/testsuite/gdb.base/set-solib-absolute-prefix.c
|
||||||
|
===================================================================
|
||||||
|
--- /dev/null
|
||||||
|
+++ gdb-7.0.1/gdb/testsuite/gdb.base/set-solib-absolute-prefix.c
|
||||||
|
@@ -0,0 +1,26 @@
|
||||||
|
+/* Copyright (C) 2012 Free Software Foundation, Inc.
|
||||||
|
+
|
||||||
|
+ This file is part of GDB.
|
||||||
|
+
|
||||||
|
+ This program is free software; you can redistribute it and/or modify
|
||||||
|
+ it under the terms of the GNU General Public License as published by
|
||||||
|
+ the Free Software Foundation; either version 3 of the License, or
|
||||||
|
+ (at your option) any later version.
|
||||||
|
+
|
||||||
|
+ This program is distributed in the hope that it will be useful,
|
||||||
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+ GNU General Public License for more details.
|
||||||
|
+
|
||||||
|
+ You should have received a copy of the GNU General Public License
|
||||||
|
+ along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||||
|
+
|
||||||
|
+#include <stdio.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
+
|
||||||
|
+int
|
||||||
|
+main (int argc, char *argv[])
|
||||||
|
+{
|
||||||
|
+ printf ("Hello, World.\n");
|
||||||
|
+ abort ();
|
||||||
|
+}
|
||||||
|
Index: gdb-7.0.1/gdb/testsuite/gdb.base/set-solib-absolute-prefix.exp
|
||||||
|
===================================================================
|
||||||
|
--- /dev/null
|
||||||
|
+++ gdb-7.0.1/gdb/testsuite/gdb.base/set-solib-absolute-prefix.exp
|
||||||
|
@@ -0,0 +1,39 @@
|
||||||
|
+# Copyright 2012 Free Software Foundation, Inc.
|
||||||
|
+
|
||||||
|
+# This program is free software; you can redistribute it and/or modify
|
||||||
|
+# it under the terms of the GNU General Public License as published by
|
||||||
|
+# the Free Software Foundation; either version 3 of the License, or
|
||||||
|
+# (at your option) any later version.
|
||||||
|
+#
|
||||||
|
+# This program is distributed in the hope that it will be useful,
|
||||||
|
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||||
|
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||||
|
+# GNU General Public License for more details.
|
||||||
|
+#
|
||||||
|
+# You should have received a copy of the GNU General Public License
|
||||||
|
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||||
|
+
|
||||||
|
+set testfile "set-solib-absolute-prefix"
|
||||||
|
+set srcfile ${testfile}.c
|
||||||
|
+
|
||||||
|
+# It is necessary to verify if the binary is 32-bit, so that the system
|
||||||
|
+# call `__kernel_vsyscall' originates from vDSO.
|
||||||
|
+
|
||||||
|
+if { ![is_ilp32_target] } {
|
||||||
|
+ return -1
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+if { [prepare_for_testing $testfile.exp $testfile $srcfile] } {
|
||||||
|
+ return -1
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+if { ![runto_main] } {
|
||||||
|
+ return -1
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+gdb_test "continue" "Program received signal SIGABRT, Aborted.*" \
|
||||||
|
+ "continue until abort"
|
||||||
|
+gdb_test "set solib-absolute-prefix /BOGUS_DIRECT" \
|
||||||
|
+ ".*warning: Unable to find dynamic linker breakpoint function.*" \
|
||||||
|
+ "set solib-absolute-prefix"
|
||||||
|
+gdb_test "bt" "__kernel_vsyscall.*" "backtrace with __kernel_vsyscall"
|
9
gdb.spec
9
gdb.spec
@ -35,7 +35,7 @@ Version: 7.4.50.%{snap}
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -572,6 +572,9 @@ Patch695: gdb-index-assert.patch
|
|||||||
Patch696: gdb-parameterref-1of2.patch
|
Patch696: gdb-parameterref-1of2.patch
|
||||||
Patch697: gdb-parameterref-2of2.patch
|
Patch697: gdb-parameterref-2of2.patch
|
||||||
|
|
||||||
|
# Testcase for `Setting solib-absolute-prefix breaks vDSO' (BZ 818343).
|
||||||
|
Patch703: gdb-rhbz-818343-set-solib-absolute-prefix-testcase.patch
|
||||||
|
|
||||||
# Include testcase for `Unable to see a variable inside a module (XLF)' (BZ 823789).
|
# Include testcase for `Unable to see a variable inside a module (XLF)' (BZ 823789).
|
||||||
#=fedoratest
|
#=fedoratest
|
||||||
#+ppc
|
#+ppc
|
||||||
@ -868,6 +871,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
|||||||
%patch696 -p1
|
%patch696 -p1
|
||||||
%patch697 -p1
|
%patch697 -p1
|
||||||
%patch698 -p1
|
%patch698 -p1
|
||||||
|
%patch703 -p1
|
||||||
|
|
||||||
%patch393 -p1
|
%patch393 -p1
|
||||||
%if 0%{!?el5:1} || 0%{?scl:1}
|
%if 0%{!?el5:1} || 0%{?scl:1}
|
||||||
@ -1357,6 +1361,9 @@ fi
|
|||||||
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 21 2012 Sergio Durigan Junior <sergiodj@redhat.com> - 7.4.50.20120603-7.fc18
|
||||||
|
- Include testcase for BZ 818343.
|
||||||
|
|
||||||
* Tue Jun 19 2012 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.4.50.20120603-6.fc18
|
* Tue Jun 19 2012 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.4.50.20120603-6.fc18
|
||||||
- Fix regression of undisplayed missing shared libraries caused by a fix for:
|
- Fix regression of undisplayed missing shared libraries caused by a fix for:
|
||||||
GNU/Linux core open: Can't read pathname for load map: Input/output error.
|
GNU/Linux core open: Can't read pathname for load map: Input/output error.
|
||||||
|
Loading…
Reference in New Issue
Block a user