- Rebase to FSF GDB 7.2.50.20110218 (which is a 7.3 pre-release).
- [vla] Fox Fortran vector slices for allocated arrays (for BZ 609782).
This commit is contained in:
parent
6b44006b8d
commit
3080c0e54f
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
/libstdc++-v3-python-r155978.tar.bz2
|
||||
/gdb-7.2.50.20110213.tar.bz2
|
||||
/gdb-7.2.50.20110218.tar.bz2
|
||||
|
@ -58,13 +58,13 @@ Http://sourceware.org/ml/gdb-patches/2010-01/msg00517.html
|
||||
* exec.c (exec_file_attach): Print a more useful error message if the
|
||||
user did "gdb core".
|
||||
|
||||
Index: gdb-7.2.50.20110107/gdb/exceptions.h
|
||||
Index: gdb-7.2.50.20110218/gdb/exceptions.h
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110107.orig/gdb/exceptions.h 2011-01-05 23:22:48.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/exceptions.h 2011-01-07 09:09:18.000000000 +0100
|
||||
@@ -78,6 +78,9 @@ enum errors {
|
||||
/* Feature is not supported in this copy of GDB. */
|
||||
UNSUPPORTED_ERROR,
|
||||
--- gdb-7.2.50.20110218.orig/gdb/exceptions.h 2011-02-14 12:35:44.000000000 +0100
|
||||
+++ gdb-7.2.50.20110218/gdb/exceptions.h 2011-02-18 10:45:31.000000000 +0100
|
||||
@@ -85,6 +85,9 @@ enum errors {
|
||||
traceframe. */
|
||||
NOT_AVAILABLE_ERROR,
|
||||
|
||||
+ /* Attempt to load a core file as executable. */
|
||||
+ IS_CORE_ERROR,
|
||||
@ -72,10 +72,10 @@ Index: gdb-7.2.50.20110107/gdb/exceptions.h
|
||||
/* Add more errors here. */
|
||||
NR_ERRORS
|
||||
};
|
||||
Index: gdb-7.2.50.20110107/gdb/exec.c
|
||||
Index: gdb-7.2.50.20110218/gdb/exec.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110107.orig/gdb/exec.c 2011-01-05 23:22:48.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/exec.c 2011-01-07 09:09:18.000000000 +0100
|
||||
--- gdb-7.2.50.20110218.orig/gdb/exec.c 2011-02-14 23:08:48.000000000 +0100
|
||||
+++ gdb-7.2.50.20110218/gdb/exec.c 2011-02-18 10:45:16.000000000 +0100
|
||||
@@ -34,6 +34,7 @@
|
||||
#include "arch-utils.h"
|
||||
#include "gdbthread.h"
|
||||
@ -115,10 +115,10 @@ Index: gdb-7.2.50.20110107/gdb/exec.c
|
||||
}
|
||||
|
||||
/* FIXME - This should only be run for RS6000, but the ifdef is a poor
|
||||
Index: gdb-7.2.50.20110107/gdb/main.c
|
||||
Index: gdb-7.2.50.20110218/gdb/main.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110107.orig/gdb/main.c 2011-01-07 09:05:02.000000000 +0100
|
||||
+++ gdb-7.2.50.20110107/gdb/main.c 2011-01-07 09:10:14.000000000 +0100
|
||||
--- gdb-7.2.50.20110218.orig/gdb/main.c 2011-02-18 10:44:17.000000000 +0100
|
||||
+++ gdb-7.2.50.20110218/gdb/main.c 2011-02-18 10:45:16.000000000 +0100
|
||||
@@ -243,6 +243,36 @@ captured_command_loop (void *data)
|
||||
return 1;
|
||||
}
|
||||
@ -156,7 +156,7 @@ Index: gdb-7.2.50.20110107/gdb/main.c
|
||||
static int
|
||||
captured_main (void *data)
|
||||
{
|
||||
@@ -726,6 +756,8 @@ captured_main (void *data)
|
||||
@@ -727,6 +757,8 @@ captured_main (void *data)
|
||||
{
|
||||
symarg = argv[optind];
|
||||
execarg = argv[optind];
|
||||
@ -165,7 +165,7 @@ Index: gdb-7.2.50.20110107/gdb/main.c
|
||||
optind++;
|
||||
}
|
||||
|
||||
@@ -867,11 +899,25 @@ captured_main (void *data)
|
||||
@@ -868,11 +900,25 @@ captured_main (void *data)
|
||||
&& symarg != NULL
|
||||
&& strcmp (execarg, symarg) == 0)
|
||||
{
|
||||
|
397
gdb-archer.patch
397
gdb-archer.patch
File diff suppressed because it is too large
Load Diff
@ -12,10 +12,10 @@
|
||||
* gdb.python/pr10659.exp. New file.
|
||||
* gdb.python/pr10659.py: New file.
|
||||
|
||||
Index: gdb-7.2.50.20110206/gdb/valprint.h
|
||||
Index: gdb-7.2.50.20110218/gdb/valprint.h
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110206.orig/gdb/valprint.h 2011-01-25 18:59:00.000000000 +0100
|
||||
+++ gdb-7.2.50.20110206/gdb/valprint.h 2011-02-06 20:55:59.000000000 +0100
|
||||
--- gdb-7.2.50.20110218.orig/gdb/valprint.h 2011-02-14 12:35:45.000000000 +0100
|
||||
+++ gdb-7.2.50.20110218/gdb/valprint.h 2011-02-18 10:44:32.000000000 +0100
|
||||
@@ -90,6 +90,9 @@ struct value_print_options
|
||||
|
||||
/* If nonzero, print the value in "summary" form. */
|
||||
@ -26,10 +26,10 @@ Index: gdb-7.2.50.20110206/gdb/valprint.h
|
||||
};
|
||||
|
||||
/* The global print options set by the user. In general this should
|
||||
Index: gdb-7.2.50.20110206/gdb/python/py-prettyprint.c
|
||||
Index: gdb-7.2.50.20110218/gdb/python/py-prettyprint.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110206.orig/gdb/python/py-prettyprint.c 2011-01-26 21:58:48.000000000 +0100
|
||||
+++ gdb-7.2.50.20110206/gdb/python/py-prettyprint.c 2011-02-06 20:56:30.000000000 +0100
|
||||
--- gdb-7.2.50.20110218.orig/gdb/python/py-prettyprint.c 2011-02-14 12:10:53.000000000 +0100
|
||||
+++ gdb-7.2.50.20110218/gdb/python/py-prettyprint.c 2011-02-18 10:45:02.000000000 +0100
|
||||
@@ -501,7 +501,7 @@ print_children (PyObject *printer, const
|
||||
|
||||
/* Use the prettyprint_arrays option if we are printing an array,
|
||||
@ -103,15 +103,15 @@ Index: gdb-7.2.50.20110206/gdb/python/py-prettyprint.c
|
||||
}
|
||||
|
||||
done:
|
||||
@@ -690,6 +713,7 @@ apply_val_pretty_printer (struct type *t
|
||||
@@ -689,6 +712,7 @@ apply_val_pretty_printer (struct type *t
|
||||
char *hint = NULL;
|
||||
struct cleanup *cleanups;
|
||||
int result = 0;
|
||||
enum string_repr_result print_result;
|
||||
+ struct value_print_options *options_copy;
|
||||
cleanups = ensure_python_env (gdbarch, language);
|
||||
enum string_repr_result print_result;
|
||||
|
||||
/* Instantiate the printer. */
|
||||
@@ -721,9 +745,21 @@ apply_val_pretty_printer (struct type *t
|
||||
/* No pretty-printer support for unavailable values. */
|
||||
@@ -726,9 +750,21 @@ apply_val_pretty_printer (struct type *t
|
||||
|
||||
/* If we are printing a map, we want some special formatting. */
|
||||
hint = gdbpy_get_display_hint (printer);
|
||||
@ -133,10 +133,10 @@ Index: gdb-7.2.50.20110206/gdb/python/py-prettyprint.c
|
||||
print_result = print_string_repr (printer, hint, stream, recurse,
|
||||
options, language, gdbarch);
|
||||
if (print_result != string_repr_error)
|
||||
Index: gdb-7.2.50.20110206/gdb/testsuite/gdb.python/pr10659.cc
|
||||
Index: gdb-7.2.50.20110218/gdb/testsuite/gdb.python/pr10659.cc
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.2.50.20110206/gdb/testsuite/gdb.python/pr10659.cc 2011-02-06 20:55:59.000000000 +0100
|
||||
+++ gdb-7.2.50.20110218/gdb/testsuite/gdb.python/pr10659.cc 2011-02-18 10:44:32.000000000 +0100
|
||||
@@ -0,0 +1,43 @@
|
||||
+#include <list>
|
||||
+#include <vector> // /usr/include/c++/4.4.1/bits/vector.tcc
|
||||
@ -181,10 +181,10 @@ Index: gdb-7.2.50.20110206/gdb/testsuite/gdb.python/pr10659.cc
|
||||
+
|
||||
+ return 0; // break
|
||||
+}
|
||||
Index: gdb-7.2.50.20110206/gdb/testsuite/gdb.python/pr10659.exp
|
||||
Index: gdb-7.2.50.20110218/gdb/testsuite/gdb.python/pr10659.exp
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.2.50.20110206/gdb/testsuite/gdb.python/pr10659.exp 2011-02-06 20:55:59.000000000 +0100
|
||||
+++ gdb-7.2.50.20110218/gdb/testsuite/gdb.python/pr10659.exp 2011-02-18 10:44:32.000000000 +0100
|
||||
@@ -0,0 +1,82 @@
|
||||
+#Copyright 2010 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -268,10 +268,10 @@ Index: gdb-7.2.50.20110206/gdb/testsuite/gdb.python/pr10659.exp
|
||||
+#
|
||||
+
|
||||
+
|
||||
Index: gdb-7.2.50.20110206/gdb/testsuite/gdb.python/pr10659.py
|
||||
Index: gdb-7.2.50.20110218/gdb/testsuite/gdb.python/pr10659.py
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-7.2.50.20110206/gdb/testsuite/gdb.python/pr10659.py 2011-02-06 20:55:59.000000000 +0100
|
||||
+++ gdb-7.2.50.20110218/gdb/testsuite/gdb.python/pr10659.py 2011-02-18 10:44:32.000000000 +0100
|
||||
@@ -0,0 +1,109 @@
|
||||
+# Copyright (C) 2008, 2009 Free Software Foundation, Inc.
|
||||
+
|
||||
@ -382,10 +382,10 @@ Index: gdb-7.2.50.20110206/gdb/testsuite/gdb.python/pr10659.py
|
||||
+fake_pretty_printers_dict = {}
|
||||
+
|
||||
+build_libfakecxx_dictionary ()
|
||||
Index: gdb-7.2.50.20110206/gdb/valprint.c
|
||||
Index: gdb-7.2.50.20110218/gdb/valprint.c
|
||||
===================================================================
|
||||
--- gdb-7.2.50.20110206.orig/gdb/valprint.c 2011-02-06 20:55:52.000000000 +0100
|
||||
+++ gdb-7.2.50.20110206/gdb/valprint.c 2011-02-06 20:55:59.000000000 +0100
|
||||
--- gdb-7.2.50.20110218.orig/gdb/valprint.c 2011-02-18 10:44:16.000000000 +0100
|
||||
+++ gdb-7.2.50.20110218/gdb/valprint.c 2011-02-18 10:44:32.000000000 +0100
|
||||
@@ -85,7 +85,8 @@ struct value_print_options user_print_op
|
||||
1, /* static_field_print */
|
||||
1, /* pascal_static_field_print */
|
||||
|
@ -1,68 +0,0 @@
|
||||
http://sourceware.org/ml/gdb-patches/2011-02/msg00234.html
|
||||
Subject: Re: [rfa/rfc] Build libcommon.a for gdb and gdbserver
|
||||
|
||||
This is a multi-part message in MIME format.
|
||||
--------------030200050701050508020307
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
On 02/12/2011 02:47 AM, Tom Tromey wrote:
|
||||
> common/Makefile.in doesn't have a copyright header.
|
||||
> I didn't check the other files.
|
||||
>
|
||||
|
||||
Add a copyright header to common/Makefile.in. Other files have
|
||||
copyright header. Applied as obvious.
|
||||
|
||||
> "make info" now fails. I didn't check other subdir targets in
|
||||
> gdb/Makefile.in. Automake would solve this plus some other things
|
||||
> ... :-)
|
||||
|
||||
Add some more targets in common/Makefile.in in this patch. `make
|
||||
{info,pdf,html,dvi}' works.
|
||||
|
||||
--
|
||||
Yao (齐尧)
|
||||
|
||||
--------------030200050701050508020307
|
||||
Content-Type: text/x-patch;
|
||||
name="more-targets.patch"
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Content-Disposition: attachment;
|
||||
filename="more-targets.patch"
|
||||
|
||||
common/
|
||||
|
||||
* Makefile.in: Add more targets for make.
|
||||
|
||||
Index: Makefile.in
|
||||
===================================================================
|
||||
RCS file: /cvs/src/src/gdb/common/Makefile.in,v
|
||||
retrieving revision 1.1
|
||||
diff -u -r1.1 Makefile.in
|
||||
--- ./gdb/common/Makefile.in 11 Feb 2011 09:57:25 -0000 1.1
|
||||
+++ ./gdb/common/Makefile.in 12 Feb 2011 02:54:15 -0000
|
||||
@@ -74,3 +91,20 @@
|
||||
distclean maintainer-clean realclean: clean
|
||||
-rm -f *~
|
||||
-rm -f Makefile config.status config.log
|
||||
+
|
||||
+.PHONY: install
|
||||
+install: all
|
||||
+
|
||||
+.PHONY: install-only
|
||||
+install-only:
|
||||
+
|
||||
+.PHONY: uninstall
|
||||
+uninstall:
|
||||
+
|
||||
+.PHONY: check installcheck info dvi pdf html
|
||||
+.PHONY: install-info install-pdf install-html clean-info
|
||||
+check installcheck:
|
||||
+info dvi pdf html:
|
||||
+install-info install-pdf install-html:
|
||||
+clean-info:
|
||||
+
|
||||
|
||||
--------------030200050701050508020307--
|
||||
|
@ -1,206 +0,0 @@
|
||||
http://sourceware.org/ml/gdb-cvs/2011-02/msg00063.html
|
||||
|
||||
### src/gdb/ChangeLog 2011/02/12 13:07:38 1.12557
|
||||
### src/gdb/ChangeLog 2011/02/13 09:09:33 1.12558
|
||||
## -1,3 +1,9 @@
|
||||
+2011-02-13 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
+
|
||||
+ * symtab.c (find_pc_sect_line): New variable objfile, initialize it
|
||||
+ from S. Iterate S using ALL_OBJFILE_SYMTABS. Verify BV for each S.
|
||||
+ * symtab.h (struct symtab) <next>: Comment extension.
|
||||
+
|
||||
2011-02-12 Yao Qi <yao@codesourcery.com>
|
||||
|
||||
* Makefile.in (CLEANDIRS): Remove duplicated common dir.
|
||||
--- src/gdb/symtab.c 2011/01/11 21:53:24 1.257
|
||||
+++ src/gdb/symtab.c 2011/02/13 09:09:36 1.258
|
||||
@@ -1904,6 +1904,7 @@
|
||||
struct blockvector *bv;
|
||||
struct minimal_symbol *msymbol;
|
||||
struct minimal_symbol *mfunsym;
|
||||
+ struct objfile *objfile;
|
||||
|
||||
/* Info on best line seen so far, and where it starts, and its file. */
|
||||
|
||||
@@ -2031,13 +2032,17 @@
|
||||
}
|
||||
|
||||
bv = BLOCKVECTOR (s);
|
||||
+ objfile = s->objfile;
|
||||
|
||||
/* Look at all the symtabs that share this blockvector.
|
||||
They all have the same apriori range, that we found was right;
|
||||
but they have different line tables. */
|
||||
|
||||
- for (; s && BLOCKVECTOR (s) == bv; s = s->next)
|
||||
+ ALL_OBJFILE_SYMTABS (objfile, s)
|
||||
{
|
||||
+ if (BLOCKVECTOR (s) != bv)
|
||||
+ continue;
|
||||
+
|
||||
/* Find the best line in this symtab. */
|
||||
l = LINETABLE (s);
|
||||
if (!l)
|
||||
--- src/gdb/symtab.h 2011/01/11 21:53:25 1.168
|
||||
+++ src/gdb/symtab.h 2011/02/13 09:09:36 1.169
|
||||
@@ -738,8 +738,7 @@
|
||||
|
||||
struct symtab
|
||||
{
|
||||
-
|
||||
- /* Chain of all existing symtabs. */
|
||||
+ /* Unordered chain of all existing symtabs of this objfile. */
|
||||
|
||||
struct symtab *next;
|
||||
|
||||
|
||||
|
||||
|
||||
http://sourceware.org/ml/gdb-cvs/2011-02/msg00064.html
|
||||
|
||||
### src/gdb/ChangeLog 2011/02/13 09:09:33 1.12558
|
||||
### src/gdb/ChangeLog 2011/02/13 09:15:50 1.12559
|
||||
## -1,5 +1,12 @@
|
||||
2011-02-13 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
+ Fix const/volatile qualifiers of C++ types, PR c++/12328.
|
||||
+ * c-typeprint.c (c_type_print_args): Update the function comment. New
|
||||
+ variable param_type, initialize it. Remove const/volatile qualifiers
|
||||
+ for language_cplus and !show_artificial. Use param_type.
|
||||
+
|
||||
+2011-02-13 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
+
|
||||
* symtab.c (find_pc_sect_line): New variable objfile, initialize it
|
||||
from S. Iterate S using ALL_OBJFILE_SYMTABS. Verify BV for each S.
|
||||
* symtab.h (struct symtab) <next>: Comment extension.
|
||||
--- src/gdb/c-typeprint.c 2011/01/07 19:36:15 1.68
|
||||
+++ src/gdb/c-typeprint.c 2011/02/13 09:15:53 1.69
|
||||
@@ -388,9 +388,12 @@
|
||||
/* Print out the arguments of TYPE, which should have TYPE_CODE_METHOD
|
||||
or TYPE_CODE_FUNC, to STREAM. Artificial arguments, such as "this"
|
||||
in non-static methods, are displayed if SHOW_ARTIFICIAL is
|
||||
- non-zero. LANGUAGE is the language in which TYPE was defined.
|
||||
- This is a necessary evil since this code is used by the C, C++, and
|
||||
- Java backends. */
|
||||
+ non-zero. If SHOW_ARTIFICIAL is zero and LANGUAGE is language_cplus
|
||||
+ the topmost parameter types get removed their possible const and volatile
|
||||
+ qualifiers to match demangled linkage name parameters part of such function
|
||||
+ type. LANGUAGE is the language in which TYPE was defined. This is
|
||||
+ a necessary evil since this code is used by the C, C++, and Java backends.
|
||||
+ */
|
||||
|
||||
void
|
||||
c_type_print_args (struct type *type, struct ui_file *stream,
|
||||
@@ -406,6 +409,8 @@
|
||||
|
||||
for (i = 0; i < TYPE_NFIELDS (type); i++)
|
||||
{
|
||||
+ struct type *param_type;
|
||||
+
|
||||
if (TYPE_FIELD_ARTIFICIAL (type, i) && !show_artificial)
|
||||
continue;
|
||||
|
||||
@@ -415,12 +420,24 @@
|
||||
wrap_here (" ");
|
||||
}
|
||||
|
||||
+ param_type = TYPE_FIELD_TYPE (type, i);
|
||||
+
|
||||
+ if (language == language_cplus && !show_artificial)
|
||||
+ {
|
||||
+ /* C++ standard, 13.1 Overloadable declarations, point 3, item:
|
||||
+ - Parameter declarations that differ only in the presence or
|
||||
+ absence of const and/or volatile are equivalent.
|
||||
+
|
||||
+ And the const/volatile qualifiers are not present in the mangled
|
||||
+ names as produced by GCC. */
|
||||
+
|
||||
+ param_type = make_cv_type (0, 0, param_type, NULL);
|
||||
+ }
|
||||
+
|
||||
if (language == language_java)
|
||||
- java_print_type (TYPE_FIELD_TYPE (type, i),
|
||||
- "", stream, -1, 0);
|
||||
+ java_print_type (param_type, "", stream, -1, 0);
|
||||
else
|
||||
- c_print_type (TYPE_FIELD_TYPE (type, i),
|
||||
- "", stream, -1, 0);
|
||||
+ c_print_type (param_type, "", stream, -1, 0);
|
||||
printed_any = 1;
|
||||
}
|
||||
|
||||
### src/gdb/testsuite/ChangeLog 2011/02/08 13:30:08 1.2576
|
||||
### src/gdb/testsuite/ChangeLog 2011/02/13 09:15:53 1.2577
|
||||
## -1,3 +1,9 @@
|
||||
+2011-02-13 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
+
|
||||
+ Fix const/volatile qualifiers of C++ types, PR c++/12328.
|
||||
+ * gdb.cp/overload-const.exp: New file.
|
||||
+ * gdb.cp/overload-const.cc: New file.
|
||||
+
|
||||
2011-02-08 Ulrich Weigand <uweigand@de.ibm.com>
|
||||
|
||||
* gdb.opencl/callfuncs.cl: New file.
|
||||
--- src/gdb/testsuite/gdb.cp/overload-const.cc
|
||||
+++ src/gdb/testsuite/gdb.cp/overload-const.cc 2011-02-13 17:47:15.587780000 +0000
|
||||
@@ -0,0 +1,28 @@
|
||||
+/* This test case is part of GDB, the GNU debugger.
|
||||
+
|
||||
+ Copyright 2011 Free Software Foundation, Inc.
|
||||
+
|
||||
+ This program is free software; you can redistribute it and/or modify
|
||||
+ it under the terms of the GNU General Public License as published by
|
||||
+ the Free Software Foundation; either version 3 of the License, or
|
||||
+ (at your option) any later version.
|
||||
+
|
||||
+ This program is distributed in the hope that it will be useful,
|
||||
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+ GNU General Public License for more details.
|
||||
+
|
||||
+ You should have received a copy of the GNU General Public License
|
||||
+ along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||
+
|
||||
+class myclass
|
||||
+{
|
||||
+public:
|
||||
+ static void func(const int aa) {}
|
||||
+};
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ myclass::func (42);
|
||||
+}
|
||||
--- src/gdb/testsuite/gdb.cp/overload-const.exp
|
||||
+++ src/gdb/testsuite/gdb.cp/overload-const.exp 2011-02-13 17:47:15.884698000 +0000
|
||||
@@ -0,0 +1,29 @@
|
||||
+# Copyright 2011 Free Software Foundation, Inc.
|
||||
+#
|
||||
+# This program is free software; you can redistribute it and/or modify
|
||||
+# it under the terms of the GNU General Public License as published by
|
||||
+# the Free Software Foundation; either version 3 of the License, or
|
||||
+# (at your option) any later version.
|
||||
+#
|
||||
+# This program is distributed in the hope that it will be useful,
|
||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
||||
+# GNU General Public License for more details.
|
||||
+#
|
||||
+# You should have received a copy of the GNU General Public License
|
||||
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
+
|
||||
+# This file is part of the gdb testsuite.
|
||||
+
|
||||
+if {[skip_cplus_tests]} { continue }
|
||||
+
|
||||
+set testfile "overload-const"
|
||||
+if [prepare_for_testing $testfile $testfile $testfile.cc {c++ debug}] {
|
||||
+ return -1
|
||||
+}
|
||||
+
|
||||
+gdb_test_no_output "set language c++"
|
||||
+
|
||||
+if [gdb_breakpoint "myclass::func"] {
|
||||
+ pass "setting breakpoint at myclass::func"
|
||||
+}
|
17
gdb.spec
17
gdb.spec
@ -23,11 +23,11 @@ Name: gdb%{?_with_debug:-debug}
|
||||
# Set version to contents of gdb/version.in.
|
||||
# NOTE: the FSF gdb versions are numbered N.M for official releases, like 6.3
|
||||
# and, since January 2005, X.Y.Z.date for daily snapshots, like 6.3.50.20050112 # (daily snapshot from mailine), or 6.3.0.20040112 (head of the release branch).
|
||||
Version: 7.2.50.20110213
|
||||
Version: 7.2.50.20110218
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 23%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 24%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||
Group: Development/Debuggers
|
||||
@ -264,7 +264,7 @@ Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
||||
|
||||
# Backported fixups post the source tarball.
|
||||
#Xdrop: Just backports.
|
||||
Patch232: gdb-upstream.patch
|
||||
#Patch232: gdb-upstream.patch
|
||||
|
||||
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
||||
#=fedoratest+ppc
|
||||
@ -558,10 +558,6 @@ Patch565: gdb-physname-pr11734-1of2.patch
|
||||
Patch566: gdb-physname-pr11734-2of2.patch
|
||||
Patch567: gdb-physname-pr12273.patch
|
||||
|
||||
# Temporary HEAD compilation fix.
|
||||
# =drop
|
||||
Patch568: gdb-compile-doc-info.patch
|
||||
|
||||
BuildRequires: ncurses-devel%{?_isa} texinfo gettext flex bison expat-devel%{?_isa}
|
||||
Requires: readline%{?_isa}
|
||||
BuildRequires: readline-devel%{?_isa}
|
||||
@ -716,7 +712,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
|
||||
%if 0%{!?_with_upstream:1}
|
||||
|
||||
%patch232 -p1
|
||||
#patch232 -p1
|
||||
%patch349 -p1
|
||||
%patch1 -p1
|
||||
%patch3 -p1
|
||||
@ -831,7 +827,6 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
||||
%patch565 -p1
|
||||
%patch566 -p1
|
||||
%patch567 -p1
|
||||
%patch568 -p1
|
||||
|
||||
%patch390 -p1
|
||||
%patch393 -p1
|
||||
@ -1239,6 +1234,10 @@ fi
|
||||
%{_infodir}/gdb.info*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 18 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20110218-24.fc15
|
||||
- Rebase to FSF GDB 7.2.50.20110218 (which is a 7.3 pre-release).
|
||||
- [vla] Fox Fortran vector slices for allocated arrays (for BZ 609782).
|
||||
|
||||
* Tue Feb 15 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20110213-23.fc15
|
||||
- Move the GFDL License to gdb-doc.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user