Removed. (thread_db_resume): Do not iterate and call clear_lwp_callback.
This commit is contained in:
parent
160bca345d
commit
2d795dbf85
38
gdb-6.3-lwp-cache-20041216.patch
Normal file
38
gdb-6.3-lwp-cache-20041216.patch
Normal file
@ -0,0 +1,38 @@
|
||||
2004-12-16 Jeff Johnston <jjohnstn@redhat.com>
|
||||
|
||||
* thread-db.c (clear_lwp_callback): Removed.
|
||||
(thread_db_resume): Do not iterate and call
|
||||
clear_lwp_callback.
|
||||
|
||||
--- gdb-6.3/gdb/thread-db.c.fix Thu Dec 16 16:32:13 2004
|
||||
+++ gdb-6.3/gdb/thread-db.c Thu Dec 16 16:32:30 2004
|
||||
@@ -822,19 +822,6 @@ thread_db_detach (char *args, int from_t
|
||||
target_beneath->to_detach (args, from_tty);
|
||||
}
|
||||
|
||||
-static int
|
||||
-clear_lwpid_callback (struct thread_info *thread, void *dummy)
|
||||
-{
|
||||
- /* If we know that our thread implementation is 1-to-1, we could save
|
||||
- a certain amount of information; it's not clear how much, so we
|
||||
- are always conservative. */
|
||||
-
|
||||
- thread->private->th_valid = 0;
|
||||
- thread->private->ti_valid = 0;
|
||||
-
|
||||
- return 0;
|
||||
-}
|
||||
-
|
||||
static void
|
||||
thread_db_resume (ptid_t ptid, int step, enum target_signal signo)
|
||||
{
|
||||
@@ -845,9 +832,6 @@ thread_db_resume (ptid_t ptid, int step,
|
||||
else if (is_thread (ptid))
|
||||
ptid = lwp_from_thread (ptid);
|
||||
|
||||
- /* Clear cached data which may not be valid after the resume. */
|
||||
- iterate_over_threads (clear_lwpid_callback, NULL);
|
||||
-
|
||||
target_beneath->to_resume (ptid, step, signo);
|
||||
|
||||
do_cleanups (old_chain);
|
7
gdb.spec
7
gdb.spec
@ -57,8 +57,6 @@ Patch4: gdb-6.3-rh-testlibunwind1fix-20041202.patch
|
||||
Patch50: gdb-6.1post-vsyscall-jul2004.patch
|
||||
#Broken: Patch51: gdb-6.1post-pie-jul2004.patch
|
||||
#Broken: Patch52: gdb-6.1post-test-pie-nov2004.patch
|
||||
# Fix for caching thread lwps for linux
|
||||
Patch77: gdb-6.1post-lwp-cache-oct2004.patch
|
||||
# Fix for allowing macros to continue after backtrace errors
|
||||
Patch78: gdb-6.1post-backtrace-nov2004.patch
|
||||
# Fix to expose multiple constructors to end-user
|
||||
@ -139,6 +137,9 @@ Patch117: gdb-6.3-removebp-20041130.patch
|
||||
# --readnever option.
|
||||
Patch118: gdb-6.3-gstack-20041123.patch
|
||||
|
||||
# Fix for caching thread lwps for linux
|
||||
Patch119: gdb-6.3-lwp-cache-20041216.patch
|
||||
|
||||
%ifarch ia64
|
||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu libunwind >= 0.96-3
|
||||
%else
|
||||
@ -190,10 +191,10 @@ and printing their data.
|
||||
%patch116 -p1
|
||||
%patch117 -p1
|
||||
%patch118 -p1
|
||||
%patch119 -p1
|
||||
|
||||
%patch50 -p1
|
||||
|
||||
%patch77 -p1
|
||||
%patch78 -p1
|
||||
%patch79 -p1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user