- Modify previous gcore patch to only apply to ia64.
This commit is contained in:
parent
20b150be89
commit
28fdd9467e
@ -1,19 +1,19 @@
|
|||||||
2005-02-04 Jeff Johnston <jjohnstn@redhat.com>
|
2005-02-07 Jeff Johnston <jjohnstn@redhat.com>
|
||||||
|
|
||||||
* linux-nat.c (linux_nat_xfer_memory): Don't use
|
* linux-nat.c (linux_nat_xfer_memory): Don't use
|
||||||
linux_proc_xfer_memory for threads.
|
linux_proc_xfer_memory for ia64 threads.
|
||||||
|
|
||||||
--- gdb-6.3/gdb/linux-nat.c.fix Fri Feb 4 22:52:40 2005
|
--- gdb-6.3/gdb/linux-nat.c.fix Fri Feb 4 22:52:40 2005
|
||||||
+++ gdb-6.3/gdb/linux-nat.c Fri Feb 4 22:56:57 2005
|
+++ gdb-6.3/gdb/linux-nat.c Mon Feb 7 19:56:01 2005
|
||||||
@@ -2382,11 +2382,18 @@ linux_nat_xfer_memory (CORE_ADDR memaddr
|
@@ -2381,12 +2381,31 @@ linux_nat_xfer_memory (CORE_ADDR memaddr
|
||||||
|
struct cleanup *old_chain = save_inferior_ptid ();
|
||||||
int xfer;
|
int xfer;
|
||||||
|
|
||||||
if (is_lwp (inferior_ptid))
|
+#ifdef NATIVE_XFER_UNWIND_TABLE
|
||||||
- inferior_ptid = pid_to_ptid (GET_LWP (inferior_ptid));
|
+ /* FIXME: For ia64, we cannot currently use linux_proc_xfer_memory
|
||||||
-
|
+ for accessing thread storage. Revert when Bugzilla 147436
|
||||||
- xfer = linux_proc_xfer_memory (memaddr, myaddr, len, write, attrib, target);
|
+ is fixed. */
|
||||||
- if (xfer == 0)
|
+ if (is_lwp (inferior_ptid))
|
||||||
- xfer = child_xfer_memory (memaddr, myaddr, len, write, attrib, target);
|
|
||||||
+ {
|
+ {
|
||||||
+ /* For lwps, we cannot use linux_proc_xfer_memory. */
|
+ /* For lwps, we cannot use linux_proc_xfer_memory. */
|
||||||
+ inferior_ptid = pid_to_ptid (GET_LWP (inferior_ptid));
|
+ inferior_ptid = pid_to_ptid (GET_LWP (inferior_ptid));
|
||||||
@ -26,6 +26,14 @@
|
|||||||
+ if (xfer == 0)
|
+ if (xfer == 0)
|
||||||
+ xfer = child_xfer_memory (memaddr, myaddr, len, write, attrib, target);
|
+ xfer = child_xfer_memory (memaddr, myaddr, len, write, attrib, target);
|
||||||
+ }
|
+ }
|
||||||
|
+#else
|
||||||
|
if (is_lwp (inferior_ptid))
|
||||||
|
inferior_ptid = pid_to_ptid (GET_LWP (inferior_ptid));
|
||||||
|
|
||||||
|
xfer = linux_proc_xfer_memory (memaddr, myaddr, len, write, attrib, target);
|
||||||
|
if (xfer == 0)
|
||||||
|
xfer = child_xfer_memory (memaddr, myaddr, len, write, attrib, target);
|
||||||
|
+#endif
|
||||||
|
|
||||||
do_cleanups (old_chain);
|
do_cleanups (old_chain);
|
||||||
return xfer;
|
return xfer;
|
||||||
|
5
gdb.spec
5
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
|||||||
Version: 6.3.0.0
|
Version: 6.3.0.0
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 0.
|
# The release always contains a leading reserved number, start it at 0.
|
||||||
Release: 0.16
|
Release: 0.17
|
||||||
|
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -418,6 +418,9 @@ fi
|
|||||||
# don't include the files in include, they are part of binutils
|
# don't include the files in include, they are part of binutils
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 07 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.17
|
||||||
|
- Modify previous gcore patch to only apply to ia64.
|
||||||
|
|
||||||
* Fri Feb 04 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.16
|
* Fri Feb 04 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-0.16
|
||||||
- Fix gcore to work properly for threaded applications
|
- Fix gcore to work properly for threaded applications
|
||||||
- Bugzilla 145309, 145092
|
- Bugzilla 145309, 145092
|
||||||
|
Loading…
Reference in New Issue
Block a user