Update gdb-6.6-buildid-locate.patch to fix RHBZ 2122947.
This commit is contained in:
parent
a6e7b2b18f
commit
267b55ff0e
@ -694,17 +694,16 @@ diff --git a/gdb/build-id.c b/gdb/build-id.c
|
|||||||
if (debug_bfd != NULL)
|
if (debug_bfd != NULL)
|
||||||
return debug_bfd;
|
return debug_bfd;
|
||||||
|
|
||||||
@@ -174,7 +678,8 @@ build_id_to_bfd_suffix (size_t build_id_len, const bfd_byte *build_id,
|
@@ -174,7 +678,7 @@ build_id_to_bfd_suffix (size_t build_id_len, const bfd_byte *build_id,
|
||||||
if (!gdb_sysroot.empty ())
|
if (!gdb_sysroot.empty ())
|
||||||
{
|
{
|
||||||
link = gdb_sysroot + link;
|
link = gdb_sysroot + link;
|
||||||
- debug_bfd = build_id_to_debug_bfd_1 (link, build_id_len, build_id);
|
- debug_bfd = build_id_to_debug_bfd_1 (link, build_id_len, build_id);
|
||||||
+ debug_bfd = build_id_to_debug_bfd_1 (link, build_id_len, build_id,
|
+ debug_bfd = build_id_to_debug_bfd_1 (link, build_id_len, build_id, NULL);
|
||||||
+ link_return);
|
|
||||||
if (debug_bfd != NULL)
|
if (debug_bfd != NULL)
|
||||||
return debug_bfd;
|
return debug_bfd;
|
||||||
}
|
}
|
||||||
@@ -183,30 +688,649 @@ build_id_to_bfd_suffix (size_t build_id_len, const bfd_byte *build_id,
|
@@ -183,30 +687,649 @@ build_id_to_bfd_suffix (size_t build_id_len, const bfd_byte *build_id,
|
||||||
return {};
|
return {};
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -1360,7 +1359,7 @@ diff --git a/gdb/build-id.c b/gdb/build-id.c
|
|||||||
if (build_id != NULL)
|
if (build_id != NULL)
|
||||||
{
|
{
|
||||||
if (separate_debug_file_debug)
|
if (separate_debug_file_debug)
|
||||||
@@ -214,8 +1338,21 @@ find_separate_debug_file_by_buildid (struct objfile *objfile)
|
@@ -214,8 +1337,21 @@ find_separate_debug_file_by_buildid (struct objfile *objfile)
|
||||||
_("\nLooking for separate debug info (build-id) for "
|
_("\nLooking for separate debug info (build-id) for "
|
||||||
"%s\n"), objfile_name (objfile));
|
"%s\n"), objfile_name (objfile));
|
||||||
|
|
||||||
@ -1383,7 +1382,7 @@ diff --git a/gdb/build-id.c b/gdb/build-id.c
|
|||||||
/* Prevent looping on a stripped .debug file. */
|
/* Prevent looping on a stripped .debug file. */
|
||||||
if (abfd != NULL
|
if (abfd != NULL
|
||||||
&& filename_cmp (bfd_get_filename (abfd.get ()),
|
&& filename_cmp (bfd_get_filename (abfd.get ()),
|
||||||
@@ -228,3 +1365,22 @@ find_separate_debug_file_by_buildid (struct objfile *objfile)
|
@@ -228,3 +1364,22 @@ find_separate_debug_file_by_buildid (struct objfile *objfile)
|
||||||
|
|
||||||
return std::string ();
|
return std::string ();
|
||||||
}
|
}
|
||||||
|
5
gdb.spec
5
gdb.spec
@ -51,7 +51,7 @@ Version: 12.1
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||||
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
||||||
@ -1189,6 +1189,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 7 2022 Alexandra Hájková - 12.1-6
|
||||||
|
- Update gdb-6.6-buildid-locate.patch to fix RHBZ 2122947.
|
||||||
|
|
||||||
* Thu Jul 28 2022 Amit Shah <amitshah@fedoraproject.org> - 12.1-5
|
* Thu Jul 28 2022 Amit Shah <amitshah@fedoraproject.org> - 12.1-5
|
||||||
- Use the dist_name macro to identify the distribution
|
- Use the dist_name macro to identify the distribution
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user