- Fix crash on a watchpoint update on an inferior stop.
- Fix the s390x part of the hardware watchpoints after a fork.
This commit is contained in:
parent
ad4fdd5fb5
commit
2234aa8fd6
@ -18,6 +18,10 @@
|
||||
|
||||
Port to gdb-6.7.50.20080227.
|
||||
|
||||
2008-06-01 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
Fix crash on a watchpoint update on an inferior stop.
|
||||
|
||||
Index: gdb-6.8/gdb/dwarf2read.c
|
||||
===================================================================
|
||||
--- gdb-6.8.orig/gdb/dwarf2read.c 2008-04-19 21:38:32.000000000 +0200
|
||||
@ -1023,15 +1027,6 @@ Index: gdb-6.8/gdb/breakpoint.c
|
||||
===================================================================
|
||||
--- gdb-6.8.orig/gdb/breakpoint.c 2008-04-19 21:38:33.000000000 +0200
|
||||
+++ gdb-6.8/gdb/breakpoint.c 2008-04-19 21:38:33.000000000 +0200
|
||||
@@ -973,7 +973,7 @@ update_watchpoint (struct breakpoint *b,
|
||||
}
|
||||
|
||||
/* Look at each value on the value chain. */
|
||||
- for (v = val_chain; v; v = next)
|
||||
+ for (v = val_chain; v; v = value_next (v))
|
||||
{
|
||||
/* If it's a memory location, and GDB actually needed
|
||||
its contents to evaluate the expression, then we
|
||||
@@ -3946,7 +3946,8 @@ describe_other_breakpoints (CORE_ADDR pc
|
||||
printf_filtered (" (thread %d)", b->thread);
|
||||
printf_filtered ("%s%s ",
|
||||
|
@ -23,6 +23,11 @@ http://sourceware.org/ml/gdb-patches/2008-01/msg00042.html
|
||||
* gdb.threads/watchpoint-fork-forkoff.c (forkoff): New delay after the
|
||||
parent/child messages to fix a race.
|
||||
|
||||
2008-05-28 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* s390-nat.c (s390_fix_watch_points): Fix its compilation failure
|
||||
- rename it to S390_FIX_WATCH_POINTS_LIST.
|
||||
|
||||
Index: gdb-6.7.50.20080227/gdb/amd64-linux-nat.c
|
||||
===================================================================
|
||||
--- gdb-6.7.50.20080227.orig/gdb/amd64-linux-nat.c 2008-03-01 10:38:02.000000000 +0100
|
||||
@ -565,7 +570,7 @@ Index: gdb-6.7.50.20080227/gdb/s390-nat.c
|
||||
|
||||
static void
|
||||
-s390_fix_watch_points (ptid_t ptid)
|
||||
+s390_fix_watch_points (int tid, struct watch_area *area_list)
|
||||
+s390_fix_watch_points_list (int tid, struct watch_area *area_list)
|
||||
{
|
||||
- int tid;
|
||||
-
|
||||
|
6
gdb.spec
6
gdb.spec
@ -13,7 +13,7 @@ Version: 6.8
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 9%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 10%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -785,6 +785,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Jun 1 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-10
|
||||
- Fix crash on a watchpoint update on an inferior stop.
|
||||
- Fix the s390x part of the hardware watchpoints after a fork.
|
||||
|
||||
* Thu May 22 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-9
|
||||
- Fix memory trashing on binaries from GNAT/Ada (workaround GCC PR 35998).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user