Fix s390x build.
This commit is contained in:
parent
aa01540273
commit
21721b8b21
@ -30,8 +30,8 @@
|
||||
|
||||
Index: gdb-6.5/gdb/doc/observer.texi
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/doc/observer.texi 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/doc/observer.texi 2006-07-11 05:04:06.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/doc/observer.texi 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/doc/observer.texi 2006-07-11 15:00:15.000000000 -0300
|
||||
@@ -122,3 +122,13 @@ haven't been loaded yet.
|
||||
@deftypefun void solib_unloaded (struct so_list *@var{solib})
|
||||
The shared library specified by @var{solib} has been unloaded.
|
||||
@ -48,8 +48,8 @@ Index: gdb-6.5/gdb/doc/observer.texi
|
||||
+@end deftypefun
|
||||
Index: gdb-6.5/gdb/infrun.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/infrun.c 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/infrun.c 2006-07-11 05:04:07.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/infrun.c 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/infrun.c 2006-07-11 15:00:17.000000000 -0300
|
||||
@@ -1703,9 +1703,19 @@ handle_inferior_event (struct execution_
|
||||
single step over a watchpoint without disabling the watchpoint. */
|
||||
if (HAVE_STEPPABLE_WATCHPOINT && STOPPED_BY_WATCHPOINT (ecs->ws))
|
||||
@ -155,8 +155,8 @@ Index: gdb-6.5/gdb/infrun.c
|
||||
stop_signal = TARGET_SIGNAL_0;
|
||||
Index: gdb-6.5/gdb/breakpoint.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/breakpoint.c 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/breakpoint.c 2006-07-11 05:04:08.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/breakpoint.c 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/breakpoint.c 2006-07-11 15:00:19.000000000 -0300
|
||||
@@ -748,6 +748,90 @@ insert_catchpoint (struct ui_out *uo, vo
|
||||
}
|
||||
}
|
||||
@ -503,8 +503,8 @@ Index: gdb-6.5/gdb/breakpoint.c
|
||||
so that a list of breakpoints will come out in order
|
||||
Index: gdb-6.5/gdb/breakpoint.h
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/breakpoint.h 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/breakpoint.h 2006-07-11 05:04:07.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/breakpoint.h 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/breakpoint.h 2006-07-11 15:00:17.000000000 -0300
|
||||
@@ -426,6 +426,11 @@ struct breakpoint
|
||||
|
||||
/* Is breakpoint pending on shlib loads? */
|
||||
@ -534,8 +534,8 @@ Index: gdb-6.5/gdb/breakpoint.h
|
||||
/* This function can be used to physically insert eventpoints from the
|
||||
Index: gdb-6.5/gdb/linux-nat.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/linux-nat.c 2006-07-11 02:57:28.000000000 -0300
|
||||
+++ gdb-6.5/gdb/linux-nat.c 2006-07-11 05:04:06.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/linux-nat.c 2006-07-11 12:32:29.000000000 -0300
|
||||
+++ gdb-6.5/gdb/linux-nat.c 2006-07-11 15:00:15.000000000 -0300
|
||||
@@ -36,6 +36,7 @@
|
||||
#include "gdbthread.h"
|
||||
#include "gdbcmd.h"
|
||||
@ -585,8 +585,8 @@ Index: gdb-6.5/gdb/linux-nat.c
|
||||
{
|
||||
Index: gdb-6.5/gdb/linux-nat.h
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/linux-nat.h 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/linux-nat.h 2006-07-11 02:57:28.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/linux-nat.h 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/linux-nat.h 2006-07-11 12:32:29.000000000 -0300
|
||||
@@ -63,6 +63,18 @@ struct lwp_info
|
||||
|
||||
/* Next LWP in list. */
|
||||
@ -608,8 +608,8 @@ Index: gdb-6.5/gdb/linux-nat.h
|
||||
/* Attempt to initialize libthread_db. */
|
||||
Index: gdb-6.5/gdb/Makefile.in
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/Makefile.in 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/Makefile.in 2006-07-11 05:04:08.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/Makefile.in 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/Makefile.in 2006-07-11 15:00:19.000000000 -0300
|
||||
@@ -2113,7 +2113,7 @@ i387-tdep.o: i387-tdep.c $(defs_h) $(dou
|
||||
$(gdb_assert_h) $(gdb_string_h) $(i386_tdep_h) $(i387_tdep_h)
|
||||
ia64-linux-nat.o: ia64-linux-nat.c $(defs_h) $(gdb_string_h) $(inferior_h) \
|
||||
@ -630,8 +630,8 @@ Index: gdb-6.5/gdb/Makefile.in
|
||||
$(floatformat_h) $(regcache_h) $(trad_frame_h) $(frame_base_h) \
|
||||
Index: gdb-6.5/gdb/linux-thread-db.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/linux-thread-db.c 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/linux-thread-db.c 2006-07-11 05:04:08.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/linux-thread-db.c 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/linux-thread-db.c 2006-07-11 15:00:18.000000000 -0300
|
||||
@@ -36,6 +36,7 @@
|
||||
#include "target.h"
|
||||
#include "regcache.h"
|
||||
@ -680,8 +680,8 @@ Index: gdb-6.5/gdb/linux-thread-db.c
|
||||
|
||||
Index: gdb-6.5/gdb/i386-linux-nat.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/i386-linux-nat.c 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/i386-linux-nat.c 2006-07-11 05:04:03.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/i386-linux-nat.c 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/i386-linux-nat.c 2006-07-11 15:00:09.000000000 -0300
|
||||
@@ -619,10 +619,9 @@ i386_linux_dr_get (int regnum)
|
||||
int tid;
|
||||
unsigned long value;
|
||||
@ -712,8 +712,8 @@ Index: gdb-6.5/gdb/i386-linux-nat.c
|
||||
ptrace (PTRACE_POKEUSER, tid,
|
||||
Index: gdb-6.5/gdb/ia64-linux-nat.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/ia64-linux-nat.c 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/ia64-linux-nat.c 2006-07-11 05:05:36.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/ia64-linux-nat.c 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/ia64-linux-nat.c 2006-07-11 15:00:00.000000000 -0300
|
||||
@@ -29,6 +29,7 @@
|
||||
#include "regcache.h"
|
||||
#include "ia64-tdep.h"
|
||||
@ -903,8 +903,8 @@ Index: gdb-6.5/gdb/ia64-linux-nat.c
|
||||
}
|
||||
Index: gdb-6.5/gdb/amd64-linux-nat.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/amd64-linux-nat.c 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/amd64-linux-nat.c 2006-07-11 05:04:03.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/amd64-linux-nat.c 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/amd64-linux-nat.c 2006-07-11 15:00:09.000000000 -0300
|
||||
@@ -234,10 +234,9 @@ amd64_linux_dr_get (int regnum)
|
||||
int tid;
|
||||
unsigned long value;
|
||||
@ -935,18 +935,17 @@ Index: gdb-6.5/gdb/amd64-linux-nat.c
|
||||
ptrace (PT_WRITE_U, tid, offsetof (struct user, u_debugreg[regnum]), value);
|
||||
Index: gdb-6.5/gdb/s390-nat.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/s390-nat.c 2006-07-11 02:57:24.000000000 -0300
|
||||
+++ gdb-6.5/gdb/s390-nat.c 2006-07-11 02:57:28.000000000 -0300
|
||||
@@ -30,6 +30,8 @@
|
||||
--- gdb-6.5.orig/gdb/s390-nat.c 2006-07-11 12:30:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/s390-nat.c 2006-07-11 15:00:26.000000000 -0300
|
||||
@@ -30,6 +30,7 @@
|
||||
#include "linux-nat.h"
|
||||
|
||||
#include "s390-tdep.h"
|
||||
+#include "linux-nat.h"
|
||||
+#include "observer.h"
|
||||
|
||||
#include <asm/ptrace.h>
|
||||
#include <sys/ptrace.h>
|
||||
@@ -114,14 +116,14 @@ fill_fpregset (fpregset_t *regp, int reg
|
||||
@@ -114,14 +115,14 @@ fill_fpregset (fpregset_t *regp, int reg
|
||||
((char *)regp) + regmap_fpregset[i]);
|
||||
}
|
||||
|
||||
@ -965,7 +964,7 @@ Index: gdb-6.5/gdb/s390-nat.c
|
||||
|
||||
return tid;
|
||||
}
|
||||
@@ -205,7 +207,7 @@ store_fpregs (int tid, int regnum)
|
||||
@@ -205,7 +206,7 @@ store_fpregs (int tid, int regnum)
|
||||
static void
|
||||
s390_linux_fetch_inferior_registers (int regnum)
|
||||
{
|
||||
@ -974,7 +973,7 @@ Index: gdb-6.5/gdb/s390-nat.c
|
||||
|
||||
if (regnum == -1
|
||||
|| (regnum < S390_NUM_REGS && regmap_gregset[regnum] != -1))
|
||||
@@ -221,7 +223,7 @@ s390_linux_fetch_inferior_registers (int
|
||||
@@ -221,7 +222,7 @@ s390_linux_fetch_inferior_registers (int
|
||||
static void
|
||||
s390_linux_store_inferior_registers (int regnum)
|
||||
{
|
||||
@ -983,7 +982,7 @@ Index: gdb-6.5/gdb/s390-nat.c
|
||||
|
||||
if (regnum == -1
|
||||
|| (regnum < S390_NUM_REGS && regmap_gregset[regnum] != -1))
|
||||
@@ -263,7 +265,7 @@ s390_stopped_by_watchpoint (void)
|
||||
@@ -263,7 +264,7 @@ s390_stopped_by_watchpoint (void)
|
||||
parea.len = sizeof (per_lowcore);
|
||||
parea.process_addr = (addr_t) & per_lowcore;
|
||||
parea.kernel_addr = offsetof (struct user_regs_struct, per_info.lowcore);
|
||||
@ -992,7 +991,7 @@ Index: gdb-6.5/gdb/s390-nat.c
|
||||
perror_with_name (_("Couldn't retrieve watchpoint status"));
|
||||
|
||||
return per_lowcore.perc_storage_alteration == 1
|
||||
@@ -271,9 +273,9 @@ s390_stopped_by_watchpoint (void)
|
||||
@@ -271,9 +272,9 @@ s390_stopped_by_watchpoint (void)
|
||||
}
|
||||
|
||||
static void
|
||||
@ -1004,7 +1003,7 @@ Index: gdb-6.5/gdb/s390-nat.c
|
||||
|
||||
per_struct per_info;
|
||||
ptrace_area parea;
|
||||
@@ -310,6 +312,16 @@ s390_fix_watch_points (void)
|
||||
@@ -310,6 +311,16 @@ s390_fix_watch_points (void)
|
||||
perror_with_name (_("Couldn't modify watchpoint status"));
|
||||
}
|
||||
|
||||
@ -1021,7 +1020,7 @@ Index: gdb-6.5/gdb/s390-nat.c
|
||||
static int
|
||||
s390_insert_watchpoint (CORE_ADDR addr, int len, int type)
|
||||
{
|
||||
@@ -323,10 +335,24 @@ s390_insert_watchpoint (CORE_ADDR addr,
|
||||
@@ -323,10 +334,24 @@ s390_insert_watchpoint (CORE_ADDR addr,
|
||||
area->next = watch_base;
|
||||
watch_base = area;
|
||||
|
||||
@ -1031,23 +1030,23 @@ Index: gdb-6.5/gdb/s390-nat.c
|
||||
+ if (iterate_over_lwps (&s390_insert_watchpoint_callback, NULL))
|
||||
+ return -1;
|
||||
+
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
return 0;
|
||||
}
|
||||
|
||||
+/* Callback routine to use with iterate_over_lwps to remove a specified
|
||||
+ watchpoint from all threads. */
|
||||
+static int
|
||||
+s390_remove_watchpoint_callback (struct lwp_info *lwp, void *data)
|
||||
+{
|
||||
+ s390_fix_watch_points (lwp->ptid);
|
||||
return 0;
|
||||
}
|
||||
|
||||
+ return 0;
|
||||
+}
|
||||
+
|
||||
+/* Remove a specified watchpoint from all threads. */
|
||||
static int
|
||||
s390_remove_watchpoint (CORE_ADDR addr, int len, int type)
|
||||
{
|
||||
@@ -348,7 +374,11 @@ s390_remove_watchpoint (CORE_ADDR addr,
|
||||
@@ -348,7 +373,11 @@ s390_remove_watchpoint (CORE_ADDR addr,
|
||||
*parea = area->next;
|
||||
xfree (area);
|
||||
|
||||
@ -1060,7 +1059,7 @@ Index: gdb-6.5/gdb/s390-nat.c
|
||||
return 0;
|
||||
}
|
||||
|
||||
@@ -364,6 +394,15 @@ s390_region_ok_for_hw_watchpoint (CORE_A
|
||||
@@ -364,6 +393,15 @@ s390_region_ok_for_hw_watchpoint (CORE_A
|
||||
return 1;
|
||||
}
|
||||
|
||||
@ -1076,7 +1075,7 @@ Index: gdb-6.5/gdb/s390-nat.c
|
||||
|
||||
void _initialize_s390_nat (void);
|
||||
|
||||
@@ -389,4 +428,6 @@ _initialize_s390_nat (void)
|
||||
@@ -389,4 +427,6 @@ _initialize_s390_nat (void)
|
||||
|
||||
/* Register the target. */
|
||||
linux_nat_add_target (t);
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: gdb-6.5/gdb/configure
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/configure 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/configure 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/configure 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/configure 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -20125,7 +20125,8 @@ fi
|
||||
# gdb/doc/gdbint.texinfo.
|
||||
build_warnings="-Wimplicit -Wreturn-type -Wcomment -Wtrigraphs \
|
||||
@ -14,8 +14,8 @@ Index: gdb-6.5/gdb/configure
|
||||
if test x${CFLAGS+set} = xset; then
|
||||
Index: gdb-6.5/gdb/mi/mi-cmd-env.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/mi/mi-cmd-env.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-cmd-env.c 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/mi/mi-cmd-env.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-cmd-env.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -126,7 +126,7 @@ mi_cmd_env_path (char *command, char **a
|
||||
static struct mi_opt opts[] =
|
||||
{
|
||||
@ -36,8 +36,8 @@ Index: gdb-6.5/gdb/mi/mi-cmd-env.c
|
||||
dont_repeat ();
|
||||
Index: gdb-6.5/gdb/mi/mi-getopt.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/mi/mi-getopt.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-getopt.c 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/mi/mi-getopt.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-getopt.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -82,7 +82,7 @@ mi_valid_noargs (const char *prefix, int
|
||||
char *optarg;
|
||||
static struct mi_opt opts[] =
|
||||
@ -49,8 +49,8 @@ Index: gdb-6.5/gdb/mi/mi-getopt.c
|
||||
if (mi_getopt (prefix, argc, argv, opts, &optind, &optarg) == -1)
|
||||
Index: gdb-6.5/gdb/mi/mi-cmd-break.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/mi/mi-cmd-break.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-cmd-break.c 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/mi/mi-cmd-break.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-cmd-break.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -90,7 +90,7 @@ mi_cmd_break_insert (char *command, char
|
||||
{"c", CONDITION_OPT, 1},
|
||||
{"i", IGNORE_COUNT_OPT, 1},
|
||||
@ -71,8 +71,8 @@ Index: gdb-6.5/gdb/mi/mi-cmd-break.c
|
||||
/* Parse arguments. */
|
||||
Index: gdb-6.5/gdb/mi/mi-cmd-disas.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/mi/mi-cmd-disas.c 2006-07-11 02:47:12.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-cmd-disas.c 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/mi/mi-cmd-disas.c 2006-07-11 15:01:22.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-cmd-disas.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -84,7 +84,7 @@ mi_cmd_disassemble (char *command, char
|
||||
{"n", NUM_OPT, 1},
|
||||
{"s", START_OPT, 1},
|
||||
@ -84,8 +84,8 @@ Index: gdb-6.5/gdb/mi/mi-cmd-disas.c
|
||||
/* Get the options with their arguments. Keep track of what we
|
||||
Index: gdb-6.5/gdb/mi/mi-main.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/mi/mi-main.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-main.c 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/mi/mi-main.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/mi/mi-main.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -773,7 +773,7 @@ mi_cmd_data_read_memory (char *command,
|
||||
static struct mi_opt opts[] =
|
||||
{
|
||||
@ -106,8 +106,8 @@ Index: gdb-6.5/gdb/mi/mi-main.c
|
||||
while (1)
|
||||
Index: gdb-6.5/gdb/p-valprint.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/p-valprint.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/p-valprint.c 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/p-valprint.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/p-valprint.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -753,7 +753,7 @@ pascal_object_print_value_fields (struct
|
||||
int dont_print_statmem)
|
||||
{
|
||||
@ -128,8 +128,8 @@ Index: gdb-6.5/gdb/p-valprint.c
|
||||
int i, n_baseclasses = TYPE_N_BASECLASSES (type);
|
||||
Index: gdb-6.5/gdb/cp-valprint.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/cp-valprint.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/cp-valprint.c 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/cp-valprint.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/cp-valprint.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -265,7 +265,7 @@ cp_print_value_fields (struct type *type
|
||||
struct type **dont_print_vb,int dont_print_statmem)
|
||||
{
|
||||
@ -150,8 +150,8 @@ Index: gdb-6.5/gdb/cp-valprint.c
|
||||
int i, n_baseclasses = TYPE_N_BASECLASSES (type);
|
||||
Index: gdb-6.5/gdb/tui/tui-layout.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/tui/tui-layout.c 2006-07-11 02:47:12.000000000 -0300
|
||||
+++ gdb-6.5/gdb/tui/tui-layout.c 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/tui/tui-layout.c 2006-07-11 15:01:22.000000000 -0300
|
||||
+++ gdb-6.5/gdb/tui/tui-layout.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -755,7 +755,7 @@ show_source_disasm_command (void)
|
||||
if (TUI_DISASM_WIN == NULL)
|
||||
{
|
||||
@ -190,8 +190,8 @@ Index: gdb-6.5/gdb/tui/tui-layout.c
|
||||
tui_term_width (),
|
||||
Index: gdb-6.5/gdb/testsuite/gdb.base/move-dir.h
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/testsuite/gdb.base/move-dir.h 2006-07-11 02:47:12.000000000 -0300
|
||||
+++ gdb-6.5/gdb/testsuite/gdb.base/move-dir.h 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/testsuite/gdb.base/move-dir.h 2006-07-11 15:01:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/testsuite/gdb.base/move-dir.h 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -1,4 +1,4 @@
|
||||
-#include <stdlib.h>
|
||||
+#include <stdio.h>
|
||||
@ -200,8 +200,8 @@ Index: gdb-6.5/gdb/testsuite/gdb.base/move-dir.h
|
||||
const char* ostring = "other";
|
||||
Index: gdb-6.5/gdb/testsuite/gdb.base/sigrepeat.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/testsuite/gdb.base/sigrepeat.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/testsuite/gdb.base/sigrepeat.c 2006-07-11 02:47:23.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/testsuite/gdb.base/sigrepeat.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/testsuite/gdb.base/sigrepeat.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -22,6 +22,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
@ -212,9 +212,19 @@ Index: gdb-6.5/gdb/testsuite/gdb.base/sigrepeat.c
|
||||
static volatile int done[2];
|
||||
Index: gdb-6.5/gdb/s390-tdep.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/s390-tdep.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/s390-tdep.c 2006-07-11 02:47:23.000000000 -0300
|
||||
@@ -2309,6 +2309,9 @@ s390_return_value (struct gdbarch *gdbar
|
||||
--- gdb-6.5.orig/gdb/s390-tdep.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/s390-tdep.c 2006-07-11 15:02:37.000000000 -0300
|
||||
@@ -2277,6 +2277,9 @@ s390_return_value (struct gdbarch *gdbar
|
||||
case RETURN_VALUE_STRUCT_CONVENTION:
|
||||
error (_("Cannot set function return value."));
|
||||
break;
|
||||
+
|
||||
+ default:
|
||||
+ break;
|
||||
}
|
||||
}
|
||||
else if (out)
|
||||
@@ -2309,6 +2312,9 @@ s390_return_value (struct gdbarch *gdbar
|
||||
case RETURN_VALUE_STRUCT_CONVENTION:
|
||||
error (_("Function return value unknown."));
|
||||
break;
|
||||
@ -226,8 +236,8 @@ Index: gdb-6.5/gdb/s390-tdep.c
|
||||
|
||||
Index: gdb-6.5/gdb/remote.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/remote.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/remote.c 2006-07-11 02:49:02.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/remote.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/remote.c 2006-07-11 15:02:32.000000000 -0300
|
||||
@@ -2523,10 +2523,10 @@ cleanup_sigint_signal_handler (void *dum
|
||||
{
|
||||
signal (SIGINT, handle_sigint);
|
||||
@ -243,8 +253,8 @@ Index: gdb-6.5/gdb/remote.c
|
||||
|
||||
Index: gdb-6.5/gdb/f-exp.y
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/f-exp.y 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/f-exp.y 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/f-exp.y 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/f-exp.y 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -567,6 +567,8 @@ ptype : typebase
|
||||
case tp_function:
|
||||
follow_type = lookup_function_type (follow_type);
|
||||
@ -256,8 +266,8 @@ Index: gdb-6.5/gdb/f-exp.y
|
||||
}
|
||||
Index: gdb-6.5/gdb/remote-fileio.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/remote-fileio.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/remote-fileio.c 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/remote-fileio.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/remote-fileio.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -1317,19 +1317,19 @@ static struct {
|
||||
char *name;
|
||||
void (*func)(char *);
|
||||
@ -293,8 +303,8 @@ Index: gdb-6.5/gdb/remote-fileio.c
|
||||
static int
|
||||
Index: gdb-6.5/gdb/source.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/source.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/source.c 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/source.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/source.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -160,7 +160,7 @@ get_current_source_symtab_and_line (void
|
||||
void
|
||||
set_default_source_symtab_and_line (void)
|
||||
@ -315,8 +325,8 @@ Index: gdb-6.5/gdb/source.c
|
||||
|
||||
Index: gdb-6.5/gdb/symfile.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/symfile.c 2006-07-11 02:47:11.000000000 -0300
|
||||
+++ gdb-6.5/gdb/symfile.c 2006-07-11 02:52:26.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/symfile.c 2006-07-11 15:01:22.000000000 -0300
|
||||
+++ gdb-6.5/gdb/symfile.c 2006-07-11 15:02:34.000000000 -0300
|
||||
@@ -2877,6 +2877,8 @@ add_psymbol_with_dem_name_to_list (char
|
||||
deprecated_bcache (buf, dem_namelength + 1, objfile->psymbol_cache);
|
||||
break;
|
||||
@ -328,8 +338,8 @@ Index: gdb-6.5/gdb/symfile.c
|
||||
/* val and coreaddr are mutually exclusive, one of them *will* be zero */
|
||||
Index: gdb-6.5/gdb/linespec.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/linespec.c 2006-07-11 02:47:12.000000000 -0300
|
||||
+++ gdb-6.5/gdb/linespec.c 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/linespec.c 2006-07-11 15:01:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/linespec.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -1631,7 +1631,7 @@ static struct symtabs_and_lines
|
||||
find_method (int funfirstline, char ***canonical, char *saved_arg,
|
||||
char *copy, struct type *t, struct symbol *sym_class)
|
||||
@ -341,8 +351,8 @@ Index: gdb-6.5/gdb/linespec.c
|
||||
struct symbol **sym_arr = alloca (total_number_of_methods (t)
|
||||
Index: gdb-6.5/gdb/macroscope.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/macroscope.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/macroscope.c 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/macroscope.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/macroscope.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -33,7 +33,7 @@
|
||||
struct macro_scope *
|
||||
sal_macro_scope (struct symtab_and_line sal)
|
||||
@ -382,8 +392,8 @@ Index: gdb-6.5/gdb/macroscope.c
|
||||
/* If there's a selected frame, use its PC. */
|
||||
Index: gdb-6.5/gdb/target.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/target.c 2006-07-11 02:47:12.000000000 -0300
|
||||
+++ gdb-6.5/gdb/target.c 2006-07-11 02:52:25.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/target.c 2006-07-11 15:01:22.000000000 -0300
|
||||
+++ gdb-6.5/gdb/target.c 2006-07-11 15:02:33.000000000 -0300
|
||||
@@ -1142,6 +1142,9 @@ target_xfer_memory (CORE_ADDR memaddr, g
|
||||
if (!write)
|
||||
return EIO;
|
||||
@ -406,8 +416,8 @@ Index: gdb-6.5/gdb/target.c
|
||||
if (region->attrib.cache)
|
||||
Index: gdb-6.5/gdb/gdb-events.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/gdb-events.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/gdb-events.c 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/gdb-events.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/gdb-events.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -321,6 +321,8 @@ gdb_events_deliver (struct gdb_events *v
|
||||
case architecture_changed:
|
||||
vector->architecture_changed ();
|
||||
@ -419,8 +429,8 @@ Index: gdb-6.5/gdb/gdb-events.c
|
||||
xfree (event);
|
||||
Index: gdb-6.5/gdb/dwarf2read.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/dwarf2read.c 2006-07-11 02:47:12.000000000 -0300
|
||||
+++ gdb-6.5/gdb/dwarf2read.c 2006-07-11 02:52:25.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/dwarf2read.c 2006-07-11 15:01:23.000000000 -0300
|
||||
+++ gdb-6.5/gdb/dwarf2read.c 2006-07-11 15:02:33.000000000 -0300
|
||||
@@ -9179,6 +9179,7 @@ dwarf_decode_macros (struct line_header
|
||||
for (;;)
|
||||
{
|
||||
@ -453,8 +463,8 @@ Index: gdb-6.5/gdb/dwarf2read.c
|
||||
{
|
||||
Index: gdb-6.5/gdb/stabsread.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/stabsread.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/stabsread.c 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/stabsread.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/stabsread.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -1794,7 +1794,8 @@ again:
|
||||
struct type *domain = read_type (pp, objfile);
|
||||
struct type *return_type;
|
||||
@ -467,8 +477,8 @@ Index: gdb-6.5/gdb/stabsread.c
|
||||
/* Invalid member type data format. */
|
||||
Index: gdb-6.5/gdb/dwarf2expr.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/dwarf2expr.c 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/dwarf2expr.c 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/dwarf2expr.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/dwarf2expr.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -559,6 +559,8 @@ execute_stack_op (struct dwarf_expr_cont
|
||||
op_ptr = read_uleb128 (op_ptr, op_end, ®);
|
||||
result += reg;
|
||||
@ -480,8 +490,8 @@ Index: gdb-6.5/gdb/dwarf2expr.c
|
||||
|
||||
Index: gdb-6.5/gdb/varobj.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/varobj.c 2006-07-11 02:47:21.000000000 -0300
|
||||
+++ gdb-6.5/gdb/varobj.c 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/varobj.c 2006-07-11 15:01:22.000000000 -0300
|
||||
+++ gdb-6.5/gdb/varobj.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -325,10 +325,9 @@ struct language_specific
|
||||
|
||||
/* Array of known source language routines. */
|
||||
@ -536,8 +546,8 @@ Index: gdb-6.5/gdb/varobj.c
|
||||
var->root->rootvar = var;
|
||||
Index: gdb-6.5/gdb/configure.ac
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/configure.ac 2006-07-11 02:46:52.000000000 -0300
|
||||
+++ gdb-6.5/gdb/configure.ac 2006-07-11 02:47:24.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/configure.ac 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/configure.ac 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -1133,7 +1133,8 @@ fi
|
||||
# gdb/doc/gdbint.texinfo.
|
||||
build_warnings="-Wimplicit -Wreturn-type -Wcomment -Wtrigraphs \
|
||||
@ -550,8 +560,8 @@ Index: gdb-6.5/gdb/configure.ac
|
||||
if test x${CFLAGS+set} = xset; then
|
||||
Index: gdb-6.5/gdb/doublest.c
|
||||
===================================================================
|
||||
--- gdb-6.5.orig/gdb/doublest.c 2005-12-17 20:33:59.000000000 -0200
|
||||
+++ gdb-6.5/gdb/doublest.c 2006-07-11 02:55:55.000000000 -0300
|
||||
--- gdb-6.5.orig/gdb/doublest.c 2006-07-11 15:00:08.000000000 -0300
|
||||
+++ gdb-6.5/gdb/doublest.c 2006-07-11 15:01:23.000000000 -0300
|
||||
@@ -94,15 +94,10 @@ get_field (const bfd_byte *data, enum fl
|
||||
{
|
||||
result |= (unsigned long)*(data + cur_byte) << cur_bitshift;
|
||||
|
Loading…
Reference in New Issue
Block a user