Rebase to FSF GDB 7.11.50.20160721 (pre-7.12 trunk snapshot).
This commit is contained in:
parent
7306e88eb4
commit
1e35566c47
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
/gdb-libstdc++-v3-python-r225521.tar.xz
|
||||
/gdb-7.11.50.20160716.tar.xz
|
||||
/gdb-7.11.50.20160721.tar.xz
|
||||
|
@ -1,54 +0,0 @@
|
||||
http://sourceware.org/ml/gdb-patches/2016-07/msg00180.html
|
||||
Subject: [testsuite patch] Skip py-unwind.exp on x86_64 -m32
|
||||
|
||||
|
||||
--vkogqOf2sHV7VnPd
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline
|
||||
|
||||
Hi,
|
||||
|
||||
(gdb) source /home/jkratoch/redhat/gdb-clean/gdb/testsuite/outputs/gdb.python/py-unwind/py-unwind.py^M
|
||||
Python script imported^M
|
||||
Python Exception <type 'exceptions.ValueError'> Bad register: ^M
|
||||
(gdb) FAIL: gdb.python/py-unwind.exp: import python scripts
|
||||
|
||||
class TestUnwinder(Unwinder):
|
||||
AMD64_RBP = 6
|
||||
AMD64_RSP = 7
|
||||
AMD64_RIP = 16
|
||||
|
||||
This was already discussed here:
|
||||
Re: [testsuite patch] Fix gdb.btrace/tailcall-only.exp errors on x86_64-m32
|
||||
https://sourceware.org/ml/gdb-patches/2016-04/msg00222.html
|
||||
Message-ID: <20160411195537.GA22299@host1.jankratochvil.net>
|
||||
but no GDB maintainer gave an answer how to run testsuite in cross-arch mode.
|
||||
|
||||
|
||||
Jan
|
||||
|
||||
--vkogqOf2sHV7VnPd
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline; filename=1
|
||||
|
||||
gdb/testsuite/ChangeLog
|
||||
2016-07-17 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* gdb.python/py-unwind.exp: Test also ![is_lp64_target].
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.python/py-unwind.exp b/gdb/testsuite/gdb.python/py-unwind.exp
|
||||
index 5172a03..e31a472 100644
|
||||
--- a/gdb/testsuite/gdb.python/py-unwind.exp
|
||||
+++ b/gdb/testsuite/gdb.python/py-unwind.exp
|
||||
@@ -28,7 +28,7 @@ if { [prepare_for_testing ${testfile}.exp ${testfile} ${srcfile}] } {
|
||||
if { [skip_python_tests] } { continue }
|
||||
|
||||
# This test runs on a specific platform.
|
||||
-if { ! [istarget x86_64-*]} { continue }
|
||||
+if { ![istarget x86_64-*-* ] || ![is_lp64_target] } { continue }
|
||||
|
||||
# The following tests require execution.
|
||||
|
||||
|
||||
--vkogqOf2sHV7VnPd--
|
||||
|
@ -1,66 +0,0 @@
|
||||
http://sourceware.org/ml/gdb-patches/2016-07/msg00179.html
|
||||
Subject: [testsuite patch] Fix gdb.gdb/selftest.exp for C++-O2-g-built GDB
|
||||
|
||||
|
||||
--ZGiS0Q5IWpPtfppv
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline
|
||||
|
||||
Hi,
|
||||
|
||||
tested on Fedora 24 x86_64 after:
|
||||
./configure; make
|
||||
That is: CFLAGS='-g -O2' CXXFLAGS='-g -O2'
|
||||
|
||||
OK for check-in?
|
||||
|
||||
|
||||
Jan
|
||||
|
||||
--ZGiS0Q5IWpPtfppv
|
||||
Content-Type: text/plain; charset=us-ascii
|
||||
Content-Disposition: inline; filename=1
|
||||
|
||||
gdb/testsuite/ChangeLog
|
||||
2016-07-16 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||
|
||||
* gdb.gdb/selftest.exp (do_steps_and_nexts): Add "next over TRY" and
|
||||
"step into captured_main (args)".
|
||||
(test_with_self): Add "captured_main (args);" case.
|
||||
|
||||
diff --git a/gdb/testsuite/gdb.gdb/selftest.exp b/gdb/testsuite/gdb.gdb/selftest.exp
|
||||
index af0026c..2cdd5c1 100644
|
||||
--- a/gdb/testsuite/gdb.gdb/selftest.exp
|
||||
+++ b/gdb/testsuite/gdb.gdb/selftest.exp
|
||||
@@ -116,6 +116,14 @@ proc do_steps_and_nexts {} {
|
||||
set description "next over lim_at_start initialization"
|
||||
set command "next"
|
||||
}
|
||||
+ -re ".*TRY.*$gdb_prompt $" {
|
||||
+ set description "next over TRY"
|
||||
+ set command "next"
|
||||
+ }
|
||||
+ -re ".*captured_main \\(args\\);.*$gdb_prompt $" {
|
||||
+ set description "step into captured_main (args)"
|
||||
+ set command "step"
|
||||
+ }
|
||||
-re ".*count . 0x3.*$gdb_prompt $" {
|
||||
set description "next over conditional stack alignment code 1"
|
||||
set command "next"
|
||||
@@ -330,6 +338,13 @@ proc test_with_self { executable } {
|
||||
-re "Starting program.*Breakpoint \[0-9\]+,.*captured_main .data.*$gdb_prompt $" {
|
||||
xfail "$description (line numbers scrambled?)"
|
||||
}
|
||||
+ -re "captured_main \\(args\\);\r\n$gdb_prompt $" {
|
||||
+ gdb_test_multiple "step" "$description" {
|
||||
+ -re "captured_main .data.* at .*main.c:.*$gdb_prompt $" {
|
||||
+ pass "$description"
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
-re "vfork: No more processes.*$gdb_prompt $" {
|
||||
fail "$description (out of virtual memory)"
|
||||
set timeout $oldtimeout
|
||||
|
||||
--ZGiS0Q5IWpPtfppv--
|
||||
|
15
gdb.spec
15
gdb.spec
@ -19,7 +19,7 @@ Summary: A GNU source-level debugger for C, C++, Fortran, Go and other languages
|
||||
Name: %{?scl_prefix}gdb
|
||||
|
||||
# Freeze it when GDB gets branched
|
||||
%global snapsrc 20160716
|
||||
%global snapsrc 20160721
|
||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||
%global snapgnulib 20150822
|
||||
%global tarname gdb-%{version}
|
||||
@ -27,7 +27,7 @@ Version: 7.11.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||
Group: Development/Debuggers
|
||||
@ -574,12 +574,6 @@ Patch1120: gdb-testsuite-dw2-undefined-ret-addr.patch
|
||||
# New test for Python "Cannot locate object file for block" (for RH BZ 1325795).
|
||||
Patch1123: gdb-rhbz1325795-framefilters-test.patch
|
||||
|
||||
# [testsuite] Fix gdb.gdb/selftest.exp for C++-O2-g-built GDB.
|
||||
Patch1139: gdb-testsuite-selftest-cxx.patch
|
||||
|
||||
# [testsuite] Skip py-unwind.exp on x86_64 -m32.
|
||||
Patch1140: gdb-testsuite-py-unwind-m32.patch
|
||||
|
||||
%if 0%{!?rhel:1} || 0%{?rhel} > 6
|
||||
# RL_STATE_FEDORA_GDB would not be found for:
|
||||
# Patch642: gdb-readline62-ask-more-rh.patch
|
||||
@ -896,8 +890,6 @@ find -name "*.info*"|xargs rm -f
|
||||
%patch1118 -p1
|
||||
%patch1120 -p1
|
||||
%patch1123 -p1
|
||||
%patch1139 -p1
|
||||
%patch1140 -p1
|
||||
|
||||
%patch1075 -p1
|
||||
%if 0%{?rhel:1} && 0%{?rhel} <= 7
|
||||
@ -1420,6 +1412,9 @@ then
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Thu Jul 21 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11.50.20160721-2.fc25
|
||||
- Rebase to FSF GDB 7.11.50.20160721 (pre-7.12 trunk snapshot).
|
||||
|
||||
* Sun Jul 17 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11.50.20160716-1.fc25
|
||||
- Rebase to FSF GDB 7.11.50.20160716 (pre-7.12 trunk snapshot).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user