[aarch64] Backport two fixes (BZ 1026484).
This commit is contained in:
parent
fe74423b08
commit
1d5872dcff
77
gdb-upstream.patch
Normal file
77
gdb-upstream.patch
Normal file
@ -0,0 +1,77 @@
|
|||||||
|
commit 1aa4cd774ca674ee6061e2068a410bb67c8bc812
|
||||||
|
Author: Andrew Pinski <apinski@cavium.com>
|
||||||
|
Date: Thu Sep 12 07:14:37 2013 +0000
|
||||||
|
|
||||||
|
2013-09-12 Andrew Pinski <apinski@cavium.com>
|
||||||
|
|
||||||
|
* aarch64-linux-nat.c (aarch64_linux_set_debug_regs): Zero out regs.
|
||||||
|
|
||||||
|
diff --git a/gdb/ChangeLog b/gdb/ChangeLog
|
||||||
|
index fa3de16..903dcba 100644
|
||||||
|
### a/gdb/ChangeLog
|
||||||
|
### b/gdb/ChangeLog
|
||||||
|
## -1,3 +1,7 @@
|
||||||
|
+2013-09-12 Andrew Pinski <apinski@cavium.com>
|
||||||
|
+
|
||||||
|
+ * aarch64-linux-nat.c (aarch64_linux_set_debug_regs): Zero out regs.
|
||||||
|
+
|
||||||
|
2013-09-10 Andreas Arnez <arnez@linux.vnet.ibm.com>
|
||||||
|
|
||||||
|
* config/s390/s390.mh (NATDEPFILES): Add linux-waitpid.o.
|
||||||
|
diff --git a/gdb/aarch64-linux-nat.c b/gdb/aarch64-linux-nat.c
|
||||||
|
index 846f156..f685619 100644
|
||||||
|
--- a/gdb/aarch64-linux-nat.c
|
||||||
|
+++ b/gdb/aarch64-linux-nat.c
|
||||||
|
@@ -312,6 +312,7 @@ aarch64_linux_set_debug_regs (const struct aarch64_debug_reg_state *state,
|
||||||
|
const CORE_ADDR *addr;
|
||||||
|
const unsigned int *ctrl;
|
||||||
|
|
||||||
|
+ memset (®s, 0, sizeof (regs));
|
||||||
|
iov.iov_base = ®s;
|
||||||
|
iov.iov_len = sizeof (regs);
|
||||||
|
count = watchpoint ? aarch64_num_wp_regs : aarch64_num_bp_regs;
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
commit 05feb1933f80f2d55e132adc657d3152947af3d1
|
||||||
|
Author: Will Newton <willnewton@sourceware.org>
|
||||||
|
Date: Thu Oct 10 10:40:42 2013 +0000
|
||||||
|
|
||||||
|
gdb/aarch64-linux-tdep.c: Call linux_init_abi.
|
||||||
|
|
||||||
|
If we are running on a Linux platform we should call linux_init_abi
|
||||||
|
in order to get all the useful hooks it enables.
|
||||||
|
|
||||||
|
gdb/ChangeLog:
|
||||||
|
|
||||||
|
2013-10-10 Will Newton <will.newton@linaro.org>
|
||||||
|
|
||||||
|
* aarch64-linux-tdep.c (aarch64_linux_init_abi): Call
|
||||||
|
linux_init_abi.
|
||||||
|
|
||||||
|
diff --git a/gdb/ChangeLog b/gdb/ChangeLog
|
||||||
|
index 4372579..7a41967 100644
|
||||||
|
### a/gdb/ChangeLog
|
||||||
|
### b/gdb/ChangeLog
|
||||||
|
## -1,3 +1,8 @@
|
||||||
|
+2013-10-10 Will Newton <will.newton@linaro.org>
|
||||||
|
+
|
||||||
|
+ * aarch64-linux-tdep.c (aarch64_linux_init_abi): Call
|
||||||
|
+ linux_init_abi.
|
||||||
|
+
|
||||||
|
2013-10-10 Joel Brobecker <brobecker@adacore.com>
|
||||||
|
|
||||||
|
* cli/cli-cmds.c (show_baud_rate): Moved to serial.c as
|
||||||
|
diff --git a/gdb/aarch64-linux-tdep.c b/gdb/aarch64-linux-tdep.c
|
||||||
|
index 8e66425..bcfcce2 100644
|
||||||
|
--- a/gdb/aarch64-linux-tdep.c
|
||||||
|
+++ b/gdb/aarch64-linux-tdep.c
|
||||||
|
@@ -270,6 +270,8 @@ aarch64_linux_init_abi (struct gdbarch_info info, struct gdbarch *gdbarch)
|
||||||
|
|
||||||
|
tdep->lowest_pc = 0x8000;
|
||||||
|
|
||||||
|
+ linux_init_abi (info, gdbarch);
|
||||||
|
+
|
||||||
|
set_solib_svr4_fetch_link_map_offsets (gdbarch,
|
||||||
|
svr4_lp64_fetch_link_map_offsets);
|
||||||
|
|
9
gdb.spec
9
gdb.spec
@ -38,7 +38,7 @@ Version: 7.6.50.%{snap}
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 14%{?dist}
|
Release: 15%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -235,7 +235,7 @@ Patch231: gdb-6.3-bz202689-exec-from-pthread-test.patch
|
|||||||
|
|
||||||
# Backported fixups post the source tarball.
|
# Backported fixups post the source tarball.
|
||||||
#Xdrop: Just backports.
|
#Xdrop: Just backports.
|
||||||
#Patch232: gdb-upstream.patch
|
Patch232: gdb-upstream.patch
|
||||||
|
|
||||||
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
# Testcase for PPC Power6/DFP instructions disassembly (BZ 230000).
|
||||||
#=fedoratest+ppc
|
#=fedoratest+ppc
|
||||||
@ -723,7 +723,7 @@ find -name "*.info*"|xargs rm -f
|
|||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
|
|
||||||
%patch349 -p1
|
%patch349 -p1
|
||||||
#patch232 -p1
|
%patch232 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
|
||||||
%patch105 -p1
|
%patch105 -p1
|
||||||
@ -1340,6 +1340,9 @@ fi
|
|||||||
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
%endif # 0%{!?el5:1} || "%{_target_cpu}" == "noarch"
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 5 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.6.50.20130731-15.fc20
|
||||||
|
- [aarch64] Backport two fixes (BZ 1026484).
|
||||||
|
|
||||||
* Sun Nov 3 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.6.50.20130731-14.fc20
|
* Sun Nov 3 2013 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.6.50.20130731-14.fc20
|
||||||
- Fix %{_bindir}gdb-add-index to also use -iex 'set auto-load no'.
|
- Fix %{_bindir}gdb-add-index to also use -iex 'set auto-load no'.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user