Rebase to FSF GDB 8.3.50.20190425 (8.4pre), and fix build breakage.
This commit is contained in:
parent
e507809c35
commit
1b0ecbf0a5
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,3 +1,3 @@
|
|||||||
/gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz
|
/gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz
|
||||||
/v2.0.tar.gz
|
/v2.0.tar.gz
|
||||||
/gdb-8.3.50.20190424.tar.xz
|
/gdb-8.3.50.20190425.tar.xz
|
||||||
|
@ -1 +1 @@
|
|||||||
05b1991f1a942f9d13b5363fb4c05e34ea44ef57
|
f88dbe3f8a9cef79a6ff32ba3734a7a308b8ea26
|
||||||
|
@ -127,7 +127,7 @@ diff --git a/gdb/amd64-linux-tdep.c b/gdb/amd64-linux-tdep.c
|
|||||||
diff --git a/gdb/amd64-tdep.c b/gdb/amd64-tdep.c
|
diff --git a/gdb/amd64-tdep.c b/gdb/amd64-tdep.c
|
||||||
--- a/gdb/amd64-tdep.c
|
--- a/gdb/amd64-tdep.c
|
||||||
+++ b/gdb/amd64-tdep.c
|
+++ b/gdb/amd64-tdep.c
|
||||||
@@ -2622,6 +2622,7 @@ amd64_frame_unwind_stop_reason (struct frame_info *this_frame,
|
@@ -2624,6 +2624,7 @@ amd64_frame_unwind_stop_reason (struct frame_info *this_frame,
|
||||||
{
|
{
|
||||||
struct amd64_frame_cache *cache =
|
struct amd64_frame_cache *cache =
|
||||||
amd64_frame_cache (this_frame, this_cache);
|
amd64_frame_cache (this_frame, this_cache);
|
||||||
@ -135,7 +135,7 @@ diff --git a/gdb/amd64-tdep.c b/gdb/amd64-tdep.c
|
|||||||
|
|
||||||
if (!cache->base_p)
|
if (!cache->base_p)
|
||||||
return UNWIND_UNAVAILABLE;
|
return UNWIND_UNAVAILABLE;
|
||||||
@@ -2630,6 +2631,10 @@ amd64_frame_unwind_stop_reason (struct frame_info *this_frame,
|
@@ -2632,6 +2633,10 @@ amd64_frame_unwind_stop_reason (struct frame_info *this_frame,
|
||||||
if (cache->base == 0)
|
if (cache->base == 0)
|
||||||
return UNWIND_OUTERMOST;
|
return UNWIND_OUTERMOST;
|
||||||
|
|
||||||
@ -146,7 +146,7 @@ diff --git a/gdb/amd64-tdep.c b/gdb/amd64-tdep.c
|
|||||||
return UNWIND_NO_REASON;
|
return UNWIND_NO_REASON;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -2763,6 +2768,7 @@ amd64_sigtramp_frame_this_id (struct frame_info *this_frame,
|
@@ -2765,6 +2770,7 @@ amd64_sigtramp_frame_this_id (struct frame_info *this_frame,
|
||||||
{
|
{
|
||||||
struct amd64_frame_cache *cache =
|
struct amd64_frame_cache *cache =
|
||||||
amd64_sigtramp_frame_cache (this_frame, this_cache);
|
amd64_sigtramp_frame_cache (this_frame, this_cache);
|
||||||
@ -154,7 +154,7 @@ diff --git a/gdb/amd64-tdep.c b/gdb/amd64-tdep.c
|
|||||||
|
|
||||||
if (!cache->base_p)
|
if (!cache->base_p)
|
||||||
(*this_id) = frame_id_build_unavailable_stack (get_frame_pc (this_frame));
|
(*this_id) = frame_id_build_unavailable_stack (get_frame_pc (this_frame));
|
||||||
@@ -2771,6 +2777,11 @@ amd64_sigtramp_frame_this_id (struct frame_info *this_frame,
|
@@ -2773,6 +2779,11 @@ amd64_sigtramp_frame_this_id (struct frame_info *this_frame,
|
||||||
/* This marks the outermost frame. */
|
/* This marks the outermost frame. */
|
||||||
return;
|
return;
|
||||||
}
|
}
|
||||||
|
7
gdb.spec
7
gdb.spec
@ -22,7 +22,7 @@
|
|||||||
Name: %{?scl_prefix}gdb
|
Name: %{?scl_prefix}gdb
|
||||||
|
|
||||||
# Freeze it when GDB gets branched
|
# Freeze it when GDB gets branched
|
||||||
%global snapsrc 20190424
|
%global snapsrc 20190425
|
||||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||||
%global snapgnulib 20161115
|
%global snapgnulib 20161115
|
||||||
%global tarname gdb-%{version}
|
%global tarname gdb-%{version}
|
||||||
@ -30,7 +30,7 @@ Version: 8.3.50.%{snapsrc}
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||||
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
||||||
@ -1025,6 +1025,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 25 2019 Sergio Durigan Junior <sergiodj@redhat.com> - 8.3.50.20190425-8
|
||||||
|
- Rebase to FSF GDB 8.3.50.20190425 (8.4pre), and fix build breakage.
|
||||||
|
|
||||||
* Wed Apr 24 2019 Sergio Durigan Junior <sergiodj@redhat.com> - 8.3.50.20190424-7
|
* Wed Apr 24 2019 Sergio Durigan Junior <sergiodj@redhat.com> - 8.3.50.20190424-7
|
||||||
- Rebase to FSF GDB 8.3.50.20190424 (8.4pre).
|
- Rebase to FSF GDB 8.3.50.20190424 (8.4pre).
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz) = a8b1c54dd348cfeb37da73f968742896be3dd13a4215f8d8519870c2abea915f5176c3fa6989ddd10f20020a16f0fab20cbae68ee8d58a82234d8778023520f8
|
SHA512 (gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz) = a8b1c54dd348cfeb37da73f968742896be3dd13a4215f8d8519870c2abea915f5176c3fa6989ddd10f20020a16f0fab20cbae68ee8d58a82234d8778023520f8
|
||||||
SHA512 (v2.0.tar.gz) = ec63151e842c81cc73ea11ba560b63e005cefbe19d98de24ae5c8caa4de7c9c1d71d1ec5b6214a347592eac675b75a3d2b26d4691ca86f91020ebfea8e912939
|
SHA512 (v2.0.tar.gz) = ec63151e842c81cc73ea11ba560b63e005cefbe19d98de24ae5c8caa4de7c9c1d71d1ec5b6214a347592eac675b75a3d2b26d4691ca86f91020ebfea8e912939
|
||||||
SHA512 (gdb-8.3.50.20190424.tar.xz) = 9dbe456b8698654f0cfcd07e310fa658132d7742e027b3030eb648f99ea51922978dc415b2cb430fc781ef4d01153a311aa3405a727ad8bda8b4ed992433bbb7
|
SHA512 (gdb-8.3.50.20190425.tar.xz) = 9d29758ebe89185be6cd35f74c89d4a776b8e07182f7550e44f1f785b4607af550fb5696e864c397e5d288b769e90cee34e0cf7c52638627b307244bd2bed2dd
|
||||||
|
Loading…
Reference in New Issue
Block a user