Fix SystemTap support regression on i686 (Sergio Durigan Junior).
This commit is contained in:
parent
254f0e90bc
commit
191f4d2883
@ -2,7 +2,7 @@ http://sourceware.org/gdb/wiki/ProjectArcher
|
|||||||
http://sourceware.org/gdb/wiki/ArcherBranchManagement
|
http://sourceware.org/gdb/wiki/ArcherBranchManagement
|
||||||
|
|
||||||
GIT snapshot:
|
GIT snapshot:
|
||||||
commit 1b94a2db24f76efe871f633ebe2c70e37f071f9d
|
commit 8cc17242e1d8f61a4aabc9e08e4272e8dbe77e52
|
||||||
|
|
||||||
branch `archer' - the merge of branches:
|
branch `archer' - the merge of branches:
|
||||||
archer-jankratochvil-vla
|
archer-jankratochvil-vla
|
||||||
@ -8709,10 +8709,10 @@ index c5c54db..9fc3b74 100644
|
|||||||
struct block *b = SYMBOL_BLOCK_VALUE (func);
|
struct block *b = SYMBOL_BLOCK_VALUE (func);
|
||||||
diff --git a/gdb/stap-probe.c b/gdb/stap-probe.c
|
diff --git a/gdb/stap-probe.c b/gdb/stap-probe.c
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..74fd9e9
|
index 0000000..123530f
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/gdb/stap-probe.c
|
+++ b/gdb/stap-probe.c
|
||||||
@@ -0,0 +1,1671 @@
|
@@ -0,0 +1,1672 @@
|
||||||
+/* SystemTap probe support for GDB.
|
+/* SystemTap probe support for GDB.
|
||||||
+
|
+
|
||||||
+ Copyright (C) 2011 Free Software Foundation, Inc.
|
+ Copyright (C) 2011 Free Software Foundation, Inc.
|
||||||
@ -9369,6 +9369,7 @@ index 0000000..74fd9e9
|
|||||||
+stap_parse_argument_conditionally (struct stap_parse_info *p)
|
+stap_parse_argument_conditionally (struct stap_parse_info *p)
|
||||||
+{
|
+{
|
||||||
+ if (*p->arg == '-' || *p->arg == '~' || *p->arg == '+' /* Unary. */
|
+ if (*p->arg == '-' || *p->arg == '~' || *p->arg == '+' /* Unary. */
|
||||||
|
+ || isdigit (*p->arg)
|
||||||
+ || gdbarch_stap_is_single_operand (p->gdbarch, p->arg))
|
+ || gdbarch_stap_is_single_operand (p->gdbarch, p->arg))
|
||||||
+ stap_parse_single_operand (p);
|
+ stap_parse_single_operand (p);
|
||||||
+ else if (*p->arg == '(')
|
+ else if (*p->arg == '(')
|
||||||
|
5
gdb.spec
5
gdb.spec
@ -27,7 +27,7 @@ Version: 7.4.50.20120103
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 1%{?_with_upstream:.upstream}%{?dist}
|
Release: 2%{?_with_upstream:.upstream}%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1197,6 +1197,9 @@ fi
|
|||||||
%{_infodir}/gdb.info*
|
%{_infodir}/gdb.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 3 2012 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.4.50.20120103-2.fc17
|
||||||
|
- Fix SystemTap support regression on i686 (Sergio Durigan Junior).
|
||||||
|
|
||||||
* Tue Jan 3 2012 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.4.50.20120103-1.fc17
|
* Tue Jan 3 2012 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.4.50.20120103-1.fc17
|
||||||
- Rebase to FSF GDB 7.4.50.20120103.
|
- Rebase to FSF GDB 7.4.50.20120103.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user