- Bump up release number.
Thu Apr 21 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-1.14 - Bump up release number. Thu Apr 21 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3-0.0-1.13 - Do not issue warning message for gcore under ia64 - Bugzilla 146416
This commit is contained in:
parent
434306b94c
commit
0e6b69254f
17
gdb-6.3-ia64-gcore-page0-20050421.patch
Normal file
17
gdb-6.3-ia64-gcore-page0-20050421.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- gdb-6.3/gdb/gcore.c.fix 2005-04-21 15:13:23.000000000 -0400
|
||||
+++ gdb-6.3/gdb/gcore.c 2005-04-21 15:16:48.000000000 -0400
|
||||
@@ -462,8 +462,13 @@ gcore_copy_callback (bfd *obfd, asection
|
||||
error ("Not enough memory to create corefile.");
|
||||
old_chain = make_cleanup (xfree, memhunk);
|
||||
|
||||
+ /* Warn if read error occurs except if we were trying to read the
|
||||
+ first page for ia64. The first page is marked readable, but it cannot
|
||||
+ be read. */
|
||||
if (target_read_memory (bfd_section_vma (obfd, osec),
|
||||
- memhunk, size) != 0)
|
||||
+ memhunk, size) != 0
|
||||
+ && (strcmp (TARGET_ARCHITECTURE->arch_name, "ia64")
|
||||
+ || bfd_section_vma (obfd, osec) != 0))
|
||||
warning ("Memory read failed for corefile section, %s bytes at 0x%s\n",
|
||||
paddr_d (size), paddr (bfd_section_vma (obfd, osec)));
|
||||
if (!bfd_set_section_contents (obfd, osec, memhunk, 0, size))
|
16
gdb.spec
16
gdb.spec
@ -11,7 +11,7 @@ Name: gdb
|
||||
Version: 6.3.0.0
|
||||
|
||||
# The release always contains a leading reserved number, start it at 0.
|
||||
Release: 1.12
|
||||
Release: 1.15
|
||||
|
||||
License: GPL
|
||||
Group: Development/Debuggers
|
||||
@ -207,6 +207,9 @@ Patch151: gdb-6.3-sepcrc-20050402.patch
|
||||
# Handle read side of DW_OP_piece.
|
||||
Patch152: gdb-6.3-dwoppieceread-20050407.patch
|
||||
|
||||
# Do not issue warning message about first page of storage for ia64 gcore
|
||||
Patch153: gdb-6.3-ia64-gcore-page0-20050421.patch
|
||||
|
||||
%ifarch ia64
|
||||
BuildRequires: ncurses-devel glibc-devel gcc make gzip texinfo dejagnu libunwind >= 0.96-3
|
||||
%else
|
||||
@ -291,6 +294,7 @@ and printing their data.
|
||||
%patch150 -p1
|
||||
%patch151 -p1
|
||||
%patch152 -p1
|
||||
%patch153 -p1
|
||||
|
||||
# Change the version that gets printed at GDB startup, so it is RedHat
|
||||
# specific.
|
||||
@ -459,6 +463,16 @@ fi
|
||||
# don't include the files in include, they are part of binutils
|
||||
|
||||
%changelog
|
||||
* Thu Apr 21 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-1.15
|
||||
- Bump up release number.
|
||||
|
||||
* Thu Apr 21 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3.0.0-1.14
|
||||
- Bump up release number.
|
||||
|
||||
* Thu Apr 21 2005 Jeff Johnston <jjohnstn@redhat.com> 6.3-0.0-1.13
|
||||
- Do not issue warning message for gcore under ia64
|
||||
- Bugzilla 146416
|
||||
|
||||
* Mon Apr 11 2005 Andrew Cagney <cagney@redhat.com> 6.3.0.0-1.12
|
||||
- Update gstack patch, handle systems that lack /proc/<pid>/tasks.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user