- Fix --with-system-readline doc build upstream regression.
This commit is contained in:
parent
6fa2f55b27
commit
0b11bd2616
52
gdb-doc-system-readline.patch
Normal file
52
gdb-doc-system-readline.patch
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
http://sourceware.org/ml/gdb-patches/2011-01/msg00001.html
|
||||||
|
Subject: [patch] make info regression on --with-system-readline
|
||||||
|
|
||||||
|
Hi,
|
||||||
|
|
||||||
|
since:
|
||||||
|
[2/2] RFA: --with-system-readline -vs- gdb.texinfo
|
||||||
|
http://sourceware.org/ml/gdb-patches/2010-11/msg00270.html
|
||||||
|
|
||||||
|
$ rm -rf gdb-7.2.50.20101231; tar xjf gdb-7.2.50.20101231.tar.bz2; cd gdb-7.2.50.20101231; CFLAGS= ./configure --with-system-readline; make; rm gdb/doc/gdb.info; make -C gdb/doc gdb.info
|
||||||
|
->
|
||||||
|
[...]
|
||||||
|
makeinfo -I ./../mi -I . \
|
||||||
|
-o gdb.info ./gdb.texinfo
|
||||||
|
./gdb.texinfo:30521: @include `rluser.texi': No such file or directory.
|
||||||
|
./gdb.texinfo:30521: @include `inc-hist.texinfo': No such file or directory.
|
||||||
|
[...]
|
||||||
|
Fedora 14 x86_64
|
||||||
|
|
||||||
|
It is because GDBvn.texi has started to depend on the configure options.
|
||||||
|
|
||||||
|
I will check it in in the case of no comments.
|
||||||
|
|
||||||
|
Another issue is that GDBvn.texi and gdb-cfg.texi should not be distributed.
|
||||||
|
But that bug is a different one on top of this bug. That bug of a needless
|
||||||
|
files distribution is dependent on magic GDB `make dist' I do not know and
|
||||||
|
also that dist bug is not serious enough.
|
||||||
|
|
||||||
|
This is a regression.
|
||||||
|
|
||||||
|
|
||||||
|
Thanks,
|
||||||
|
Jan
|
||||||
|
|
||||||
|
|
||||||
|
doc/
|
||||||
|
2011-01-01 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||||
|
|
||||||
|
* Makefile.in (GDBvn.texi): Add dependency on Makefile.
|
||||||
|
|
||||||
|
--- a/gdb/doc/Makefile.in
|
||||||
|
+++ b/gdb/doc/Makefile.in
|
||||||
|
@@ -298,7 +298,7 @@ refcard.pdf : refcard.tex $(REFEDITS)
|
||||||
|
rm -f sedref.log sedref.tex tmp.sed
|
||||||
|
|
||||||
|
# File to record current GDB version number (copied from main dir version.in)
|
||||||
|
-GDBvn.texi : ${gdbdir}/version.in
|
||||||
|
+GDBvn.texi : ${gdbdir}/version.in Makefile
|
||||||
|
echo "@set GDBVN `sed q $(srcdir)/../version.in`" > ./GDBvn.new
|
||||||
|
if [ -n "$(PKGVERSION)" ]; then \
|
||||||
|
echo "@set VERSION_PACKAGE $(PKGVERSION)" >> ./GDBvn.new; \
|
||||||
|
|
68
gdb-doc-system-readline2.patch
Normal file
68
gdb-doc-system-readline2.patch
Normal file
@ -0,0 +1,68 @@
|
|||||||
|
http://sourceware.org/ml/gdb-patches/2011-01/msg00002.html
|
||||||
|
Subject: [patch] make info out-of-src-tree regression on --with-system-readline
|
||||||
|
|
||||||
|
On Sat, 01 Jan 2011 02:13:24 +0100, Jan Kratochvil wrote:
|
||||||
|
> Another issue is that GDBvn.texi and gdb-cfg.texi should not be distributed.
|
||||||
|
> But that bug is a different one on top of this bug. That bug of a needless
|
||||||
|
> files distribution is dependent on magic GDB `make dist' I do not know and
|
||||||
|
> also that dist bug is not serious enough.
|
||||||
|
|
||||||
|
This part has a real consequence - the previous patch does not apply for build
|
||||||
|
trees out of the src tree. It may be even a makeinfo bug.
|
||||||
|
|
||||||
|
The change below is not needed for texi2dvi. In fact it even breaks it.
|
||||||
|
|
||||||
|
As Fedora does not package texi2roff I did not test it.
|
||||||
|
|
||||||
|
Another possibility is to error out if $(srcdir)/GDBvn.texi exists so that no
|
||||||
|
disambiguities may exist. GDBvn.texi would have to be removed from the
|
||||||
|
distributed tars.
|
||||||
|
|
||||||
|
Comment on this part is more than welcome.
|
||||||
|
|
||||||
|
This is a regression.
|
||||||
|
|
||||||
|
|
||||||
|
Thanks,
|
||||||
|
Jan
|
||||||
|
|
||||||
|
|
||||||
|
gdb/doc/
|
||||||
|
2011-01-01 Jan Kratochvil <jan.kratochvil@redhat.com>
|
||||||
|
|
||||||
|
Fix out-of-src doc build if using --with-system-readline.
|
||||||
|
* Makefile.in (MAKEINFO): New comment.
|
||||||
|
(gdb.info, gdb/index.html): Remove $(srcdir)/ from gdb.texinfo.
|
||||||
|
|
||||||
|
--- a/gdb/doc/Makefile.in
|
||||||
|
+++ b/gdb/doc/Makefile.in
|
||||||
|
@@ -45,6 +45,9 @@ gdbdir = $(srcdir)/..
|
||||||
|
TEXIDIR=${gdbdir}/../texinfo
|
||||||
|
|
||||||
|
# where to find makeinfo, preferably one designed for texinfo-2
|
||||||
|
+# Call makeinfo always with gdb.texinfo and not $(srcdir)/gdb.texinfo.
|
||||||
|
+# In the latter case GDBvn.texi would be included also from $(srcdir) even if
|
||||||
|
+# different GDBvn.texi exists in the current directory.
|
||||||
|
MAKEINFO=makeinfo
|
||||||
|
|
||||||
|
MAKEHTML = $(MAKEINFO) --html
|
||||||
|
@@ -365,7 +368,7 @@ gdb.pdf: ${GDB_DOC_FILES}
|
||||||
|
# GDB MANUAL: info file
|
||||||
|
gdb.info: ${GDB_DOC_FILES}
|
||||||
|
$(MAKEINFO) $(READLINE_TEXI_INCFLAG) -I ${GDBMI_DIR} -I $(srcdir) \
|
||||||
|
- -o gdb.info $(srcdir)/gdb.texinfo
|
||||||
|
+ -o gdb.info gdb.texinfo
|
||||||
|
|
||||||
|
# GDB MANUAL: roff translations
|
||||||
|
# Try to use a recent texi2roff. v2 was put on prep in jan91.
|
||||||
|
@@ -440,7 +443,8 @@ gdb.mm: $(GDB_DOC_FILES) links2roff
|
||||||
|
# GDB MANUAL: HTML file
|
||||||
|
|
||||||
|
gdb/index.html: ${GDB_DOC_FILES}
|
||||||
|
- $(MAKEHTML) $(MAKEHTMLFLAGS) $(READLINE_TEXI_INCFLAG) -I ${GDBMI_DIR} -I $(srcdir) $(srcdir)/gdb.texinfo
|
||||||
|
+ $(MAKEHTML) $(MAKEHTMLFLAGS) $(READLINE_TEXI_INCFLAG) \
|
||||||
|
+ -I ${GDBMI_DIR} -I $(srcdir) gdb.texinfo
|
||||||
|
|
||||||
|
# Clean these up before each run. Avoids a catch 22 with not being
|
||||||
|
# able to re-generate these files (to fix a corruption) because these
|
||||||
|
|
11
gdb.spec
11
gdb.spec
@ -27,7 +27,7 @@ Version: 7.2.50.20101231
|
|||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 5%{?_with_upstream:.upstream}%{dist}
|
Release: 6%{?_with_upstream:.upstream}%{dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and GFDL and BSD and Public Domain
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and GFDL and BSD and Public Domain
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -506,6 +506,10 @@ Patch511: gdb-bz592031-siginfo-lost-5of5.patch
|
|||||||
# Verify GDB Python built-in function gdb.solib_address exists (BZ # 634108).
|
# Verify GDB Python built-in function gdb.solib_address exists (BZ # 634108).
|
||||||
Patch526: gdb-bz634108-solib_address.patch
|
Patch526: gdb-bz634108-solib_address.patch
|
||||||
|
|
||||||
|
# Fix --with-system-readline doc build upstream regression.
|
||||||
|
Patch531: gdb-doc-system-readline.patch
|
||||||
|
Patch532: gdb-doc-system-readline2.patch
|
||||||
|
|
||||||
BuildRequires: ncurses-devel%{?_isa} texinfo gettext flex bison expat-devel%{?_isa}
|
BuildRequires: ncurses-devel%{?_isa} texinfo gettext flex bison expat-devel%{?_isa}
|
||||||
Requires: readline%{?_isa}
|
Requires: readline%{?_isa}
|
||||||
BuildRequires: readline-devel%{?_isa}
|
BuildRequires: readline-devel%{?_isa}
|
||||||
@ -745,6 +749,8 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
|
|||||||
%patch510 -p1
|
%patch510 -p1
|
||||||
%patch511 -p1
|
%patch511 -p1
|
||||||
%patch526 -p1
|
%patch526 -p1
|
||||||
|
%patch531 -p1
|
||||||
|
%patch532 -p1
|
||||||
|
|
||||||
%patch393 -p1
|
%patch393 -p1
|
||||||
%patch335 -p1
|
%patch335 -p1
|
||||||
@ -1121,6 +1127,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 1 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20101231-6.fc15
|
||||||
|
- Fix --with-system-readline doc build upstream regression.
|
||||||
|
|
||||||
* Sat Jan 1 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20101231-5.fc15
|
* Sat Jan 1 2011 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.2.50.20101231-5.fc15
|
||||||
- Rebase to FSF GDB 7.2.50.20101231 (which is a 7.3 pre-release).
|
- Rebase to FSF GDB 7.2.50.20101231 (which is a 7.3 pre-release).
|
||||||
- Remove gdb-6.3-bt-past-zero-20051201.patch, gdb-archer-ada.patch and
|
- Remove gdb-6.3-bt-past-zero-20051201.patch, gdb-archer-ada.patch and
|
||||||
|
Loading…
Reference in New Issue
Block a user