Rebase to FSF GDB 8.3.50.20190517 (8.4pre).
This commit is contained in:
parent
a17be6a448
commit
06f4849386
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,3 +1,3 @@
|
||||
/gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz
|
||||
/v2.0.tar.gz
|
||||
/gdb-8.3.50.20190510.tar.xz
|
||||
/gdb-8.3.50.20190517.tar.xz
|
||||
|
@ -1 +1 @@
|
||||
f3e606a3db56db3ce1ab172511a4ffe9310a496f
|
||||
6275948b473f6ed3149e97bc18f6f8de28bb3f04
|
||||
|
@ -8,7 +8,7 @@ Subject: gdb-archer-pie-addons-keep-disabled.patch
|
||||
diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
|
||||
--- a/gdb/breakpoint.c
|
||||
+++ b/gdb/breakpoint.c
|
||||
@@ -15425,6 +15425,50 @@ static struct cmd_list_element *enablebreaklist = NULL;
|
||||
@@ -15431,6 +15431,50 @@ static struct cmd_list_element *enablebreaklist = NULL;
|
||||
|
||||
cmd_list_element *commands_cmd_element = nullptr;
|
||||
|
||||
|
@ -14,7 +14,7 @@ Bug in FSF GDB exploited by the ptrace-on-utrace interaction.
|
||||
diff --git a/gdb/breakpoint.c b/gdb/breakpoint.c
|
||||
--- a/gdb/breakpoint.c
|
||||
+++ b/gdb/breakpoint.c
|
||||
@@ -11919,6 +11919,8 @@ update_global_location_list (enum ugll_insert_mode insert_mode)
|
||||
@@ -11925,6 +11925,8 @@ update_global_location_list (enum ugll_insert_mode insert_mode)
|
||||
traps we can no longer explain. */
|
||||
|
||||
old_loc->events_till_retirement = 3 * (thread_count () + 1);
|
||||
|
@ -1022,7 +1022,7 @@ diff --git a/gdb/gdbtypes.h b/gdb/gdbtypes.h
|
||||
|
||||
#define TYPE_ARRAY_UPPER_BOUND_VALUE(arraytype) \
|
||||
(TYPE_HIGH_BOUND(TYPE_INDEX_TYPE((arraytype))))
|
||||
@@ -1948,6 +1963,7 @@ extern struct type *create_array_type_with_stride
|
||||
@@ -1950,6 +1965,7 @@ extern struct type *create_array_type_with_stride
|
||||
struct dynamic_prop *, unsigned int);
|
||||
|
||||
extern struct type *create_range_type (struct type *, struct type *,
|
||||
@ -1683,10 +1683,41 @@ diff --git a/gdb/testsuite/gdb.fortran/vla-ptype.exp b/gdb/testsuite/gdb.fortran
|
||||
diff --git a/gdb/testsuite/gdb.fortran/vla-sizeof.exp b/gdb/testsuite/gdb.fortran/vla-sizeof.exp
|
||||
--- a/gdb/testsuite/gdb.fortran/vla-sizeof.exp
|
||||
+++ b/gdb/testsuite/gdb.fortran/vla-sizeof.exp
|
||||
@@ -44,3 +44,7 @@ gdb_test "print sizeof(pvla)" " = 0" "print sizeof non-associated pvla"
|
||||
gdb_breakpoint [gdb_get_line_number "pvla-associated"]
|
||||
gdb_continue_to_breakpoint "pvla-associated"
|
||||
@@ -32,7 +32,8 @@ gdb_test "print sizeof(vla1)" " = 0" "print sizeof non-allocated vla1"
|
||||
gdb_test "print sizeof(vla1(3,2,1))" \
|
||||
"no such vector element \\(vector not allocated\\)" \
|
||||
"print sizeof non-allocated indexed vla1"
|
||||
-gdb_test "print sizeof(vla1(3:4,2,1))" "slice out of range" \
|
||||
+gdb_test "print sizeof(vla1(3:4,2,1))" \
|
||||
+ "provided bound\\(s\\) outside array bound\\(s\\)" \
|
||||
"print sizeof non-allocated sliced vla1"
|
||||
|
||||
# Try to access value in allocated VLA
|
||||
@@ -41,7 +42,7 @@ gdb_continue_to_breakpoint "vla1-allocated"
|
||||
gdb_test "print sizeof(vla1)" " = 4000" "print sizeof allocated vla1"
|
||||
gdb_test "print sizeof(vla1(3,2,1))" "4" \
|
||||
"print sizeof element from allocated vla1"
|
||||
-gdb_test "print sizeof(vla1(3:4,2,1))" "800" \
|
||||
+gdb_test "print sizeof(vla1(3:4,2,1))" "8" \
|
||||
"print sizeof sliced vla1"
|
||||
|
||||
# Try to access values in undefined pointer to VLA (dangling)
|
||||
@@ -49,7 +50,8 @@ gdb_test "print sizeof(pvla)" " = 0" "print sizeof non-associated pvla"
|
||||
gdb_test "print sizeof(pvla(3,2,1))" \
|
||||
"no such vector element \\(vector not associated\\)" \
|
||||
"print sizeof non-associated indexed pvla"
|
||||
-gdb_test "print sizeof(pvla(3:4,2,1))" "slice out of range" \
|
||||
+gdb_test "print sizeof(pvla(3:4,2,1))" \
|
||||
+ "provided bound\\(s\\) outside array bound\\(s\\)" \
|
||||
"print sizeof non-associated sliced pvla"
|
||||
|
||||
# Try to access values in pointer to VLA and compare them
|
||||
@@ -58,4 +60,8 @@ gdb_continue_to_breakpoint "pvla-associated"
|
||||
gdb_test "print sizeof(pvla)" " = 4000" "print sizeof associated pvla"
|
||||
gdb_test "print sizeof(pvla(3,2,1))" "4" \
|
||||
"print sizeof element from associated pvla"
|
||||
-gdb_test "print sizeof(pvla(3:4,2,1))" "800" "print sizeof sliced pvla"
|
||||
+gdb_test "print sizeof(pvla(3:4,2,1))" "8" "print sizeof sliced pvla"
|
||||
+
|
||||
+gdb_breakpoint [gdb_get_line_number "vla1-neg-bounds"]
|
||||
+gdb_continue_to_breakpoint "vla1-neg-bounds"
|
||||
|
@ -318,7 +318,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
||||
{
|
||||
/* If bounds are constant do the final calculation here. */
|
||||
if (low.kind == PROP_CONST && high.kind == PROP_CONST)
|
||||
@@ -25520,7 +25623,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
||||
@@ -25537,7 +25640,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
||||
attr = dwarf2_attr (die, DW_AT_allocated, cu);
|
||||
if (attr_form_is_block (attr))
|
||||
{
|
||||
@ -327,7 +327,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
||||
add_dyn_prop (DYN_PROP_ALLOCATED, prop, type);
|
||||
}
|
||||
else if (attr != NULL)
|
||||
@@ -25534,7 +25637,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
||||
@@ -25551,7 +25654,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
||||
attr = dwarf2_attr (die, DW_AT_associated, cu);
|
||||
if (attr_form_is_block (attr))
|
||||
{
|
||||
@ -336,7 +336,7 @@ diff --git a/gdb/dwarf2read.c b/gdb/dwarf2read.c
|
||||
add_dyn_prop (DYN_PROP_ASSOCIATED, prop, type);
|
||||
}
|
||||
else if (attr != NULL)
|
||||
@@ -25546,7 +25649,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
||||
@@ -25563,7 +25666,7 @@ set_die_type (struct die_info *die, struct type *type, struct dwarf2_cu *cu)
|
||||
|
||||
/* Read DW_AT_data_location and set in type. */
|
||||
attr = dwarf2_attr (die, DW_AT_data_location, cu);
|
||||
|
7
gdb.spec
7
gdb.spec
@ -27,7 +27,7 @@
|
||||
Name: %{?scl_prefix}gdb
|
||||
|
||||
# Freeze it when GDB gets branched
|
||||
%global snapsrc 20190510
|
||||
%global snapsrc 20190517
|
||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||
%global snapgnulib 20161115
|
||||
%global tarname gdb-%{version}
|
||||
@ -35,7 +35,7 @@ Version: 8.3.50.%{snapsrc}
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 12%{?dist}
|
||||
Release: 13%{?dist}
|
||||
|
||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and LGPLv3+ and BSD and Public Domain and GFDL
|
||||
# Do not provide URL for snapshots as the file lasts there only for 2 days.
|
||||
@ -1131,6 +1131,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri May 17 2019 Sergio Durigan Junior <sergiodj@redhat.com> - 8.3.50.20190517-13
|
||||
- Rebase to FSF GDB 8.3.50.20190517 (8.4pre).
|
||||
|
||||
* Fri May 10 2019 Sergio Durigan Junior <sergiodj@fedoraproject.org> - 8.3.50.20190510-12
|
||||
- Rebase to FSF GDB 8.3.50.20190510 (8.4pre).
|
||||
|
||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
||||
SHA512 (gdb-libstdc++-v3-python-8.1.1-20180626.tar.xz) = a8b1c54dd348cfeb37da73f968742896be3dd13a4215f8d8519870c2abea915f5176c3fa6989ddd10f20020a16f0fab20cbae68ee8d58a82234d8778023520f8
|
||||
SHA512 (v2.0.tar.gz) = ec63151e842c81cc73ea11ba560b63e005cefbe19d98de24ae5c8caa4de7c9c1d71d1ec5b6214a347592eac675b75a3d2b26d4691ca86f91020ebfea8e912939
|
||||
SHA512 (gdb-8.3.50.20190510.tar.xz) = 7864f78f8216abae9585eea34ebeafe02fd43871aab12f347de54fb55c794255adeefc870690b3fdefa7ad829ea35f6857f3d43ec77b3986ea047f44a708afbf
|
||||
SHA512 (gdb-8.3.50.20190517.tar.xz) = cd0ea818faf1dfabc6b9a58efaeff11ed2ee7fb21aef1790fe8673655dc48a0d3fb9b7c4d03f2dd4043edb6440e4a3d1f4fd1396bdeb285e852c459457743b35
|
||||
|
Loading…
Reference in New Issue
Block a user