- Fix pstack/gstack cutting very long lines (BZ 497849).
This commit is contained in:
parent
373e1bc565
commit
06e575d259
@ -67,7 +67,7 @@ Index: gdb-6.8.50.20090226/gdb/gstack.sh
|
||||
===================================================================
|
||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||
+++ gdb-6.8.50.20090226/gdb/gstack.sh 2009-02-26 22:10:05.000000000 +0100
|
||||
@@ -0,0 +1,45 @@
|
||||
@@ -0,0 +1,48 @@
|
||||
+#!/bin/sh
|
||||
+
|
||||
+if test $# -ne 1; then
|
||||
@ -107,6 +107,9 @@ Index: gdb-6.8.50.20090226/gdb/gstack.sh
|
||||
+
|
||||
+# Run GDB, strip out unwanted noise.
|
||||
+$GDB --quiet $readnever -nx /proc/$1/exe $1 <<EOF 2>&1 |
|
||||
+set width 0
|
||||
+set height 0
|
||||
+set pagination no
|
||||
+$backtrace
|
||||
+EOF
|
||||
+sed -n \
|
||||
|
@ -24,7 +24,7 @@ Index: gdb-6.3/gdb/gstack.sh
|
||||
if $GDB -nx --quiet --batch --readnever > /dev/null 2>&1; then
|
||||
readnever=--readnever
|
||||
@@ -39,7 +39,7 @@ fi
|
||||
$GDB --quiet $readnever -nx /proc/$1/exe $1 <<EOF 2>&1 |
|
||||
set pagination no
|
||||
$backtrace
|
||||
EOF
|
||||
-sed -n \
|
||||
|
5
gdb.spec
5
gdb.spec
@ -13,7 +13,7 @@ Version: 6.8.50.20090302
|
||||
|
||||
# The release always contains a leading reserved number, start it at 1.
|
||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||
Release: 21%{?_with_upstream:.upstream}%{?dist}
|
||||
Release: 22%{?_with_upstream:.upstream}%{?dist}
|
||||
|
||||
License: GPLv3+
|
||||
Group: Development/Debuggers
|
||||
@ -861,6 +861,9 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Apr 27 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-22
|
||||
- Fix pstack/gstack cutting very long lines (BZ 497849).
|
||||
|
||||
* Sun Apr 19 2009 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8.50.20090302-21
|
||||
- New test for parsing elf64-i386 files for kdump PAE vmcore dumps (BZ 457187).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user