Rebase to FSF GDB 7.11.90.20160904 (pre-7.12 branch snapshot).
- Make Version tag 7.12; but it is still a pre-release.
This commit is contained in:
parent
d987921748
commit
0300a2eb2d
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,3 +1,3 @@
|
|||||||
/gdb-libstdc++-v3-python-6.1.1-20160817.tar.xz
|
/gdb-libstdc++-v3-python-6.1.1-20160817.tar.xz
|
||||||
/v1.5.tar.gz
|
/v1.5.tar.gz
|
||||||
/gdb-7.11.90.20160829.tar.xz
|
/gdb-7.11.90.20160904.tar.xz
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
Index: gdb-7.10.50.20151022/gdb/infrun.c
|
Index: gdb-7.11.90.20160904/gdb/infrun.c
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.10.50.20151022.orig/gdb/infrun.c 2015-10-22 22:30:15.887224452 +0200
|
--- gdb-7.11.90.20160904.orig/gdb/infrun.c 2016-09-04 17:57:12.733853848 +0200
|
||||||
+++ gdb-7.10.50.20151022/gdb/infrun.c 2015-10-22 22:30:25.742282478 +0200
|
+++ gdb-7.11.90.20160904/gdb/infrun.c 2016-09-04 17:57:45.568145391 +0200
|
||||||
@@ -2175,7 +2175,7 @@ static const char *const scheduler_enums
|
@@ -2218,7 +2218,7 @@
|
||||||
schedlock_replay,
|
schedlock_replay,
|
||||||
NULL
|
NULL
|
||||||
};
|
};
|
||||||
@ -11,11 +11,11 @@ Index: gdb-7.10.50.20151022/gdb/infrun.c
|
|||||||
static void
|
static void
|
||||||
show_scheduler_mode (struct ui_file *file, int from_tty,
|
show_scheduler_mode (struct ui_file *file, int from_tty,
|
||||||
struct cmd_list_element *c, const char *value)
|
struct cmd_list_element *c, const char *value)
|
||||||
Index: gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-cli.exp
|
Index: gdb-7.11.90.20160904/gdb/testsuite/gdb.mi/mi-cli.exp
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.10.50.20151022.orig/gdb/testsuite/gdb.mi/mi-cli.exp 2015-10-22 22:29:38.352003447 +0200
|
--- gdb-7.11.90.20160904.orig/gdb/testsuite/gdb.mi/mi-cli.exp 2016-09-04 17:57:12.733853848 +0200
|
||||||
+++ gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-cli.exp 2015-10-22 22:30:15.888224458 +0200
|
+++ gdb-7.11.90.20160904/gdb/testsuite/gdb.mi/mi-cli.exp 2016-09-04 17:57:45.569145399 +0200
|
||||||
@@ -199,7 +199,7 @@ mi_expect_stop "breakpoint-hit" "main" "
|
@@ -199,7 +199,7 @@
|
||||||
# Test that the token is output even for CLI commands
|
# Test that the token is output even for CLI commands
|
||||||
# Also test that *stopped includes frame information.
|
# Also test that *stopped includes frame information.
|
||||||
mi_gdb_test "34 next" \
|
mi_gdb_test "34 next" \
|
||||||
@ -24,11 +24,11 @@ Index: gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-cli.exp
|
|||||||
"34 next: run"
|
"34 next: run"
|
||||||
|
|
||||||
# Test that the new current source line is output to the console
|
# Test that the new current source line is output to the console
|
||||||
Index: gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-logging.exp
|
Index: gdb-7.11.90.20160904/gdb/testsuite/gdb.mi/mi-logging.exp
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.10.50.20151022.orig/gdb/testsuite/gdb.mi/mi-logging.exp 2015-10-22 22:29:38.352003447 +0200
|
--- gdb-7.11.90.20160904.orig/gdb/testsuite/gdb.mi/mi-logging.exp 2016-09-04 17:57:12.733853848 +0200
|
||||||
+++ gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-logging.exp 2015-10-22 22:30:15.888224458 +0200
|
+++ gdb-7.11.90.20160904/gdb/testsuite/gdb.mi/mi-logging.exp 2016-09-04 17:57:45.569145399 +0200
|
||||||
@@ -53,7 +53,7 @@ close $chan
|
@@ -53,7 +53,7 @@
|
||||||
|
|
||||||
set mi_log_prompt "\[(\]gdb\[)\] \[\r\n\]+"
|
set mi_log_prompt "\[(\]gdb\[)\] \[\r\n\]+"
|
||||||
|
|
||||||
@ -37,7 +37,7 @@ Index: gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-logging.exp
|
|||||||
pass "Log file contents"
|
pass "Log file contents"
|
||||||
} else {
|
} else {
|
||||||
fail "Log file contents"
|
fail "Log file contents"
|
||||||
@@ -76,7 +76,7 @@ set chan [open $milogfile]
|
@@ -76,7 +76,7 @@
|
||||||
set logcontent [read $chan]
|
set logcontent [read $chan]
|
||||||
close $chan
|
close $chan
|
||||||
|
|
||||||
@ -46,11 +46,11 @@ Index: gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-logging.exp
|
|||||||
pass "Redirect log file contents"
|
pass "Redirect log file contents"
|
||||||
} else {
|
} else {
|
||||||
fail "Redirect log file contents"
|
fail "Redirect log file contents"
|
||||||
Index: gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-console.exp
|
Index: gdb-7.11.90.20160904/gdb/testsuite/gdb.mi/mi-console.exp
|
||||||
===================================================================
|
===================================================================
|
||||||
--- gdb-7.10.50.20151022.orig/gdb/testsuite/gdb.mi/mi-console.exp 2015-10-22 22:29:38.353003453 +0200
|
--- gdb-7.11.90.20160904.orig/gdb/testsuite/gdb.mi/mi-console.exp 2016-09-04 17:57:12.733853848 +0200
|
||||||
+++ gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-console.exp 2015-10-22 22:30:15.888224458 +0200
|
+++ gdb-7.11.90.20160904/gdb/testsuite/gdb.mi/mi-console.exp 2016-09-04 17:57:45.569145399 +0200
|
||||||
@@ -60,6 +60,9 @@ if { [gdb_compile "${srcdir}/${subdir}/
|
@@ -60,6 +60,9 @@
|
||||||
|
|
||||||
mi_run_to_main
|
mi_run_to_main
|
||||||
|
|
||||||
@ -60,3 +60,16 @@ Index: gdb-7.10.50.20151022/gdb/testsuite/gdb.mi/mi-console.exp
|
|||||||
# The output we get from the target depends on how it is hosted. If
|
# The output we get from the target depends on how it is hosted. If
|
||||||
# we are semihosted (e.g., the sim or a remote target that supports
|
# we are semihosted (e.g., the sim or a remote target that supports
|
||||||
# the File I/O remote protocol extension), we see the target I/O
|
# the File I/O remote protocol extension), we see the target I/O
|
||||||
|
Index: gdb-7.11.90.20160904/gdb/testsuite/gdb.opt/inline-cmds.exp
|
||||||
|
===================================================================
|
||||||
|
--- gdb-7.11.90.20160904.orig/gdb/testsuite/gdb.opt/inline-cmds.exp 2016-09-04 17:59:44.600202299 +0200
|
||||||
|
+++ gdb-7.11.90.20160904/gdb/testsuite/gdb.opt/inline-cmds.exp 2016-09-04 18:00:04.616380027 +0200
|
||||||
|
@@ -331,7 +331,7 @@
|
||||||
|
|
||||||
|
send_gdb "interpreter-exec console \"step\"\n"
|
||||||
|
gdb_expect {
|
||||||
|
- -re "\\^running\r\n\\*running,thread-id=\"all\"\r\n${mi_gdb_prompt}${cli_output_re}" {
|
||||||
|
+ -re "\\^running\r\n\\*running,thread-id=\"1\"\r\n${mi_gdb_prompt}${cli_output_re}" {
|
||||||
|
pass $message
|
||||||
|
}
|
||||||
|
timeout {
|
||||||
|
@ -27,10 +27,36 @@ cannot reproduce it.
|
|||||||
Thanks,
|
Thanks,
|
||||||
Jan
|
Jan
|
||||||
|
|
||||||
--FCuugMFkClbJLl1L
|
--- ./gdb/dwarf2loc.c 2016-08-29 04:01:25.000000000 +0200
|
||||||
Content-Type: text/plain; charset=us-ascii
|
+++ ./gdb/dwarf2loc.c 2016-09-01 11:00:20.258909494 +0200
|
||||||
Content-Disposition: inline; filename="vlastringonly.patch"
|
@@ -2289,6 +2289,15 @@ const struct dwarf_expr_context_funcs dw
|
||||||
|
dwarf_expr_get_obj_addr
|
||||||
|
};
|
||||||
|
|
||||||
|
+static void
|
||||||
|
+select_frame_cleanup (void *arg)
|
||||||
|
+{
|
||||||
|
+ struct frame_info *frame = (struct frame_info *) arg;
|
||||||
|
+
|
||||||
|
+ if (frame != NULL)
|
||||||
|
+ select_frame (frame);
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
/* Evaluate a location description, starting at DATA and with length
|
||||||
|
SIZE, to find the current location of variable of TYPE in the
|
||||||
|
context of FRAME. BYTE_OFFSET is applied after the contents are
|
||||||
|
@@ -2318,6 +2327,11 @@ dwarf2_evaluate_loc_desc_full (struct ty
|
||||||
|
|
||||||
|
ctx = new_dwarf_expr_context ();
|
||||||
|
old_chain = make_cleanup_free_dwarf_expr_context (ctx);
|
||||||
|
+
|
||||||
|
+ make_cleanup (select_frame_cleanup, deprecated_safe_get_selected_frame ());
|
||||||
|
+ if (frame != NULL)
|
||||||
|
+ select_frame (frame);
|
||||||
|
+
|
||||||
|
value_chain = make_cleanup_value_free_to_mark (value_mark ());
|
||||||
|
|
||||||
|
ctx->gdbarch = get_objfile_arch (objfile);
|
||||||
Index: gdb-7.9.50.20150520/gdb/testsuite/gdb.fortran/dynamic-other-frame-stub.f90
|
Index: gdb-7.9.50.20150520/gdb/testsuite/gdb.fortran/dynamic-other-frame-stub.f90
|
||||||
===================================================================
|
===================================================================
|
||||||
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
|
||||||
|
10
gdb.spec
10
gdb.spec
@ -22,12 +22,12 @@ Name: %{?scl_prefix}gdb
|
|||||||
%global snapsrc 20160801
|
%global snapsrc 20160801
|
||||||
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
# See timestamp of source gnulib installed into gdb/gnulib/ .
|
||||||
%global snapgnulib 20150822
|
%global snapgnulib 20150822
|
||||||
%global tarname gdb-%{version}
|
%global tarname gdb-7.11.90.20160904
|
||||||
Version: 7.11.90.20160829
|
Version: 7.12
|
||||||
|
|
||||||
# The release always contains a leading reserved number, start it at 1.
|
# The release always contains a leading reserved number, start it at 1.
|
||||||
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
# `upstream' is not a part of `name' to stay fully rpm dependencies compatible for the testing.
|
||||||
Release: 8%{?dist}
|
Release: 9%{?dist}
|
||||||
|
|
||||||
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
License: GPLv3+ and GPLv3+ with exceptions and GPLv2+ and GPLv2+ with exceptions and GPL+ and LGPLv2+ and BSD and Public Domain and GFDL
|
||||||
Group: Development/Debuggers
|
Group: Development/Debuggers
|
||||||
@ -1463,6 +1463,10 @@ then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Sep 4 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.12-0.9.20160904.fc25
|
||||||
|
- Rebase to FSF GDB 7.11.90.20160904 (pre-7.12 branch snapshot).
|
||||||
|
- Make Version tag 7.12; but it is still a pre-release.
|
||||||
|
|
||||||
* Mon Aug 29 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11.90.20160829-8.fc25
|
* Mon Aug 29 2016 Jan Kratochvil <jan.kratochvil@redhat.com> - 7.11.90.20160829-8.fc25
|
||||||
- Rebase to FSF GDB 7.11.90.20160829 (pre-7.12 branch snapshot).
|
- Rebase to FSF GDB 7.11.90.20160829 (pre-7.12 branch snapshot).
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
131d0dfd20cd6014c168fbcab9be2c43 gdb-libstdc++-v3-python-6.1.1-20160817.tar.xz
|
131d0dfd20cd6014c168fbcab9be2c43 gdb-libstdc++-v3-python-6.1.1-20160817.tar.xz
|
||||||
29efc08219d9d6a0536d58f9807c8722 v1.5.tar.gz
|
29efc08219d9d6a0536d58f9807c8722 v1.5.tar.gz
|
||||||
693f1a93282c04f41cd08cb79fbc63c7 gdb-7.11.90.20160829.tar.xz
|
67e2a5a5c4faead18837fa54ae90576a gdb-7.11.90.20160904.tar.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user